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Chapter 1   
Welcome to the 
world of Lightkey 

 

Lightkey is a modern professional lighting con- 
troller for live events, nightclubs, churches, and 
any other kind of venue. Engineered exclusively 
for Macs, it employs the latest technologies and 
comes with the familiar look and feel you love. 

Thank you for choosing Lightkey! Whether you’re a seasoned LJ or a rookie to the 
world of lighting, Lightkey is a powerful, flexible, and approachable controller for 
DMX and smart lights, providing all the tools you need to build sophisticated, 
professional light shows. It was built from the ground up as a native Mac app, 
leveraging the latest technologies to deliver maximum performance with up to 8192 
DMX channels. But beyond that, we hope that Lightkey enhances your creative 
process and makes it fun to create spectacular light shows. 

This User Guide strives to be a comprehensive reference for Lightkey. It covers 
everything you need to know to use the software, no matter what you want to achieve. 
If you’re a beginner looking to get started, you can also find a series of video tutorials 
on the Lightkey website. 

Lightkey is built on open standards and works with a wide range of USB–DMX 
interfaces from various manufacturers, in addition to the Art-Net, sACN, or ESP Net 
network protocols. This is made possible by the Open Lighting Architecture, an open-
source framework developed by the Open Lighting Project. 
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Starting with version 4 smart lights can complement a DMX installation, controlled 
alongside your DMX lights through the same user interface. 

Setting up a lighting installation with Lightkey is quick and easy. It comes with a 
library of several thousand high-quality fixture profiles, and an interactive assistant 
guides you through the entire setup process. 

When setup is complete, Lightkey makes it easy and fun to build stunning light 
shows. You can create presets, sequence, and cues, add effects using the powerful 
effects engine, and synchronize your light show to music. 

Lightkey’s elegant, Mac-style user interfaces unites all relevant controls in a single, 
well-arranged window. The white-on-dark controls have been specially designed for 
low-light environments and provide large clickable areas which work great with 
touch screens. 

Lightkey includes a sophisticated system of keyboard shortcuts and gestures to 
control virtually every application feature. Once you have mastered these shortcuts, 
you can work faster than ever before. Beyond that a powerful, fully configurable 
external control system enables integration with hardware controllers and other 
software. 

But that’s not all. We’re constantly extending and improving Lightkey—as you can 
see in the release notes—and push out updates regularly. If you want to share your 
ideas or feedback, please get in touch: We love to hear from you. 
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Chapter 2   
Intro to DMX 

 

DMX512 or simply DMX (Digital Multiplex) is the 
industry standard for controlling lighting fixtures 
and other stage equipment. This chapter gives a 
brief introduction to the DMX technology and how 
it’s used. 

Developed in the 1980s, DMX enables a controller—in this case, Lightkey—to send 
data to various kinds of fixtures. DMX allows for up to 512 control channels per data 
line or universe. Each channel can adopt any value in the range 0 to 255. This was 
originally designed for dimmers, where zero means 0% brightness and 255 means 
100% brightness. While this is still the case with dimmers, DMX channels today 
control many other aspects of modern fixtures, such as pan, tilt, or color. 

Connect your fixtures 
DMX is a unidirectional protocol: The signal travels from the controller to the first 
fixture and all the way to the last. The fixtures form a “daisy chain” where the “out” 
port of each fixture is connected to the “in” port of the next fixture with a DMX cable. 
A DMX interface connects the computer to the first fixture. You can connect the 
fixtures in any order, but try to keep cable lengths to a minimum for optimal data 
transmission. Because DMX is unidirectional, the software cannot tell which fixtures 
are connected and whether they actually receive a signal. 
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A DMX terminator is plugged into the “out” port of the last fixture in the chain. It 
contains a resistor which prevents the signal from “bouncing back” through the 
signal line. Some modern fixtures are self-terminating and require no terminator if 
they’re at the end of the DMX chain. 

 

Each daisy chain of fixtures forms a DMX universe which operates up to 512 
channels. For many installations a single universes is sufficient, but Lightkey can 
control up to 16 full universes or 8192 channels. Network interfaces with two, four, 
eight or more outputs let you send DMX to multiple separate DMX chains. 

 

Another way to output multiple universes is to use multiple DMX interfaces. However, 
there are various limitations which are explained in chapter 14, DMX output and 
input. For example, Lightkey can only control a single USB interface and a single Art-
Net node. Using a single DMX interface is the preferred way to output multiple 
universes. 

in in inoutout out

DMX terminator

DMX interface

USB or network
connection

DMX cable

in

in

in

in

in

in

in

out

out

outin out

out

Multi-universe
DMX interface

Network connection
(Ethernet or Wi-Fi)

Universe 1

Universe 2
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The cables which connect the fixtures use XLR connectors with five (XLR-5) or three 
(XLR-3) pins. Although the original DMX specification stipulated XLR-5 connectors, 
both types are in common use. From Lightkey’s perspective it doesn’t matter which 
one you use, and you can mix both types with a suitable adapter. Do not confuse 
XLR-5 connectors with DIN connectors, often used for MIDI, which look similar but 
are incompatible to XLR-5. 

 

Be sure to use only cables designed for carrying digital signals. Microphone cables, 
which share the same XLR-3 connectors, are made for analog signals and have a 
lower impedance. They’re not suitable for DMX and can—even though they may seem 
to work at first—cause random errors or flicker later on. 

If your fixtures fit within a single universe but their layout doesn’t allow for a single 
run of cables you can use a DMX splitter to split the universe into separate DMX 
chains. A splitter does not change the fixtures’ DMX addresses and the universe is 
still limited to 512 channels. 

 

There are splitters with 5- or 3-pin connectors and different numbers of outputs. 
Most splitters also amplify the signal, which can improve transmission quality over 
long cable runs. 

XLR-5  ! XLR-3  ! DIN  "

inout

DMX interface Splitter

in

in

in

out

out

out

out
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A DMX transmitter lets you send DMX wirelessly (shown below). Other equipment 
includes DMX boosters, which amplify the signal over long cable runs. From 
Lightkey’s perspective it doesn’t matter if you employ splitters, transmitters, 
boosters, or cable adapters along the DMX line. The software does not specifically 
control those devices and isn’t even aware they’re there. 

 

Some fixtures, like traditional PAR cans or house lights, may not have XLR 
connectors. You can connect their power cables to a DMX dimmer or dimmer pack 
which varies its outgoing voltage depending on the DMX input. Use a switch or switch 
pack for non-dimmable lights. Never connect a DMX-controlled fixture to a dimmer 
pack. 

 

You can connect digital LED strips through a DMX-controlled decoder which 
translates DMX to a PWM (pulse-width modulation) signal for controlling the LED 
colors. Most decoders control multiple LED strips at once. 

out

in

Other DMX 
fixtures

DMX interface

DMX transmitter

in

in inoutout out

Power cables

Dimmer pack
(4 channels)in
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Some more advanced fixtures have RJ45 (Ethernet) ports and can receive data 
directly from the computer or through an Ethernet router or switch using network 
protocols like Art-Net or Streaming ACN (sACN or ANSI E1.31). Most of these fixtures 
also have an RJ45 out port so they can be daisy-chained. 

 

Some network-enabled fixtures can also route the Art-Net or sACN input to their 
XLR out port, so you can connect more fixtures with DMX cables. The exact 
capabilities depend on the fixture; please refer to the fixture documentation for 
details. 

DMX interfaces 
The device which connects the DMX network to your computer is called a DMX 
interface. There are two kinds of interfaces: 

• USB–DMX interfaces: Lightkey works with USB interfaces from various 
manufacturers. You can find a list on the Lightkey website. 

in inoutout out
LED decoder
(8 outputs)in

Network router or switch

Cat 5 (Ethernet) cable

in in

in

out

in out
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USB interfaces with a built-in microprocessor buffer the DMX data received 
from the computer. If they don’t receive new data they continue to send the last 
state. Some low-end devices do not have a microprocessor: If the computer is 
busy and fails to send new data fast enough, the interface sends out zero 
values, which can cause the lights to flicker. 

• Network interfaces: Lightkey works with any interface that supports the Art-
Net, sACN (ANSI E1.31), or ESP Net protocols. You can use an Ethernet network 
or Wi-Fi to connect the interface to the computer. 

Network protocols can carry a large number of DMX universes, and Ethernet 
cabling or Wi-Fi are well-suited for covering long distances. If you want to 
output more than two universes you need to use a network interface. Lightkey 
can output up to four universes through Art-Net. Use sACN to output more 
universes. 

Fixture addresses 
Every fixture, dimmer pack, or LED decoder occupies a fixed range of channels within 
its universe. It’s important that these ranges do not overlap. However, it is possible to 
map multiple identical fixtures to the same range of channels: In this case, they will 
always behave identically. 

The first channel that a fixture occupies it called its address. You can choose any 
address between 1 and 512, as long as the last occupied channel does not exceed 
512. For example, if a fixture uses six channels then 507 is the highest possible 
address (fixture occupies channels 507 through 512). Also, keep in mind that the 
fixtures’ address ranges must not overlap. It’s fine if there are unused channels 
between fixtures. 

 

Some fixtures have a DIP switch (Dual In-line Package) for setting the address as a 
binary number. Other fixtures have an on-device menu. See the documentation that 
came with your fixture. 

Fixture address

Fixture 1
4 channels

Fixture 2
5 channels

Fixture address

076 082079 085077 083080 086 088078 084081 087
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How many channels does a fixture occupy? Some fixtures use a fixed number of 
channels, others have multiple modes (or “personalities”) with different capabilities 
and a different number of channels. They are described in the fixture’s manual. 

Before you begin assigning fixture addresses you should therefore consider which 
mode suits your needs best, and then determine how many channels each fixture 
requires. The combined number of channels determines how many universes you 
need. 
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Chapter 3   
Lightkey licenses 

 

Without a license output from Lightkey is limited 
to 24 DMX channels and five Hue lights. A license 
enables up to 8192 channels and 100 Hue lights. 

To use one of the paid Lightkey editions you need to purchase a license and activate 
it on your Mac. Activation binds the license to a particular computer. You can always 
deactivate the license to move it to a different computer. 

Buy a license 
You can buy licenses from the Lightkey Online Store. Licenses are always valid for 
one year. 

Go to the Online Store 

Do one of the following: 

‣ Open Lightkey and choose Lightkey > Buy License. 

‣ Go to lightkeyapp.com/en/buy. 

Activate your license 
When the purchase has been completed you receive an email with your license key. 
You use this key to activate the license on your computer. 
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For the standard activation process, the computer on which you want to activate a 
license must be connected to the Internet. There is an alternative way you can use if 
the computer has no Internet connection. 

Activate your license 

	 1	 Copy the license key to the Clipboard. 

	 2	 Open Lightkey and choose Lightkey > Manage License… 

	 3	 Click Activate License… 

	 4	 Paste the license key into the text field and then click Activate. 

Activate your license on a computer with no Internet connection 

	 1	 Copy the license key to the Clipboard. 

	 2	 Open Lightkey and choose Lightkey > Manage License… 

	 3	 Click “No Internet connection?”. 

	 4	 Paste the license key into the text field and then click Save File… 

	 5	 Choose a destination—for example, the Desktop—and then click Save. 

	 	 Lightkey creates an Activation Request file in the selected location. 

	 6	 Click Done. 

	 7	 Email the Activation Request file to activate@lightkeyapp.com. 

	 	 You will shortly receive a reply email with an Activation Response file. We try to 
process activation requests as soon as possible, but can do so only within our 
business hours. 

	 8	 Double-click the Activation Response file. 

	 	 Lightkey will show a dialog which tells you that it has been successfully 
activated. 

	 9	 Click Done. 

Renew your license 
A few days before your license expires, Lightkey will show a reminder dialog each 
time you start the application. In the dialog, you can click Buy License… to go directly 
to the Lightkey Online Store. 
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Renew your license 

	 1	 Go to the Lightkey Online Store and select an edition. 

	 2	 During the purchase process you are asked for the starting date of your license. 
Enter the date when your old license expires. (To find the expiration date, open 
Lightkey and choose Lightkey > Manage License…) 

	 3	 Complete the purchase process. At the end you will receive an email with a new 
license key. 

	 4	 On the day when your old license expires, choose Lightkey > Manage License… 
and then activate the new license: 

‣ Click Deactivate License to deactivate the old license. 

‣ Click Activate License… and paste the new license key. 

	 	 Deactivating the license does not affect your data or settings. 

Move a license between computers 
A license can only be active on one computer at a time, but you can move it between 
computers as often as you like. This requires that you deactivate the license on the 
computer where it’s currently activated. 

For the standard deactivation process, the computer must be connected to the 
Internet. There is an alternative way which works similar to the activation process 
with no Internet connection (see Activate your license above). 

Move a license to another computer 

	 1	 Open Lightkey on the computer where your license is currently activated and 
choose Lightkey > Manage License… 

	 2	 Click Deactivate License, then click Done. This does not affect your data or 
settings. 

	 3	 Activate the license on the new computer, as described in Activate your license. 

 

	❖	 Note: After deactivation, the first computer still “remembers” the license key 
and suggests it again when you activate a license. This makes it easy to 
repeatedly move a license between computers.
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If you no longer have access to the computer with the active license, please contact 
our support team. 

Moving the license does not move your projects, which are stored locally on the 
computer. To move a project, use the Finder to copy the project file to the other 
computer. 
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Chapter 4   
Set up your lights 

 

Before you can create light shows, you need to 
tell Lightkey about your lighting installation. 
An interactive assistant guides you through 
configuring DMX output, patching your fixtures, 
and building the virtual Preview. 

This chapter is about setting up DMX fixtures. Philips Hue smart lights are discussed 
in chapter 15, Smart lights. 

Step 1: Create a project 
When you first start Lightkey, the Project Browser appears. It shows a preview of the 
recently used projects (probably none if you’re just getting started) and the built-in 
demo projects. 

Create a new project 

	 1	 In the Project Browser, click New Project. 

	 2	 Enter a name and choose a location for the project file, then click Save. 

For more information about projects, see chapter 5, Projects. 
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Step 2: Choose an output method 
Next, you need to tell Lightkey how you will output DMX. The following options are 
available: 

• No DMX Output: Disables DMX output. Use this if you want to test Lightkey with 
no fixtures connected. You can always add an output method later. 

• USB: This option shows a list of all connected USB–DMX interfaces that are 
compatible with Lightkey. If your interface is missing, click Find Devices. If this 
doesn’t help, refer to If your USB–DMX interface does not appear in chapter 14, 
DMX output and input. 

• Art-Net: Art-Net is a communication protocol for distributing DMX data over a 
local network. Select the network interface which your Art-Net interface is 
connected to (for example, your computer’s Ethernet port) and then select your 
Art-Net interface from the list. If your interface is missing, click Find Devices. 
See DMX Output settings in chapter 14, DMX output and input, for more 
information. 

• sACN: Streaming ACN (sACN or ANSI E1.31) is a communication protocol for 
distributing DMX data over a local network. Select the network interface which 
your sACN interface is connected to (for example, your computer’s Ethernet 
port). Lightkey sends its output to all sACN nodes on this network, so you don’t 
need to select your sACN interface. See DMX Output settings in chapter 14, DMX 
output and input, for more information. 

• ESP Net: ESP (Enttec Show Protocol) is a DMX-over-Ethernet communication 
protocol developed by Enttec. Select the network interface which your ESP Net 
interface is connected to (for example, your computer’s Ethernet port). See 
DMX Output settings in chapter 14, DMX output and input, for more information. 

Choose an output method 

‣ Select one of the output methods as described above, then click Next. 

Lightkey creates a single DMX universe with the selected output method. If you wish 
to use multiple universes you can add them later, as described in Configure 
universes in chapter 14, DMX output and input. If you with to add smart lights see 
chapter 15, Smart lights. 
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Step 3: Patch your fixtures 
In the next step you will tell Lightkey about your fixtures. For each type of fixture you 
need a fixture profile, a file which contains a description of the fixture’s capabilities 
and the way they are controlled. For each of your fixtures you need to tell Lightkey 
which DMX universe it’s connected to and which DMX address it responds to. 

On the left of the window is the fixture library which contains all built-in, imported, 
and user-created fixture profiles. Lightkey comes with thousands of fixture profiles 
from many different manufacturers, and it can import many freely available profiles 
in the formats SSL2, FXT, and PFF. The first column lists the manufacturers, the 
second column shows the profiles for the selected manufacturer. The library also 
contains a number of generic profiles which don’t relate to a specific fixture model. 

On the right is a grid representing the 512 DMX channels in a universe. Your license 
determines how many channels are available for output. New projects contain a 
single universe, but you can add more universes later. 

Find the right fixture profile 
For simple fixtures you can often use one of the profiles in the Generic category of 
the built-in library. You can find an overview of the generic profiles at the end of this 
User Guide. 

The Generic category also includes a selection of flexible fixture profiles (“FLEX”). 
Flexible fixture profiles are for LED strips and matrixes and let you choose the 
desired number of LEDs when you patch the fixture. 

If your lights are connected through a dimmer pack, patch the generic profiles PAR 
Wash, PAR Spot, or PAR Beam (depending on the type of light) several times to 
consecutive channels—once for each light. (For a switch pack, use the generic Switch 
profile.) The address of the first fixture must match the address of your dimmer/
switch pack. This way each light appears as a separate fixture in the Preview and you 
don’t need a fixture profile for the dimmer or switch pack. 

For more complex lights, you need a profile specific to the fixture. It’s important to 
use a fixture profile which exactly matches your fixture model, or the fixture will not 
work correctly. Profiles for other—even similar—lights will often not work. 
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Find a profile for a specific fixture 

	 1	 Browse the built-in fixture library for a matching profile. Use the search field at 
the top to search by manufacturer or model name. Profile names generally 
match the name on the cover page of the fixture manual. Double-click a profile 
to see more information. 

	 2	 Check Lightkey’s online fixture library. It’s frequently updated and contains a 
large number of high-quality profiles in Lightkey’s native format. 

	 3	 We can create a profile for you if you send us the fixture’s DMX chart (usually 
part of the manual and/or available as a PDF on the manufacturer’s website). 
Please use this online form to request a profile. 

	 4	 Create a profile using Lightkey’s built-in fixture editor or import a profile in the 
formats SSL2 (Sunlite) or PFF/FXT (DMX FreeStyler). There are thousands of 
free profiles available on the Internet. Note that imported profiles may need a 
bit of editing in the fixture editor before they work correctly with Lightkey. 

	 	 Click 􀍠 at the top of the fixture library and then choose New Profile… to create 
a new profile, or Import Profiles… to import a profile. 

Add your fixtures 
Once you have profiles for your fixtures, you can add them to the channel grid. The 
process of filling the grid with fixtures is called patching. 

Add your fixtures 

	 1	 Drag a fixture profile from the library to the channel grid. The first occupied 
channel should match the fixture’s DMX address. Fixtures must not overlap. 

The fixture will appear in the channel grid with a dashed outline. Below it you 
see a window with additional options. 

 

2
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	 2	 If the fixture has different operation modes (or “personalities”), select a mode 
from the pop-up menu below the fixture name. Be sure to select the same 
mode as on the fixture, or Lightkey will not be able to control the fixture. The 
mode determines how many channels the fixture occupies. 

	 	 When patching a flexible LED strip or matrix, you can enter the desired number 
of LEDs here. The fixture will grow or shrink in the channel grid depending on 
the number of LEDs. 

 

	 3	 Assign a short name to the fixture. Short names appear in Lightkey’s Preview; 
they can be up to four characters long and typically include one or two letters 
and a number. If the short name ends with a number, you can increase/
decrease it by pressing the Up/Down Arrow keys while the insertion point is in 
the field. 

	 	 Lightkey proposes a short name based on the fixture type, but you should 
choose a naming scheme that’s suitable for your lighting installation. For 
example, if you have a row of PAR cans on the floor and one at the ceiling, you 
can name them F1, F2, F3, … and C1, C2, C3, … 

	 4	 If necessary, you can correct the fixture’s DMX address in the Address field. 
(You can increase/decrease the address by pressing the Up/Down Arrow keys 
while the insertion point is in the field.) 

	 5	 If the Count value is greater than one, Lightkey displays multiple instances of 
the fixture in the Preview which always share the same fixture properties. This 
is useful when you patch several identical fixtures to the same DMX address. 

	 6	 To patch multiple fixtures of the same type to consecutive DMX addresses, 
enter their number here. (You can increase/decrease the number by pressing 
the Up/Down Arrow keys while the insertion point is in the field.) 

3

5

4

6
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	 	 If the short name ends with a number, Lightkey automatically increments the 
number for each fixture. For example, if you add four moving heads and enter 
“MH6”, their names will be MH6 through MH9. 

	 7	 Click Patch (or press Return). 

	 8	 Repeat the steps until all fixtures have been added. If you don’t have profiles for 
some fixtures, you can come back and add them later. 

	 9	 Click Next. 

You can change the fixture patching information later. See chapter 13, Manage DMX 
fixtures, for more information. 

Step 4: Build the Preview 
Now you begin to build the Preview, a 2D representation of your lighting installation. 
The next screen shows a number of icons representing fixtures. Drag the icons 
around so they approximately match the physical locations of your fixtures. You can 
also add shapes and images. 
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Depending on the venue and the location of the lighting computer you can use a top 
view (e.g. a floor plan) or a front view (e.g. of your stage). 

Locate fixtures 
If you’re not sure which fixture a particular icon belongs to, you can use Highlight 
Mode. When Highlight Mode is enabled, the selected fixture(s) will light up. This 
works for both DMX fixtures and smart lights. 

Enable Highlight Mode 

‣ Click  in the toolbar or choose Layout > Highlight Mode (or press Command-

Shift-H). 

PAR Moving head, scanner Light bulb

Array of PARs Array of moving heads

Strobe Blinder Panel

Fog machine Switch Laser, generic fixture

LED bar LED matrix

LED strip (open) LED strip (closed)
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Size and rotate fixture icons 
Change the length and rotation of the icons to reflect the size and placement of the 
actual fixture. This works for LED fixtures as well as PAR and moving head arrays. 
You can “bend” LED strips to any shape and choose between two icon sizes for LED 
fixtures. 

Select multiple fixtures to resize or rotate them at once, provided they are of the 
same type. 

Resize or rotate a fixture icon 

‣ Click the fixture icon to select it, then drag one of the blue selection handles 
around it. 

Rotate an LED matrix 

	 1	 Click the fixture icon to select it. 

	 2	 Hold down the Command key and drag one of the blue selection handles around 
it. 

Edit the shape of an LED strip 

	 1	 Select one or more LED strips. 

	 2	 Click Edit Shape in the Inspector or press Return. 

	 3	 Use the yellow handles to change the shape: 

‣ 	To select a single handle, click the handle. 

‣ To select multiple handles, press the mouse button over a blank part of 
the Preview and drag across the handles. 

‣ To toggle a handle’s selection state, hold down the Command key and 
click the handle. 

‣ To select a range of handles, click the first handle, then hold down the 
Shift key and click the last handle in the range. 

‣ To select the handles one by one, press Control-Tab. Press Control-Shift-
Tab to reverse the order. 

‣ To move the selected handles, drag them. You can also press the Arrow 
keys. 
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‣ 	To add a handle, place the pointer in between two yellow handles, then 
click the white handle that appears in between them. 

‣ 	To remove the selected handles, choose Edit > Delete or press the Delete 
key. 

	 4	 To end editing the shape, press Return or click in the empty area outside the 
LED strip. 

Change the icon size of LED strips and matrixes 

	 1	 Select one or more LED fixtures. 

	 2	 Click one of the size options on the right. 

Add shapes, images, and text 
You can add shapes (such as rectangles, ovals, lines, and trusses) as well as built-in 
or custom images to create a visual representation of your venue. You can also add 
text labels. 

Add an object 

Do one of the following: 

‣ Click either Shapes or Images in the right sidebar, then drag an object to the 
desired position in the Preview. 

‣ Choose Layout > Insert and then choose one of the options in the submenu. 

Add a custom image 

Do one of the following: 

‣ Choose Layout > Insert > Image File…, then select an image file and click 
Insert. Lightkey can handle all common image formats. 

‣ To add an image from another application, copy the image to the Clipboard, go 
to Lightkey, and choose Edit > Paste. 

‣ Drag an image file from the Finder to the Preview area and position it where 
you want it. 

After adding an image, drag it to the desired location and adjust its size by dragging 
one of the blue selection handles around it. Hold down the Command key as you 
resize an image to distort its aspect ratio. 
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Add text 

	 1	 Click Shapes, then place the pointer over the  icon and drag it to the desired 
location in the Preview. 

	 2	 Double-click the text to select it, then type. 

	 3	 To change the text formatting, choose Edit > Font > Show Fonts and then use 
the Font window to change the font, font size, and other options. 

	 4	 Click outside the text or press Return to finish editing. 

There are many more things you can do when you design your preview. See chapter 
7, Preview, for details. 

When you are done creating your preview, click Next. 

Step 5: Group fixtures 
In the next step you can create groups of similar fixtures. Grouped fixtures can be 
quickly selected at once, although it is still possible to select them individually. You 
should group fixtures with the same type and in the same location—for example, a 
row of blinders above the stage. 

Create a fixture group 

	 1	 Select the fixtures to be grouped. You can press the mouse button over a blank 
part of the Preview and drag it over the fixtures. Alternatively, hold down the 
Shift key and click the fixtures one by one. 

	 2	 Do one of the following: 

‣ Click  in the toolbar. 

‣ Control-click one of the fixtures and choose Group from the shortcut 
menu. 

‣ Choose Layout > Group (or press Command-Option-G). 

When you’re done creating fixture groups, click Next. 

T
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Step 6: Set beam directions 

 

In this step you tell Lightkey about the positions of your moving and static lights so it 
can match what you see on the screen with the actual fixture. This is called 
calibration. 

Calibrate the position of a moving light 

	 1	 Click Set… below the fixture icon. 

	 2	 Follow the instructions and click Next after each step, or Done after the last 
step. 

‣ Home: This step tells Lightkey in which direction the fixture is pointing. 
The fixture moves to the center of its pan range and tilts by 90°. 

Imagine you’re looking through the base of the moving light in the 
direction of the pan axis. Drag the arrow until it points in the direction of 
the light beam. 

‣ Rotation: This step tells Lightkey in which direction the light turns. The 
light performs a slow pan movement, then turns back in blackout and 
repeats the movement. 

The rotating arrow should follow the direction of the light beam. If 
necessary, click the arrow to reverse its direction. 

‣ Limits: This steps is optional. It allows you to limit the allowed ranges for 
pan and tilt. This can be useful, for example, to prevent a light from 
pointing directly at a wall behind it or into the DJ booth. 

Drag the handles to limit the allowed ranges for pan and tilt. 

‣ Perspective: This step is important to make the virtual light beams match 
the fixture. The light moves to the center of its pan and tilt ranges. 

Consider the Preview on the screen. Select the direction in which the light 
beam is currently pointing—to the left or right, up or down, or parallel to 
the viewing direction. 

	 	 When calibration is complete, a checkmark appears below the fixture icon. 

	❖	 Note: This step only applies if you have fixtures with virtual light beams 
(PARs, moving heads, scanners, blinders, strobes, panels, or LED bars).
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Calibrate the position of a static light 

	 1	 Click Set… below the fixture icon. 

	 2	 Follow the instructions, then click Done. 

	 	 When you’re done, a checkmark appears below the fixture icon. 

 

Once you have set the beam positions for all fixtures, click Next. 

Step 7: Set beam colors 

 

For fixtures with a static color, you need to tell Lightkey the color for the virtual light 
beam. 

Set a fixture’s beam color 

	 1	 Click Set… below the fixture icon. 

	 2	 Choose a color. 

	 	 When you’re done, a checkmark appears below the fixture icon. 

 

Once you have set the beam colors for all fixtures, click Next. 

You’re done 
After completing these steps, Lightkey is ready to control your lights. Click Get 
Started, and you will see the normal Lightkey window. For more information about 
the parts of the window, refer to chapter 6, The Lightkey window. 

	★	 Tip: Select multiple fixtures of the same type to set their beam directions at 
once (assuming they point in the same direction).

	❖	 Note: This step only applies if you have any monochrome fixtures whose color 
can’t be controlled through DMX.

	★	 Tip: Select multiple fixtures to set their beam colors at once.
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If you did not complete all steps during the setup, you can come back and change the 
settings at any time: 

‣ Click Edit in the toolbar or choose View > Edit Preview to edit the Preview. 

‣ Click  in the toolbar or choose Lightkey > Manage Fixtures… to add, remove, 
or change fixtures and manage DMX output settings. 
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Chapter 5   
Projects 

 

The first thing you see when you open Lightkey is 
the Project Browser. It shows the most recently 
used projects (if any) and two demo projects. 

A Lightkey project is a file which contains all the information about your fixtures and 
light shows for a given lighting installation. A project contains: 

You can create as many projects as you like, but only one can be open at a time. 
Having multiple projects can be useful if you use Lightkey in different environments, 
but in most cases a single project is all you need. 

You can also copy project files between computers—for example, to edit the project 
on a second computer and then move it back to the main lighting computer. The 
project file includes copies of the fixture profiles used in the project, so projects with 
self-created profiles will work instantly on any computer. 
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• Your fixtures’ patching information 

• Configuration information for your universes 

• The virtual Preview 

• Presets, sequences, and cues 

• Effect templates and movement paths 

• Live view pages 

• Your external control configurations



Because Lightkey uses the macOS Auto Save technology, projects are saved 
automatically in the background. 

Create a project 

	 1	 If a project is open, choose File > Close Project. The Project Browser appears. 

	 2	 Click New Project or choose File > New Project. 

	 3	 Enter a name and choose a location for the project file, then click Save. 

	 4	 Follow the instructions of the interactive assistant to set up your project. The 
setup process is explained in chapter 4, Set up your lights. 

Open or close a project 
When you start Lightkey, it automatically opens the recently used project. Therefore, 
as long as you only have a single project, you rarely need to manually open or close 
projects. When you close a project, all of your changes are saved. 

 

Open a project 

	 1	 If another project is currently open, choose File > Close Project. The Project 
Browser appears. 

	 2	 Do one of the following: 

‣ If the desired project appears in the Project Browser, double-click it. 

‣ Choose File > Open…, select a project file, and click Open. 

‣ Double-click a project file in the Finder. 

Close the current project 

	 1	 Do one of the following: 

‣ Choose File > Close Project (or press Command-W). 

‣ Click the red close button in the upper-left corner of the Lightkey window. 

	★	 Tip: To have Lightkey reopen the last project when you start the application, 
make sure that “Close windows when quitting an application” is turned off in 
the Desktop & Dock pane of System Settings.
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	 2	 If Lightkey asks you if you are sure, click Close. This is a precaution to prevent 
you from accidentally closing the project and turning off all lights. 

	 	 After closing the project, Lightkey returns to the Project Browser. 

What happens when you close a project 
When you close a project or quit the application, Lightkey performs the following 
steps, in this order, depending on your settings: 

	 1	 It sets your lights’ Dimmer properties to zero. This affects all DMX fixtures 
which have a Dimmer property and all Hue fixtures. 

	 2	 It applies any cues with the “Activate before quitting” option for approximately 
0.5 seconds. This is useful to reset moving heads to their home position or turn 
off fixtures with no Dimmer property. See Edit button appearance and behavior 
in chapter 11, Live control. 

	 3	 If enabled, it sends a “Lamp Off” command to fixtures for a preset duration 
which turns off their illuminant. This applies to all DMX fixtures which support 
Lamp On/Off commands. 

	 4	 If enabled, it sets the channels in all output universes to zero. This can be 
useful when using other controllers such as DMX wall panels which only take 
control when all DMX channels are zero. 

You can choose which of these steps should be performed in the Settings window. 

Choose what happens when you close a project 

	 1	 Choose Lightkey > Settings… (or press Command-Comma) and then click 
General. 

	 2	 Change the settings in the section labelled “Before quitting”. 

Rename a project or save a copy 
You can rename the currently open project or save a copy with a new name. 

Rename the current project 

‣ Click the project name at the top of the window, then type a new name. 
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Save a copy of the current project 

	 1	 Choose File > Save As… (or press Command-Option-Shift-S). 

	 2	 Enter a name and choose a location for the project file, then click Save. 

You can then continue with the copied project. 

Manage projects 
When no project is open, the Project Browser shows the most recently used projects 
for quick access. You can change the number of projects shown. 

Change the number of recent projects shown 

‣ Click the arrow next to Recent Projects and choose an item from the menu. 

Clear the recent projects 

‣ Control-click one of the recent projects, then choose Clear Recent Projects 
from the shortcut menu. 

Use the Finder for tasks like duplicating or deleting projects. If you want to move a 
project to another computer, all you need to do is copy the project file. 

Locate a project in the Finder 

‣ If the project is currently open, hold down the Command key and click the 
project’s name at the top of the window. A menu appears showing the hierarchy 
of folders and volumes which contain the project. Select the topmost folder to 
show the project file in the Finder. 

‣ If the project is not currently open, Control-click it the Project Browser, then 
choose Show in Finder from the shortcut menu. 

Move a project to another Mac 

‣ Use the Finder to copy the project file to the other computer (for example, using 
AirDrop). The file contains all the necessary information to use the project on 
another computer. 

On the target computer, double-click the file to open it. The project will not 
appear under Recent Projects until it has been opened. 
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Note that older Lightkey versions may not be able to open projects created by newer 
versions, because they contain new features which previous versions don’t know 
about. If you want to move a project back and forth between computers you should 
therefore use the same Lightkey version on both. 

Search a project 
Lightkey lets you easily and quickly search the contents of the current project. This 
includes: 

• fixtures and fixture properties, 

• items in the Preset Palette, 

• cues and other items in the Live view. 

You can also “filter” the content of the Preset Palette and a cuelist so that only items 
whose name contains the search text are shown. 

Find items in a project 

	 1	 Do one of the following: 

‣ Click 􀊫 in the toolbar. 

‣ Choose Edit > Find… (or press Command-Option-F). 

	 A search field appears near the right end of the toolbar. 

	 2	 Make sure the placeholder text in the search field reads Search Project. If not, 
click the  symbol in the field and choose Entire Project from the menu. 

	 3	 Enter the text to search for in the search field. As you type a list of results 
appears. 

	 4	 Click a result to select it in the project. 

 

	★	 Tip: You can use the Up/Down Arrow keys to select search results, and the 
Return key to select a result in the project. Press Esc to hide the search 
results.
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Filter items in the Preset Palette 

	 1	 Reveal the search field in the toolbar, as described above. 

	 2	 Click the 􀊫 symbol in the search field and choose Preset Palette from the 
menu. 

	 3	 Enter the text to search for in the search field. As you type the Preset Palette is 
filtered accordingly. 

	 4	 To remove the filter click 􀁡 in the search field. 

Filter items in a cuelist 

	 1	 Reveal the search field in the toolbar, as described above. 

	 2	 Click the  symbol in the search field and choose Cuelist from the menu. This 

option is only available if the current Live view page contains a cuelist. 

	 3	 Enter the text to search for in the search field. As you type the cuelist is filtered 
accordingly. 

	 4	 To remove the filter click 􀁡 in the search field. 

Undo changes 
As you work with Lightkey, you can undo most of the changes you can do to a project. 
This includes changes to the Preview, presets, sequences, cues, effects, the Live 
view, and even fixture properties. You can also redo actions that you have undone. 

Undo or redo changes 

‣ To undo the last action, choose Edit > Undo (or press Command-Z). 

‣ To redo the last action you undid, choose Edit > Redo (or press Command-
Shift-Z). 
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Chapter 6   
The Lightkey window 

 

This chapter introduces the user interface that’s 
shown once you open a project. All the controls 
you need are united in a single, well-arranged 
window. The dark user interface has been 
specially designed for low-light environments. 
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The toolbar provides quick 
access to many features

The Preview shows the 
fixtures on your stage or 
dance floor

The Preset Palette is where 
you manage presets and 
sequences

The Shortcuts view shows 
keyboard shortcuts and 
gestures for the current 
context

The Design view lets you change the properties of the selected fixtures. 
The properties you see here depend on the selected fixtures.



Toolbar 
The toolbar at the top of the window shows the current project’s name and provides 
quick access to frequently-used functions. The items in the toolbar change 
depending on the current context. Here’s how the toolbar looks once you open a 
project: 

 

A

G H I J K L

B C D E F

A Manage fixtures

B Lock or unlock Lightkey

C Show the overridden fixture properties

D Clear the overridden fixture properties

E Enter or exit blind mode

F Freeze or unfreeze output

G Show actions for the selected fixtures

H Add an effect for the selected fixtures

I Edit the Preview

J Add a preset (hold down the mouse button to add sequences or groups)

K Search the project

L Show view options

Lightkey User Guide	 46



Customize the Lightkey window 
You can show or hide parts of Lightkey’s window depending on your needs: For 
example, during a live show you may want to switch to the Live view and hide the 
Preset Palette. You may even hide the Preview entirely to have more space for the 
Live view. Or you may want to hide the Shortcuts view once you’re familiar with the 
shortcuts. 

Switch between the Design and Live view 

Do one of the following: 

‣ Click Design or Live below the Preview. 

‣ Choose View > Design (or press Command-D) to show the Design view. Choose 
View > Live (or press Command-L) to show the Live view. 

Hide or show the Preview 

Do one of the following: 

‣ Click  in the toolbar and choose Hide/Show Preview from the menu. 

‣ Choose View > Hide/Show Preview (or press Command-Shift-R). 

 

Hide or show the Preset Palette 

Do one of the following: 

‣ Click  in the toolbar and choose Hide/Show Preset Palette from the menu. 

‣ Choose View > Hide/Show Preset Palette (or press Command-Shift-P). 

Hide or show the Shortcuts area 

Do one of the following: 

‣ Click  in the toolbar and choose Hide/Show Shortcuts from the menu. 

‣ Choose View > Hide/Show Shortcuts (or press Command-Shift-S). 

	❖	 Note: The Design view isn’t available when the Preview is hidden because 
there’s no way to select fixtures.
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Resize the parts of the window 

‣ Drag one of the dividers between the parts. 

Full screen view 
Lightkey’s user interface is ideally suited for the macOS full screen view. By default, 
the window expands to the entire screen when you open a project and shrinks back to 
a window when you close a project. 

In full screen view, move the pointer to the top of the screen to show the menu bar. 

Zoom the Lightkey window to the full screen 

Do one of the following: 

‣ Click the green zoom button in the top-left corner of the window. 

‣ Choose View > Enter Full Screen (or press Command-F). 

Return to regular view 

Do one of the following: 

‣ Move the pointer to the top of the screen, then click the green zoom button in 
the top-left corner. 

‣ Choose View > Exit Full Screen (or press Command-F). 

Change the behavior when opening and closing a project 

	 1	 Choose Lightkey > Settings… (or press Command-Comma) and then click 
General. 

	 2	 Select “Enter full screen when opening a project” to automatically expand the 
window to the entire screen when you open a project and shrink it back when 
you close the project. 
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Dual windows 
If you have a second display connected to your computer, you can place the Preview 
on one display and the Live view on the other. You can also use an iPad as a second 
display for the Live view using apps like Duet or Luna Display. 

 

Show the Live view on a second display 

	 1	 Choose View > Dual Windows. 

	 	 The Live view appears in a second window titled Live. 

	 2	 Drag the Live window to the second display. 

	 3	 Click in the Live window to make sure it’s selected, then choose View > Enter 
Full Screen to expand the window to the full screen. 

Lightkey restores the two windows on their respective screens when you quit and 
reopen the application. To return the Live view to the main window, choose View > 
Single Window. 

Adaptive background color 
By default, the background of Lightkey’s window adapts itself to the predominant 
light color. 

Change the adaptive background color 

	 1	 Choose Lightkey > Settings… and then click General. 

	 2	 Select or deselect “Adaptive background color”. 
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Lock Lightkey 
You can protect your projects and settings against changes with a password, Touch 
ID (if available on your Mac), or an Apple Watch which is set up to unlock your Mac. 
Only people who know the password can: 

• edit presets, sequences, or cues, 

• edit the Preview, Live view, and Design view, 

• patch fixtures and universes, 

• edit external control configurations, 

• open the Settings window. 

In addition, you can optionally lock the Preset Palette, Design view, and HUDs. In this 
mode users can only control the lights from the Live view. You can also lock 
individual cue buttons in the Live view. 

To set up Touch ID or unlocking with an Apple Watch, go to System Settings > Touch 
ID & Password. 

Lock Lightkey with a password 

	 1	 Click 􀎤 in the toolbar or choose Lightkey > Lock. 

	 2	 In the dialog that appears, enter a password in the Password field, then enter it 
again in the Verify field. 

	 3	 Enter a hint to help you remember the password. The hint appears if you enter 
the wrong password three consecutive times. 

	 4	 Click Options to select additional settings: 

‣ Select “Using the Preset Palette, Design view, and HUDs” to prevent 
access to the Preset Palette, Design view, and HUDs when Lightkey is 
locked. (The corresponding external control actions will also be disabled.) 

‣ Select “Touch ID” or “Apple Watch” to allow unlocking with the respective 
options. 

	 5	 Click Lock. 

	 	 Note that the lock icon in the toolbar is now closed. 

Unlock Lightkey 

	 1	 Click 􀎠 in the toolbar or choose Lightkey > Unlock… 
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	 2	 Enter your password and then click Unlock, place your finger on the Touch ID 
sensor, or confirm with your Apple Watch. 

The lock icon in the toolbar is now open. Lightkey remains unlocked until you 
quit the application or lock it again. 

Lock Lightkey again 

‣ Click 􀎤 in the toolbar or choose Lightkey > Lock. 

Permanently remove the password protection 

	 1	 Choose Lightkey > Remove Lock. 

	 2	 Enter your password, place your finger on the Touch ID sensor, or confirm with 
your Apple Watch (only necessary if Lightkey is currently locked). 

You can extend the password protection to individual cue buttons in the Live view. 
When you do this, the cue can only be activated or deactivated when Lightkey is 
unlocked. For example, you could create an “always-on” cue which operators cannot 
deactivate. 

For more information about cue buttons see chapter 11, Live Control. 

Require unlocking to activate or deactivate a cue button 

	 1	 Open the cue inspector, as described in Edit cue contents and options in chapter 
11, Live control. 

	 2	 Scroll to “Options”. 

	 3	 Select “Require unlocked app”. 

The button’s initial state depends on the “Restore active cues, modifiers, and Master 
Dimmer” option in the Settings window: 

• If the option is selected, Lightkey preserves the cue’s state at the time it was 
locked. 

• Otherwise, the cue is off by default when you open Lightkey or the project. If you 
want the cue to be active, select the option “Activate at startup” in the cue 
inspector. 

For more information see Startup state in chapter 11, Live Control. 
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Keyboard shortcuts and gestures 
Lightkey provides many keyboard shortcuts and Multi-Touch gestures to help you 
work faster. The Shortcuts view in the lower-right shows the most relevant shortcuts 
for the current context. You can find an overview of the built-in shortcuts and 
gestures in appendix 2, Shortcuts and gestures. 

In addition to that you can define your own keyboard shortcuts. See chapter 16, 
External control, for more information. 
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Chapter 7   
Preview 

 

The centerpiece of Lightkey’s user interface is a 
2D view of your lighting installation. You can 
extend it from simple fixture icons to a visual 
representation of your venue, complete with 
virtual light beams. 

You begin creating the Preview when you first set up your project, as described in 
chapter 4, Set up your lights, but you can always come back and complement it later. 
Lightkey includes a flexible graphics editor which lets you create a detailed view of 
your venue quickly and effortlessly. This chapter covers all tools and techniques for 
building the Preview. 

Zoom 
The Preview automatically adapts it size to fit all items in the available space (there is 
a minimum size which can’t be undercut, however). You can enlarge the view to focus 
on a section of your rig or select individual light beams more easily. 

Zoom the Preview 

‣ Hold down the Option key and scroll up or down while the mouse pointer is over 
the Preview. (The modifier key can be changed in Lightkey’s settings. See Multi-
Touch gestures in chapter 16, External control.) 

‣ On a trackpad, pinch using two fingers while the pointer is over the Preview 
(requires a multi-touch trackpad or Apple Magic Trackpad). 
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‣ Choose View > Zoom > Zoom In (or press Command–Plus) to enlarge the 
view. Choose Zoom Out (or press Command-Minus) to reduce the view. 

‣ Choose View > Zoom > Zoom to Fit (or press Command–0) to see all fixtures. 

‣ Choose View > Zoom > Zoom to Selection (or press Command–Shift–0) to 
zoom to the selected items. 

When the Preview is enlarged you can scroll to move the visible area. 

Edit the Preview 
Before you can change the objects in the Preview, you must put the Preview into edit 
mode. The remainder of this chapter assumes that the Preview is in edit mode. 

Enter or exit edit mode 

Do one of the following: 

‣ To enter edit mode, click Edit in the toolbar. To exit edit mode, click Done. 

‣ Choose View > Edit Preview (or press Command-J). 

‣ Control-click a blank part of the Preview and choose Edit Preview from the 
shortcut menu. 

‣ Hold down the Command key and double-click a blank part of the Preview. 

While the Preview is in edit mode, a grid is shown in the background which helps you 
to align objects. You can hold down the Space bar and drag to pan the Preview area.  
On the right of the window is the Inspector where you can change the properties of 
the selected objects. 

Edit objects 
The Preview contains various types of objects: Fixture icons, shapes (such as 
rectangles, ovals, lines, and trusses), text, and images. This section covers basic 
editing techniques common to all objects. 

Select objects 
Before you make changes to objects in the Preview you need to select them. 
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Select or deselect objects 

‣ To select a single object, click anywhere on the object. 

‣ To select additional objects, hold down the Shift key and click each object. 

‣ To remove an object from the selection, hold down the Shift key and click the 
selected object. 

‣ To select a fixture that is part of a group, double-click the fixture. 

‣ To select multiple objects at once, press the mouse button over a blank part of 
the Preview and drag it over the objects. (Hold down the Option key to select 
outward from the starting point.) 

‣ To add or remove multiple objects to/from the selection, hold down the Shift 
key, press the mouse button over a blank part of the Preview, and drag it over 
the objects. 

‣ To select all objects in the Preview, choose Edit > Select All (or press 
Command-A). 

‣ To deselect all objects in the Preview, choose Edit > Deselect All (or press 
Command-Shift-A or Esc) or click a blank part of the Preview. 

Move objects 
All objects in the Preview can be moved freely. You can scroll in any direction if you 
need more space. When you exit edit mode, Lightkey adjusts the size of the Preview 
to fit all objects in the available space. 

Move objects within the Preview 

‣ Press the mouse button over an object and drag it to a new location. To move 
multiple objects, select the objects and then drag them to a new location. 

As you drag, Lightkey shows smart alignment and spacing guides that help you 
to precisely align objects. 

‣ To disable alignment and spacing guides, hold down the Control key as you 
drag. 

‣ To constrain the motion to horizontal or vertical, drag the object(s) while 
holding down the Shift key. 
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‣ To move objects in small steps, select the objects and press one of the arrow 
keys. To move objects in larger steps, hold down the Shift key while pressing an 
arrow key. 

Align objects 
You can quickly align objects so they line up along a horizontal or vertical axis. 

 

Align objects 

	 1	 Select the objects you want to align. 

	 2	 Do one of the following: 

‣ Choose Layout > Align and then choose one of the options in the 
submenu. 

‣ Click 􀩉 in the toolbar and choose one of the options in the menu. 

‣ Control-click one of the objects and choose one of the options in the Align 
submenu of the shortcut menu. 

Space objects evenly 
You can quickly position objects with even spacing on the horizontal or vertical axis. 

 

Space objects evenly 

	 1	 Select the objects. 

	 2	 Do one of the following: 

‣ Choose Layout > Distribute and then choose one of the options in the 
submenu. 

‣ Click 􀩉 in the toolbar and choose one of the options in the menu. 

Vertical centers aligned

Even horizontal spacing
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‣ Control-click one of the objects and choose one of the options in the 
Distribute submenu of the shortcut menu. 

Resize and rotate objects 
Resizable objects show handles when they are selected. You can resize multiple 
objects of the same kind at once. Some fixtures can’t be resized and have no handles. 

Resize one or more objects 

‣ Select one or more objects and then drag one of the blue selection handles. To 
resize objects in one direction, drag a side handle instead of a corner handle. 

‣ To resize objects from their center, press the Option key as you drag. 

‣ To constrain a rectangle or oval to a square or circle, hold down the Shift key as 
you drag. 

‣ To constrain a curved truss to a circle segment, hold down the Shift key as you 
drag. 

‣ To constrain a line’s or straight truss’s angle to 45°, hold down the Shift key as 
you drag. 

‣ Some objects maintain their proportions when resized. To resize those objects 
disproportionally, hold down the Command key as you drag. 

‣ To disable alignment and spacing guides, hold down the Control key while you 
resize objects. 

Rectangles, rounded rectangles, ovals, triangles, images, and LED matrixes can also 
be rotated freely. You can rotate multiple objects at once. 

Rotate an object 

	 1	 Select one or more objects. 

	 2	 Hold down the Command key and drag one of the blue selection handles around 
it. Hold down Shift to constrain the angle to 45°. 

Edit fixtures 
This section discusses editing actions which pertain to fixtures. 
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Size and rotate fixture icons 
LED fixtures can be represented in various ways, depending on the number of beams 
and their arrangement (as defined by the fixture profile) and the shape you choose 
for their icon. You can freely edit their shape and change the icon size to reflect the 
physical LED strip. Here are various types of icons for LED fixtures: 

 

You can also change the size and orientation of PAR or moving head arrays. 

Change the icon size of LED strips and matrixes 

	 1	 Select one or more LED fixtures. 

	 2	 Click one of the two size options in the Inspector. 

Change between a line and a ring 

	 1	 Select one or more LED strips. 

	 2	 Click either the line    or ring    option in the Inspector. 

Flip LED fixtures horizontally or vertically 

	 1	 Select one or more LED fixtures. 

	 2	 Do one of the following: 

‣ Click  or  in the toolbar. 

‣ Click one of the fixtures’ name and choose Flip Horizontally or Flip 
Vertically from the shortcut menu. 

‣ Choose Layout > Flip Horizontally or Flip Vertically. 

Edit the shape of an LED strip 

	 1	 Select one or more LED strips. 

	 2	 Click Edit Shape in the Inspector or press Return. 

	 3	 Use the yellow handles to change the shape: 

‣ 	To select a single handle, click the handle. 
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‣ To select multiple handles, press the mouse button over a blank part of 
the Preview and drag across the handles. 

‣ To toggle a handle’s selection state, hold down the Command key and 
click the handle. 

‣ To select a range of handles, click the first handle, then hold down the 
Shift key and click the last handle in the range. 

‣ To select the handles one by one, press Control-Tab. Press Control-Shift-
Tab to reverse the order. 

‣ To move the selected handles, drag them. You can also press the Arrow 
keys. 

‣ 	To add a handle, place the pointer in between two yellow handles, then 
click the white handle that appears in between them. 

‣ 	To remove the selected handles, choose Edit > Delete or press the Delete 
key. 

	 4	 To end editing the shape, press Return or click in the empty area outside the 
LED strip. 

Position fixture names 
You can reposition the name tags of fixtures to prevent them from overlapping with 
other objects. 

Move a fixture’s name tag 

‣ Drag the name tag to a position near the fixture’s icon. 

Set beam directions 
Moving lights, PARS, and similar fixtures are represented by round icons in the 
Preview. For moving lights, an arrow indicates the current pan position: 

 

Lightkey needs some information about the positions of your moving and static lights 
to match what you see on the screen with the actual fixture. This is called calibration. 

Moving light Static light
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Calibrate the position of a moving light 

	 1	 Click the fixture icon to select it. 

	 2	 Do one of the following: 

‣ Click Beam Direction… in the Inspector. 

‣ Click the fixture’s name and choose Beam Direction… from the shortcut 
menu. 

‣ Choose Layout > Beam Direction… (or press Command-Shift-Option-P). 

	 3	 Follow the instructions and click Next after each step, or Done after the last 
step. 

‣ Home: This step tells Lightkey in which direction the fixture is pointing. 
The fixture moves to the center of its pan range—the home angle—and 
tilts by 90°. 

Imagine you’re looking through the base of the moving light in the 
direction of the pan axis. Drag the arrow until it points in the direction of 
the light beam. 

 

‣ Rotation: This step tells Lightkey in which direction the fixture’s yoke 
turns. The light performs a slow pan movement, then turns back in 
blackout and repeats the movement. 

The rotating arrow should follow the direction of the light beam. If 
necessary, click the arrow to reverse its direction. 

Pan axis

Viewing direction
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‣ Limits: This step is optional. It allows you to limit the allowed ranges for 
pan and tilt. This can be useful, for example, to prevent a light from 
pointing directly at a wall behind it or into the DJ booth. 

Drag the handles to reduce the allowed ranges for pan and tilt. 

‣ Perspective: This step is important to make the virtual light beams match 
the fixture. The fixture moves to the center of its pan and tilt ranges so it’s 
pointing away from its base. 

 

Consider the Preview on the screen. Select the direction to which the light 
beam is currently pointing—to the left or right, up or down, or parallel to 
the viewing direction. For example, if the light is suspended from the 
ceiling and the Preview shows the stage from the front, as in the image 
above, select the “down” direction at the top. If the light points either 
towards the viewer or away from the viewer, select the center option. 

	 	 When calibration is complete, a checkmark appears below the fixture icon. 
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Calibrate the position of a static light 

	 1	 Click the fixture icon to select it. 

	 2	 Do one of the following: 

‣ Click Beam Direction… in the Inspector. 

‣ Click the fixture’s name and choose Beam Direction… from the shortcut 
menu. 

‣ Choose Layout > Beam Direction… (or press Command-Shift-Option-P). 

	 3	 Follow the instructions, then click Done. 

 

Set beam colors 
For fixtures with a fixed color that can’t be changed through DMX—such as a PAR 
with a color gel—, you can choose the color of the virtual light beam. The color is also 
displayed as a dot inside the fixture icon. 

Set a fixture’s beam color 

	 1	 Click the fixture icon to select it. 

	 2	 Do one of the following: 

‣ Click Beam Color… in the Inspector. 

‣ Click the fixture’s name and choose Beam Color… from the shortcut 
menu. 

‣ Choose Layout > Beam Color… (or press Command-Shift-Option-C). 

	 3	 Choose a color. 

	❖	 Note: Lightkey needs to know a moving light’s pan and tilt ranges to match its 
beam direction. This information is part of the fixture profile. Some moving 
lights let you choose between different pan/tilt ranges in their device settings. 
In this case, always select the largest possible range, because this is what the 
fixture profile uses.

	★	 Tip: Select multiple fixtures of the same type to set their beam directions at 
once (assuming they point in the same direction).
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Group fixtures 
Grouped fixtures can be quickly selected at once, although it is still possible to select 
them individually. You should group fixtures with the same type and in the same 
location—for example, a row of blinders above the stage. 

Create a fixture group 

	 1	 Select the fixtures to group. 

	 2	 Do one of the following: 

‣ Click  in the toolbar. 

‣ Control-click one of the fixtures and choose Group from the shortcut 
menu. 

‣ Choose Layout > Group (or press Command-Option-G). 

Ungroup grouped fixtures 

	 1	 Select the fixture group. 

	 2	 Do one of the following: 

‣ Click  in the toolbar. 

‣ Control-click one of the fixtures in the group and choose Ungroup from 
the shortcut menu. 

‣ Choose Layout > Ungroup (or press Command-Option-G). 

Locate fixtures 
If you are not sure which fixture a particular icon belongs to, you can use Highlight 
Mode. When Highlight Mode is enabled, the selected fixture(s) will light up. This 
works for both DMX fixtures and smart lights. 

Enable Highlight Mode 

‣ Click  in the toolbar or choose Layout > Highlight Mode (or press Command-

Shift-H). 

	★	 Tip: Select multiple fixtures to set their beam colors at once.
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Disable fixtures or hide light beams 
If a fixture is temporarily disconnected, broken, or simply not in use, you can disable 
it in Lightkey. A disabled fixture shows no light beam, can’t be selected in the 
Preview, and all its DMX channels are set to zero. 

You can also tell Lightkey to hide a fixture’s virtual light beam. 

Disable or enable a fixture 

‣ Select one or more fixtures and click Disable in the Inspector. 

If multiple fixtures are patched to the same DMX address, you can disable each one 
individually. When all fixtures are disabled, the corresponding DMX channels are set 
to zero. 

 

Hide the virtual light beam 

‣ Select one or more fixtures and click “Hide light beam” in the Inspector. 

Add or remove fixtures 
You can add or remove fixtures in the Fixture Manager. You can also add multiple 
icons in the Preview for a single fixture, which is useful if you patched several 
identical fixtures to the same DMX address. See chapter 13, Manage DMX fixtures, 
for more information. 

Edit shapes, images, and text 
This section discusses editing actions which pertain to shapes, built-in or custom 
images, and text labels. Shapes include rectangles, rounded rectangles, ovals, 
triangles, lines, and various types of trusses. 

Add shapes, images, or text 
Use the icons on the right side of the window to add objects. 

	❖	 Note: You can also disable or enable fixtures in the Fixture Manager. See 
Disable fixtures in chapter 13, Manage DMX fixtures.
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Add an object 

Do one of the following: 

‣ Click either Shapes or Images, then drag an object to the desired position in the 
Preview. 

‣ Choose Layout > Insert and then choose one of the options in the submenu. 

Add a custom image 

Do one of the following: 

‣ Choose Layout > Insert Image File…, then select an image file and click Insert. 

‣ To add an image from another application, copy the image to the Clipboard, go 
to Lightkey, and choose Edit > Paste. 

‣ Drag an image file from the Finder to the Preview area and position it where 
you want it. 

Add text 

Do one of the following: 

‣ Click Shapes, then place the pointer over the  icon and drag it to the desired 
location in the Preview. 

‣ Choose Layout > Insert > Text. 

Double-click the text label to begin editing, then type. To start a new line, press 
Option-Return. Click outside the text label or press Return to finish editing. 

To edit an existing text label, double-click the text label or select it and press Return. 

Change text formatting later in this chapter describes how to change the style for 
new text items. 

Copy and paste shapes, images, and text 
You can copy shapes, images, and text labels to the Clipboard and paste them again 
later, as common in many Mac apps. You can also copy and paste images between 
applications. 

T
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Cut or copy an object 

Do one of the following: 

‣ Select the object(s) and choose Edit > Cut or Edit > Copy (or press Command-
X or Command-C). 

‣ Control-click the object and choose Cut or Copy from the shortcut menu. 

Paste objects from the Clipboard 

Do one of the following: 

‣ Choose Edit > Paste (or press Command-V). 

‣ Control-click anywhere in the Preview and choose Paste from the shortcut 
menu. 

Duplicate shapes, images, and text 

‣ Select the object(s) and choose Edit > Duplicate (or press Command-Shift-D). 

‣ Control-click an object and choose Duplicate from the shortcut menu. 

‣ Hold down the Option key while you drag an object. 

‣ Hold down the Option key and press one of the arrow keys. The new object will 
be offset from the original by one unit in the arrow direction. 

Delete shapes, images, and text 

‣ Select the object(s) and press the Delete key. 

If you accidentally deleted an object, choose Edit > Undo Delete. 

Flip shapes and images 
Lines, some trusses, and images can be flipped on the horizontal or vertical axis. 

Flip objects horizontally or vertically 

	 1	 Select one or more objects. 

	 2	 Do one of the following: 

‣ Click 􀞒 or 􀟨 in the toolbar. 
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‣ Control-click the object and choose Flip Horizontally or Flip Vertically 
from the shortcut menu. 

‣ Choose Layout > Flip Horizontally or Flip Vertically. 

Order shapes, images, and text 
The order or layering of shapes, images, and text determines whether objects appear 
above or below other objects. Note that fixtures always appear on top of other 
objects. 

Change the order of objects 

	 1	 Select one or more objects. 

	 2	 Do one of the following: 

‣ Choose Layout > Order and then choose one of the options in the 
submenu. 

‣ Click 􀐟 in the toolbar and choose one of the options in the menu. 

‣ Control-click one of the objects and choose one of the options in the Order 
submenu of the shortcut menu. 

Change the style of shapes and images 
You can change attributes like fill color, stroke width, stroke color, and opacity for 
shapes and images. 

Change the style of a shape or built-in image 

	 1	 Select one or more shapes and images. 

	 2	 Use the Inspector to change the fill color, stroke width, and stroke color. You 
can also use custom colors. 

Change the opacity of a custom image 

	 1	 Select the image. 

	 2	 Use the Opacity slider in the Inspector to change the image opacity. 
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Adjust shape features 
Some shapes have specific features which you can change with special selection 
handles. 

Adjust the corner radius of a rounded rectangle 

	 1	 Select the rounded rectangle. 

	 2	 Drag the green selection handle near its top-left corner. 

Edit the shape of a line 

	 1	 Select a line. 

	 2	 Click Edit Shape in the Inspector or press Return. 

	 3	 Use the yellow handles to change the shape: 

‣ 	To select a single handle, click the handle. 

‣ To select multiple handles, press the mouse button over a blank part of 
the Preview and drag across the handles. 

‣ To toggle a handle’s selection state, hold down the Command key and 
click the handle. 

‣ To select a range of handles, click the first handle, then hold down the 
Shift key and click the last handle in the range. 

‣ To select the handles one by one, press Control-Tab. Press Control-Shift-
Tab to reverse the order. 

‣ To move the selected handles, drag them. You can also press the Arrow 
keys. 

‣ 	To add a handle, place the pointer in between two yellow handles, then 
click the white handle that appears in between them. 

‣ 	To remove the selected handles, choose Edit > Delete or press the Delete 
key. 

	 4	 To end editing the line, press Return or click in the empty area outside the line. 

Change the starting or ending angle of a curved truss 

	 1	 Select the curved truss. 
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	 2	 Drag one of the green selection handles at each end. Hold down the Shift key as 
you drag to constrain the angle to 45°. 

Change text formatting 
You can change fonts, font sizes, and other text attributes like in many other Mac 
applications. 

Change the formatting of a text label 

	 1	 Select one or more text labels. To change only a part of the text, double-click a 
text label and select the desired range. 

	 2	 Do one of the following: 

‣ Click Show Fonts in the Inspector or choose Edit > Font > Show Fonts. 
Select a font, font size, and other options in the Font window. 

‣ Choose Edit > Font > Bold, Underline, Italic to change the text style. 

‣ Click Show Colors in the Inspector or choose Edit > Font > Show Colors, 
then select a color in the Color window. 

‣ Choose Edit > Alignment, then choose one of the options in the submenu 
to change the alignment of the label. 

You can change the default font and style for new text labels. Each project has its 
own default style for text labels. 

Set the default style for new text labels 

	 1	 Select a single text label whose style you want to become the new default. 

	 2	 Do one of the following: 

‣ Choose Edit > Set Default Style. 

‣ Control-click the label and choose Set Default Style from the shortcut 
menu. 

Reset the default style to the original state 

	 1	 Select a single text label. 

	 2	 Hold down the Option key and choose Edit > Reset Default Style. 
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Chapter 8   
Fixture properties 

 

Controlling fixtures through DMX starts with 
fixture properties. This chapter looks at each 
property—such as Dimmer, Color, or Position—
and explains how it’s controlled in Lightkey. 

A fixture property comprises one or more traits of a fixture that can be controlled 
through DMX. Each fixture has a different set of properties which are defined in its 
fixture profile. 

When you assign a value to a fixture property, the property is defined or overridden. 
A blue dot to the left of the fixture name indicates that it has at least one defined 
property. 

 

Changing a fixture property generally involves two steps: 

• Select one or more fixtures, or one or more individual light beams. 

• Change a property of the fixtures or light beams. 

The fixture has
overridden properties
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Select fixtures 
There are many ways to select fixtures using the keyboard, mouse, and even external 
control hardware. Selected fixtures show a blue rectangle around the name and a 
frame around the icon. 

 

Select all fixtures 
You can quickly select or deselect all fixtures in the project. 

Select or deselect all fixtures 

‣ To select all fixtures, choose Edit > Select All (or press Command-A). 

‣ To deselect all fixtures, choose Edit > Deselect All (or press Command-Shift-A 
or Esc) or click a blank part of the Preview. 

Select fixtures by location 
You can select or deselect fixtures by their location in the Preview. Selecting a 
grouped fixture selects the entire group. 

Select or deselect fixtures by location 

‣ To select a single fixture, click its icon. 

‣ To select all fixtures in a group, click the icon of one of the fixtures. To select an 
individual fixture in a group, double-click its icon. 

‣ To select additional fixtures, hold down the Shift or Command key and click 
each fixture. 

‣ To remove a fixture from the selection, hold down the Shift or Command key 
and click the fixture. 

‣ To select multiple fixtures at once, press the mouse button over a blank part of 
the Preview and drag it over the fixtures. (Hold down the Option key to select 
outward from the starting point.) 

‣ To add or remove multiple fixtures to/from the selection, hold down the Shift or 
Command key, press the mouse button over a blank part of the Preview, and 
drag it over the fixtures. 

	❖	 Note: If a fixture has been disabled it can’t be selected.
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‣ To select the nearest fixture in any direction, press one of the arrow keys. 

‣ To extend the fixture selection in any direction, hold down the Shift key and 
press one of the arrow keys. 

Select fixtures by type 
When a single fixture is selected, you can quickly extend the selection to all other 
fixtures of the same type (for example, all moving heads or all blinders). 

Select fixtures by type 

	 1	 Select a single fixture. 

	 2	 Choose Edit > Select All [fixture type] (for example, Select All Moving Heads) 
(or press Command-Option-A). 

Select fixtures by name 
You can quickly select a fixture by typing its short name, or select multiple fixtures by 
typing a common prefix of their short names. You can also step through fixtures in 
alphabetical order. 

Select fixture(s) by their short name 

‣ When the Preview has focus, type one or more letters or numbers. Do not use 
the Shift key or other modifier keys. 

Example: Suppose your rig consists of moving heads and PARs, arranged like this: 

 

PR1PR2PR3MH6MH5MH4MH3MH2MH1PL3PL2PL1
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Here are examples how you can select these fixtures using type selection: 

Step through fixtures by their short name 

‣ To select the next fixture in alphabetical order, press Control-Tab. 

‣ To select the previous fixture in alphabetical order, press Control-Shift-Tab. 

Select fixtures through external control 
You can set up bindings to select fixtures through DMX-In, MIDI, or custom keyboard 
shortcuts. See chapter 16, External control, for more information. 

Select light beams 
Many fixtures have multiple light beams which can be controlled individually. To 
change properties for individual beams, you first select the beam or beams and then 
change their properties. If no beams are selected then changes apply to all beams of 
the selected fixtures. Here are some fixtures with multiple light beams: 

 

Fixtures can have additional light beams which aren’t shown in the Preview. Each 
beam has a number, starting with the main beams shown in the Preview and 
followed by the additional beams. 

Type this… … to select these fixtures

M All moving heads

MH2 MH2

P All PARs

PL PARs on the left (PL1–3)

PR PARs on the right (PR1–3)

P1 Outmost PARs

Lightkey User Guide	 73



Some fixtures have groups of beams which always share the same properties. For 
example, each of the rings of the moving head shown above may form a group. In this 
case selecting one beam from a group will select the others as well. If you can’t 
select any beams then none of the fixture’s properties allows beam-level control 
(that is, all beams form a single group). 

Only the Dimmer, Color, Shutter/Strobe, and Position properties can apply to 
individual beams. Whether a fixture property applies to individual beams depends on 
the fixture profile and the selected mode. 

Lightkey marks the selected beams by a white outline. An orange diamond symbol 
appears if the selection includes beams not shown in the Preview. 

 

Select light beams in the Preview 

	 1	 Select one or more fixtures with multiple light beams. 

	 2	 If necessary, choose View > Zoom > Zoom In (or press Command-Plus) to 
enlarge the fixture icon. You can also hold down the Option key and scroll up or 
down while the mouse pointer is over the icon. 

	 3	 Do one of the following: 

‣ Click one of the beams in a fixture’s icon to select it. You can select 
multiple beams by dragging across them. 

‣ To select a range of beams, click the first beam, then hold down the Shift 
key and click the last beam. 

‣ To select more beams or remove beams from the selection, hold down the 
Command key and click a beam or drag across multiple beams. 

‣ To select beams across multiple fixtures, e.g. adjacent LED matrixes, drag 
across the fixtures. 

Selected light beams Additional light beams 
are selected
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Select light beams not shown in the Preview 

‣ In the Preview, click the name of a fixture with multiple light beams and choose 
Beams from the menu, then choose one of the items from the submenu. 

‣ To select more beams or remove beams from the selection, hold down the 
Command key while you select an item from the menu. 

‣ For more fine-granular control, choose Select Beams… from the menu. In the 
dialog that appears, click the beams you wish to select or enter the desired 
beam numbers in the text field. For example, to select the first and last two 
beams of the LED bar shown above, enter “1–2, 9–10”. 

Select the same light beams of multiple fixtures 

	 1	 Select multiple fixtures of the same type. 

	 2	 Do one of the following: 

‣ Choose Fixture > Beams, then choose one of the items from the 
submenu. 

‣ To select more beams or remove beams from the selection, hold down the 
Command key white you select an item from the menu. 

‣ For more fine-granular control, choose Select Beams… from the menu (or 
press Command–Option–B). In the dialog that appears, click the beams 
you wish to select or enter the desired beam numbers in the text field. For 
example, to select the first and last two beams of the LED bar shown 
above, enter “1–2, 9–10”. 

	 	 The beams will be selected on all selected fixtures. 

 

Deselect all light beams 

‣ Choose Edit > Deselect All (or press Command-Shift-A or Esc). Alternatively, 
click a blank part of the Preview to deselect all fixtures and beams. 

	❖	 Note: The items in the menu that appears when you click a fixture name and 
choose Beams select beams of the clicked fixture only. The items in the 
Fixture > Beams menu select beams on all selected fixtures, if the fixtures 
are of the same type.
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Fixture properties 
A fixture property comprises one or more traits of a fixture that can be controlled 
through DMX—for example, Dimmer, Color, and Position. Most fixture properties are 
controlled from the Design view below the Preview, which adapts itself to the fixtures 
selected in the Preview. 

 

Depending on your settings, some fixture properties may be controlled through 
Heads-up displays (or HUDs) which appear around the fixture’s icon in the Preview. 

 

Lastly, the Lamp and Command properties are controlled from the menu bar or the 
fixture’s shortcut menu. 

Show the Design view 

Do one of the following: 

‣ Click Design below the Preview. 

‣ Choose View > Design (or press Command-D). 

Click to show the Design view

The frame shows the Gobo Wheel property 
is selected

The blue dot indicates that the 
Dimmer property is defined

HUD for Zoom property
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Select a fixture property 
When a fixture property is selected, you can use specific keyboard shortcuts to 
change its values. These shortcuts are listed in the following sections; you also see 
them in the Shortcuts view when the property is selected. 

A property with a HUD is selected when the HUD is open. 

The Design view shows only properties that pertain to the fixtures selected in the 
Preview. If no fixtures are selected, the Design view is empty. 

 

Select a fixture property 

	 1	 Select one or more fixtures in the Preview. 

	 2	 Do one of the following: 

‣ Click a fixture’s name and select the property from the shortcut menu. 

‣ Click  (or 􀍡) in the toolbar and choose Select Property from the menu, 
then select a property. 

‣ Choose Fixture > Select Property, then select a property from the menu. 

Fixture properties in the Design view are automatically selected when you click one 
of their controls. For example, the Shutter/Strobe property is selected when you click 
one of the shutter states. A colored frame indicates that the property is selected. 

Many fixture properties have a keyboard shortcut (a letter) which selects the property 
in the Design view or opens its HUD. After using the shortcut to select the property, 
you can use property-specific keyboard shortcuts to change its value. This way you 
can control many fixture properties solely by using the keyboard. 

	❖	 Note: You can’t select properties that have been hidden from the Design view. 
See Reorder and hide custom properties below on how to show or hide 
properties in the Design view.

Fixture property Shortcut letter

Dimmer D

Color, Color Wheel C

Gobo Wheel G
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Select a fixture property using keyboard shortcuts 

	 1	 Select one or more fixtures which support the property. 

	 2	 Do one of the following: 

‣ Hold down the Shift key and press the letter for the fixture property. 

‣ Press only the letter for the fixture property until the property is selected 
in the Design view or until a HUD appears. 

Cycle the fixture properties in the Design view 

	 1	 Make sure the Design view is visible (see above). 

	 2	 Select one or more fixtures. 

	 3	 Press the Tab key to select the next (or first) enabled property in the Design 
view, or press Shift-Tab to select the previous enabled property. 

Deselect any fixture property 

‣ Press Return, Enter, or Esc. 

‣ Click the empty area at the top of the Design view. 

‣ Click a blank part of the Preview. (This will also deselect all fixtures.) 

Position P

Shutter/Strobe S

Prism M

Focus F

Zoom Z

Iris I

Frost R

Fog O

Fixture property Shortcut letter
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Define a fixture property 
When you assign a value to a fixture property in the Design view or a HUD, the 
property is said to be defined or overridden. In this state the assigned value is 
applied directly to the fixture and overrides active presets, sequences, and cues. A 
property is either defined or undefined for a given fixture—you cannot define it for 
only some of a fixture’s beams, or define only some of the property’s traits. 

The Design view and HUDs reflect the state of the overridden fixture properties for 
the selected fixtures. Undefined properties show no value, even if an active preset or 
cue contains values for them. This means that a property like Dimmer may appear as 
off in the Design view even though the fixture’s dimmer is turned on by an active cue. 

A blue dot to the left of a property’s name indicates that the property is defined for 
the selected fixtures. A gray dot means that the property is defined for some but not 
all fixtures. Changing a property’s value (for example, by dragging the Dimmer 
slider) defines the property for all selected fixtures. 

Clear a defined fixture property 

Do one of the following: 

‣ Click the blue (or gray) dot to the left of the property’s name in the Design view 
or the property’s HUD. 

‣ Select the property and press the Delete key. 

For more information see View overridden fixture properties and Clear fixture 
properties later in this chapter. 

Effects 
When a fixture property has an effect, its value is defined by the effect. In this case 
the property’s controls in the Design view are replaced with an effect icon. Click the 
icon to edit the effect. See chapter 10, Effects, for more information about effects. 

	★	 Tip: If your Mac has a Touch Bar, you can use it to conveniently control any 
fixture property. Select the fixture property as described above, then change 
its value with the Touch Bar.
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Remove an effect for a fixture property 

Do one of the following: 

‣ Click the blue (or gray) dot to the left of the property’s name in the Design view. 

‣ Select the property and press the Delete key. 

Dimmer 
Most lighting fixtures support the Dimmer property, which controls the light’s 
intensity or brightness. 

Select the Dimmer property 

	 1	 Select one or more fixtures which support the Dimmer property. 

	 2	 Do one of the following: 

‣ Click one of the fixtures’ names and choose Dimmer from the shortcut 
menu. 

‣ Press Shift-D or press D until the Dimmer property is selected. 

The keyboard shortcuts in this section assume that the Dimmer property is selected. 

Change a fixture’s intensity 

Do one of the following: 

‣ Drag the Dimmer slider in the Design view. To disable snapping press and hold 
the Command key. 

‣ Place the pointer over the Dimmer slider and scroll up or down. (If this doesn’t 
work, choose Lightkey > Settings…, click Gestures, and make sure “Scrolling 
changes slider and HUD values” is selected.) 

‣ Press the Up/Down Arrow keys or Plus/Minus keys to increase/decrease the 
intensity by 10%. 

‣ Hold down the Option key and press the Up/Down Arrow keys or Plus/Minus 
keys to increase/decrease the intensity by 1%. 

‣ Type a number to set the intensity to an exact value. (Type a single digit to set 
the value in steps of 10%. Type two or three digits to set an exact percent value.) 
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‣ Hold down the Command key and scroll up or down while the pointer is over the 
Preview. (This gesture can be changed in the Settings window. See Multi-Touch 
gestures in chapter 16, External control.) The Dimmer property needs not be 
selected for this. 

 

Choose how intensities are applied to multiple fixtures 

‣ Click Dimmer and choose one of the following options from the menu: 

• Absolute: All fixtures are assigned the same intensity, regardless of their 
previous state. 

• Relative: This mode maintains the relative distances between the fixtures’ 
intensities. For example, if you increase the intensity by 10%, all fixtures’ 
intensities increase by 10% from the previous value. 

You may note that the Dimmer property is also available for fixtures with no explicit 
Dimmer DMX channel. If a fixture uses the RGB color model (see Color below), 
Lightkey will also display the Dimmer property which then affects the color’s 
brightness. This feature has several advantages, for example: 

• It allows dimming fixtures of different types at once, whether they have a 
Dimmer channel or not. 

• Fixtures with no explicit Dimmer support are also affected by the Master 
Dimmer (see below). 

• It allows controlling the intensity separately from the color, e.g. in different 
presets. 

Master Dimmer 
Apart from the Dimmer property, the intensity of all fixtures is also affected by the 
Master Dimmer. You can tell Lightkey to ignore the Master Dimmer for individual 
fixtures. 

	❖	 Note: As a convenience, when you select an intensity greater than zero and 
the shutter state is closed, Lightkey automatically opens the shutter (for 
fixtures which support the Shutter property).
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Change the Master Dimmer 

Do one of the following: 

‣ Click Live to show the Live view, then drag the Master slider. Alternatively, 
place the pointer over the slider and scroll up or down. (If this doesn’t work, 
choose Lightkey > Settings…, click Gestures, and make sure “Scrolling 
changes slider and HUD values” is selected.) 

‣ Place the pointer over the Preview and swipe up or down with four fingers on 
your trackpad. (This gesture requires that four-finger gestures are not assigned 
to other actions in System Settings. It can be changed in the Settings window. 
See Multi-Touch gestures in chapter 16, External control.) 

 

Ignore the Master Dimmer for individual fixtures 

	 1	 Click Edit in the toolbar or choose View > Edit Preview to edit the Preview. 

	 2	 Select one or more fixtures. 

	 3	 Click Ignore Master Dimmer in the Inspector on the right. 

	 4	 Click Done in the toolbar. 

Color 
The Color property mixes a fixture’s light color by combining a number of base colors 
in varying degrees. Traditionally color mixing used the CMY model with the base 
colors Cyan, Magenta, and Yellow. With the advent of LEDs the RGB (Red, Green, 
Blue) model has become more common. 

Fixtures with a color wheel use the Color Wheel property (described below) instead. 

For fixtures that use the CMY or RGB models, the Design view shows a round control 
comprised of three sliders which control the color’s hue (outer ring), saturation (left 
inner slider), and brightness (right inner slider). Lightkey translates these values to 
the equivalent RGB or CMY components. 

Select the Color property 

	 1	 Select one or more fixtures which support the Color property. 

	❖	 Note: The Master Dimmer only affects fixtures that can be dimmed.
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	 2	 Do one of the following: 

‣ Click one of the fixtures’ names and choose Color from the shortcut menu. 

‣ Press Shift-C or press C until the Color property is selected. 

The keyboard shortcuts in this section assume that the Color property is selected. 

Choose the color’s hue 

Do one of the following: 

‣ Drag the outer round slider. To disable snapping press and hold the Command 
key. 

‣ Place the pointer over the Hue slider and scroll up or down. (If this doesn’t 
work, choose Lightkey > Settings…, click Gestures, and make sure “Scrolling 
changes slider and HUD values” is selected.) 

‣ Press the Up/Down Arrow keys or Plus/Minus keys to increase/decrease the 
hue by 10°. 

‣ Hold down the Option key and press the Up/Down Arrow keys or Plus/Minus 
keys to increase/decrease the hue by 1°. 

‣ Type a number between 0 and 360 to change the hue. 

‣ Hold down the Command and Option keys and scroll up or down while the 
pointer is over the Preview. (This gesture can be changed in the Settings 
window. See Multi-Touch gestures in chapter 16, External control.) The Color 
property needs not be selected for this. 

Choose the color’s saturation 

Do one of the following: 

‣ Drag the inner left slider. To disable snapping press and hold the Command 
key. 

‣ Place the pointer over the Saturation slider and scroll up or down. (If this 
doesn’t work, choose Lightkey > Settings…, click Gestures, and make sure 
“Scrolling changes slider and HUD values” is selected.) 

‣ Press the Left/Right Arrow keys to decrease/increase the saturation by 10%. 

‣ Hold down the Option key and press the Left/Right Arrow keys to decrease/
increase the saturation by 1%. 
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‣ Hold down the Command, Shift, and Option keys and scroll up or down while the 
pointer is over the Preview. (This gesture can be changed in the Settings 
window. See Multi-Touch gestures in chapter 16, External control.) The Color 
property needs not be selected for this. 

Choose the color’s brightness 

Do one of the following: 

‣ Drag the inner right slider. To disable snapping press and hold the Command 
key. 

‣ Place the pointer over the Brightness slider and scroll up or down. (If this 
doesn’t work, choose Lightkey > Settings…, click Gestures, and make sure 
“Scrolling changes slider and HUD values” is selected.) 

Choose a color using the system color window 

	 1	 Click the current color in the center of the color control. 

	 	 The system color window opens. 

	 2	 Choose a color in the color window. You can also drag colors from the color 
window to the center of the color control. 

 

Additional colors and features 
Some fixtures include additional LEDs for any of the following colors: cool and warm 
white, amber, lime, ultraviolet. Fixtures may also support the following additional 
features: 

• Color temperature: The tint of white light, in degrees Kelvin. 

Why are my lights blue? 

If a fixture’s Color property is not defined—that is, it’s neither overridden nor 
defined by any active preset, cue, or sequence—then Lightkey applies its default 
color. For RGB and CMY fixtures the default color is normally blue. Therefore, if 
the fixture’s dimmer is open (or it cannot be dimmed), the light color is blue. 

You can change the default color to any other color, including black. See Default 
values later in this chapter for more information.
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• Green saturation: The shift from the neutral point to full minus green or full 
plus green, in percent. 

• Xfade to color: Transition between pure white (0%) and full color (100%). 

Change additional colors and features 

Do one of the following: 

‣ Drag the sliders next to the main color control. To disable snapping press and 
hold the Command key. 

‣ Place the pointer over a slider and scroll up or down. (If no sliders are visible 
then the selected fixtures don’t support these features.) 

‣ When the Color property is selected, press the Tab key until a border appears 
around the slider you’d like to change. Then use the Up/Down Arrow keys or 
type a numeric value to change the slider’s value. 

You can enlarge the sliders for additional colors and features for more precise 
control. The enlarged sliders also permanently show their values. 

Change the size of the sliders for additional colors/features 

‣ Click Color and choose Small Sliders or Large Sliders from the menu. 

Color favorites 
Lightkey lets you save frequently used colors for quick access. Color favorites 
include additional components such as Amber and features such as Green 
Saturation. They appear below the color sliders in the Design view and are stored in 
the project. To reveal additional favorite color swatches, click 􀍠. 

Add a color to the favorites 

‣ Drag the current color from the center of the round sliders to one of the color 
swatches. This replaces the swatch’s previous color. 

Apply a color favorite 

‣ Click the color favorite. 
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Color Wheel 
The Color Wheel property controls a fixture’s color wheel, which contains colored 
gels to create a tinted light beam. Some fixtures have multiple superimposed color 
wheels; in this case there are up to three independent Color Wheel properties. 

The Design view shows a visual representation of each color wheel. The colors may 
be shown as a grid if multiple fixtures of different kinds are selected or a fixture has 
a large number of colors. If different fixtures are selected, the grid contains the 
union of all available colors. 

Some fixtures support “special” colors: 

• “Split colors” are created by stopping the color wheel at a position where two 
adjacent color gels are in front of the light source. 

• Color correction gels appear as “CTO” (Color Temperature Orange) or “CTB” 
(Color Temperature Blue) and may include the color temperature in Kelvin. 

• Numbers represent “unknown” colors not specified in the fixture profile. 

Fixtures which mix colors from RGB or CMY components use the previously 
described Color property instead. 

Select the Color Wheel property 

	 1	 Select one or more fixtures with a color wheel. 

	 2	 Do one of the following: 

‣ Click one of the fixtures’ names and choose Color Wheel from the shortcut 
menu. 

‣ Press Shift-C or press C until the Color Wheel property is selected. 

The keyboard shortcuts in this section assume that the Color Wheel property is 
selected. 

Select a color 

Do one of the following: 

‣ Click one of the colors. To select a split color, click between two colors on the 
wheel (if supported by the fixture). 

‣ Press an arrow key. 
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‣ Type a number to select colors by index. 

If multiple kinds of fixtures are selected and the selected color is not available on all 
fixtures, Lightkey tries to apply the closest matching color. 

Color wheel modes 
Some fixtures support additional modes for the color wheel: 

• Many fixtures can rotate their color wheel continuously, creating a rainbow 
effect. You can usually change the rotation direction and speed. 

• Some fixtures have modes where colors are selected randomly or in sync to 
music. The exact functionality of these modes depends on the fixture. 

Select a rainbow effect 

‣ Press the mouse button over the  icon and drag up or down to select the 

speed and direction. 

Select random color mode 

‣ Click . Click again to change the speed (if the fixture supports multiple speed 
options). 

Select sound-controlled color mode 

‣ Click . 

Gobo Wheel 
The Gobo Wheel property controls a fixture’s gobo wheel. A gobo is a metal or glass 
stencil that is placed in front of the light source, projecting an image onto a surface. 
The term is an acronym for “GOes Before Optics”. Similar to color wheels, gobos are 
arranged on a wheel so that they can be moved sequentially through the light beam. 
Some fixtures have multiple superimposed gobo wheels; in this case there are up to 
three independent Gobo Wheel properties. 

The Design view shows a visual representation of each gobo wheel. The gobos may 
be shown as a grid if multiple fixtures of different kinds are selected or a fixture has 
a large number of gobos. If different fixtures are selected, the grid contains the union 
of all available gobos. 
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Select the Gobo Wheel property 

	 1	 Select one or more fixtures with a gobo wheel. 

	 2	 Do one of the following: 

‣ Click one of the fixtures’ names and choose Gobo Wheel from the shortcut 
menu. 

‣ Press Shift-G or press G until the Gobo Wheel property is selected. 

The keyboard shortcuts in this section assume that the Gobo Wheel property is 
selected. 

Select a gobo 

Do one of the following: 

‣ Click one of the gobos. 

‣ Press an arrow key. 

‣ Type a number to select gobos by index. 

Gobo wheel modes 
Some fixtures support additional modes for the gobo wheel: 

• Many fixtures support a gobo cycle effect which continuously rotates the gobo 
wheel. You can usually change the rotation direction and speed. 

• Some fixtures have modes where gobos are selected randomly or in sync to 
music. The exact functionality of these modes depends on the fixture. 

Select a gobo cycle effect 

‣ Press the mouse button over the  icon and drag up or down to select the 

speed and direction. 

Select random gobo mode 

‣ Click . Click again to change the speed (if the fixture supports multiple speed 
options). 

Select sound-controlled gobo mode 

‣ Click . 
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Gobo states 
Many fixtures support some or all of the following gobo states: 

• Rotation: Continuous rotation in clockwise or counterclockwise direction. 

• Bouncing: Continuous rotation with alternating direction. 

• Indexing: Changes the gobo’s angle. 

• Shake: Rotates the gobo wheel slightly backward and forward. 

Change a gobo’s rotation state 

‣ Click  or press R to enable rotation. Repeat to reverse the rotation direction, 

and repeat again to stop the rotation. 

‣ If the fixture supports gobo rotation with variable speed: Press the mouse 
button over  and drag up or down to adjust the speed, or press the Minus/

Plus keys. Press Option-Minus or Option-Plus for fine control. 

Change a gobo’s bounce state 

‣ Click  or press B to enable bouncing. Repeat to stop bouncing. 

‣ If the fixture supports gobo bouncing with variable speed: Press the mouse 
button over  and drag up or down to adjust the speed, or press the Minus/
Plus keys. Press Option-Minus or Option-Plus for fine control. 

Rotate a gobo (indexing) 

Do one of the following: 

‣ Press the mouse button over  and drag up or down to adjust the angle. Click 

again to disable gobo indexing. 

‣ Press I to turn indexing on or off. Press the Minus/Plus keys to change the 
angle; press Option-Minus or Option-Plus for fine control. 

Change a gobo’s shake state 

‣ Click  or press S to enable shake. Repeat to stop the gobo from shaking. 

‣ If the fixture supports gobo shake with variable speed: Press the mouse button 
over  and drag up or down to adjust the speed, or press the Minus/Plus keys. 
Press Option-Minus or Option-Plus for fine control. 
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Position 
Moving heads and scanners can typically rotate around two axes called pan and tilt. 
Their position is therefore defined by two angles: The pan angle describes the 
rotation of the yoke, and tilt angle describes the rotation of the head inside the yoke. 

Lightkey visualizes positions in a circular area which reflects the physical direction of 
the light. The angle around the circle represents pan, and the distance from the 
center represents tilt. To understand the displayed positions, imagine looking in the 
direction of the pan axis: 

 

Before you use the position control, you should calibrate the fixture’s beam direction, 
as described in Set beam directions in chapter 7, Preview. This ensures that the 
position control and virtual light beams match the physical fixture. 

Pan angles are measured from the center of the physical pan range. That position is 
called the home angle and is always at 0°. Likewise, tilt angles are measured from 
the center of the tilt range (0°). At this position the head is parallel to the yoke, 
pointing away from the fixture’s base. 

	❖	 Note: Rotation, bounce, and indexing are not available for the open gobo.

Pan axis

Home angle

Viewing direction

Tilt axis
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The shaded area at the outside marks tilt angles beyond 90°. 

The Position control observes any limits you set during calibration for the pan and tilt 
range. If you limit the pan or tilt range, the 0° positions may no longer be in the 
center of the selectable range. 

A given direction of the light beam can be the result of more than one pan/tilt 
combination. For example, at pan = –60°, tilt = +45°, the light beam points in the 
same direction as at pan = +120°, tilt = –45°. This is matched by Lightkey’s position 
control, where both pan/tilt combinations are represented by the same point in the 
circle: 

 

To help distinguish between these cases, positions in the negative pan range appear 
red and positions in the positive pan range green. Positions in the negative tilt range 
appear in a lighter color. 

Many fixtures can pan by more than 360°, so there may be two more pan/tilt 
combinations which result in the same beam direction: 

 

Current position

Pan

Home angle

Tilt

Pan: –60°
Tilt: +45°

Pan: +120°
Tilt: –45°

Pan: +300°
Tilt: +45°

Pan: –240°
Tilt: –45°
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It’s important to understand that these are different states, even though the light 
beam effectively points in the same direction. This becomes apparent when you 
switch between presets or cues with different positions: For example, if the pan 
angle changes from –60° to +300°, the yoke will make a full turn, even though the 
light beam ends up in the same direction. 

You can choose whether the Position property is controlled from the Design view or a 
HUD. 

Choose how to control the Position property 

	 1	 Choose Lightkey > Settings… (or press Command-Comma) and then click 
General. 

	 2	 Select one of the options next to “Design view”. 

Select the Position property 

	 1	 Select one or more fixtures which support the Position property. 

	 2	 Do one of the following: 

‣ Click one of the fixtures’ names and choose Position from the shortcut 
menu. 

‣ Press Shift-P or press P until the Position property is selected or the 
Position HUD appears. 

If the Position property is controlled from a HUD and you have a trackpad which 
supports Force Touch, you can also force click a fixture icon to open the HUD, or 
press the mouse button over a fixture icon for about 0.5 seconds. These gestures can 
be configured in Lightkey’s Settings window. For more information, see Multi-Touch 
gestures in chapter 16, External control. 

The following tasks in this section assume that the Position property is selected. 

Change the fixture position 

‣ Drag the colored dot or click anywhere inside the position control. 

‣ To disable snapping to some pan/tilt angles, hold down the Control key as you 
drag. 

‣ To lock the pan angle, hold down the Command key as you click or drag. To lock 
the tilt angle, hold down the Shift key as you click or drag. 
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‣ Another way to change only pan or only tilt is to drag the colored triangles next 
to the pan or tilt scale. 

‣ To reverse the sign of the pan or tilt angle, Control-click the position control 
and choose Flip Pan or Flip Tilt from the shortcut menu. 

If the Position property is controlled from a HUD, you can quickly change a fixture’s 
position with just one press and release of the mouse button. 

To quickly change the fixture position 

‣ Press the mouse button while the pointer is over a fixture’s icon. When the 
Position HUD opens, drag the pointer to a point in the position control, then 
release the mouse button. 

You can also change the position with the keyboard, by scrolling, or with a joystick. 

Additional ways to change the fixture position 

‣ Press one of the arrow keys to move the position in steps of 1°. The Left/Right 
Arrow keys change pan and the Up/Down Arrow keys change tilt. Hold down the 
Shift key to move in 10° steps, or the Command key to move in 0.1° steps. 

‣ Place the pointer over the position control and scroll up or down to pan. (If 
scrolling has no effect, choose Lightkey > Settings…, click Gestures, and make 
sure “Scrolling changes slider and HUD values” is selected.) Hold down the 
Command key as you scroll to tilt. Hold down the Shift key to move faster or the 
Option key to move slower. 

‣ Press a key on the numeric keypad to select a pan angle according to the 
location of the key. 

	 	  

8

2

4 6

7 9

1 3

Lightkey User Guide	 93



‣ You can also control fixture positions with a joystick. The joystick’s horizontal 
axis controls pan and the vertical axis controls tilt. This works even when the 
Position property is not selected. You can adjust the speed in the Gestures tab 
of the Settings window. 

As explained earlier in this section, a point in the position control may correspond to 
multiple pan/tilt combinations, so a click in the circle may not always result in the 
desired position. The following techniques let you select all possible pan and tilt 
angles. 

Reverse the sign of the pan angle 

Do one of the following: 

‣ In the position control, drag the colored dot from the negative range through 
the home angle to the positive range, or vice versa. 

‣ Press the Left or Right Arrow key to change the pan angle until its sign 
changes. (You can hold down the Shift key to increase the steps.) 

‣ Control-click the position control and choose Flip Pan. This will reverse the sign 
of the pan angle. 

Reverse the sign of the tilt angle 

Do one of the following: 

‣ Hold down the Command key to lock the pan angle and drag the pointer across 
the center of the position control. 

‣ Drag the colored triangle next to the tilt axis across the center of the position 
control. 

‣ Press the Down or Up Arrow key to change the tilt angle until its sign changes. 
(You can hold down the Shift key to increase the steps.) 

‣ Control-click the position control and choose Flip Tilt. This will reverse the sign 
of the tilt angle. 

As with all fixture properties, changes to the Position property affect all selected 
fixtures. You can choose how Lightkey applies fixture positions if these fixtures have 
different home angles, rotation directions, pan/tilt ranges and limits, or starting 
positions. 
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Choose how angles are applied to multiple fixtures 

‣ Click Position and choose one of the following options from the menu: 

• Absolute: All fixtures point in the same direction, regardless of their home 
angle and rotation direction (as long as the position is within their range). 
For example, if you select a position where the beam points upwards in 
the Preview, all fixtures will point upwards. 

• Relative to Home Position: All fixtures are assigned the same pan and tilt 
angles (as long as they’re within their respective ranges). For example, if 
you select a pan angle of +30°, all fixtures move to a pan angle of +30° 
relative to their respective home angle. 

• Relative to Current Position: This mode maintains the relative distances 
between the fixtures. For example, if you increase the pan angle by 15° 
then all fixtures move by 15° from their current position. 

Some fixtures allow infinite rotation around the pan or tilt axis with variable speed. 

Enable infinite pan or tilt rotation 

In the Design view: 

‣ Press the mouse button over  (pan) or  (tilt) and drag up or down to adjust 

the rotation speed and change the direction. 

‣ Click the icon to reverse the rotation direction. Click again to disable rotation. 

In the Position HUD: 

	 1	 Click  (pan) or  (tilt). Repeat to reverse the rotation direction, and repeat 

again to disable rotation. 

	 2	 Drag the Pan Speed or Tilt Speed slider to adjust the rotation speed. 

Close the Position HUD 

Do one of the following: 

‣ Click anywhere outside the HUD. 

‣ Press Return, Enter, or Esc. 
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On/Off 
The On/Off property toggles the state of a fixture. It is used by smart plugs and DMX 
switch packs, for example. 

Select the On/Off property 

	 1	 Select one or more fixtures which support the On/Off property. 

	 2	 Click one of the fixtures’ names and choose On/Off from the shortcut menu. 

The keyboard shortcuts in this section assume that the On/Off property is selected. 

Turn a fixture on or off 

Do one of the following: 

‣ Click On or Off. 

‣ Press 1 for On or 0 for Off. 

Shutter/Strobe 
The Shutter/Strobe property can control two slightly different things: 

• A fixture’s shutter, which can be moved in front of the light source so that no 
light is emitted. Often the shutter can also be used to create stroboscope 
effects (regular or irregular flashes of light) or pulse effects (gradually 
increasing the amount of light and abruptly reducing it, or vice versa). 

• A stroboscope (strobe) effect, which may or may not be realized through a 
shutter (it may also be realized by a xenon flash lamp, for example). 

Select the Shutter/Strobe property 

	 1	 Select one or more fixtures which support the Shutter/Strobe property. 

	 2	 Do one of the following: 

‣ Click one of the fixtures’ names and choose Shutter/Strobe from the 
shortcut menu. 

‣ Press Shift-S or press S until the Shutter/Strobe property is selected. 

The keyboard shortcuts in this section assume that the Shutter/Strobe property is 
selected. 
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Open or close the shutter 

Do one of the following: 

‣ Click Open or Closed. 

‣ Press O to open or C to close the shutter. 

 

Control strobe effects 

‣ Click Strobe or press S to enable strobing (if supported by the fixture). Repeat 
to select synchronized strobe, random strobe, random synchronized strobe, or 
lightning strobe (if supported by the fixture). 

 

‣ Press the mouse over the Strobe button and drag up or down to adjust the 
strobe speed (if the fixture supports variable strobe speeds). 

‣ If the fixture supports a sound-controlled strobing, drag the mouse up until the 
label reads “Sound-Active”. 

‣ You can also press the Up/Down Arrow keys or Minus/Plus keys to decrease/
increase the strobe speed. (Press Option-Up/Down Arrow or Option-Minus/Plus 
for fine control.) 

Control shutter pulse effects 

‣ Click Pulse or press P to enable the pulse effect (if supported by the fixture). 
Repeat to change the pulse style. The button cycles between the following 
states if they are supported by the selected fixtures: 

 

‣ Press the mouse over the Pulse button and drag up or down to adjust the pulse 
speed (if the fixture supports variable pulse speeds). 

	❖	 Note: As a convenience, Lightkey automatically sets the shutter state to open 
when you apply a non-zero Dimmer value if the shutter was previously closed.

Strobe

Lightning strobe

Synchronized strobe Random strobe

Random synchronized strobe

Pulse
opening

Random
burst pulse

Random pulse
alternating

Random pulse
closing

Random pulse
opening

Pulse
closing

Pulse
alternating

Burst
pulse

Lightkey User Guide	 97



‣ You can also press the Up/Down Arrow keys or Minus/Plus keys to decrease/
increase the pulse speed. (Press Option-Up/Down Arrow or Option-Minus/Plus 
for fine control.) 

Movement Speed 
The Movement Speed property (sometimes abbreviated “Mspeed”) controls a moving 
light’s movement while the Position property (pan and tilt) changes. Some fixtures 
support multiple speed modes like Tracking or Vector. Other fixtures simply let you 
change the speed from slow to fast. 

Select the Movement Speed property 

	 1	 Select one or more fixtures which support the Movement Speed property. 

	 2	 Click one of the fixtures’ names and choose Movement Speed from the shortcut 
menu. 

The keyboard shortcuts in this section assume that the Movement Speed property is 
selected. 

Change the speed mode (if available) 

	 1	 Click the button below the words “Movement Speed”. (The button is only visible 
if your fixtures support different speed modes.) 

	 2	 Select one of the available options. (Lightkey only shows the options that your 
fixtures support). 

• Tracking: The fixture follows the position sent by Lightkey as closely as 
possible. This mode is appropriate for most situations. Always use this 
mode if the position is controlled by a movement path or sequence. (You 
can quickly select this mode by pressing T.) 

• Tracking, Slow/Medium/Fast Speed: Some fixtures provide specialized 
algorithms for slow, medium, and fast movements. See your fixture’s 
documentation for more information. 

• Vector: The fixture uses an internal algorithm to calculate a smooth 
movement between the positions sent by Lightkey. The speed can be 
controlled with the Speed slider. Using this mode is usually not necessary 
because Lightkey can generate continuous fixture movements. (You can 
quickly select this mode by pressing V.) 
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• Blackout During Pan/Tilt Movement: Like tracking, but the dimmer or 
shutter close while the fixture is in motion. (You can quickly select this 
mode by pressing B.) 

• Blackout During Wheel Movement: Like tracking, but the dimmer or 
shutter close during color or gobo wheel transitions. 

• Blackout During Pan/Tilt & Wheel Movements: Like tracking, but the 
dimmer or shutter close while the fixture moves and during color or gobo 
wheel transitions. 

Change the movement speed (if available) 

	 1	 If the selected fixtures support multiple speed modes, make sure Vector is 
selected. 

	 2	 Do one of the following to change the vector speed: 

‣ Drag the Speed slider. Alternatively, place the pointer over the slider and 
scroll. (If this doesn’t work, choose Lightkey > Settings…, click Gestures, 
and make sure “Scrolling changes slider and HUD values” is selected.) 

‣ Press the Left/Right Arrow keys or Minus/Plus keys to decrease/increase 
the speed. (Press Option-Left/Right Arrow or Option-Minus/Plus for fine 
control.) 

Prism 
The Prism property multiplies the light beam by passing it through a faceted glass 
lens. Each facet produces a copy of the beam at a slightly different focus. Many 
fixtures support rotating prisms at fixed or variable speeds. Some fixtures have 
multiple superimposed prisms; in this case there are multiple Prism properties 
which can be controlled independently. 

Select the Prism property 

	 1	 Select one or more fixtures which support the Prism property. 

	 2	 Do one of the following: 

‣ Click one of the fixtures’ names and choose Prism from the shortcut 
menu. 

‣ Press Shift-M or press M until the Prism property is selected. 
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The keyboard shortcuts in this section assume that the Prism property is selected. 

Select a prism type 

Do one of the following: 

‣ Click a prism icon. (Only the prism types that are supported by your fixtures are 
shown.) 

‣ Type a number. 

Prism states 
Some fixtures support some or all of the following prism states: 

• Rotation: Continuous rotation in clockwise or counterclockwise direction. 

• Bouncing: Continuous rotation with alternating direction. 

• Indexing: Changes the prism’s angle. 

Change the prism rotation state 

‣ Click  or press R to enable rotation. Repeat to reverse the rotation direction, 

and repeat again to stop the rotation. (The icon is only visible if the fixture 
supports prism rotation.) 

‣ If the fixture supports prism rotation with variable speed: Press the mouse 
button over  and drag up or down to adjust the speed, or press the Minus/

Plus keys. Press Option-Minus or Option-Plus for fine control. 

Change the prism bounce state 

‣ Click  or press B to enable bouncing. Repeat to stop bouncing. 

‣ If the fixture supports prism bouncing with variable speed: Press the mouse 
button over  and drag up or down to adjust the speed, or press the Minus/
Plus keys. Press Option-Minus or Option-Plus for fine control. 

Rotate the prism (indexing) 

‣ Press the mouse button over  and drag up or down to adjust the angle. Click 

again to disable prism indexing. (The icon is only visible if the fixture supports 
prism indexing.) 
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‣ Press I to turn indexing on or off. Press the Minus/Plus keys to change the 
angle; press Option-Minus or Option-Plus for fine control. 

Focus 
The Focus property adjusts the beam so that the light is concentrated on the focal 
point. This gives you control over the sharpness or clarity of a gobo on a surface. 

You can choose whether the Focus property is controlled from the Design view or a 
HUD. 

Choose how to control the Focus property 

	 1	 Choose Lightkey > Settings… (or press Command-Comma) and then click 
General. 

	 2	 Select one of the options next to “Design view”. 

Select the Focus property 

	 1	 Select one or more fixtures which support the Focus property. 

	 2	 Do one of the following: 

‣ Click one of the fixtures’ names and choose Focus from the shortcut 
menu. 

‣ Press Shift-F or press F until the Focus property is selected or the Focus 
HUD appears. 

The following tasks in this section assume that the Focus property is selected. 

Change the focus 

In the Design view: 

‣ Drag the Focus slider. To disable snapping press and hold the Command key. 

‣ Place the pointer over the slider and scroll. (If this doesn’t work, choose 
Lightkey > Settings…, click Gestures, and make sure “Scrolling changes slider 
and HUD values” is selected.) 

‣ Press the Left/Right Arrow keys or Plus/Minus keys to increase/decrease focus 
by 10%. 
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‣ Hold down the Option key and press the Left/Right Arrow keys to increase/
decrease focus by 1%. 

‣ Type a number to set the focus to an exact value. (Type a single digit to set the 
value in steps of 10%. Type two digits to set an exact percent value.) 

In the Focus HUD: 

‣ Click inside the focus control (the circle around the selected fixture’s icon). To 
adjust the focus hold down the mouse button and drag. To disable snapping 
press and hold the Control key. 

‣ Place the pointer over the focus control and scroll. (If this doesn’t work, choose 
Lightkey > Settings…, click Gestures, and make sure “Scrolling changes slider 
and HUD values” is selected.) 

‣ Place the pointer over the focus control and pinch on the trackpad using two 
fingers (requires a multi-touch trackpad or Apple Magic Trackpad). 

‣ Press the Up/Down Arrow keys or Plus/Minus keys to increase/decrease focus 
by 10%. 

‣ Hold down the Option key and press the Up/Down Arrow keys to increase/
decrease focus by 1%. 

‣ Type a number to set the focus to an exact value. (Type a single digit to set the 
value in steps of 10%. Type two digits to set an exact percent value.) 

Choose how the focus is applied to multiple fixtures 

‣ Click Focus and choose one of the following options from the menu: 

• Absolute: All fixtures are assigned the same focus value, regardless of 
their previous state. 

• Relative: This mode maintains the relative distances between the fixtures’ 
focus values. For example, if you increase the focus by 10%, all fixtures’ 
focus values increase by 10% from the previous value. 

Close the Focus HUD 

Do one of the following: 

‣ Click anywhere outside the HUD. 

‣ Press Return, Enter, or Esc. 
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Zoom 
The Zoom property controls the spread (angle) of the light beam, in degrees, by 
moving a lens back and forward inside the fixture. 

You can choose whether the Zoom property is controlled from the Design view or a 
HUD. 

Choose how to control the Zoom property 

	 1	 Choose Lightkey > Settings… (or press Command-Comma) and then click 
General. 

	 2	 Select one of the options next to “Design view”. 

Select the Zoom property 

	 1	 Select one or more fixtures which support the Zoom property. 

	 2	 Do one of the following: 

‣ Click one of the fixtures’ names and choose Zoom from the shortcut 
menu. 

‣ Press Shift-Z or press Z until the Zoom property is selected or the Zoom 
HUD appears. 

The following tasks in this section assume that the Zoom property is selected. 

Change the zoom angle 

In the Design view: 

‣ Drag the Zoom slider. To disable snapping press and hold the Command key. 

‣ Place the pointer over the slider and scroll. (If this doesn’t work, choose 
Lightkey > Settings…, click Gestures, and make sure “Scrolling changes slider 
and HUD values” is selected.) 

‣ Press the Left/Right Arrow keys or Plus/Minus keys to increase/decrease the 
zoom angle by 1°. 

‣ Hold down the Shift key and press the Left/Right Arrow keys to increase/
decrease the zoom angle by 10°. 

‣ Type a number to set the zoom angle to an exact value. 
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In the Zoom HUD: 

‣ Click inside the zoom control (the circle around the selected fixture’s icon). To 
adjust the angle hold down the mouse button and drag. To disable snapping 
press and hold the Control key. 

‣ Place the pointer over the zoom control and scroll. (If this doesn’t work, choose 
Lightkey > Settings…, click Gestures, and make sure “Scrolling changes slider 
and HUD values” is selected.) 

‣ Place the pointer over the zoom control and pinch on the trackpad using two 
fingers (requires a multi-touch trackpad or Apple Magic Trackpad). 

‣ Press the Up/Down Arrow keys or Plus/Minus keys to increase/decrease the 
zoom angle by 1°. 

‣ Type a number to set the zoom angle to an exact value. 

Choose how zoom angles are applied to multiple fixtures 

‣ Click Zoom and choose one of the following options from the menu: 

• Absolute: All fixtures are assigned the same zoom angle (as long as it is 
within their zoom ranges), regardless of their previous state. 

• Relative: This mode maintains the relative distances between the fixtures’ 
zoom angles. For example, if you increase the angle by 20°, all fixtures’ 
zoom angles increase by 20° from the previous value. 

Close the Zoom HUD 

Do one of the following: 

‣ Click anywhere outside the HUD. 

‣ Press Return, Enter, or Esc. 

Iris 
The Iris property controls a set of blades which reduce the size of the light beam, 
similar to the iris in a camera lens. It lets you adjust the beam diameter without 
changing focus or zoom. 
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You can choose whether the Iris property is controlled from the Design view or a 
HUD. 

Choose how to control the Iris property 

	 1	 Choose Lightkey > Settings… (or press Command-Comma) and then click 
General. 

	 2	 Select one of the options next to “Design view”. 

Select the Iris property 

	 1	 Select one or more fixtures which support the Iris property. 

	 2	 Do one of the following: 

‣ Click one of the fixtures’ names and choose Iris from the shortcut menu. 

‣ Press Shift-I or press I until the Iris property is selected or the Iris HUD 
appears. 

The following tasks in this section assume that the Iris property is selected. 

Change the iris size 

In the Design view: 

‣ Drag the Iris slider. To disable snapping press and hold the Command key. 

‣ Place the pointer over the slider and scroll. (If this doesn’t work, choose 
Lightkey > Settings…, click Gestures, and make sure “Scrolling changes slider 
and HUD values” is selected.) 

‣ Press the Left/Right Arrow keys or Plus/Minus keys to increase/decrease the 
iris size angle by 10%. 

‣ Hold down the Option key and press the Left/Right Arrow keys to increase/
decrease the iris size by 1%. 

‣ Type a number to set the iris size to an exact value. (Type a single digit to set 
the value in steps of 10%. Type two digits to set an exact percent value.) 

In the Iris HUD: 

‣ Click inside the iris control (the circle around the selected fixture’s icon). To 
adjust the iris size hold down the mouse button and drag. To disable snapping 
press and hold the Control key. 
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‣ Place the pointer over the iris control and scroll. (If this doesn’t work, choose 
Lightkey > Settings…, click Gestures, and make sure “Scrolling changes slider 
and HUD values” is selected.) 

‣ Place the pointer over the iris control and pinch on the trackpad using two 
fingers (requires a multi-touch trackpad or Apple Magic Trackpad). 

‣ Press the Up/Down Arrow keys or Plus/Minus keys to increase/decrease the 
iris size by 10%. 

‣ Hold down the Option key and press the Up/Down Arrow keys to increase/
decrease the iris size by 1%. 

‣ Type a number to set the iris size to an exact value. (Type a single digit to set 
the value in steps of 10%. Type two digits to set an exact percent value.) 

Choose how iris sizes are applied to multiple fixtures 

‣ Click Iris and choose one of the following options from the menu: 

• Absolute: All fixtures are assigned the same iris size (as long as it is 
within their iris ranges), regardless of their previous state. 

• Relative: This mode maintains the relative distances between the fixtures’ 
iris sizes. For example, if you increase the size by 10%, all fixtures’ iris 
sizes increase by 10% from the previous value. 

Close the Iris HUD 

Do one of the following: 

‣ Click anywhere outside the HUD. 

‣ Press Return, Enter, or Esc. 

Frost 
The Frost property controls a diffusion filter which softens the light beam. Some 
fixtures allow control over the degree of softening, others simply let you control if the 
effect is on or off. Some fixtures also support a frost pulse effect (gradually 
increasing the frost amount and abruptly reducing it, or vice versa). 

Select the Frost property 

	 1	 Select one or more fixtures which support the Frost property. 
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	 2	 Do one of the following: 

‣ Click one of the fixtures’ names and choose Frost from the shortcut menu. 

‣ Press Shift-R or press R until the Frost property is selected. 

The keyboard shortcuts in this section assume that the Frost property is selected. 

Enable or disable the frost filter 

‣ Click On or Off or press O. 

Control the degree of softening 

	 1	 Click Linear or press L. 

	 2	 Do one of the following to adjust the frost amount: 

‣ Drag the slider. Alternatively, place the pointer over the slider and scroll. 
(If this doesn’t work, choose Lightkey > Settings…, click Gestures, and 
make sure “Scrolling changes slider and HUD values” is selected.) 

‣ Press the Left/Right Arrow keys or Minus/Plus keys to decrease/increase 
the frost amount by 10%. 

‣ Hold down the Option key and press the Left/Right Arrow keys or Minus/
Plus keys to decrease/increase the frost amount by 1%. 

‣ Type a number to set the frost amount to an exact value. (Type a single 
digit to set the value in steps of 10%. Type two digits to set an exact 
percent value.) 

Apply a frost pulse effect 

	 1	 Click Pulse or press P. Do this again to change the pulse direction (if the fixture 
supports both increasing and decreasing pulse effects). 

	 2	 Do one of the following to change the pulse speed: 

‣ Drag the Pulse Speed slider. Alternatively, place the pointer over the 
slider and scroll. (If this doesn’t work, choose Lightkey > Settings…, click 
Gestures, and make sure “Scrolling changes slider and HUD values” is 
selected.) 

‣ Press the Left/Right Arrow keys or Minus/Plus keys to decrease/increase 
the speed. (Press Option-Left/Right Arrow or Option-Minus/Plus for fine 
control.) 
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Fog 
The Fog property controls the amount of fog or haze produced by a fog machine or 
hazer. 

Select the Fog property 

	 1	 Select one or more fixtures which support the Fog property. 

	 2	 Do one of the following: 

‣ Click one of the fixtures’ names and choose Fog from the shortcut menu. 

‣ Press Shift-O or press O until the Fog property is selected. 

The keyboard shortcuts in this section assume that the Fog property is selected. 

Change the fog amount 

Do one of the following: 

‣ Drag the Fog slider. To disable snapping press and hold the Command key. 

‣ Alternatively, place the pointer over the slider and scroll. (If this doesn’t work, 
choose Lightkey > Settings…, click Gestures, and make sure “Scrolling 
changes slider and HUD values” is selected.) 

‣ Press the Left/Right Arrow keys or Minus/Plus keys to decrease/increase the 
fog amount by 10%. 

‣ Hold down the Option key and press the Left/Right Arrow keys or Minus/Plus 
keys to decrease/increase the fog amount by 1%. 

‣ Type a number to set the fog amount to an exact value. (Type a single digit to set 
the value in steps of 10%. Type two digits to set an exact percent value.) 
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Custom fixture properties 
Many fixtures have additional, non-standard properties which can be controlled in 
the Design view. These properties can take three forms: 

 

Select a custom fixture property 

	 1	 Select one or more fixtures which support the property. 

	 2	 Click one of the fixtures’ names and choose the property name from the 
shortcut menu. 

The keyboard shortcuts in this section assume that the property is selected. 

Slider 
A slider represents a linear value in a finite range, such as 0–100% or 0–255 (the 
range of a DMX channel). 

Change the property’s value 

Do one of the following: 

‣ Drag the slider. To disable snapping press and hold the Command key. 

‣ Place the pointer over the slider and scroll. (If this doesn’t work, choose 
Lightkey > Settings…, click Gestures, and make sure “Scrolling changes slider 
and HUD values” is selected.) 

‣ Press the Left/Right Arrow keys or Minus/Plus keys to decrease/increase the 
value. 

Chocolate

ChocolateStrawberry

StrawberryVanilla

Vanilla

Fan Speed

Slider List of options List of options with slider

Strawberry Strawberry
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‣ Hold down the Option key and press the Left/Right Arrow keys or Minus/Plus 
keys to decrease/increase the value in smaller increments. 

‣ Hold down the Shift key and press the Left/Right Arrow keys or Minus/Plus keys 
to decrease/increase the value in larger increments. 

‣ Type a number to select an exact value. 

List of options 
If the property is represented by a list of options, you can choose one of the options 
from the list. The property may also have a slider, whose meaning usually depends 
on the selected option and which may not be available for all options. 

Select an option and change the slider value (if available) 

	 1	 Do one of the following: 

‣ Click the property’s button. 

‣ Press Return or Enter (when the property is selected). 

	 	 The list of options appears. 

	 2	 Do one of the following: 

‣ Click an option. 

‣ Type the first letters of an option’s name. 

‣ Press the Up/Down Arrow keys to select the previous/next option. 

	 3	 If a slider is visible and enabled, do one of the following: 

‣ Drag the slider. Alternatively, place the pointer over the slider and scroll. 

‣ Press the Left/Right Arrow keys or Minus/Plus keys to decrease/increase 
the value. 

	 4	 Press Return or Enter to hide the list of options. 

 
	★	 Tip: Double-click an option to select it and hide the options.
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Reorder or hide custom properties 
By default, custom properties are ordered as they appear in the fixture profile, but 
you can reorder or hide properties as you like. For example, you can hide unused 
properties to free up space in the Design view. 

You can’t reorder or hide the built-in standard fixture properties. 

Reorder or hide custom properties 

	 1	 Select one or more fixtures with custom properties. 

	 2	 Click Edit in the top-right of the Design view. Alternatively, choose View > Edit 
Design View or press Command-Shift-Option-D. 

	 3	 Make changes in the Design view as appropriate: 

‣ To change the order of the custom properties, drag them to the desired 
position. 

‣ To hide a custom property, click the box to the left of its name. 

	 4	 Click Done (or press Command-Return). 

Quickly hide a fixture property 

‣ Click the fixture property’s name in the Design view and select Hide This 
Property from the menu. 

Lamp 
The Lamp property turns a fixture’s illuminant on or off. Lightkey automatically turns 
the lamp on when you start the application or open a project, and you can tell it to 
turn the lamp off when you quit the application or close the project. You will rarely 
need to use this property during normal operation. Note that only some fixtures 
support the Lamp property. 

 
	❖	 Note: The Lamp property can’t be stored in presets.
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Manually turn a fixture’s lamp on or off 

Do one of the following: 

‣ Click the fixture’s name and choose Lamp > On or Lamp > Off from the 
shortcut menu. 

‣ Select the fixture and choose Fixture > Lamp > On or Fixture > Lamp > Off. 

Automatically turn the lamp off when you quit Lightkey or close the project 

	 1	 Choose Lightkey > Settings… (or press Command-Comma) and then click 
General. 

	 2	 Select “Send Lamp Off to fixtures” and choose how long the “lamp off” value 
should be sent. You can find the required duration in your fixtures’ 
documentation. 

Command 
The Command property can be used to send various commands to a fixture. 
(Technically, this is done by setting a DMX channel to a certain value for a short 
amount of time.) The available commands depend on your fixtures; common 
commands are: 

• Reset 

• Reset Pan/Tilt 

• Enable blackout during pan/tilt movement 

• Disable blackout during pan/tilt movement 

 

Send a command 

Do one of the following: 

‣ Click the fixture’s name, choose Command from the shortcut menu and then 
choose one of the commands from the submenu. 

‣ Select the fixture, choose Fixture > Command and then choose one of the 
commands from the submenu. 

	❖	 Note: The Command property can’t be stored in presets.

Lightkey User Guide	 112



Default values 
Lightkey uses sensible default values for fixture properties that aren’t defined. For 
example, it sets the Shutter property to “closed” and the Movement Speed to the 
fastest speed. You can change those defaults, if necessary, for each individual fixture. 

Change a fixture property’s default values 

	 1	 Select one or more fixtures in the Preview. The new defaults will only affect 
those fixtures. 

	 2	 Change the fixture property in the Design view or a HUD. The property must not 
be fanned or have an effect. 

	 3	 Press the mouse button over the fixture property name in the Design view or 
HUD and choose Set as Default from the menu. 

If you previously set a custom default value for a fixture property you can load it—that 
is, add it to the overridden fixture properties—or reset it to the original state. 

Load a fixture property’s default values 

	 1	 Select one or more fixtures in the Preview. 

	 2	 Hold down the Option key, press the mouse button over the fixture property 
name, and choose Load Default. 

Reset a fixture property’s default values to the original values 

	 1	 Select one or more fixtures in the Preview. The change will only affect those 
fixtures. 

	 2	 Press the mouse button over the fixture property name and choose Reset 
Default. 

Copy and paste fixture properties 
You can copy a fixture’s properties—including fanned values and effects—to the 
Clipboard and then paste them to other fixtures. This copies the overridden 
properties or the properties of the preset being edited, but not values applied by 
other active presets, sequences, or cues, or default property values. 
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You can copy properties between fixtures of different kinds, assuming that the 
involved fixtures support them. Lightkey tries to convert the values as necessary: For 
example, if you copy a CMY fixture’s Color property to an RGB fixture, Lightkey 
determines the equivalent RGB color. 

Copy and paste fixture properties 

	 1	 Do one of the following: 

‣ Select a single fixture, then choose Edit > Copy Properties (or press 
Command-C). This copies all overridden properties. To copy a single 
property, choose Copy Property > (property name). 

‣ Select a single fixture, then click  (or 􀍡) in the toolbar and choose Copy 
Properties from the menu. This copies all overridden properties. To copy a 
single property, choose Copy Property > (property name). 

‣ Select one or more fixtures, then click the name of a fixture property in 
the Design view or a HUD and select Copy (property name) from the menu. 
This will copy only a single fixture property. 

	 	 To copy the properties of an individual light beam, select the beam before 
copying. 

	 2	 Select one or more fixtures you want to apply the properties to. To apply the 
properties to individual light beams only, select those beams. 

	 3	 Do one of the following: 

‣ Choose Edit > Paste Properties (or press Command-V). 

‣ Click  (or 􀍡) in the toolbar and choose Paste Properties from the menu. 

‣ Click the name of a fixture property in the Design view or a HUD and 
choose Paste (property name) from the menu. 

 

	❖	 Note: The menu for copying fixture properties doesn’t include properties that 
have been hidden from the Design view. See Reorder or hide custom 
properties earlier in this chapter on how to show or hide properties in the 
Design view.
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View overridden fixture properties 
Lightkey can give you a quick overview of the fixture properties that are currently 
overridden. 

Show the overridden fixture properties 

Do one of the following: 

‣ Click Overrides in the toolbar. 

‣ Click the blue dot next to a fixture’s name. 

‣ Choose Fixture > Show Properties (or press Command-P). 

‣ Control-click in a blank part of the Preview and choose Show Properties from 
the shortcut menu. 

Lightkey will display the names of the overridden properties next to the fixtures’ 
icons. You can quickly select one of the properties for editing or clear a property. 

 

Hide the overridden fixture properties 

‣ Click anywhere in the Preview or press Esc, Return, or Enter. 

Clear fixture properties 
You can quickly clear (or “undefine”) some or all overridden properties. This will also 
remove effects and fanning. 

Clear a single fixture property 

	 1	 Select one or more fixtures. 

Click a property to 
select and edit it

Move the pointer over a 
property and click the ! icon 
to clear the property for the 
fixture. Hold down the Option 
key to clear the property for all 
fixtures
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	 2	 Do one of the following: 

‣ Click the blue (or gray) dot to the left of the property’s name in the Design 
view or the property’s HUD. 

‣ Select a fixture property and press the Space bar or Delete key. 

Clear all overridden fixture properties for a set of fixtures 

	 1	 Select one or more fixtures. 

	 2	 Do one of the following: 

‣ Click one of the fixtures’ names and choose Clear Properties from the 
shortcut menu. 

‣ Click  (or 􀍡) in the toolbar and choose Clear Properties from the menu. 

‣ Select Fixture > Clear Properties (or press Delete). 

Clear all overridden properties from all fixtures 

Do one of the following: 

‣ Click  in the toolbar. 

‣ Select Fixture > Clear Properties for All Fixtures (or press Command-Shift-
Delete). 

‣ Control-click a blank part of the Preview and choose Clear Properties for All 
Fixtures from the shortcut menu. 

After all properties have been cleared, the blue dots to the left of the fixtures’ names 
in the Preview disappear. 

Undo changes 
If you inadvertently changed a fixture property, you can undo the change. You can 
also redo changes that you have undone. 

Undo or redo changes 

‣ To undo the last action, choose Edit > Undo (or press Command-Z). 

‣ To redo the last action you undid, choose Edit > Redo (or press Command-
Shift-Z). 
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Fanning 
Fanning (also called “spreading”) lets you create interesting looks by distributing 
fixture property values evenly across a range of fixtures. You define the property 
values for at least two fixtures or beams—usually the first and last—, and Lightkey 
calculates the values for the fixtures or beams in between. In the following, the term 
pixel is used for the smallest unit which can be individually controlled—either a 
fixture or a beam. Depending on the fixture property being fanned, the term value 
refers to a percentage, color, fixture position, etc. 

Example: By fanning colors across the beams of LED strips you can easily create 
color gradients. 

 

Example: Pan angles spread over a row of moving lights. 

 

You can apply fanning to the following fixture properties: 

• Dimmer 
• Color 
• Position 
• Focus 
• Zoom 
• Iris 
• Frost 
• Fog 
• Any custom property represented by a slider 

Like regular property values, fanned properties can be stored in presets, sequences, 
and cues while staying fully editable at any time. 

Fan a fixture property 
You can apply fanning to any fixture property listed above. 
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Fan a fixture property 

	 1	  Select at least three fixtures, or a fixture with at least three beams. You can 
select individual beams to constrain fanning to those beams. 

	 2	  Do one of the following to select a fixture property: 

‣ Click one the fixture’s names and select a property from the shortcut 
menu. 

‣ Choose Fixture > Select Property, then select a property from the menu. 

	 3	 Click the fixture property’s name in the Design view or the property’s HUD, then 
choose Add (property name) Fanning… from the menu. 

	 	 Lightkey displays the Fanning HUD around the fixtures’ icons in the Preview. 

 

In the example above, the fixtures are ordered from left to right. There are other 
possibilities for ordering fixtures and beams which affect the result of the fanning. 

Change the order of fixtures (or beams) 

	 1	 When the Fanning HUD is visible, click Fixture Order. 

	 	 As you move the mouse pointer over an item in the menu, Lightkey shows the 
resulting fixture order in the Preview. 

	 2	 Select an option as appropriate: 

• Left to Right: Sort the fixtures or beams from left to right as they appear 
in the Preview. 

The blue dots indicate that 
positions have been defined 
for the outer fixtures

Select whether the pan angle, tilt 
angle, or both should be fanned 
(Position property only)
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• Right to Left: Sort the fixtures or beams from right to left as they appear 
in the Preview. 

• Top to Bottom: Sort the fixtures or beams from top to bottom as they 
appear in the Preview. 

• Bottom to Top: Sort the fixtures or beams from bottom to top as they 
appear in the Preview. 

• By Short Name: Sort the fixtures alphabetically by their short name, either 
ascending or descending. Beams are sorted by their index. 

• By Address: Sort the fixtures by their universe and DMX address, either 
ascending or descending. Beams are sorted by their index. 

• Consider Spacing: When using one of the position-based options, consider 
the distances of the pixels in the Preview. 

• Select Fixtures: Treat all beams of a fixture as a single pixel. 

• Select Beams: For fixtures with multiple beams, treat the beams as 
individual pixels. 

Example: Colors fanned across multiple fixtures with the Left to Right order. 

 

If the By Short Name order is selected instead, the result would look like this: 

 

Example: Colors fanned from left to right across four LED matrixes using the 
Fixtures option. All beams of each matrix have the same color. 
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If the Beams option is selected instead, fanning includes the individual beams: 

 

Example: Positions fanned across six unevenly spaced moving lights. 

 

The same example with the Consider Spacing option selected: 

 

Define the value for a fixture or beam 

‣ Click the fixture or beam, then choose a value. 

A blue dot near the fixture or beam indicates that a value has been defined. The 
values for the fixtures or beams in between are calculated automatically. 

Change the value for a fixture or beam 

	 1	 Do one of the following: 

‣ Click the fixture or beam with a value. 

‣ Press Tab to edit the first fixture or beam with a value, or Shift-Tab to edit 
the last. 

	 2	 Change the value as desired. 

	 3	 Press Tab or Shift-Tab to edit the previous or next value. 

	 4	 Press Return, Enter, or Esc to end editing. 
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Remove the defined value for a fixture or beam 

Do one of the following: 

‣ Click the blue dot near the fixture or beam. 

‣ Control-click the fixture or beam and choose Delete from the shortcut menu. 

You can’t remove the last two defined values. 

Copy a value to another pixel or beam 

	 1	 In the Fanning HUD, Control-click a fixture or beam with a value, then choose 
Cut or Copy from the shortcut menu. 

	 2	 Control-click another fixture or beam and then choose Paste. 

Edit Fanning 
When a fixture property is being fanned, its area in the Design view shows an icon 
instead of the normal controls. You can open the Fanning HUD and edit the fanning 
settings at any time. 

Edit a fanned fixture property 

Do one of the following: 

‣ Click the icon in the Design view. 

‣ Click a fixture’s name in the Preview, then select a fixture property from the 
shortcut menu. Fanned properties are marked with an 􀜍 icon. 

‣ Click Overrides in the toolbar. The names of the overridden properties appear 
next to the fixtures’ icons, and an 􀜎 icon marks fanned properties. Click a 
fixture property’s name to edit it. 

Delete Fanning 
When you delete fanning, you can either keep the fanned values or clear the entire 
fixture property so it’s no longer defined. 

Delete fanning and keep the fanned values 

‣ While the Fanning HUD is open, click the title at the upper-left and choose 
Delete Fanning and Keep Values from the menu. 
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Delete fanning 

Do one of the following: 

‣ While the Fanning HUD is open, click the title at the upper-left and choose 
Delete Fanning from the menu. 

‣ If the fixture property appears in the Design view, select the fixtures and then 
click the blue dot to the left of the property’s name in the Design view. 

‣ Click  in the toolbar or choose Fixture > Clear Properties for All Fixtures (or 

press Command-Shift-Delete). This will also remove any other overridden 
properties from all fixtures. 
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Chapter 9   
Presets and sequences 

 

Presets and sequences are the basic building 
blocks of your light show. They are also the basis 
for cues, which will be introduced in the next 
chapter. 

A preset stores an arbitrary combination of fixture properties for a set of fixtures. For 
example, it could contain colors for a group of moving heads, or their pan/tilt 
positions, or both. Presets can contain (or define) different properties for different 
fixtures. They can also contain effects, which remain fully editable. A preset can 
either define or not define a property for a given fixture: It cannot define the property 
for some of a fixture’s beams only, or define only some of the property’s traits. 

Although the concept of presets is deliberately flexible, there are common patterns 
for using them. You may want to create “looks” for groups of related fixtures which 
you can later combine to a complete scene. A more modular approach is to create 
presets with only one or two properties for a given group of fixtures. There could be a 
set of “color” presets, another set of “gobo” presets, and so on, which you can later 
use to quickly compose a look on the stage. 

Whichever way you prefer, it is a good idea to organize similar presets in groups. 
Here’s an example of three typical preset groups: 

􀆈  LED Bars 

 Magenta 

 Orange 

 Yellow

􀆈  Moving Head Colors 

 Deep Blue 

 Lime Green 

 Color Change

􀆈  Moving Head Gobos 

 Spiral 

 Spiral (rotating) 

 Flower (shaking)
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Presets remain editable at any time. When you change a preset, the change affects 
all cues which use it. That makes presets a great way to built a flexible system which 
lets you adjust parameters like positions or intensities throughout the project. 

A sequence contains a number of presets (called steps) which are activated one after 
the other. Each step has a duration which determines how long it remains active. 
Lightkey can crossfade between two succeeding steps, which can be the basis for 
interesting effects. There are various settings which control the order and timing of 
sequences. You can also synchronize sequences to music, which means they will 
advance to the next step in sync to the beat. 

Presets and sequences appear in the Preset Palette at the right side of the main 
window. 

If you don’t see the Preset Palette 

‣ Choose View > Show Preset Palette. 

Create a preset 
There are two ways to create a preset: You can define some fixture properties and 
then save the result as a preset. Or you can begin with an empty preset and then 
define its fixture properties. 

You can also capture the current state of all fixtures in a new preset. 

Create a preset from the overridden fixture properties 

	 1	 Select one or more fixtures and change their properties. (See chapter 8, Fixture 
properties, for more information.) Fixtures with overridden properties display a 
blue dot to the left of their name in the Preview. 

	 2	 Do one of the following: 

‣ Click 􀅼 in the toolbar. 

‣ Choose Preset > New Preset (or press Command-N). 

‣ Control-click an item in the Preset Palette and choose New Preset from 
the shortcut menu. (If the clicked item is a group or sequence, the new 
preset is added at the end of the group or sequence. If the clicked item is a 
preset, the new preset is inserted after the preset.) 
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	 	 A new preset appears in the Preset Palette, containing the overridden 
properties of all fixtures. Lightkey automatically creates an icon and proposes a 
name for the preset depending on its content. 

	 3	 If you want to keep the proposed name, simply press Return. Otherwise type a 
different name and then press Return. 

Create a preset that is initially empty 

	 1	 Click  in the toolbar or choose Fixture > Clear Properties for All Fixtures to 

make sure no fixture properties are overridden. 

	 2	 Click 􀅼 in the toolbar, or use one of the alternatives listed above. 

	 	 A new, empty preset appears in the Preset Palette. 

	 3	 Select one or more fixtures and change their properties. 

	 4	 Click the checkmark next to the preset’s name in the Preset Palette. 

Create a preset which captures the current state of all fixtures 

	 1	 Do one of the following: 

‣ Press the mouse button over the 􀅼 symbol in the toolbar until a menu 
appears, then choose New Preset With Snapshot. 

‣ Choose Preset > New Preset With Snapshot. 

‣ Control-click an item in the Preset Palette and choose New Preset With 
Snapshot from the shortcut menu. 

	 	 A new preset appears in the Preset Palette, containing the state of all fixtures 
at the time the preset was created. The preset includes all fixtures and all 
properties, even if a fixture is off. 

	 2	 Enter a name for the preset and then press Return. 

View preset contents 
Lightkey can give you a quick overview of the fixtures and fixture properties affected 
by a given preset. 

Lightkey User Guide	 125



Show the contents of a preset 

Do one of the following: 

‣ Click the preset in the Preset Palette. (This will also activate the preset, as 
described below.) 

‣ Control-click the preset and choose Show Properties from the shortcut menu. 

Lightkey will display the names of the properties defined for each fixture next to the 
fixture icons in the Preview. 

Hide the contents of a preset 

Do one of the following: 

‣ Click anywhere in the Preview. 

‣ Press Esc, Return, or Enter. 

Activate or deactivate presets 
A preset is active when it’s selected in the Preset Palette. When a preset is active, its 
fixture properties are applied to the fixtures. (Note that overridden fixture properties 
take precedence over active presets.) 

Activate a preset 

‣ Click the preset in the Preset Palette. 

Activate a range of presets 

	 1	 Click the first preset. 

	 2	 Hold down the Shift key and click the last preset. 

Toggle a preset’s active state 

‣ Hold down the Command key and click the preset. 

Deactivate all presets 

‣ When the Preset Palette has focus, choose Edit > Deactivate All (or press 
Command-Shift-A or Esc). 
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Active presets take precedence over cues (see chapter 11, Live Control). It’s 
therefore a good idea to deactivate all presets before you run a show from the Live 
view. 

Edit a preset 
You can always change the fixture properties stored in a preset after it has been 
created. 

Edit the fixture properties in a preset 

	 1	 Do one of the following: 

‣ Move the pointer over the preset in the Preset Palette and click Edit. 

‣ Hold down the Command key and double-click the preset. 

‣ Click the preset in the Preset Palette and choose Preset > Edit (or press 
Command-Shift-E). 

‣ Control-click the preset and choose Edit from the shortcut menu. 

	 	 White you are editing a preset, its name appears in the center area of the 
toolbar. 

	 2	 Make changes to the fixture properties. (See chapter 8, Fixture properties, for 
more information.) 

	 3	 Click Update next to the preset’s name in the Preset Palette, or press Return. 
(To discard your changes and return to the preset’s previous state, hold down 
the Option key and click Cancel next to the preset’s name, choose Preset > 
Cancel Editing, or press Esc). 

Lightkey will update the preset’s contents and icon. If the preset’s name has been 
automatically assigned by Lightkey, it is updated too. 

Presets and overridden properties 
You can add the contents of a preset—that is, the fixture properties it defines—to the 
overridden fixture properties. When you do this, the fixture properties in the preset 
replace any previous values for those properties. Fixture properties not defined by 
the preset remain unchanged. 
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Add the contents of presets to the overridden properties 

Do one of the following: 

‣ Select one or more presets in the Preset Palette and choose Preset > Apply. 

‣ Control-click a preset and choose Apply from the shortcut menu. 

‣ Select one or more presets and drag them to the Preview area. 

Hold down the Option key to only change the selected fixtures. 

You can use the same technique to merge two presets. 

Merge two presets 

	 1	 Move the pointer over the first preset in the Preset Palette and click Edit. 

	 2	 Control-click the second preset and choose Apply from the shortcut menu. 

	 3	 Click the checkmark next to the first preset’s name in the Preset Palette, or 
press Return. 

If some fixture properties are defined by both presets, the properties from the 
second preset will replace those from the first. 

In reverse, you can also add the overridden fixture properties to one or more existing 
presets. In this case the overridden properties replace any previous values in the 
presets. Fixture properties that aren’t overridden remain unchanged. 

This technique is an alternative to editing the preset, as described earlier. It is 
especially handy when you need to change multiple presets at once. 

Add the overridden fixture properties to one or more presets 

	 1	 Select one or more fixtures and change their properties. (See chapter 8, Fixture 
properties, for more information.) Fixtures with overridden properties display a 
blue dot to the left to their name in the Preview. 

	 2	 Do one of the following: 

‣ Select one or more presets in the Preset Palette and choose Preset > 
Add Overrides. 

‣ Control-click a preset and choose Add Overrides from the shortcut menu. 
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‣ To add the overridden properties for the selected fixtures only, hold down 
the Option key as you perform one of the preceding steps. The command 
changes to Add Overrides for Selected Fixtures. 

Create a preset group 
As your list of presets grows, you may find it easier to create groups of similar 
presets, which can be collapsed and expanded as necessary. Apart from presets, 
groups can also contain sequences and other groups. 

Create an empty preset group 

	 1	 Do one of the following: 

‣ Press the mouse button over the 􀅼 symbol in the toolbar until a menu 
appears, then choose New Group. 

‣ Choose Preset > New Group (or press Command-Shift-N). 

‣ Control-click an item in the Preset Palette and choose New Group from 
the shortcut menu. 

	 2	 Enter a name for the group and then press Return. 

Create a group from existing items 

	 1	 Select some presets, sequences, or groups in the Preset Palette. (Hold down 
the Shift or Command key to select multiple items.) 

	 2	 Do one of the following: 

‣ Press the mouse button over the 􀅼 symbol in the toolbar until a menu 
appears, then choose New Group From Selection. 

‣ Choose Preset > New Group From Selection (or press Command-Option-
Shift-N). 

	 3	 Enter a name for the group and then press Return. 

Expand or collapse a group 

Do one of the following: 

‣ Click the disclosure triangle to the left of the group name. 

‣ Click the group in the Preset Palette and choose Preset > Expand/Collapse 
Group (or press Command-Left/Right Arrow). 
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Create a sequence 
Sequences look similar to groups in the Preset Palette; you can distinguish them by 
their icon to the left of the name. Like groups, they can be collapsed and expanded. 
Sequences contain a list of presets, but unlike groups, they cannot contain groups or 
other sequences. The presets in a sequence are also called steps. 

Create an empty sequence 

	 1	 Do one of the following: 

‣ Press the mouse button over the 􀅼 symbol in the toolbar until a menu 
appears, then choose New Sequence. 

‣ Choose Preset > New Sequence (or press Command-Control-N). 

‣ Control-click an item in the Preset Palette and choose New Sequence 
from the shortcut menu. 

	 2	 Type a name for the sequence and then press Return. 

Create a sequence from existing presets 

	 1	 Select the presets in the Preset Palette. (Hold down the Shift or Command key 
to select multiple presets.) 

	 2	 Do one of the following: 

‣ Press the mouse button over the 􀅼 symbol in the toolbar until a menu 
appears, then choose New Sequence From Selection. 

‣ Choose Preset > New Sequence From Selection (or press Command-
Control-Option-N). 

	 3	 Type a name for the sequence and then press Return. 

View sequence contents 
Lightkey can give you a quick overview of the fixtures and fixture properties affected 
by a given sequence—or, more precisely, all fixture properties affected by any preset 
in the sequence. 

Show the contents of a sequence 

Do one of the following: 

‣ Click the sequence in the Preset Palette. 
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‣ Control-click the sequence and choose Show Properties from the shortcut 
menu. 

Lightkey will display the names of the properties defined for each fixture next to the 
fixture icons in the Preview. 

Hide the contents of a sequence 

Do one of the following: 

‣ Click anywhere in the Preview. 

‣ Press Esc, Return, or Enter. 

Run sequences 

Run or stop a sequence 

Do one of the following: 

‣ Click  or  to the right of the sequence’s name in the Preset Palette. 

‣ Click the sequence in the Preset Palette and choose Preset > Start Sequence 
or Preset > Stop Sequence. 

Sequence order 
There are various options which determine the order in which the steps in a 
sequence are activated. As an example, consider a sequence with four steps which 
define different fixture colors: 

	 	 Name 
	 	 Green 
	 	 Orange 
	 	 Red 
	 	 Purple 

If you run the sequence with the default settings, each step is activated once, from 
top to bottom: 

 time
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Change a sequence’s order 

	 1	 Do one of the following: 

‣ Double-click the sequence in the Preset Palette. 

‣ Control-click the sequence and choose Get Info from the shortcut menu. 

	 2	 In the window that appears, click Options at the top and change the settings as 
appropriate: 

‣ Repeat: Choose how many times the sequence repeats before it stops. 
Click the arrow in the text field and choose “inf” from the menu to make 
the sequence repeat infinitely. 

	  

‣ Backwards: If selected, the steps will be activated in reverse order (from 
bottom to top). 

	  

‣ Autoreverse: If selected, the sequence will reverse its direction after each 
pass. (The repeat count must be greater than one for this to have an 
effect.) If the Backwards option is selected, the first pass will be 
backwards; otherwise the first pass will be forwards. 

	  

‣ Random: With this option, each pass through the sequence activates the 
steps in a random order. The Backwards and Autoreverse options are 
ignored. 

‣ Freeze on completion: If selected, the last step will remain active when 
the sequence has finished. 

	  

 

Reorder sequence steps 
Lightkey provides two useful commands to quickly reverse the order of steps in a 
sequence or to reorder them randomly (shuffle). 

time

time

time

	❖	 Note: The options for Pan/Tilt movements in this window are described below 
in Create fixture movements with sequences.
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Reverse of shuffle all steps in a sequence 

Do one of the following: 

‣ Select the sequence in the Preset Palette, then choose Preset > Reverse 
Presets or Presets > Shuffle Presets. 

‣ Control-click the sequence and choose Reverse Presets or Shuffle Presets 
from the shortcut menu. 

Reverse or shuffle some of the steps in a sequence 

	 1	 Select some steps in the same sequence. (Hold down the Shift or Command key 
to select multiple items.) 

	 2	 Do one of the following: 

‣ Choose Preset > Reverse Presets or Presets > Shuffle Presets. 

‣ Control-click one of the selected steps and choose Reverse Presets or 
Shuffle Presets from the shortcut menu. 

Sequence timing 
A sequence can either use manual timing or beat-controlled timing. This section 
discusses the various parameters in the two modes and how they affect timing. 

Manual timing 
When using manual timing, each step in a sequence has a hold time which 
determines how long the step remains active. Consider the example from the 
previous section with the following hold times: 

	 	 Name	 Hold Time 
	 	 Green	 00:02.0 
	 	 Orange	 00:04.0 
	 	 Red	 00:02.0 
	 	 Purple	 00:04.0 

If you run the sequence, it would look like this: 

 00:00 00:02 00:04 00:06 00:08 00:10 00:12
time
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Lightkey can crossfade between consecutive steps. During the crossfade, fixture 
property values gradually change from the old to the new state. Crossfading only 
works under the following conditions: 

• The fixture property must be fadeable. For example, Lightkey can fade between 
Dimmer or Focus values but not between Shutter states like open and closed. 
Properties which are not fadeable will change in the middle of the crossfade 
period. 

• The fixture property must be defined in both the old and new step. For example, 
to have a fixture gradually light up from no to full intensity, the first step must 
define the Dimmer property with a value of 0% and the second step must define 
it with a value of 100%. 

The duration of a crossfade is called the fade time; it is added to the hold time. By 
default the fade time is zero, so all properties change instantly, as in the previous 
example. Here’s the same sequence with a fade time of 1 second: 

 

 

By setting the hold times to zero you can create a continuous animation. Changing 
the hold times to zero and the fade times to 4 seconds creates a rainbow effect: 

 

The crossfade between steps is also affected by the fade curve which appears to the 
left of the fade time. For details see Fade curves in chapter 11, Live control. 

A sequence has a default hold time, fade time, and fade curve. They are initially 
applied to all steps in the sequence but can be overridden for individual steps, as 
described below. 

time
00:14 00:1600:00 00:02 00:04 00:06 00:08 00:10 00:12

hold fade fade fadehold hold hold

	➤	 Important: Fade times do not apply to smart lights. They use a fixed fade time 
which can’t be changed in Lightkey.

time
00:14 00:1600:00 00:02 00:04 00:06 00:08 00:10 00:12

fade fade fade
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When using manual timing, you can quickly change the overall speed of a sequence 
through its speed rate. All hold and fade times are multiplied by this factor. Its 
default value is 1. 

Here’s the original sequence with a speed rate of 0.5: 

 

Here’s the original sequence with a speed rate of 1.5. 

 

Beat-controlled timing 
Beat-controlled timing lets you synchronize a sequence to music. In the simplest 
case the sequence advances to the next step on each beat: 

 

You can extend individual steps by increasing their length. If you set the length of the 
second and fourth step to 2, the sequence looks like this: 

 

To scale the entire sequence you can use a beat multiplier. In the previous examples 
the beat multiplier was 1. Setting the beat multiplier to ÷2, for example, results in the 
following timing: 

 

	❖	 Note: The fade time for the last step is only meaningful if the sequence 
repeats. In this case it defines the time to fade from the last step to the first.

00:00 00:02 00:04 00:06 00:08 00:10
time

00:12

time
00:14 00:1600:00 00:02 00:04 00:06 00:08 00:10 00:12

time

beat

time

beat

time

beat
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The beat multiplier does not only make the sequence shorter or longer, but scales 
the beat grid to which the sequence steps are aligned. All beat-controlled sequences 
and effects with the same multiplier use the same beat grid, so they all advance 
together even if they were started at different times. For example, all sequences and 
effects with a multiplier of ×4 will advance on beats 0, 4, 8, and so on. 

In the preceding examples, the start of the sequence fell exactly on a beat. This is no 
coincidence—Lightkey uses a technique called quantization by default to align the 
sequence start with the beat. With quantization enabled, Lightkey waits for the next 
beat before activating the first step. If a sequence is started very shortly after a beat, 
it may also activate the first step immediately. 

 

To further align the sequence on the beat grid you can increase its quantum. The 
sequence in the example is four beats long, so you may want to align it to a full bar 
when using a quadruple meter. Setting the quantum to 4 constrains the possible 
start points for the sequence to every 4th beat—that is, beats 0, 4, 8, and so on. As a 
consequence Lightkey may skip several beats before the first step becomes active: 

 

Sequences with a beat multiplier are already aligned to a scaled beat grid. If you also 
apply a quantum, it is multiplied with the beat multiplier: For example, a sequence 
with a multiplier of ×4 and a quantum of 2 can start on every 8th beat. 

When you sync Lightkey’s beat grid to an audio software, sometimes beat numbers 
are shifted by one or more beats. You can apply an offset to correct this. For 
example, a sequence with a quantum of 4 and an offset of 1 may start at beats 1, 5, 9, 
and so on. 

If you want a sequence to start immediately without any wait time you can disable 
quantization. This is useful to avoid blackouts between cues, for example. If you start 
the sequence between two beats then the first step will be shorter than the following 
ones: 

 

time

beat

time

beat 2 3 4 5 6 7 8

time

beat
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Beat-controlled sequences don’t have hold times, but you can still set fade times. 
Unlike with manual timing they do not prolong the total duration of the sequence. If 
the interval between two beats is shorter than the fade time, the fade will be 
interrupted. 

 

For information on how to set the tempo and sync it to external sources see chapter 
12, Beat control. 

Change a sequence’s timing options 

	 1	 Do one of the following: 

‣ Double-click the sequence in the Preset Palette. 

‣ Control-click the sequence and choose Get Info from the shortcut menu. 

	 2	 In the window that appears, click Timing at the top and change the settings as 
appropriate. Select “Individual fade times” to allow individual steps to override 
the default fade time, as described below. 

Change the hold or fade time of individual steps 

	 1	 Select one or more steps. (Hold down the Command or Shift key as you click to 
select multiple steps.) By selecting multiple steps you can change their hold or 
fade times at once. 

	 2	 Click the hold or fade time (to the right of the step name). The fade time is only 
visible if the Individual option is selected in the sequence inspector. 

	 3	 Enter a new value. You can press the Up/Down Arrow keys to increase/decrease 
the time by one second. Leave the field empty to use the sequence’s default 
hold or fade time. 

	 4	 Press Return to end editing. 

 

time

beat

fade fade fade

	★	 Tip: When editing hold or fade times, press Tab or Shift-Tab to quickly jump to 
the next or previous field.

Lightkey User Guide	 137



You can change the initial hold and fade times for new sequences in the Timing pane 
of Lightkey’s Settings window. You can also increase the precision (number of 
decimal places shown) for hold and fade times. 

Change the hold and fade times for newly created sequences 

	 1	 Choose Lightkey > Settings… (or press Command-Comma) and click Timing. 

	 2	 Change the values in the fields for the sequence hold and fade time. (To revert a 
value to the standard value, delete the field contents and press Return.) 

Change the precision for hold and fade times 

	 1	 Choose Lightkey > Settings… (or press Command-Comma) and click Timing. 

	 2	 Select an option from the “Time precision” pop-up menu. 

Create fixture movements with sequences 
If the steps in a sequence define different pan/tilt positions, your fixtures will move 
between these positions as the sequence runs. Lightkey provides different options to 
control the exact movement of the fixtures. 

 

	❖	 Note: Another way to create fixture movements are movement effects, as 
described in chapter 10, Effects. Each technique has its advantages and 
drawbacks. A movement effect is quick to create, easy to reuse on different 
fixtures, and provides a better visual impression of how the fixture moves. On 
the other hand, a sequence lets you combine the fixture movement with other 
property changes and gives you more control over timing.
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As an example, consider a sequence with five steps which define positions for a 
fixture: 

	 Name	 Hold Time	 Fade Time 
	 Position 1 (P1)	 00:01.0	 00:02.0 
	 Position 2 (P1)	 00:01.0	 00:06.0 
	 Position 3 (P1)	 00:01.0	 00:04.0 
	 Position 4 (P1)	 00:01.0	 00:02.0 
	 Position 5 (P1)	 00:01.0	 00:02.0 

The following graph shows when the fixture reaches the different positions if no 
special options are applied. In the graph, the vertical dimension represents the 
fixture position (which actually consists of two dimensions, pan and tilt). During the 
crossfade periods, Lightkey linearly interpolates the fixture positions between the 
previous and next step. 

 

Changing all hold times to zero creates a continuous movement where the fixture 
moves like this: 

 

The fixture moves on the direct way from one position to the next, changing its 
movement direction at each point. If you want a smoother movement instead, you can 
select the option “Smooth movements”. 

P1

P2

P3
P4

P5

00:00 00:02 00:04 00:06 00:08 00:10 00:12 00:14 00:16 00:18

00:00 00:02 00:04 00:06 00:08 00:10 00:12 00:14

P1

P2

P3
P4

P5
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Lightkey will calculate a curve which passes all five fixture positions at the times 
determined by the steps’ hold and fade times. For example, the time it takes to move 
from P1 to P2 is the sum of the first step’s hold and fade times (with this option there 
is no longer a difference between hold and fade time). 

The movement speed from each position to the next may vary—it depends on the 
hold/fade times and the distance between the positions. In the example, P1 and P2 
are relatively far apart, but the fade time is short, so the fixture moves at a high 
speed. To create a uniform movement, select the option “Constant pace”. 

 

Lightkey will adjust the time at which each position is reached so that the fixture 
moves at (approximately) constant speed (ignoring the individual hold/fade times). 
The total time for moving through the sequence is still the same (that is, it is 
determined by the total hold and fade times). 

Organize presets and sequences 
Here are ways to organize presets, groups, and sequences in the Preset Palette. 

Move a preset, group, or sequence 

‣ Drag the item up or down in the Preset Palette. You can move items in and out 
of groups and sequences (however, sequences can’t contain groups or other 
sequences). 

00:00 00:02 00:04 00:06 00:08 00:10 00:12 00:14

P1

P2

P3
P4

P5

00:00 00:02 00:04 00:06 00:08 00:10 00:12 00:14

P1

P2

P3 P4

P5
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Reorder multiple presets, groups, or sequences 

	 1	 Select the items in the Preset Palette. Hold down the Shift or Command key to 
select multiple items. 

	 2	 Drag the selected items to the desired position. 

Rename a preset, preset group, or sequence 

	 1	 Click the preset, preset group, or sequence in the Preset Palette to select it. 

	 2	 Do one of the following: 

‣ Click the item’s name in the Preset Palette. 

‣ Choose Edit > Rename (or press Return). 

‣ Control-click the item and choose Rename from the shortcut menu. 

	 3	 Enter a new name and then press Return. 

Duplicate a preset, preset group, or sequence 

	 1	 Click the preset, preset group, or sequence in the Preset Palette to select it. 

	 2	 Choose Edit > Duplicate (or press Command-Shift-D). Lightkey will create a 
copy of the item below the original item. 

After duplicating a preset, Lightkey will automatically begin to edit it (see Edit a 
preset). 

Duplicate a preset, preset group, or sequence by dragging 

‣ Hold down the Option key and drag the preset, preset group, or sequence. 
Lightkey will add a copy of the item at the target location. 

After duplicating a preset, Lightkey will automatically begin to edit it (see Edit a 
preset). 

Delete a preset, preset group, or sequence 

	 1	 Click the item in the Preset Palette to select it. (Hold down the Shift or 
Command key to select multiple items.) 

	 2	 Do one of the following: 

‣ Choose Edit > Delete. 

‣ Control-click the item and choose Delete from the shortcut menu. 
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‣ Press Delete. 

	 3	 If the preset or sequence is part of a cue, an alert message will appear. Click 
Delete to delete the item and remove it from any cues. 

If you accidentally deleted an item, choose Edit > Undo Delete. 

Filter items in the Preset Palette 
To quickly find an item you can filter the Preset Palette so only items whose name 
contains the search text are shown. 

Filter items in the Preset Palette 

	 1	 Do one of the following: 

‣ Click 􀊫 in the toolbar. 

‣ Choose Edit > Find… (or press Command-Option-F). 

	 A search field appears near the right end of the toolbar. 

	 2	 Click the  symbol in the search field and choose Preset Palette from the 

menu. 

	 3	 Enter the text to search for in the search field. As you type the Preset Palette is 
filtered accordingly. 

	 4	 To remove the filter click 􀁡 in the search field. 

Export and import items in the Preset Palette 
You can export the items in the Preset Palette—presets, sequences, and groups—to 
a file which you can then import into other projects. If the projects have different sets 
of fixtures, you can choose how the fixtures are mapped during import. 

Export items from the preset palette 

	 1	 Choose Preset > Export… 

	 2	 In the dialog that appears, enter a filename and choose a location. 

	 3	 Select either “All items” (export all items in the Preset Palette) or “Selected 
items” (export only the currently select items). 
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	 4	 Click Export. 

Import items into the preset palette 

	 1	 Choose Preset > Import… 

	 2	 In the dialog that appears, select a file that was previously exported, then click 
Continue. 

	 3	 The next dialog lets you choose how fixtures in the source project should be 
mapped to those in the current project. The left column shows the fixtures in 
the current project. On the right, select the corresponding fixture in the source 
project. 

	 	 You can select multiple rows to assign a source fixture to all of them. 

	 4	 Click Import. 

	 	 The imported items are added at the end of the Preset Palette. 
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Chapter 10   
Effects 

 

Lightkey’s powerful effects engine makes it easy 
and fun to create dynamic looks. It comes with 
over 70 editable templates and lets you build 
custom effects for almost any fixture property. 
Synchronize effects to music and overlay multi-
ple effects for limitless possibilities. 

An effect controls the value of a fixture property for an arbitrary set of fixtures. Often 
the fixtures are of the same type, but they don’t have to be. Effects can be applied to 
the individual beams of an LED fixture or across multiple fixtures. Like regular 
property values, effects can be stored in presets, sequences, and cues while staying 
fully editable at any time. 

There are three basic kinds of effects which apply to different fixture properties: 

Effect Use for

Pattern Dimmer, Color

Curve Dimmer, Color, Position, Focus, Zoom, Iris, Frost, Fog, any custom 
property represented by a slider

Movement Position
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Pattern effects 
A pattern effect generates a pattern from a set of predefined samples. Pattern 
effects can be applied to the Dimmer and Color properties, so the term sample 
refers to either an intensity value (0–100%) or a color. You can choose from a number 
of patterns such as a chase. Some patterns repeat after a predefined duration, 
others change randomly. 

Curve effects 
A curve effect lets you draw a curve which determines the fixture property’s value at 
a given time. Lightkey comes with a number of built-in curves—for example, a sine 
wave—but also lets you draw completely new curves. 

Some fixture properties consist of multiple components, each of which has its own 
curve: 

• Color: A color usually consists of at three components which depend on the 
color model. Color models are HSB (hue, saturation, brightness), RGB (red, 
green, blue), CMY (cyan, magenta, yellow). In addition, the following compo- 
nents may be added if the fixtures support them: cool white, warm white, 
amber, lime, ultraviolet. 

• Position: A moving light’s position consists of the pan angle and tilt angle. 

Movement effects 
A movement effect describes a continuous pan and tilt movement along a predefined 
closed path—for example, a circle or a figure eight. Movement paths are defined by 
two or more control points from which Lightkey interpolates the fixture’s position at 
any given time. 

Lightkey allows you to design movement paths in a natural way: The points on the 
path give an indication of where the light beam points in reality, and the path’s shape 
(although only in 2D) resembles the actual movement. This may be different from 
other applications which show movement paths in a Cartesian coordinate system 
which has little resemblance to the actual fixture movement. As a consequence, the 
same fixture movement may look entirely different in Lightkey than in other apps. 
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Lightkey comes with a set of built-in movement paths which you can freely edit and 
build upon. Whenever you change a built-in path, Lightkey creates a copy. Those self-
created paths are stored in the project. 

 

Add an effect 

	 1	 Select one or more fixtures for the effect. You can select individual beams to 
constrain the effect to those beams. 

	 	 The fixture’s light beams should be visible (that is, their shutters and dimmers 
should be open) so you can see the effect. 

	 2	 Do one of the following: 

‣ Click 􀜎 in the toolbar and choose a fixture property from the menu. 

‣ Choose Fixture > Add Effect, then choose a fixture property (or press 
Command-Option-E). 

‣ Click a fixture property’s name in the Design view or in a property’s HUD 
and choose Add [property name] Effect… from the menu. 

	❖	 Note: This also means that you can’t create some paths which look (on the 
screen) like a certain path in Cartesian coordinates. For example, you can’t 
create a perfect circle because moving lights with a finite pan range can’t 
(indefinitely) move in a circle. In such a situation, think about how you want 
the fixture to move and create your path accordingly. Lightkey allows you to 
build any movement path that can be created in a Cartesian coordinate 
system.

	❖	 Note: Another way to create fixture movements are sequences, as described 
in Create fixture movements with sequences in chapter 9, Presets and 
sequences. Each technique has its advantages and drawbacks. A movement 
effect is quick to create, easy to reuse on different fixtures, and provides a 
better visual impression of how the fixtures move. On the other hand, a 
sequence lets you combine the movement with other fixture properties and 
gives you more control over timing.
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	 3	 Select the appropriate options in the area below the Preview. 

	 	 To start from an effect template: 

‣ Click one of the available templates. When a template is selected, 
Lightkey shows a preview of the effect. Templates which don’t apply to the 
selected fixtures appear gray. 

‣ The  icon indicates that an effect is beat-controlled. 

‣ Enter text in the search field at the top-right to filter the displayed 
templates by name. 

‣ Move the pointer over an effect template and click Add to add the effect to 
the selected fixtures. You can edit the effect’s properties later. 

	 	 To add a custom effect: 

‣ Click Custom Effect. 

‣ Select a fixture property and the kind of effect. The available effect types 
depend on the fixture property you selected. 

‣ Click Add Effect. 

	 4	 If there’s already an effect for the same fixture property, an alert message 
appears. 

‣ Click Replace to replace the existing effect. 

‣ Click Overlay to overlay the new effect with the existing one. See Overlay 
effects later in this chapter. 

Lightkey adds the effect to the selected fixtures and shows its settings in the area 
below the Preview. 

Edit an effect 
When a fixture property is controlled by an effect, the fixture property’s area in the 
Design view shows an effect icon instead of the normal controls. You can edit an 
effect’s settings at any time. 

Edit an effect 

Do one of the following: 

‣ Click the 􀜎 icon in the Design view. 
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‣ Click a fixture’s name in the Preview, then select a fixture property from the 
shortcut menu. Properties with an effect are marked with an 􀜎 icon. 

‣ Click Overrides in the toolbar. The names of the overridden properties appear 
next to the fixtures’ icons, and an 􀜎 icon marks properties with an effect. Click 
a fixture property’s name to edit the effect. 

When you edit an effect, Lightkey displays its settings in the area below the Preview. 
They are described in the following sections. 

Edit effect timing 
Effects continue to loop until they’re deactivated—they don’t have an end point. Their 
speed is determined by a fixed duration or the beat. 

You can choose between multiple timing modes for effects: 

• Fixed duration: The effect has a fixed duration after which it repeats. You can 
change the duration in the Duration field. When you add an effect to a cue, the 
duration is multiplied by the cue’s Speed modifier. 

• Beat-controlled timing: The effect runs in sync with the beat. You can choose a 
beat multiplier which controls how often the effect repeats per beat. For 
example, an effect with a beat multiplier of ÷2 repeats twice during each beat. 
Beat synchronization is available for curve effects and some pattern effects. 

For information on how to set the tempo and sync it to external sources see 
chapter 12, Beat control. 

• Random timing: Some pattern effects are entirely random so none of the 
preceding options applies to them. 

You can set the timing options in the area below the Preview: 

 

Beat-controlled 
timing

Fixed duration
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Edit the fixture order 
When you assign an effect to multiple fixtures or to fixtures with multiple beams (e.g. 
LED bars, strips, or matrixes), the order of the fixtures (or beams) has an important 
impact on the effect. In the following, the term pixel will be used for the smallest unit 
which can be individually controlled—either a fixture or a group of beams which can 
be individually controlled. 

You can change the order of the fixtures (or beams) when you edit an effect. You can 
also change the fixtures and beams the effect applies to. 

Change the order of fixtures (or beams) for an effect 

	 1	 Edit an effect, then click Fixture Order in the area below the Preview. 

	 	 As you move the mouse pointer over an item in the menu, Lightkey shows the 
resulting fixture order in the Preview. 

	 2	 Select an option as appropriate: 

• Left to Right: Pass through pixels from left to right as they appear in the 
Preview. 

• Right to Left: Pass through pixels from right to left as they appear in the 
Preview. 

• Top to Bottom: Pass through pixels from top to bottom as they appear in 
the Preview. 

• Bottom to Top: Pass through pixels from bottom to top as they appear in 
the Preview. 

• Custom Direction: Pass through pixels in an arbitrary direction as they 
appear in the Preview. Setting the direction is described below. 

• By Short Name: Pass through fixtures alphabetically by their short name, 
either ascendingly or descendingly. Pass through beams by their index. 

• By Address: Pass through fixtures by their universe and DMX address, 
either ascendingly or descendingly. Pass through beams by their index. 

• Random (Fixed): Pass through pixels in a random order. The random 
order changes each time you select this option but stays the same 
afterwards. 

• Random (Variable): Pass through pixels in a random order. The random 
order changes each time the effect becomes active. 
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• Custom Order: Pass through fixtures in an arbitrary order you can choose. 
Setting the order is described below. 

• Consider Spacing: When using one of the position-based orders, consider 
the distances of the pixels in the Preview. Available for curve and move- 
ment effects. 

• Select Fixtures: Treat all beams of a fixture as a single pixel. 

• Select Beams: For fixtures with multiple beams, treat each group of 
beams that can be individually controlled as an individual pixel. 

• Origin: These options control where the effect begins. 

• Start to End: Use the order as described above. 

• From Center: Based on the order described above, pass through the 
pixels from the center to the edges. This option can’t be used with 
random or custom orders. 

• To Center: Based on the order described above, pass through the 
pixels from the edges to the center. This option can’t be used with 
random or custom orders. 

• Grouping: Treat several adjacent pixels as a group that acts like a single 
pixel. For example (grouping set to 3): 1 / 1 / 1 / 2 / 2 / 2 / 3 / 3 / 3 / 4 / 4 / 4. 
Does not apply to custom orders. 

• Repeat: Repeat the effect after every 2nd, 3rd, 4th … pixel. For example 
(repeat set to 3): 1 / 2 / 3 / 1 / 2 / 3 / 1 / 2 / 3 / 1 / 2 / 3. Does not apply to 
custom orders. 

Select a custom direction 

	 1	 Edit an effect, then click Fixture Order in the area below the Preview and 
choose Custom Direction… from the menu. 

	 2	 Drag the mouse across the fixtures in the Preview to set the effect’s direction. 

	 3	 Click OK. 

 

	❖	 Note: When using a custom direction, you should always select the Consider 
Spacing option. Lightkey automatically selects this option when you apply a 
custom direction.
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Select a custom fixture order 

	 1	 Edit an effect, then click Fixture Order in the area below the Preview and 
choose Custom Order… from the menu. 

	 2	 Click and edit the numbers next to the fixtures in the Preview to change their 
order. If you assign the same number to multiple fixtures, they will behave like 
a single pixel. If you skip numbers you create a “gap” in the effect. 

	 3	 Click OK. 

 

Change the fixtures and beams that participate in an effect 

	 1	 Edit an effect, then click Fixture Order in the area below the Preview and 
choose Select Fixtures… from the menu. 

	 2	 Select or deselect fixtures and beams in the Preview. 

	 3	 Click OK. 

Edit pattern effects 
Pattern effects generate a repeating or random pattern from a set of predefined 
samples. Depending on the fixture property, a sample is either an intensity value (0–
100%) or a color. 

	❖	 Note: When using a custom order, the effect can only apply to whole fixtures, 
not individual beams.
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Reorder the samples 

‣ Drag a sample to the left or right. 

Duplicate a sample 

Do one of the following: 

‣ Control-click a sample and choose Duplicate from the shortcut menu. 

‣ Hold down the Option key and drag the sample to the left or right. 

Delete a sample 

Do one of the following: 

‣ Control-click a sample and choose Delete from the shortcut menu. 

‣ Drag the sample outside the samples area and release the mouse button. 

The following sections describe the available patterns and their parameters. 

Chase 
The pixels cyclically take on the value of each sample. 

This pattern can be beat-controlled. In this case the chase is advanced on each beat 
(can be adjusted with beat multiplier). 

Click a sample 
to edit it

Change the sample’s color

Select a pattern

Additional parameters 
depending on pattern

Add a new sample
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Example: A chase pattern with four colors, no time offset or delay. 

 

The chase with a time offset of 100%. 

 

Steps per Value The number of chase steps before a pixel takes on the next value (see 
examples below).

Phase Manual timing: Controls where the chase begins when the effect becomes 
active, relative to its duration. For example, a phase of 50% makes the 
chase begin half way through the duration. 

This setting is especially useful when overlaying multiple effects.

Time Offset Manual timing: Time offset between consecutive pixels, relative to the 
duration for a single sample. A time offset of 0% means that all pixels 
change at the same time. Higher offsets mean that each pixel changes 
later than the preceding one (see Edit the fixture order above). 

To evenly distribute the time offset across all pixels, Control-click the 
slider and choose Spread Evenly from the shortcut menu. 

For more precise control you can adjust the range of the slider: Control-
click the slider and choose a range from the shortcut menu. 

A time offset is similar to the Delay parameter except at the beginning of 
the effect (see examples below).

Delay Manual timing: Adds a delay between consecutive pixels, relative to the 
duration for a single sample. At the beginning of the effect each pixel 
starts at the first sample (see examples below). 

To evenly distribute the delay across all pixels, Control-click the slider 
and choose Spread Evenly from the shortcut menu. 

For more precise control you can adjust the range of the slider: Control-
click the slider and choose a range from the shortcut menu.

Smoothness A smoothness value greater than zero lets Lightkey blend between 
consecutive samples (see examples below).

time

Pixel 1
Pixel 2
Pixel 3
Pixel 4
Pixel 5

time

Pixel 1
Pixel 2
Pixel 3
Pixel 4
Pixel 5
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The original chase with a delay of 100%. 

 

The chase with a time offset of 100%, 2 steps per value. 

 

The following diagram illustrates the effect of the smoothness parameter: 

 

Scanner 
A “scanning eye” moves forth and back on a static background, known as a Larson 
scanner or cylon effect. The first sample defines the background, the remaining 
samples are used in turn for the moving eye. 

This pattern can be beat-controlled. In this case the scanner reverses its direction on 
each beat (can be adjusted with beat multiplier). 

time

Pixel 1
Pixel 2
Pixel 3
Pixel 4
Pixel 5

time

Pixel 1
Pixel 2
Pixel 3
Pixel 4
Pixel 5

time

0%
33%

100%

Length The eye’s size (number of pixels).

Overshoot The number of pixels by which the eye overshoots the edges.

Phase Manual timing: Controls where the pattern begins when the effect 
becomes active, relative to its duration. For example, a phase of 50% 
makes the pattern begin half way through the duration. 

This setting is especially useful when overlaying multiple effects.

Fringe Blends the moving eye with the background near the edges.

Noise Adds random noise when blending the eye with the background. Use if 
fringe is greater than zero.
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Yo-yo 
Fills and clears the pixels in the style of a yo-yo. The first sample defines the back-
ground, the remaining samples are used in turn for the filled pixels. 

This pattern can be beat-controlled. In this case the pattern repeats after each beat 
(can be adjusted with beat multiplier). 

Fill 
Successively fills all pixels with one of the sample values. The first sample defines 
the background, the remaining samples are used in turn for filling. 

Example: A fill pattern with a background color and two fill colors. 

 

Rain 
Streaks of rain move at constant pace across a static background. The first sample 
defines the background, the remaining samples are used in turn for the streaks. 

This pattern can be beat-controlled. In this case a new streak appears on each beat 
(can be adjusted with beat multiplier). 

Phase Manual timing: Controls where the pattern begins when the effect 
becomes active, relative to its duration. For example, a phase of 50% 
makes the pattern begin half way through the duration. 

This setting is especially useful when overlaying multiple effects.

Center Controls the ratio between filling and clearing the pixels.

Steepness Controls the pacing of the pattern. With a steepness of 0% pixels are filled 
in a linear fashion. With a larger steepness the animation becomes faster 
towards the end.

time

Pixel 1
Pixel 2
Pixel 3
Pixel 4
Pixel 5

Length The length of each streak (number of pixels).

Distance The number of pixels between successive streaks.
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Example: A rain pattern with a background sample and two foreground samples 
(length = 4, distance = 2, fringe = 100%). 

 

Meteor 
A series of “meteoroids” pass by, leaving a trail of particles which disintegrate in a 
random fashion. The first sample defines the static background, the remaining 
samples are used for the meteors. 

This pattern can be beat-controlled. In this case a new meteoroid is launched on 
each beat (can be adjusted with beat multiplier). 

Phase Manual timing: Controls where the pattern begins when the effect 
becomes active, relative to its duration. For example, a phase of 50% 
makes the pattern begin half way through the duration. 

This setting is especially useful when overlaying multiple effects.

Fringe If greater than zero, each streak fades out towards the background.

Noise Adds random noise when fading out the streaks. Use if fringe is greater 
than zero.

Pixel 1
Pixel 2
Pixel 3
Pixel 4
Pixel 5
Pixel 6
Pixel 7
Pixel 8

time

Pixel 9

Distance

Length

Length The length of each meteoroid (number of pixels), without the trail.

Distance The number of pixels between successive meteoroids.

Phase Manual timing: Controls where the pattern begins when the effect 
becomes active, relative to its duration. For example, a phase of 50% 
makes the pattern begin half way through the duration. 

This setting is especially useful when overlaying multiple effects.

Trail The length of the meteor’s trail.

Use samples as 
palette

If selected, the samples (except the background sample) are used as a 
palette for colorizing the meteors. 

If not selected, the non-background samples are used in turn for each 
meteor.
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Example: A meteor pattern with two alternating foreground samples (length = 2, 
distance = 6). 

 

Sparkle 
Random pixels light up on a static background. The first sample defines the back-
ground, the remaining samples are used for the “sparkles”. 

Example: A sparkle pattern with a background color and four foreground colors 
(fringe = 100%). The locations of new sparkles are chosen randomly. 

 

pixel

Distance Length

Trail Meteoroid

Interval The time interval after which a new sparkle ignites (in seconds).

Lifetime The time each sparkle remains visible (in seconds).

Fringe If greater than zero, each sparkle fades out towards the background 
value.

Noise Adds random noise when fading out the sparkles. Use if fringe is greater 
than zero.

Use samples as 
palette

If selected, each sparkle will pass thru all samples (except the back-
ground sample) during its lifetime. In other words, the samples act like a 
palette for colorizing the sparkles. 

If not selected, the non-background samples are used in turn for each 
sparkle.

Pixel 1
Pixel 2
Pixel 3
Pixel 4
Pixel 5

time

New spark 
ignited

Lifetime

Interval
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Fire 
Resembles a burning flame. The samples are interpreted as a color palette for the 
fire, with the “hottest” values towards the right. This pattern looks best on LED strips 
with 20 or more pixels. 

Jellyfish 
Generates a pattern of elements which move along the pixels while pulsating like a 
jellyfish. The first sample defines the background, the remaining samples are used 
for the “jellyfish”. This pattern looks best on LED strips with 20 or more pixels. 

Snakes 
A series of variable-length “snakes” creeps along the pixels at constant pace. The 
lengths of the snakes and their distances are randomized. The first sample defines 
the background, the remaining samples are used in turn for the snakes. 

Speed Controls the speed of the effect.

Sparking Controls how fast a flame cools down. More cooling means shorter 
flames.

Cooling Controls how often a new spark will ignite at the bottom of the fire. A 
higher value makes the fire more active.

Count The maximum number of jellyfish visible at a time.

Size Controls the size of the jellyfish.

Speed Controls the speed by which the jellyfish move.

Fringe Controls how the jellyfish fade out towards the edges.

Use samples as 
palette

If selected, the samples (except the background sample) are used as a 
palette for colorizing the jellyfish. 

If not selected, the non-background samples are used in turn for each 
jellyfish.

Length The minimum and maximum snake length.

Distance The minimum and maximum distance between successive snakes.

Speed Controls the speed by which the snakes move.

Fringe Controls how the snakes fade out towards the edges.
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Example: A snakes pattern with a background color and two foreground colors. The 
lengths and distances are chosen randomly. 

 

Edit curve effects 
Curve effects let you draw a curve which determines the fixture property’s value at a 
given time. You can edit the curve in the area below the Preview. For fixture 
properties with multiple components (Color, Position), each component has its own 
curve. 

 

Select a built-in curve template 

‣ Click Select Template…, then click one of the templates. 

A curve is defined by a set of control points. The curve segments between the points 
can be either straight or curved. 

Noise Adds random noise when fading out the snakes. Use if fringe is greater 
than zero.

pixel

Distance Length

Select a color model
(color effects only)

Click a component to 
edit its curve

Control point Selected control point
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Select control points 

‣ To select a single point, click the point. 

‣ To select multiple points, press the mouse button over a blank part of the curve 
area and drag across the points. 

‣ To toggle a point’s selection state, hold down the Command key and click the 
point. 

‣ To select a range of points, click the first point, then hold down the Shift key and 
click the last point in the range. 

‣ To select all points, choose Edit > Select All (or press Command-A). 

‣ To clear the selection, choose Edit > Deselect All (or press Command-Shift-A 
or Esc) or click a black part of the curve area. 

‣ To select the points one by one from left to right, press Control-Tab. To select 
from right to left, press Control-Shift-Tab. 

Move control points 

‣ Drag a point to move it. You can select multiple points to move them at once. 

As you drag, Lightkey shows alignment guides that help with precise 
positioning, and snaps to gridlines and other points. 

‣ To disable alignment guides and snapping, hold down the Control key as you 
drag. 

‣ To constrain the motion to horizontal or vertical, hold down the Shift key as you 
drag. 

‣ To move points in small steps, select one or more points and press one of the 
arrow keys. To move the points in larger steps, hold down the Shift key while 
pressing an arrow key. 

Add or remove control points 

‣ To add a point, place the pointer over the curve and click the transparent handle 
which appears between two points. 

‣ To add a point under the mouse, place the pointer over the curve, hold down the 
Option key, and then click. 

‣ To remove one or more points, select them and press the Delete key. You can 
also Control-click a point and choose Delete from the shortcut menu. 
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Make a segment straight and curved 

‣ To toggle a curve segment between a straight line and a curve, place the 
pointer over the segment and double-click. You can also Control-click the 
segment and choose Straight or Curved from the shortcut menu. 

‣ Double-click a control point to toggle the adjacent curve segments between 
straight lines and curves. 

Transform control points or the entire curve 

	 1	 Select three or more control points. If no points are selected the entire curve 
will be transformed. 

 	 2	 Control-click and choose Transform Points or Transform Curve from the 
shortcut menu (or press T). 

	 	 A blue outline with handles appears around the control points. 

	 3	 To scale the points: 

‣ 	Drag one of the four blue handles at the edges of the blue outline to scale 
the points along the horizontal or vertical axis. 

‣ Hold down the Option key as you drag to scale from the center. 

‣ To disable alignment guides and snapping, hold down the Control key as 
you drag. 

	 	 To move the points: 

‣ 	Place the pointer over the blue outline and drag. 

	 4	 Click outside the blue outline or press Return or Esc to exit transform mode. 

Flip control points or the curve horizontally or vertically 

	 1	 Select a range of two or more control points. If no points are selected the entire 
curve will be flipped. 

 	 2	 Control-click and choose Flip Horizontally or Flip Vertically from the shortcut 
menu. 

Copy and paste a curve 

	 1	 While editing a curve effect, choose Edit > Copy (or press Command-C). 

	 2	 Go to another curve effect or select a different color component. 
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 	 3	 Choose Edit > Paste (or press Command-V). 

Lightkey shows an animated dot on the curve which reflects the location at the 
current time. Multiple dots appear if the effect has multiple pixels and a time offset. 
(No dots are shown when a control point is selected or while transforming the curve.) 
You can disable this animation if you find it distracting. 

Hide or show the current location 

‣ Control-click over a blank part of the curve area and choose Hide/Show Current 
Location. 

The horizontal axis below the curve can either display percentage values from 0 to 
100% or exact times if the effect has a fixed duration. For beat-controlled effects it 
always displays a percentage. 

Configure the horizontal axis 

‣ Click the labels below the curve to toggle between percent and time. You can 
also Control-click the labels and choose Percent or Time from the shortcut 
menu. 

‣ If you selected Percent, you can choose the number of subdivisions: Control-
click the labels and choose Subdivisions from the shortcut menu, then select 
the desired number. 

Additional options appear to the right of the curve: 

Select Template… Select one of the built-in curve templates.

Time Offset Time offset between consecutive pixels, in percent of the effect’s 
duration. For example, with a duration of 10 seconds and a time offset of 
5%, the second pixel will be 0.5 seconds behind the first, the third pixel 
will be 1 second behind, and so on. See Edit the fixture order above. 

To evenly distribute the time offset across all pixels, Control-click the 
slider and choose Spread Evenly from the shortcut menu. 

For more precise control you can adjust the range of the slider: Control-
click the slider and choose a range from the shortcut menu.
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Some options are available for the Position property only. To change them, click the 
Options button in the lower-left. 

Edit movement effects 
Movement effects define the pan and tilt movement of a moving light using 
movement paths (or simply paths). When you edit a movement effect, the built-in and 
user-created movement paths appear in the area below the Preview. Click a path to 
use it for the effect. Movement paths are stored independently of the effect, so you 
can reuse them for other effects. 

If you edit a movement path later, the changes will affect all effects and fixtures to 
which the path was applied. You can prevent this by duplicating the path before 
editing it. When you begin editing a built-in path Lightkey automatically duplicates it. 

 

Duplicate a path 

	 1	  Do one of the following: 

‣ Click a path to select it, then choose Edit > Duplicate (or press 
Command-Shift-D). 

Mirror pan 

Mirror tilt

If you select the “From Center” fixture order option (see Edit the fixture 
order above), Lightkey can “mirror” the pan and/or tilt angles on one side 
of the center (that is, reverse their sign). Here’s an example of mirrored 
pan angles: –30° / –15° / 0° / +15° / +30°.

Relative If you select this option, the effect’s pan and tilt values are added to the 
pan/tilt values defined elsewhere. For example, you could have two cues 
active at the same time: One cue defines “absolute” positions for some 
fixtures and the other adds a relative effect “on top”.

All built-in paths and user paths appear here

The selected path is used for the effect
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‣ Control-click a path and choose Duplicate from the shortcut menu. 

	 2	  Type a name for the new path and press Return. 

Rename a user path 

	 1	  Do one of the following: 

‣ Click a path to select it, then choose Edit > Rename. 

‣ Control-click a path and choose Rename from the shortcut menu. 

‣ Select a path and press Return. 

	 2	  Type a new name for the path and press Return. 

You cannot rename the built-in movement paths. 

Delete a user path 

	 1	  Do one of the following: 

‣ Click a path to select it, then choose Edit > Delete. 

‣ Control-click a path and choose Delete… from the shortcut menu. 

‣ Press Delete. 

	 2	  In the dialog that appears, click Delete. 

The following table describes the options for movement effects. 

Time Offset Time offset between consecutive pixels, in percent of the effect’s 
duration. For example, with a duration of 10 seconds and a time offset of 
5%, the second pixel will be 0.5 seconds behind the first, the third pixel 
will be 1 second behind, and so on. See Edit the fixture order above. 

To evenly distribute the time offset across all pixels, Control-click the 
slider and choose Spread Evenly from the shortcut menu. 

For more precise control you can adjust the range of the slider: Control-
click the slider and choose a range from the shortcut menu.

Pan Offset Adds an offset (in degrees) to the pan angle between two consecutive 
fixtures. For example, if the pan offset is 10° then the pan angle of the 
second fixture will always be 10° larger than the pan angle of the first, 
and the pan angle of the third fixture will be 20° larger than the pan angle 
of the first, and so on. See Edit the fixture order above.

Tilt Offset Adds an offset (in degrees) to the tilt angle between two consecutive 
fixtures.
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Additional options are shown when you click the Options button in the lower-left: 

All built-in and self-created movement paths are fully editable: For example, you can 
move, add, and remove points as well as flip or transform the path. When you edit a 
built-in path, a copy is created. 

Whenever you make a mistake as you edit a path, you can choose Edit > Undo to 
undo the last change. 

Begin editing a movement path 

Do one of the following: 

‣ Move the pointer over the selected path and then click Edit. 

‣ Click one of the effect’s fixtures in the Preview. 

The Position HUD appears and shows the movement path. 

Edit paths 
Every movement path consists of two or more control points. The point where the 
movement starts is marked with a dot. 

You can select one or more control points. When you select a point, the fixtures move 
to the corresponding position and follow it as you move the point. When you clear the 
selection, the fixture resumes moving along the path from there. 

Mirror pan 

Mirror tilt

If you select the “From Center” fixture order option (see Edit the fixture 
order above), Lightkey can “mirror” the pan and/or tilt angles on one side 
of the center (that is, reverse their sign). Here’s an example of mirrored 
pan angles: –30° / –15° / 0° / +15° / +30°.

Relative If selected, the effect’s pan and tilt values are added to the pan/tilt values 
from cues with a lower priority. For example, you could have two cues 
active at the same time: One cue defines “absolute” positions for some 
fixtures and the other adds a relative effect “on top”.
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Select control points 

‣ Click a point to select it. 

‣ To select the next point in movement order, press Tab. To select the previous 
point, press Shift-Tab. 

‣ To select a range of points, click the first point, then hold down the Shift key and 
click the last point (in movement order). 

‣ To toggle a point’s selection state, hold down the Command key and click the 
point. 

‣ To select multiple points, press the mouse button over a blank part of the 
position control and drag across the points. 

‣ To select all points, choose Edit > Select All (or press Command-A). 

‣ To clear the selection, choose Edit > Deselect All (or press Command-Shift-A 
or Esc) or click a black part of the position control. 

Move control points 

‣ Drag a point to move it. You can select multiple points to move them at once. 

As you drag, Lightkey shows alignment guides that help with precise 
positioning, and snaps to certain positions and other control points. You can 
press modifier keys to change the behavior: 

‣ To lock the current pan angle, hold down the Command key. 

Three points are selected

The fixtures’
current position

Pan and tilt angles for 
the current position

Starting point
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‣ To lock the current tilt angle, hold down the Shift key. 

‣ To disable snapping, hold down the Control key. 

‣ To move points in steps of 1°, select one or more points and press one of the 
arrow keys. The Left/Right Arrow keys change pan and the Up/Down Arrow keys 
change tilt. Hold down the Shift key to move in 10° steps, or the Command key 
to move in 0.1° steps. 

‣ Another way to move points is to select one or more points and then scroll to 
change pan. (If scrolling has no effect, choose Lightkey > Settings…, click 
Gestures, and make sure “Scrolling changes slider and HUD values” is 
selected.) Hold down the Command key to change tilt. Hold down the Shift key 
to move faster or the Option key to move slower. 

‣ You can also move control points with a joystick. The joystick’s horizontal axis 
controls pan and the vertical axis controls tilt. 

To deal with fixtures whose pan range exceeds 360° or to apply negative tilt angles, 
you can use the techniques described in Position in chapter 8, Fixture properties. 

Add a control point 

‣ If the path has connection lines between the points (Curve and Line types), 
move the pointer over a connection line and click the transparent handle which 
appears between the points. 

‣ If the path has no connection lines (Points type), double-click anywhere in the 
position control. 

Remove control points 

Do one of the following: 

‣ Select one or more points, then press the Delete key. 

‣ Control-click a point and choose Delete Point from the shortcut menu. 

Flip points 

‣ To flip the pan or tilt angle of the selected points (e.g. from +50° to –50°), 
Control-click one of the selected points point and choose Flip Pan or Flip Tilt 
from the shortcut menu. 

‣ To flip the entire path, click 􀍠 (or 􀍡) and choose Flip Pan Values or Flip Tilt 
Values from the menu. 
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Change the starting point 

‣ Control-click a point and choose Make Starting Point from the shortcut menu. 

Reverse the points in a path 

‣ Click 􀍠 (or 􀍡) and choose Reverse Path from the menu. 

Lightkey shows an animated dot on the path which reflects the fixture position at the 
current time. Multiple dots appear if the effect has multiple fixtures and a time 
offset. You can disable this animation if you find it distracting. 

Hide or show the current location 

‣ Click 􀍠 (or 􀍡) and choose Hide/Show Current Location from the menu. 

Path types 
There are three different ways how Lightkey can interpolate the path positions 
between the control points. The following graphs illustrate these types for a 
movement path with four control points. In the graphs, the vertical dimension 
represents the fixture position (which actually consists of two dimensions, pan and 
tilt). 

• Smooth: The fixture moves smoothly between the control points. The time for 
moving from one point to the next depends on the distance between the points. 

 

• Line: The fixture moves on the direct way from one control point to the next, 
changing its movement direction at each control point. The time for moving 
from one point to the next depends on the distance between the points. 

time

Effect duration
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• Points: The fixture moves instantly from one control point to the next, with 
maximum speed. It remains at each control point for an equal time. (This is 
often used together with the “Blackout during pan/tilt movement” feature of 
many moving lights.) 

 

Change a path’s type 

‣ Click 􀍠 (or 􀍡) and choose Curve, Lines, or Points from the menu. 

Transform paths 
In transform mode you can move or scale the entire path in pan or tilt direction. 

Transform a path 

	 1	 Click  (or press T) to enter Transform mode. 

	 	 A blue outline with handles appears around the control points. 

	 2	 Do one of the following to move the path: 

‣ Hold down the Shift key and drag around the center to move the path 
along the pan axis. 

‣ Hold down the Command key and drag away from the center or towards 
the center to move the path along the tilt axis. 

time

Effect duration

time

Effect duration
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‣ If you don’t press a modifier key, the path moves either in pan or tilt 
direction, depending on the mouse movement. 

‣ To disable snapping to certain pan or tilt angles, hold down the Control 
key as you drag. 

‣ Place the pointer over the position control and scroll up or down to move 
the path along the pan axis. (If scrolling has no effect, choose Lightkey > 
Settings…, click Gestures, and make sure “Scrolling changes slider and 
HUD values” is selected.) Hold down the Command key as you scroll to 
move along the tilt axis. Hold down the Shift key to move faster or the 
Option key to move slower. 

‣ To move the path in steps of 1°, press one of the arrow keys. The Left/
Right Arrow keys change pan and the Up/Down Arrow keys change tilt. 
Hold down the Shift key to move in 10° steps, or the Command key to 
move in 0.1° steps. 

‣ You can also move the path with a joystick. The joystick’s horizontal axis 
moves in the pan direction and the vertical axis moves in the tilt direction. 

	 3	 Drag one of the four handles at the edges of the blue outline to scale the path. 
Hold down the Option key to resize the path from its center. To disable snapping 
to certain pan or tilt angles, hold down the Control key as you drag. 

	 4	 Click  again (or press T or Esc) to exit Transform mode. 

Copy and paste effects 
Because an effect is like a special value for a fixture property, you can copy effects 
between fixtures in the same way as you copy fixture property values. 

When you copy and paste an effect, the new effect is independent of the original one. 
If you want to add more fixtures to an effect instead, see Edit the fixture order earlier 
in this chapter. 

Copy an effect between fixtures 

	 1	 Select a single fixture with an effect. 

	 2	 Choose Edit > Copy Property, then choose a fixture property. An icon marks 
properties with effects. 

	 3	 Select one or more fixtures you want to apply the effect to. 
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	 4	 Choose Edit > Paste Properties. 

Delete an effect 
When you delete an effect, you can either keep the current values at the time the 
effect was deleted, or clear the entire fixture property so it’s no longer defined. 

Deleting an effect removes it from all fixtures. If you want to remove individual 
fixtures from an effect instead, see Edit the fixture order earlier in this chapter. 

Delete an effect and keep the current values 

‣ While you’re editing an effect, click the effect’s name below the Preview and 
choose Delete Effect and Keep Values from the menu. 

Delete an effect 

Do one of the following: 

‣ While you’re editing an effect, click the effect’s name below the Preview and 
choose Delete Effect from the menu. 

‣ If the fixture property appears in the Design view, select the fixtures and then 
click the blue dot to the left of the property’s name in the Design view. 

‣ Click  in the toolbar or choose Fixture > Clear Properties for All Fixtures (or 

press Command-Shift-Delete). This will also remove any other overridden 
properties from all fixtures. 

Overlay effects 
You can overlay multiple effects for the same fixture property to create entirely new 
looks. If there are multiple effects for a fixture property, Lightkey adds their output 
values to determine the final output. If the values are colors, Lightkey uses the 
“screen” blend mode to blend the output colors of the individual effects. 

 

Effect 1
Effect 2
Result
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Overlay an existing effect with a new effect 

	 1	 Select one or more fixtures with an effect. Choose Fixture > Add Effect and 
choose a fixture property, then select a new effect for the same property (see 
Add an effect earlier in this chapter). 

	 2	 Click Add Effect. 

	 3	 In the alert message that appears, click Overlay. 

Overlay an effect by duplicating 

	 1	 Edit an effect. 

	 2	 Click the effect’s name below the Preview and choose Duplicate from the menu. 

A second effect is added with the same parameters. You can now modify the new 
effect’s settings. 

Switch between multiple effects during editing 

‣ Click the edited effect’s name below the Preview and choose a different effect 
from the menu. 

Save an effect template 
You can save an effect as a template which appears in the Effects Chooser so you can 
quickly select it for new effects. Effect templates are part of the project. 

Save an effect as a template 

	 1	 Edit an effect. 

	 2	 Click the effect’s name below the Preview and choose Save as Template… from 
the menu. 

	 3	 In the dialog that appears, enter a name for the template. To include the 
settings from the Fixture Order menu in the template, select “Include fixture 
order”. 

	 4	 Click Save. 

Rename an effect template 

	 1	 Choose Fixture > Add Effect, then choose a fixture property to open the Effects 
Chooser. 
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	 2	 Control-click an effect template and choose Rename from the shortcut menu. 

	 3	 Type a new name, then press Return. 

Delete an effect template 

	 1	 Choose Fixture > Add Effect, then choose a fixture property to open the Effects 
Chooser. 

	 2	 Control-click an effect template and choose Delete… from the shortcut menu. 

	 3	 In the dialog that appears, click Delete. 

You can’t delete or rename the built-in effect templates. 
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Chapter 11   
Live control 

 

The Live view lets you build a custom-tailored 
control panel for your show. Add buttons and 
faders to activate lighting cues on the fly, or a 
cuelist to recall cues in a predefined order. 

The Live view is the central place from where you run your show, but it’s still 
possible to override fixture properties on the fly or activate presets and sequences. 
Overridden properties or active presets and sequences always take precedence over 
the Live view. If you don’t need this and want to prevent accidental overrides of cues 
you can lock the Design view, HUDs, and Preset Palette, as described in Lock 
Lightkey in chapter 6, The Lightkey window. 

Show the Live view 

Do one of the following: 

‣ Click Live below the Preview. 

‣ Choose View > Live (or press Command-L). 

 

	★	 Tip: If you have a second display—or a touch screen—connected to your Mac 
you can move the Live view to the second display. See Dual windows in 
chapter 6, The Lightkey window, for more information.
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Live view pages 
The Live view can have multiple pages, but only one of them is visible at a time. Only 
the cues on the current page have an effect on the output. Depending on your needs 
you might create separate pages for different occasions, users, or songs being 
performed, for example. 

Manage Live view pages 

	 1	 Do one of the following: 

‣ Choose Live > Manage Live Pages… (or press Command-Shift-Option-L). 

‣ Click Live at the top of the Live view and choose Manage Live Pages… from 
the menu. 

	 2	 In the dialog that appears, make changes as appropriate: 

‣ To add a page: Click 􀅼 and choose an item from the menu. Enter a name 
for the new page and press Return. 

‣ To reorder the pages: Drag the rows in the list up or down. 

‣ To rename a page: Select the page, then click 􀍠 and choose Rename 
from the menu. Alternatively, select the page and click its name. Type a 
new name and press Return. 

‣ To change a page’s fade time: Select a page and click in the Fade Time 
column. Type a new value and press Return. 

‣ To duplicate a page: Select a page, then click 􀍠 and choose Duplicate 
from the menu. Enter a name for the new page and press Return. This will 
also duplicate any external control bindings for the page. 

‣ To delete a page: Select the page and click 􀅽 or press the Delete key, 
then click Delete in the dialog that appears. This will also delete any 
external control bindings for the page. 

	 3	 Click Done. 

You can change the default fade time which is used for new Live pages. Changing this 
value will not affect existing pages. 

Change the fade time for new Live pages 

	 1	 Choose Lightkey > Settings… (or press Command-Comma) and click Timing. 
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	 2	 Change the value for “Live page: Fade time”. 

Switch between pages 

‣ Click Live at the top of the Live view, then select a page from the menu. 

When you switch away from a page, the cues on that page no longer have an effect on 
the output. Lightkey remembers the active cue buttons and restores them when you 
return to the page. If you prefer the cues to be deactivated you can change the 
behavior in Lightkey’s settings. 

Deactivate cues before switching pages 

	 1	 Choose Lightkey > Settings… (or press Command-Comma) and then click 
General. 

	 2	 Select “Deactivate cues before switching pages”. 

Build Live view pages 
The central element on Live view pages is a cue, which consists of a combination of 
presets and sequences from the Preset Palette. Cues either belong to a button in the 
Live view or are part of a cuelist. 

A page can contain an unlimited number of cue buttons which you can freely arrange, 
style, attach, and group in frames. You can also add a cuelist and text labels. 

There are two types of buttons: 

• Push button: A push button simply activates or deactivates a cue. 

• Fader: A fader lets you control a cue’s intensity between 0% and 100%, like on a 
traditional lighting console. The intensity determines to what degree a cue 
affects the fixtures’ properties. There are horizontal and vertical faders. 
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See Live view pages earlier in this chapter to learn how to create a page. 

Edit a page 
Enter edit mode to change the objects on the current page. 

Enter or exit edit mode 

Do one of the following: 

‣ To enter edit mode, click Edit at the top-right of the Live view. To exit edit mode, 
click Done. 

‣ Choose View > Edit Live View (or press Command-Option-J). 

‣ Control-click a blank part of the Live view and choose Edit Live View from the 
shortcut menu. 

‣ Hold down the Command key and double-click a blank part of the Live view. 

‣ Press Command-Return to exit edit mode. 

When the Live view is in edit mode, a grid is shown in the background which helps 
you to align objects. You can hold down the Space bar and drag to pan the Live view 
area. The remainder of this section assumes that the Live view is in edit mode. 

Enclose buttons in 
frames for visual 
separation

Attach multiple buttons if only one of them should be active at 
any time. The buttons’ colors are automatically chosen to 
reflect their contents

Modifiers control various aspects of a 
cue. They can be applied to cues and 
frames
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Add cue buttons 
When you create a cue button, Lightkey automatically adds the active presets and 
sequences to its cue. If there are overridden fixture properties, it also adds a special 
item named “Ad hoc properties” which contains those properties. You can think of it 
as a preset which does not appear in the Preset Palette. 

Add a button 

	 1	 Do one of the following: 

‣ Choose Live > New Button. 

‣ Control-click a blank part of the Live view and choose New Button from 
the shortcut menu. 

‣ While the Live view is in edit mode, click  (or 􀅼). 

	 	 The Live view changes to edit mode and a new button is added. The cue 
inspector appears on the right of the Live view, showing the cue’s contents and 
other options. 

	 2	 Type a name for the button, then press Return. 

	 3	 Drag presets and sequences from the Preset Palette to the upper part of the 
cue inspector. 

	 4	 Edit the button’s other properties in the inspector, as described in Edit cue 
contents and options later in this chapter. 

Create a button from one or more presets and sequences 

‣ Select one or more presets and/or sequences in the Preset Palette and drag 
them to a blank part of the Live view. 

‣ Drag the presets or sequences onto a frame (but not onto a button) to create a 
new button in the frame. 

‣ Drag the presets or sequences between two attached buttons to insert a new 
button between them. When you release the mouse the existing buttons will 
move to make room for the new button. 

‣ By default, Lightkey creates a single button which contains all dragged objects. 
If you hold down the Command key, Lightkey creates a new button for each 
dragged object instead. 
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Set default styles later in this chapter describes how to change the initial size, font, 
alignment, and color for new buttons. 

Add frames 
You can enclose related buttons in a frame and assign a title to it. Frames serve 
several purposes. They: 

• visually group the enclosed cue buttons, 

• allow you step through cue buttons in sequential order, 

• can have modifiers which affect the output of all contained cues. See Edit 
modifiers later in this chapter. 

Frames always enclose their cue buttons. You can enlarge them but you cannot 
make them smaller than their buttons. 

Add a frame 

	 1	 Select one or more buttons (as described below). 

	 2	 Do one of the following: 

‣ Choose Live > New Frame. 

‣ Click  near the top-right of the Live view. 

	 3	 Type a title for the frame, then press Return. 

Add cue buttons to an existing frame 

Do one of the following: 

‣ Drag one or more buttons onto a frame and release the mouse button. 

‣ Drag one or more buttons over a frame and rest the mouse until the frame 
flashes. The frame is extended to include the dragged buttons, and you can 
continue to drag them to their final position. 

Remove buttons from a frame 

Do one of the following: 

‣ Select one or more buttons and choose Live > Remove From Frame. 

‣ Control-click a button and select Remove from Frame from the shortcut menu. 

If you remove all buttons from a frame, the frame disappears. 
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Add text labels 
You can add text labels anywhere on the page for annotations etc. 

Add a text label 

	 1	 Do one of the following: 

‣ While the Live view is in edit mode, click 􀅶 (or ). 

‣ Choose Layout > Insert > Text. 

‣ Control-click a blank part of the Live view and choose Insert Text from the 
shortcut menu. 

	 2	 Drag the text label to where you want it. 

	 3	 Double-click the text label to begin editing, then type. To start a new line, press 
Option-Return. 

	 4	 Click outside the text label or press Return to finish editing. 

To edit an existing text label, double-click the text label or select it and press Return. 

Set default styles later in this chapter describes how to change the initial font and 
alignment for new text labels. 

Select objects 
The following actions pertain to buttons, frames, text labels, and cuelists. 

Select and deselect objects 

‣ To select a single object, click it. 

‣ To select additional objects, hold down the Shift key and click each object. 

‣ To remove an object from the selection, hold down the Shift key and click the 
selected object. 

‣ To select multiple objects at once, press the mouse button over a blank part of 
the Live view and drag it over the objects. (Hold down the Option key to select 
outward from the starting point.) 

‣ To add or remove multiple objects to/from the selection, hold down the Shift 
key, press the mouse button over a blank part of the Live view, and drag it over 
the objects. 

T
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‣ To select all objects in the Live view, choose Edit > Select All (or press 
Command-A). 

‣ To deselect all objects in the Live view, choose Edit > Deselect All (or press 
Command-Shift-A or Esc) or click a blank part of the Live view. 

When an object is selected, it shows handles at its corners and edges. 

Move objects 
You can freely arrange buttons, text labels, and cuelists in the Live view. 

Move objects in the Live view 

‣ Press the mouse button over an object and drag it to a new location. To move 
multiple objects, select the objects and then drag them to a new location. 

By default, objects snap to the grid in the background as you drag. Lightkey also 
shows smart alignment guides that help with precise alignment. 

‣ To disable grid snapping, hold down the Control key as you drag. 

‣ To constrain the motion to horizontal or vertical, drag the object(s) while 
holding down the Shift key. 

‣ To move the objects by one grid unit, select the objects and press one of the 
arrow objects. To move objects by five units, hold down the Shift key and then 
press an arrow key. 

Attach buttons 
By default you can activate as many cue buttons as you like, independent of each 
other. If you attach two or more buttons they act as a group where only one button 
can be active at a time. 

 

By default buttons 
are activated 

independently

Attach buttons to 
create a group 
where only one can 
be active at a time

Spots

House Lights

Back Lights

Front Lights

Fast Movement

Ballyhoo

Slow Movement

Stage Center
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Attach buttons 

‣ Move two or more buttons together so their borders touch (see Move objects 
above). 

To detach a button from the group, move it away from the other buttons. 

 

Lightkey can take a number of cue buttons and attach them in a horizontal row or 
vertical column. 

Arrange buttons horizontally or vertically 

‣ Select two or more buttons and choose Layout > Arrange > Horizontally or 
Vertically. 

To order the buttons by their name, hold down the Option key. 

Resize objects 
You can freely resize all objects in the Live view. Frames always enclose their cue 
buttons but you can enlarge them to cover a larger area. 

You can also resize multiple buttons and text labels at once. 

Resize objects 

‣ Select one or more objects and then drag one of the blue selection handles. To 
resize the objects in one direction, drag a side handle instead of a corner 
handle. 

‣ To resize the objects from their center, press the Option key as you drag. 

‣ To disable grid snapping, hold down the Control key while you resize objects. 

You can shrink frames so they just enclose their cue buttons. 

	❖	 Note: When you switch between attached buttons, Lightkey performs a 
crossfade between the cues. This creates a smoother transition than fading 
the cues out and in independently. For best results, attached buttons should 
have identical fade times and curves, and the fade-out curve should match 
the (inverted) fade-in curve.
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Shrink-wrap a frame 

‣ Select a frame and choose Live > Shrink-Wrap. 

‣ Control-click a blank part of a frame and choose Shrink-Wrap from the shortcut 
menu. 

Rename objects 
You can change the names of cue buttons and frames at any time. 

Rename a button or frame 

	 1	 Click a button or a blank part of a frame to select it. 

	 2	 Do one of the following: 

‣ Click the button’s or frame’s name. 

‣ Choose Edit > Rename (or press Return). 

‣ Control-click the button or frame and choose Rename from the shortcut 
menu. 

	 3	 Type a new name and then press Return. 

Duplicate objects 
You can duplicate buttons and text labels, which creates an independent copy. You 
can’t duplicate cuelists because a Live view page can only have one cuelist. 

	 1	 Done one of the following: 

‣ Select the object and choose Edit > Duplicate (or press Command-Shift-
D). 

‣ Control-click the object and choose Duplicate from the shortcut menu. 

‣ Hold down the Option key while you drag an object. 

	 2	 After duplicating a button, type a name for the new button and then press 
Return. 

Copy and paste objects 
You can copy buttons, text labels, and cuelists to the Clipboard and paste them either 
on the same page or a different one within the project. You can also copy and paste 
cues between buttons and cuelists. 
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Cut or copy an object 

Do one of the following: 

‣ Select the object(s) and choose Edit > Cut or Edit > Copy (or press Command-
X or Command-C). 

‣ Control-click an object and choose Cut or Copy from the shortcut menu. 

Paste objects from the Clipboard 

Do one of the following: 

‣ Choose Edit > Paste (or press Command-V). 

‣ Control-click anywhere in the Live view and choose Paste from the shortcut 
menu. 

A Live page can only contain one cuelist, so you can’t paste a cuelist if the page 
already contains one. 

Delete objects 

	 1	 Click an object to select it. (Hold down the Shift or Command key to select 
multiple objects.) 

	 2	 Do one of the following: 

‣ Choose Edit > Delete. 

‣ Control-click the object and choose Delete from the shortcut menu. 

‣ Press Delete. 

If you accidentally deleted an object, choose Edit > Undo Delete. 

Change text formatting 
You can change fonts, font sizes, and other text attributes for text labels, buttons, 
and frames. This works similarly to many other Mac applications. 

Change the formatting of an object 

	 1	 Select one or more objects. 
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	 2	 Do one of the following: 

‣ Choose Edit > Font > Show Fonts. Select a font, font size, and other 
options in the Font window. 

‣ Choose Edit > Font > Bold, Italic, or Underline to change the text style. 

‣ Choose Edit > Font > Show Colors, then select a color in the Color 
window. (This applies to text labels only.) 

‣ Choose Edit > Alignment, then choose one of the options in the submenu 
to change the text alignment. 

 

Set default styles 
You can change the default style that is used for new cue buttons, frames, and text 
labels. This includes the font, text alignment, color, and size (for buttons). Each 
project has its own set of default styles. 

Set the default style for new objects 

	 1	 Select a single cue button, frame, or text label whose style you want to become 
the new default. 

	 2	 Do one of the following: 

‣ Choose Edit > Set Default Style. 

‣ Control-click the object and choose Set Default Style from the shortcut 
menu. 

The style will be applied to new objects of the same kind (button, frame, or text label) 
in the project. 

Reset the default style to the original state 

	 1	 Select a single cue button, frame, or text label. 

	 2	 Hold down the Option key and choose Edit > Reset Default Style. 

	★	 Tip: Another way to access the formatting menu options is to control-click an 
object. You can also change the text alignment in the cue and frame 
inspector.
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This resets the project’s default style for the selected kind of object (button, frame, 
or text label) to the original state. 

Configure frames 
You can add controls to a frame which, when clicked, activate the frame’s buttons in 
sequential order. The order is determined by the locations of the buttons in the 
frame. 

Add Previous/Next controls to a frame 

	 1	 Do one of the following: 

‣ Click a blank part of the frame to select it and choose Live > Get Info (or 
press Command-I). 

‣ Control-click a blank part of the frame and choose Get Info from the 
shortcut menu. 

‣ Double-click a frame while the Live view is in edit mode. 

	 	 The frame inspector appears on the right side of the Live view. 

	 2	 In the inspector, select “Previous cue” or “Next cue”. 

Like buttons, frames have a priority which is relevant if multiple cues define the 
same fixture properties. See Output order of precedence later in this chapter for 
more information. 

Set a frame’s priority 

	 1	 Do one of the following: 

‣ Click a blank part of the frame to select it and choose Live > Get Info (or 
press Command-I). 

‣ Control-click a blank part of the frame and choose Get Info from the 
shortcut menu. 

‣ Double-click a frame while the Live view is in edit mode. 

	 	 The frame inspector appears on the right side of the Live view. 

	 2	 Select a value from the Priority pop-up menu in the inspector. 
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Cuelists 
A cuelist lets you recall cues in a fixed order during a show. It contains a series of 
cues which can be arranged in groups for a better overview. Cuelists are best used if 
you want to preprogram an entire show with no or minimal interventions during 
performance. 

At most one cue in a cuelist is active at any time. When the cuelist runs you advance 
to the next cue by pressing the Space bar or dragging the Xfade slider. Or you can set 
a hold time after which the cuelist automatically activates the next cue. The 
transition between subsequent cues can be immediate or with a crossfade. 

It is often useful to number cues so you can quickly refer to them. To do this simply 
add a number before the cues’ names, e.g. “001 My cue”. When you add a new cue or 
duplicate a cue, Lightkey automatically increments the new cue’s number. 

One way to create a cuelist is to add a new Live view page and choose the Cuelist 
option, as described in Live view pages earlier in this chapter. You can also add a 
cuelist to an existing page. A page can’t contain more than one cuelist. 

Add a cuelist to an existing page 

	 1	 Do one of the following: 

‣ Choose Layout > Insert > Cuelist. 

‣ Control-click a blank part of the Live view and choose Insert Cuelist from 
the shortcut menu. 

	 2	 Move and resize the cuelist as appropriate. Lightkey will automatically enlarge 
the cuelist to fit the Live view when you exit edit mode. 

Like buttons and frames, cuelists have a priority. If the Live page also contains cue 
buttons, the priority determines whether the cuelist or the buttons take precedence. 
See Output order of precedence later in this chapter for more information. 

Set a cuelists’s priority 

	 1	 Do one of the following: 

‣ Click the cuelist to select it and choose Live > Get Info (or press 
Command-I). 

‣ Control-click the cuelist and choose Get Info from the shortcut menu. 
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‣ Double-click a cuelist while the Live view is in edit mode. 

	 	 The cuelist inspector appears on the right side of the Live view. 

	 2	 Select a value from the Priority pop-up menu in the inspector. 

You can choose between two text sizes for cuelists and hide some of their elements if 
you don’t need them. You can also decide if a cuelist should repeat after reaching the 
last cue. 

Change other cuelist options 

	 1	 Do one of the following: 

‣ Click the cuelist to select it and choose Live > Get Info (or press 
Command-I). 

‣ Control-click the cuelist and choose Get Info from the shortcut menu. 

‣ Double-click a cuelist while the Live view is in edit mode. 

	 	 The cuelist inspector appears on the right side of the Live view. 

	 2	 Change the options in the inspector as appropriate: 

• Size: Choose one of two text sizes. 

• + – buttons: Deselect to hide the buttons for adding and removing cues in 
each row. 

• Xfade slider: Deselect to hide the slider for manual crossfades. 

• Loops: If selected, the cuelist will repeat after reaching the last cue. 

Edit cuelists 
Before you can add cues to a cuelist you need to exit the Live view’s edit mode. Click 
Done at the top-right of the Live view or press Command-Option-J. 

Add cues 
When you create a cue, Lightkey automatically adds the active presets and 
sequences to the cue. If there are overridden fixture properties, it also adds a special 
item named “Ad hoc properties” which contains those properties. You can think of it 
as a preset which does not appear in the Preset Palette. 
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Add a cue 

	 1	 Do one of the following: 

‣ Click 􀅼 next to an item in the cuelist. A new cue is inserted below the 
item. (To insert a cue above the clicked item, hold down the Shift key as 
you click 􀅼.) 

‣ Choose Live > New Cue (or press Command-Plus). A new cue is inserted 
below the selection, or at the end of the cuelist if no items are selected. 

‣ Control-click anywhere in the cuelist and choose New Cue from the 
shortcut menu. A new cue is inserted below the clicked item. 

	 	 When the cue has been added, the cue inspector appears to the right of the 
cuelist, showing the cue’s contents and other options. 

	 2	 Type a name for the cue, then press Return. 

	 3	 Drag presets and sequences from the Preset Palette to the upper part of the 
cue inspector. 

	 4	 Edit the cue’s other properties in the inspector, as described in Edit cue 
contents and options later in this chapter. 

Create a cue from one or more presets and sequences 

‣ Select one or more presets and/or sequences in the Preset Palette and drag 
them to a blank part of the cuelist or in between two rows. 

	 	 Lightkey creates a new cue which contains the dragged objects. 

Create multiple cues from presets and sequences 

	 1	 Select several presets and/or sequences in the Preset Palette. 

	 2	 Drag the presets or sequences to a blank part of the cuelist or in between two 
rows. Hold down the Command key when the pointer is over the cuelist. 

	 	 Lightkey creates a new cue for each dragged object, containing just this object. 

Cue groups 
For a better overview you can organize your cues in groups which can be collapsed 
and expanded as necessary. Whether a group is expanded or not has no effect on 
playback order. Groups can also contain other groups. 
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Create an empty cue group 

	 1	 Do one of the following: 

‣ Choose Live > New Group (or press Command-Shift-Plus). A new group 
is inserted below the selection, or at the end of the cuelist if no items are 
selected. 

‣ Control-click anywhere in the cuelist and choose New Group from the 
shortcut menu. A new group is inserted below the clicked item. 

	 2	 Enter a name for the group and then press Return. 

Create a cue group from existing items 

	 1	 Select some items in the cuelist. (Hold down the Shift or Command key to select 
multiple items.) 

	 2	 Do one of the following: 

‣ Choose Live > New Group From Selection (or press Command-Shift-
Option-Plus). 

‣ Control-click one of the items and choose New Group From Selection 
from the shortcut menu. 

	 3	 Enter a name for the group and then press Return. 

Expand or collapse a cue group 

‣ Click the disclosure triangle to the left of the group name. 

Cuelist timing 
Each cue in a cuelist can have a hold time after which it is deactivated and the next 
cue is activated (possibly with a crossfade) when the cuelist runs. Alternatively you 
can click  or press the Space bar to manually go to the next cue. 

In addition, each cue has a fade time which determines the duration of the crossfade 
to the next cue. If the fade time is zero then the next cue becomes active instantly. 
Alternatively you can drag the Xfade slider to manually control the crossfade 
duration. 
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Example: Cue 1 has a hold time. Cue 2 has no hold time and remains active until  is 
pressed. 

 

If a cue contains one or more sequences with a fixed loop count, Lightkey will 
automatically proceed to the next cue in the cuelist when all sequences have finished 
(even if the cue has no hold time or if the hold time has not yet elapsed). 

Change a cue’s hold or fade time 

	 1	 Select one or more cues. (Hold down the Command or Shift key as you click to 
select multiple cues. By selecting multiple cues you can change their hold or 
fade times at once.) 

	 2	 Click in the Hold Time or Fade Time column and type a new value. You can also 
use the following keyboard shortcuts: 

‣ Up/Down Arrow: Increase/decrease the time by one second. 

‣ Option-Up/Down Arrow: Increase/decrease the time by 0.1 seconds. 

‣ Shift-Up/Down Arrow: Increase/decrease the time by 10 seconds. 

	 	 Leave the hold time field empty if you want to advance to the next cue manually. 

	 3	 Press Return to end editing. 

 

You can also change hold and fade times in the Timing section of the cue inspector. 
See Edit cue timing options later in this chapter. 

	➤	 Important: Fade times do not apply to smart lights. They use a fixed fade time 
which can’t be changed in Lightkey.

Hold Time 1 Fade Time 1 Fade Time 2

Cue 1 Cue 2 Cue 3

	★	 Tip: When editing hold or fade times, press Tab or Shift-Tab to quickly jump to 
the next or previous field.
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The crossfade between cues is also affected by the fade curve which appears to the 
left of the fade time. For details, see Fade curves later in this chapter. 

Select cues for playback 
Sometimes you may want to skip a cue when the cuelist runs. For example, you may 
want to retain two versions of a cue but only use one of them in the show. 

Skip or unskip a cue 

‣ Click the checkbox to the left of the cue name. 

If the checkbox is off, the cue will be skipped. 

Organize cues 
Here are ways to organize cues in a cuelist. 

Move a cue or group 

‣ Drag the item up or down in the cuelist. 

Reorder multiple cues or groups 

	 1	 Select the items in the cuelist. Hold down the Shift or Command key to select 
multiple items. 

	 2	 Drag the selected items to the desired position. 

Rename a cue or group 

	 1	 Click the item in the cuelist to select it. 

	 2	 Do one of the following: 

‣ Click the item’s name. 

‣ Choose Edit > Rename (or press Return). 

‣ Control-click the item and choose Rename from the shortcut menu. 

	 3	 Enter a new name and then press Return. 
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Renumber cues 

	 1	 Rename the first of the cues that you would like to renumber and add a number 
before its name, for example, “010 My cue”. This determines where the cue 
numbers begin. 

	 2	 Select all cues that you would like to renumber, including the cue you just 
changed. 

	 3	 Do one of the following: 

‣ Choose Live > Renumber. 

‣ Control-click one of the cues and choose Renumber from the shortcut 
menu. 

	 	 Lightkey adds increasing numbers before the names of the cues (or updates 
any existing numbers). 

Duplicate a single cue or group 

‣ Hold down the Option key and click 􀅼 next to an item in the cuelist. 

	 	 Lightkey will create a copy of the item below the original. 

Duplicate multiple cues or groups 

	 1	 Select the items in the cuelist. (Hold down the Command or Shift key as you 
click to select multiple items.) 

	 2	 Do one of the following: 

‣ Choose Edit > Duplicate (or press Command-Shift-D). 

‣ Control-click one of the items and choose Duplicate from the shortcut 
menu. 

	 	 Lightkey will create a copy of the items below the original items. 

Duplicate cues or groups by dragging 

	 1	 Select the items in the cuelist. Hold down the Command or Shift key and click to 
select multiple items. 

	 2	 Hold down the Option key and drag the items up or down. 

	 	 Lightkey will add copies of the items at the target location. 
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Delete a single cue or group 

‣ Click 􀅽 next to an item in the cuelist. 

Delete multiple cues or groups 

	 1	 Select the items in the cuelist. (Hold down the Command or Shift key as you 
click to select multiple items.) 

	 2	 Do one of the following: 

‣ Choose Edit > Delete. 

‣ Control-click one of the items and choose Delete from the shortcut menu. 

‣ Press Delete. 

If you accidentally deleted an item, choose Edit > Undo Delete. 

Copy and paste cues 
You can copy cues and entire cue groups to the Clipboard and paste them again later. 
You can also copy and paste cues between different Live view pages. 

Cut or copy a cue or group 

Do one of the following: 

‣ Select the items in the cuelist and choose Edit > Cut or Edit > Copy (or press 
Command-X or Command-C). 

‣ Control-click a cue or group and choose Cut or Copy from the shortcut menu. 

Paste cues from the Clipboard 

Do one of the following: 

‣ Choose Edit > Paste (or press Command-V). 

‣ Control-click anywhere in the cuelist and choose Paste from the shortcut 
menu. 

Filter cuelist items 
To quickly find an item you can filter the cuelist so only items whose name contains 
the search text are shown. 
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Filter items in a cuelist 

	 1	 Do one of the following: 

‣ Click 􀊫 in the toolbar. 

‣ Choose Edit > Find… (or press Command-Option-F). 

	 A search field appears near the right end of the toolbar. 

	 2	 Click the  symbol in the search field and choose Cuelist from the menu. 

	 3	 Enter the text to search for in the search field. As you type the cuelist is filtered 
accordingly. 

	 4	 To remove the filter click 􀁡 in the search field. 

Edit cue contents and options 
You can edit the contents and other options for cues in the cue inspector which 
appears on the right of the Live view. This applies to both cues associated with a 
button and cues in a cuelist. 

Inspect a cue with a button 

Do one of the following: 

‣ Hold down the Command key and click the button. 

‣ Control-click a button and choose Get Info from the shortcut menu. 

‣ In edit mode, select one or more buttons and choose Live > Get Info (or press 
Command-I). 

‣ In edit mode, double-click a button. 

‣ Force click a button (requires a trackpad with Force Touch support). 

Inspect a cue in a cuelist 

Do one of the following: 

‣ Select one or more cues and choose Live > Get Info (or press Command-I). 

‣ Hold down the Command key and click the cue’s name. 

‣ Control-click a cue and choose Get Info from the shortcut menu. 

‣ Force click a cue (requires a trackpad with Force Touch support). 
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Edit cue contents 
You can easily change the presets and sequences in a cue by drag and drop. 

Edit a cue’s contents 

	 1	 Make sure that only a single cue is selected. (You cannot edit the contents of 
multiple cues.) The contents are shown in the upper part of the cue inspector. 

	 2	 Edit the cue’s contents: 

‣ To add a preset or sequence to the cue, drag it from the Preset Palette to 
the upper part of the cue inspector. 

‣ To remove a preset or sequence from the cue, click the object in the cue 
inspector and press Delete. Alternatively, place the pointer over the object 
and swipe left, then click Remove. 

‣ To show the fixture properties defined by a preset or sequence, select it in 
the cue inspector. Lightkey will display the names of the defined 
properties next to the fixture icons in the Preview. 

‣ To edit a preset in a cue, move the pointer over the preset in the cue 
inspector and click Edit, or double-click the preset. See Edit a preset in 
chapter 9, Presets and sequences. 

‣ To reveal a preset or sequence in the Preset Palette, Control-click the 
object in the cue inspector and choose Show in Palette from the shortcut 
menu. 

Add a preset or sequence to several cues 

	 1	 Select multiple cue buttons or cues in a cuelist. 

	 2	 Drag a preset or sequence from the Preset Palette to the upper part of the cue 
inspector. 

	 	 The preset or sequence is added to all selected cues. 

Quickly add presets or sequences to a cue 

‣ Drag one or more presets or sequences from the Preset Palette to a button in 
the Live view or to a cue in a cuelist. 

The items in the Preset Palette are often organized in groups. Lightkey can show the 
names of the top-level enclosing group in the cue inspector for a better overview. 
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Change whether the cue inspector shows group names 

	 1	 Choose Lightkey > Settings… (or press Command-Comma) and then click 
General. 

	 2	 Click “Show top-level preset groups in cue inspector”. 

Often all presets in a group define the same set of properties for the same set of 
fixtures. For example, each preset in a group might select a different gobo for a set 
of moving lights. It wouldn’t make sense to add more than one of these presets to the 
same cue, and Lightkey can help you prevent this. 

Mark presets as mutually exclusive 

	 1	 Do one of the following: 

‣ Double-click a group in the Preset Palette. 

‣ Control-click a preset group and choose Get Info from the shortcut menu. 

	 2	 In the window that appears, select “Presets are mutually exclusive”. 

If you add a preset from a group of mutually exclusive presets to a cue, Lightkey will 
remove any other presets in that group from the cue. Enabling this option does not 
change the contents of existing cues. 

View cue contents 
Lightkey can give you a quick overview of the fixtures and fixture properties affected 
by a cue. 

Show the contents of a cue 

Do one of the following: 

‣ Hold down the Command and Option keys and click a button in the Live view or 
a cue’s name in a cuelist. 

‣ Control-click a button in the Live view or a cue in a cuelist and choose Show 
Properties from the shortcut menu. 

‣ Select a button in the Live view (when the Live view is in edit mode) or a cue in a 
cuelist, then choose Live > Show Properties. 
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Lightkey will display the names of the properties defined for each fixture next to the 
fixture icons in the Preview. 

Hide the contents of a cue 

Do one of the following: 

‣ Click anywhere in the Preview. 

‣ Press Esc, Return, or Enter. 

Edit ad hoc properties 
Apart from presets and sequences from the Preset Palette, a cue can also contain 
fixture properties that have been overridden when the cue was created. These 
appear in the cue inspector as a special item called “Ad hoc properties”. You can edit 
a cue’s ad hoc properties after the cue has been created. 

Edit the ad hoc properties in a cue 

	 1	 Do one of the following: 

‣ Control-click a button in the Live view or a cue in a cuelist and choose Edit 
Ad Hoc Properties from the shortcut menu. 

‣ Select a button in the Live view (when the Live view is in edit mode) or a 
cue in a cuelist, then choose Live > Edit Ad Hoc Properties. 

	 	 An item which represents the ad hoc properties is added to the Preset Palette 
while the properties are being edited. 

	 2	 Change the desired fixture properties from the Design view and HUDs. (See 
chapter 8, Fixture properties, for more information.) 

	 3	 Click Update next to the “Ad hoc properties” item in the Preset Palette or in the 
toolbar (or press Return). (To discard your changes and return to the preset’s 
previous state, hold down the Option key and click Cancel or choose Preset > 
Cancel Editing). 

After editing, the item for the ad hoc properties disappears again from the Preset 
Palette. 

Alternatively you can merge the currently overridden fixture properties into the ad 
hoc properties of one or more cues. This technique is especially useful when you 
want to change the ad hoc properties of multiple cues at once. 
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Add the overridden fixture properties to one or more cues 

	 1	 Select one or more fixtures and change their properties. (See chapter 8, Fixture 
properties, for more information.) Fixtures with overridden properties display a 
blue dot to the left to their name in the Preview. 

	 2	 Do one of the following: 

‣ Control-click a button in the Live view or a cue in a cuelist and choose Add 
Overrides from the shortcut menu. 

‣ Select one or more buttons in the Live view (when the Live view is in edit 
mode) or one or more cues in a cuelist, then choose Live > Add Overrides. 

‣ To add the overridden properties for the selected fixtures only, hold down 
the Option key as you perform one of the preceding steps. The command 
changes to Add Overrides for Selected Fixtures. 

You can merge the contents of a preset into the ad hoc properties, which is useful for 
making quick changes without affecting other cues. You can also save the ad hoc 
properties as a new preset in the Preset Palette. 

Add a preset’s contents to the ad hoc properties 

‣ Control-click a preset in the cue inspector and choose Add to Ad Hoc Properties 
from the shortcut menu. Lightkey adds the preset’s contents to the cue’s ad hoc 
properties and removes the preset from the cue. 

Create a preset from ad hoc properties 

‣ Control-click the ad hoc properties in the cue inspector and choose Add to 
Palette from the shortcut menu. Lightkey creates a new preset from the ad hoc 
properties and adds it to the cue, replacing the ad hoc properties. 

Edit cue timing options 
The Timing section of the cue inspector lets you change a cue’s timing options. 

Cue buttons have a fade-in and fade-out time which apply when the cue becomes 
active or inactive, respectively. If a fade time is zero, the cue activates or deactivates 
instantly. Each fade time has a corresponding fade curve. 
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Cues in a cuelist have a hold time (which is optional) and fade time to the following 
cue. See Cuelist timing earlier in this chapter for more information. Cues also have a 
fade curve for the crossfade to the next cue. 

 

Change a cue’s timing options 

	 1	 Open a cue’s inspector (as described earlier in this section) and scroll to 
Timing. 

	 2	 Change the settings as appropriate: 

• For cue buttons, change the fade-in and fade-out time and the 
corresponding fade curves. 

• For cues in a cuelist, change the hold time, fade time, and fade curve. 

	 	 Editing fade curves is described in Fade curves later in this chapter. 

If you’re using a cuelist, you can also change hold and fade times directly in the list. 
See Cuelist timing earlier in this chapter. 

You can set the initial hold time, fade times, and fade curves for new cues in the 
Timing pane of Lightkey’s Settings window. You can also increase the precision 
(number of decimal places shown) for hold and fade times. 

Change the hold and fade times for newly created cues 

	 1	 Choose Lightkey > Settings… (or press Command-Comma) and click Timing. 

	 2	 Change the values in the fields for the cue hold and fade time. (To revert a value 
to the standard value, delete the field contents and press Return.) 

Change the precision for hold and fade times 

	 1	 Choose Lightkey > Settings… (or press Command-Comma) and click Timing. 

	 2	 Select an option from the “Time precision” pop-up menu. 

	➤	 Important: Fade times do not apply to smart lights. They use a fixed fade time 
which can’t be changed in Lightkey.
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Edit button appearance and behavior 
There are different types of cue buttons which are described earlier in this chapter. 
This section doesn’t apply to cuelists. 

Change button options 

	 1	 Open the inspector for a button in the Live view and scroll to Button. 

	 2	 Change the settings as appropriate: 

• Button Type: Changes the button’s type, as described at the beginning of 
this chapter. 

• Behavior (push buttons): Allows you to choose how a push button activates 
its cue. There are two options: 

• Toggle: Clicking the button once activates the cue, clicking it again 
deactivates the cue. 

• Flash: The cue is activated when you press the mouse button over 
the button and deactivated when you release the mouse. 

• Controls (faders): Determines which fixture properties are affected by the 
fader value. If you select All Properties (the default), dragging the fader 
affects all properties defined in the cue. If you select individual properties, 
like Dimmer, Color, or Iris, only those properties are affected by the 
fader’s value. 

• Priority: Controls the cue’s priority which is relevant if multiple cues 
define the same fixture properties. See Output order of precedence later 
in this chapter for more information. 

• Color: Allows you to choose the color in which the button appears in the 
Live view. If you choose Automatic, Lightkey tries to find a color based on 
the cue’s contents. 

• Alignment: Change the alignment of the button’s title. 

• Show Fonts: Change the font of the button’s title. Only available in edit 
mode. 

Lightkey User Guide	 201



• Activate at startup: Lightkey can automatically activate one or more cue 
buttons in the selected Live view page when you open the application or a 
project. This way you can define a default state for your lights. (Note that 
this setting will be ignored if the option “Restore active cues, modifiers, 
and Master Dimmer“ is selected in the Settings window. See Startup state 
later in this chapter.) 

• Activate before quitting: Lightkey can also activate one or more cue 
buttons just before you quit the application or close the project. Their cues 
will be active for 0.5 seconds, which is useful for things like moving your 
moving lights to their home positions, etc. 

• Always active: This option applies when a cue button is attached to other 
buttons. If selected, it ensures that one of the attached buttons is active at 
any time. This can be useful, for example, for a group of color selection 
buttons. 

Edit modifiers 
A modifier is a parameter which alters the output of one or more cues in some way. 
You can quickly change modifier values in the Live view or with an external controller 
while you run your show. 

You can add modifiers to a single cue or to a frame. Frame modifiers apply to all cues 
in the frame, similar to a “submaster”. 

Modifiers are applied to the final output of the cue, whether it comes from fixture 
properties defined in the cue, sequences in the cue, fanning, or effects. For example, 
they can change the result of a movement or color effect while the effect is running. 
This makes modifiers a powerful way to change a cue’s look on the fly. 

Some modifiers are multiplied with the value of a fixture property. Here’s an example 
showing the results of the Dimmer modifier at 150%: 

Fixture Dimmer in cue Dimmer output

FX1 50 % 75 %

FX2 40 % 60 %

FX3 100 % 100 %
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Other modifiers are added to the value of a fixture property. The following example 
shows the results of the Pan Angle modifier at +30°: 

If a modifier is present in a button and its enclosing frame, both modifiers are applied 
to the output. For example, if a cue’s Pan Angle modifier has a value of +50° and the 
enclosing frame’s modifier has a value of –20° then the pan angles are shifted by 
+30°. 

The following modifiers are available: 

• Speed: Affects the speed of the cue. For example, setting the speed to 2.0× 
makes the cue run at twice the normal speed. 

	 	 You can choose exactly which aspects of the cue are affected by the modifier. 
For example, you may want to control the speed of a movement effect but not 
the gobo rotation speed. See below for more information. 

	 	 Setting the Speed modifier to 0 pauses the cue, and changing it to a positive 
value resumes seamlessly from where it left off. 

• Beat Multiplier: Affects the timing of beat-controlled sequences and effects in 
the cue. For example, a multiplier of ×2 makes them advance on every second 
beat. 

	 	 The modifier is multiplied with the sequence’s or effect’s own beat multiplier. 
For example, if a cue contains a sequence whose beat multiplier is ÷2, and the 
cue’s Beat Multiplier modifier is set to ×6, then the resulting multiplier is ×3 
(the sequence advances on every third beat). However, the resulting multiplier 
can never be smaller than ÷12 or higher than ×12. 

• Time Offset: The modifier value is added to the Time Offset parameter of any 
chase pattern, curve, and movement effects in the cue. 

• Fade Time: Extends or shortens a cue’s fade times. For example, a modifier 
value of 200% doubles the fade time, and a value of 0% disables fading. 

• Dimmer: The Dimmer values in the cue are multiplied by the modifier. 

Fixture Pan angle in cue Pan angle output

FX1 –120° –90°

FX2 +50° +80°

FX3 –90° –60°
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• Hue: Applies to fixtures with RGB or CMY color mixing. The modifier value 
(between 0° and 360°) is added to the hue values in the cue. 

• Color Temperature: The modifier value (between −5000K and +5000K) is added 
to the color temperatures in the cue. 

• Green Saturation: The modifier value (between −100% and +100%) is added to 
the green saturation values in the cue. 

• Xfade to Color: The xfade to color values in the cue are multiplied by the 
modifier. 

• Pan Angle, Tilt Angle: The modifier values (between −180° and +180°) are 
added to the pan and tilt angles defined in the cue. 

• Focus: The focus values in the cue are multiplied by the modifier. 

• Zoom Angle: The zoom angles in the cue are multiplied by the modifier. 

• Iris Size: The iris sizes in the cue are multiplied by the modifier. 

• Frost Amount: The frost amounts in the cue are multiplied by the modifier. 

• Fog Amount: The fog amounts in the cue are multiplied by the modifier. 

You can choose which aspects of the cue are affected by the Speed modifier: 

• Sequence Speed: Affects the speed of any sequences in the cue with manual 
timing. 

• Effect Speed: Affects the speed of any effects in the cue with manual timing. 

• Rainbow Speed: Affects the speed of any rainbow effects (color wheel rotation). 

• Vector Speed: Affects the speed of pan/tilt movements in vector mode. 

• Infinite Pan/Tilt Speed: Affects the speed of any infinite pan or tilt movement. 

• Gobo Rotation Speed: Affects the gobo rotation speed. 

• Gobo Shake Speed: Affects the gobo shake speed. 

• Gobo Change Speed: Affects the gobo change speed (gobo wheel rotation). 

• Strobe Speed: Affects the speed of strobe effects. 

• Shutter Pulse Speed: Affects the speed of shutter pulse effects. 

• Prism Rotation Speed: Affects the prism rotation speed. 
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Select which modifiers are visible in the Live view 

	 1	 Open the inspector for a cue or frame (as described earlier in this section) and 
scroll to Modifiers. 

	 2	 Select the modifiers you would like to control. If you selected a cue, only 
modifiers which apply to the cue are enabled (for example, Pan Angle is only 
available if the cue defines the Position property for at least one fixture). 

	 3	 To select which aspects are affected by the Speed modifier, click Options and 
choose items from the menu. If you selected a cue, only options which apply to 
the cue are enabled (for example, Gobo Rotation Speed is only available if at 
least one fixture in the cue has a rotating gobo). 

You can set default values for modifiers which will be applied at startup. This 
requires that the option “Restore active cues, modifiers, and Master Dimmer“ in the 
Settings window is off. For more information see Startup state later in this chapter. 

Change the default value for a modifier 

	 1	 Exit edit mode, if necessary. 

	 2	 Press the mouse button over a modifier’s icon and drag up or down to set the 
modifier’s value. 

	 3	 Control-click the modifier and choose Set as Default from the shortcut menu. 

Fade curves 
Lightkey gives you fine-grained control over the way cues fade in, out, or crossfade. 
You can choose one of the built-in fade curves or create your own, including 
individual curves for selected fixture properties and fixtures. This section also 
applies to sequence steps. 

A fade determines how fixture properties change over time between two states—e.g. 
when you activate or deactivate a cue, or switch between two cues, sequence steps, 
or Live view pages (crossfade). The time between the two end states is called the 
fade time. If the fade time is zero, fixture properties change instantly and the fade 
curve has no effect. 
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A fade curve determines the value of fadeable fixture properties like Dimmer or Pan 
and Tilt during the fade. For a fade-in or crossfade, the curve starts at 0% (cue is off 
resp. first cue is on) and ends at 100% (cue is fully on resp. second cue is on). For a 
fade-out, the curve starts at 100% (fully on) and ends at 0% (fully off). The default 
fade curve is simply a line between those values (linear fade). 

Fixture properties with discrete (non-fadeable) values, like Color Wheel or Shutter, 
change when the fade curve crosses 50%. 

 

 

Edit a fade curve 

‣ Click the curve icon to the left of the fade time for a cue (in the cue inspector or 
a cuelist) or sequence step (in the sequence inspector or Preset Palette). 

To edit the fade curve for a sequence step, the step must have an individual fade 
time. Otherwise the sequence’s default fade time and curve will be used. 

The fade curve appears. 

 

	❖	 Note: When you switch between attached buttons, Lightkey performs a 
crossfade between the cues. This creates a smoother transition than fading 
the cues out and in independently. For best results, attached buttons should 
have identical fade times and curves, and the fade-out curve should match 
the (inverted) fade-in curve.

	➤	 Important: Fade curves do not apply to smart lights. They use a predefined 
fading behavior which can’t be changed in Lightkey. 

	 	 Fade curves also do not apply to manual fades with the Xfade slider.

Expand the view and 
show more options

Select a curve 
template

Control point

Preview the fade
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Choose a curve template 

‣ Click  and select a fade curve from the menu. 

Preview the fade 

‣ Click 􀊄. (This feature is not available for sequences.) 

A curve is defined by a set of control points. The curve segments between the points 
can be either straight or curved. 

Select control points 

‣ To select a single point, click the point. 

‣ To select multiple points, press the mouse button over a blank part of the curve 
area and drag across the points. 

‣ To toggle a point’s selection state, hold down the Command key and click the 
point. 

‣ To select a range of points, click the first point, then hold down the Shift key and 
click the last point in the range. 

‣ To select all points, choose Edit > Select All (or press Command-A). 

‣ To clear the selection, choose Edit > Deselect All (or press Command-Shift-A 
or Esc) or click a black part of the curve area. 

‣ To select the points one by one from left to right, press Control-Tab. To select 
from right to left, press Control-Shift-Tab. 

Move control points 

‣ Drag a point to move it. You can select multiple points to move them at once. 

As you drag, Lightkey shows alignment guides that help with precise 
positioning, and snaps to gridlines and other points. 

‣ To disable alignment guides and snapping, hold down the Control key as you 
drag. 

‣ To constrain the motion to horizontal or vertical, hold down the Shift key as you 
drag. 

‣ To move points in small steps, select one or more points and press one of the 
arrow keys. To move the points in larger steps, hold down the Shift key while 
pressing an arrow key. 
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Add or remove control points 

‣ To add a point, move the pointer over the curve and click the transparent handle 
which appears between two points. 

‣ To add a point under the mouse, move the pointer over the curve, hold down the 
Option key, and then click. 

‣ To remove one or more points, select them and press the Delete key. You can 
also Control-click a point and choose Delete from the shortcut menu. 

Make a segment straight and curved 

‣ To toggle a curve segment between a straight line and a curve, move the 
pointer over the segment and double-click. You can also Control-click the 
segment and choose Straight or Curved from the shortcut menu. 

‣ Double-click a control point to toggle the adjacent curve segments between 
straight lines and curves. 

Transform control points 

	 1	 Select three or more—but not all—control points. (You can’t transform the 
entire curve because the endpoints must remain fixed.) 

 	 2	 Control-click and choose Transform Points from the shortcut menu (or press 
T). 

	 	 A blue outline with handles appears around the control points. 

	 3	 To scale the points: 

‣ 	Drag one of the four handles at the edges of the blue outline to scale the 
points along the horizontal or vertical axis. 

‣ Hold down the Option key as you drag to scale from the center. 

‣ To disable alignment guides and snapping, hold down the Control key as 
you drag. 

	 	 To move the points: 

‣ 	Place the pointer over the blue outline and drag. 

	 4	 Click outside the blue outline or press Return or Esc to exit transform mode. 

Copy and paste a curve 

	 1	 While editing a fade curve, choose Edit > Copy (or press Command-C). 

Lightkey User Guide	 208



	 2	 Edit the fade curve of another cue or sequence step. 

 	 3	 Choose Edit > Paste (or press Command-V). 

Apart from the built-in curve templates Lightkey lets you create your own. Fade 
curve templates are part of the project. 

Save the current curve as a template 

‣ Click  and choose Save as Template. 

Remove a curve template 

	 1	 Click  and choose Remove Templates… 

	 2	 In the dialog that appears, click one or more curves to select them, then click 
Remove. 

Click More Options to expand the view and reveal options for multiple fade curves. 

 

You can define special fade curves for selected fixture properties or fixtures. For 
example, you may want the Zoom property to change instantly while other properties 
gradually fade in. Multiple fade curves let you compose sophisticated transitions 
where sets of fixtures fade in one after the other. You can also use them for move-in-
black behavior where moving lights remain blacked out until they moved to their 
positions. 

Switch between  
curves

Add a curve
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Special fade curves can also apply to fixture properties which are not fadeable, such 
as Gobo Wheel or Shutter. These properties are still affected by fade curves because 
they change when the curve crosses 50%. For example, you may want the gobo to 
change at the start or end of the fade. 

Add a special fade curve 

	 1	 Click 􀅼. 

	 2	 In the dialog that appears, select one or more fixture properties or fixtures to 
which the special curve should apply. 

	 3	 Click OK. 

	 	 A new fade curve is added which applies to the selected properties or fixtures 
only. All other fixture properties or fixtures use the default fade curve. 

	 4	 Edit the curve as previously described. 

Edit the criteria for a special fade curve 

	 1	 Click the name of a special fade curve to select it. 

	 2	 Click 􀍠 and choose Edit (curve name)… from the menu. 

	 3	 Change the curve’s criteria as desired, then click OK. 

Remove a special fade curve 

	 1	 Click the name of a special fade curve to select it. (You can’t remove the default 
curve.) 

	 2	 Click 􀍠 and choose Remove (curve name) from the menu. 

Here are some examples for what you can do with special fade curves: 

 

DefaultDefault

Fade lights in with delay Move in black

L1 L2 Pan/Tilt
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Configure the axes 

‣ Click the labels below the curve to toggle between percent and time. You can 
also Control-click the labels and choose Percent or Time from the shortcut 
menu. 

‣ To change the number of subdivisions for percent values on the horizontal or 
vertical axis, Control-click the labels and choose Subdivisions from the shortcut 
menu, then select the desired number. 

You can change the default fade curves for new cues and sequences. These settings 
are independent of the project, so you can only choose from the built-in curves. 
Changing the default fade curve does not affect existing cues and sequences. 

You can also change the fade curve for transitions between Live view pages. The 
same curve is used for all Live view pages. 

Change default fade curves 

	 1	 Choose Lightkey > Settings… (or press Command-Comma) and click Timing. 

	 2	 Click one of the curve icons next to a fade time and select a built-in curve from 
the menu. 

Live control with cue buttons 
This section describes how you use the Live view during a show to activate cues, 
change their intensity, and change modifiers. Note that active presets and overridden 
fixture properties take precedence over the Live view. You may want to deselect all 
presets, or even hide the Preset Palette, and clear the overridden properties before 
you start a show. The following tasks assume that the Live view is not in edit mode. 

 

Push buttons 
Push buttons may use either “toggle” behavior or “flash” behavior. 

	❖	 Note: All actions in this section can also be performed through external 
hardware, such as a MIDI controller, or through custom keyboard shortcuts. 
See chapter 16, External control, for more information.
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Activate or deactivate a cue with a push button and “toggle” behavior 

‣ Click the button. 

Activate a cue with a push button and “flash” behavior 

‣ Press the mouse button over the button. 

	 	 The cue is activated until you release the mouse. 

Depending on the cue’s options, the cue will either (de-)activate instantly or fade (see 
Edit cue options earlier in this chapter). If a button is attached to other cue buttons, 
the other cues in the group will be deactivated. If the “Always active” option is 
enabled for a group, you cannot deactivate the active button in the group. 

Cues normally remain active until you deactivate them, except for the following cases 
where Lightkey automatically deactivates cues: 

• If you activate a button that is attached to other cue buttons, then the other 
buttons are automatically deactivated. (See Attach buttons earlier in this 
chapter for more information.) 

• If a cue contains one or more sequences, it is automatically deactivated when 
all sequences have finished. (If at least one sequence repeats infinitely or has 
its “Freeze on completion” option selected, the cue is never automatically 
deactivated.) 

Faders 
Faders control to which degree (from 0% to 100%) a cue affects the output. By 
default, the fader’s state affects all properties defined by the cue, but you can confine 
it to specific properties like Dimmer or Iris. If a property can’t be faded (like Shutter 
or Gobo), its value changes when the fader crosses 50%. 

Change a cue’s intensity with a fader 

‣ Drag the fader to 0% to deactivate the cue or to 100% to fully activate the cue. 
The fader values in between gradually change how much the cue affects the 
output. 
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Step through buttons in a frame 
If buttons are enclosed in a frame, you can step through them in sequential order 
using the arrow buttons in the upper right. The arrows can be shown or hidden in the 
frame inspector, as explained in Frames earlier in this chapter. 

 

Successively activate the buttons in a frame 

‣ Click the arrows at the top-right of the frame to activate the previous or next 
button. The order is determined by the locations of the buttons. 

Change modifiers 
Modifiers are a convenient and powerful way to alter the output of a cue during a 
show. They can be added to individual cues or an entire frame, in which case they 
affect all cues in the frame. 

 

Change the value of a modifier 

‣ Press the mouse button over the modifier’s icon, then drag the mouse up or 
down. 

‣ Hold down the Shift key as you drag to change the modifier in coarse steps. 

‣ To disable snapping to the neutral value, hold down the Control key. 

Each modifier has a neutral value where it doesn’t change the output of the cue, and 
a customizable default value which may be different from the neutral value. A small 
dot below the modifier icon indicates that the modifier has a non-neutral value and 
therefore affects the cue’s result. 

Fast Movement

Ballyhoo

Slow Movement

Moving Lights

Ballyhoo
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Reset a modifier to its neutral or default value 

‣ Control-click the modifier’s icon and choose Reset to Neutral or Reset to 
Default from the shortcut menu. 

Continue effects across cues 
When a cue contains effects, they normally start from the beginning when the cue 
becomes active. However, in some situations Lightkey can continue effects across 
multiple cue buttons. This works under the following conditions: 

• Both cue buttons must be attached to each other. 

• Both cues contain the same preset which defines the effect. 

• If the effects are affected by modifiers, both cues have identical values for those 
modifiers. 

Live control with cuelists 
This section describes how you run a light show from a cuelist. The cues are typically 
activated one by one in sequential order, although it’s possible to skip to a random 
cue at any time. Whether groups are expanded or not doesn’t affect the playback 
order. If the checkbox to the left of a cue’s name is not selected, the cue is skipped. 

 

Control playback 
During playback, the name of the active cue is shown in the center of the toolbar. 

Start playback 

‣ Click 􀊄. 

	 	 Lightkey will activate the first cue in the cuelist. If the cue has a hold time, it will 
begin to run. 

	❖	 Note: The actions in this section can also be performed through external 
hardware, such as a MIDI controller, or through custom keyboard shortcuts. 
See chapter 16, External control, for more information.
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Pause or resume playback 

‣ Click 􀊆. When playback is paused, the hold time of the current cue stops 
running. Pausing has no effect unless the current cue has a hold time. 

Activate the next cue 

‣ Click  or press the Space bar. 

	 	 Lightkey will activate the next cue (possibly with a crossfade). If there is no next 
cue, the current cue will be deactivated. 

Activate the previous cue 

‣ Hold down the Shift key and click  or press Shift-Space. 

Stop playback 

‣ Click 􀛷. 

	 	 Lightkey will deactivate all cues in the cuelist. 

Manual crossfading 
Instead of setting fixed fade times for each cue, you can use the Xfade slider to 
perform manual crossfades. This gives you full control over the fade speed and is 
especially useful with a hardware controller. The Xfade slider can be shown or 
hidden in the cuelist inspector, as explained in Cuelists earlier in this chapter. You 
need to start playback before you can use the Xfade slider. 

Manually crossfade between cues 

‣ Drag the Xfade slider from its current position to the opposite end. 

	 	 This starts a crossfade from the current cue to the next, ignoring the cue’s fade 
time. The crossfade ends when the slider has reached the opposite endpoint. If 
you move the slider all the way back to the original endpoint while the fade is in 
progress you can cancel the crossfade. 

‣ Hold down the Shift key as you drag the Xfade slider to fade to the the previous 
cue instead. 

After the crossfade has completed, move the Xfade slider in the opposite direction to 
begin the next crossfade. 
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Activate arbitrary cues 
Although cuelists are usually played back in their predefined order, you can skip to a 
random time when necessary. 

Jump to a specific cue instantly 

Do one of the following: 

‣ Control-click a cue and choose Activate from the shortcut menu. 

‣ Double-click a cue. 

‣ Select a cue and press Command-Return. 

Skip to a specific cue with a fade 

Do one of the following: 

‣ Control-click a cue and choose Activate With Fade from the shortcut menu. This 
fades to the cue according to the previous cue’s fade time. 

‣ Hold down the Option key and double-click a cue. 

‣ Select a cue and press Command-Option-Return. 

Jump to a specific cue by name 

	 1	 Choose Live > Go to Cue… (or press Command-G). 

	 2	 Start typing the name of the desired cue. (If you use cue numbers, simply type 
the cue’s number.) 

	 3	 When the completed name matches the cue that you want to select, click Go. 
(Hold down the Option key to enable crossfading.) 

Change modifiers 
Modifiers are a convenient and powerful way to alter the output of a cue during a 
show. 

	➤	 Important: Manual crossfading does not apply to smart lights. They use a 
fixed fade time which can’t be changed in Lightkey.
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Change the value of a cue’s modifier 

‣ Press the mouse button over the modifier’s icon to the right of the cue name, 
then drag the mouse up or down. 

‣ Hold down the Shift key as you drag to change the modifier in coarse steps. 

‣ To disable snapping to the neutral value, hold down the Control key. 

Each modifier has a neutral value where it doesn’t change the output of the cue, and 
a customizable default value which may be different from the neutral value. A small 
dot next to the modifier icon indicates that the modifier has a non-neutral value and 
therefore affects the cue’s result. 

Reset a modifier to its neutral or default value 

‣ Control-click the modifier’s icon and choose Reset to Neutral or Reset to 
Default from the shortcut menu. 

Continue effects across cues 
When a cue contains effects, they normally start from the beginning when the cue 
becomes active. However, in some situations Lightkey can continue effects across 
multiple cues in a cuelist. This works under the following conditions: 

• Both cues are in the same cuelist. 

• Both cues contain the same preset which defines the effect. 

• If the effects are affected by modifiers, both cues have identical values for those 
modifiers. 

Blind mode 
Blind mode allows you to make changes without affecting the DMX output. You can 
still see the results of your changes in the Preview. Once you exit blind mode, all 
changes are applied to the DMX output at once. 

Enter blind mode 

‣ Click  in the toolbar or choose View > Blind Mode (or press Command-B). 
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While in blind mode, any active cuelists, sequences, and effects continue to run in the 
DMX output. You can make the following changes without affecting the DMX output: 

• Activate/deactivate presets, sequences, and cues 

• Change the overridden fixture properties 

• Change a cue’s intensity or modifiers 

• Change the Master Dimmer 

Exit blind mode and apply your changes 

‣ Click  in the toolbar or choose View > Blind Mode (or press Command-B). 

Exit blind mode and revert any changes you made 

Do one of the following: 

‣ Choose View > Cancel Blind Mode. 

‣ Hold down the Option key and click  in the toolbar. 

 

Freeze output 
When you freeze the output, Lightkey stops updating the DMX output and the 
Preview. This pauses any running cuelists, sequences, and effects. 

Freeze or unfreeze the output 

‣ Click  in the toolbar or choose View > Freeze Output (or press Command-

Period). 

Briefly freeze the output 

‣ Press and hold the mouse button over the  button in the toolbar. Release the 

mouse button to unfreeze the output. 

When you unfreeze the output, cuelists, sequences, and effects will continue to run 
seamlessly from where they left off. 

	❖	 Note: You can also enter or exit blind mode through external hardware, such 
as a MIDI controller, or through custom keyboard shortcuts. See chapter 16, 
External control, for more information.

Lightkey User Guide	 218



 

Startup state 
By default, Lightkey presents the same default state each time you start the 
application or open a project: 

• The first live page is selected. 

• No presets, sequences, or cues are active except for the cues where the 
“Activate at startup” option is selected. 

• Modifiers are at their default values. 

• The Master Dimmer is at 100%. 

This behavior is useful if you want to start with a “clean slate”, regardless of how the 
project was left after the last performance. 

You can tell Lightkey to automatically activate one or more cue buttons at startup. 
This option is not available for cuelists. 

Automatically activate a cue at startup 

	 1	 Open the cue inspector and scroll to Button. (See Edit button appearance and 
behavior earlier in this chapter.) 

	 2	 Select “Activate at startup”. 

Alternatively, you can tell Lightkey to remember the state before quitting or closing a 
project. This will restore the selected live page, active cues, modifier values, and 
Master Dimmer. In this case the “Activate at startup” option for cues is ignored. 

Restore the last state at startup 

	 1	 Choose Lightkey > Settings… (or press Command-Comma) and then click 
General. 

	 2	 Select “Restore active cues, modifiers, and Master Dimmer”. 

	❖	 Note: You can also freeze or unfreeze the output through external hardware, 
such as a MIDI controller, or through custom keyboard shortcuts. See chapter 
16, External control, for more information.
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Output order of precedence 
When a fixture property is defined at multiple points, the final output is determined in 
the following order: 

	 1.	 Overridden fixture properties. 

	 2.	 Selected presets and running sequences in the Preset Palette, in order of 
activation. 

	 3.	 Cues in the Live view, ordered by descending priority. Priorities are evaluated 
as follows: 

• The priority of the enclosing frame, for cue buttons within a frame. 

• The priority of the cue’s button, for cues with a button. 

• The priority of the cuelist, for cues in a cuelist. 

If two cues have equal priority, the most recently activated cue takes 
precedence. 

	 4.	 The default value of the fixture property. 

You can change cue, frame, and cuelist priorities in the Live view inspector. 

	★	 Tip: To have Lightkey reopen the last project when you start the application, 
make sure that “Close windows when quitting an application” is turned off in 
the Desktop & Dock pane of System Settings.
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Chapter 12   
Beat control 

 

Lightkey lets you run light shows in sync with 
music. This chapter describes how to enable beat 
control for sequences and effects, and how to 
synchronize Lightkey to music. 

Lightkey has a single, global source for the beat which usually matches the music 
that’s playing. The beat source affects all sequences and effects that are marked as 
“beat-controlled”. In other words, sequences and effects cannot use different beats, 
and the beat does not depend on the active sequences and effects. 

In this context, the term beat or beat grid actually means two things: 

• It defines the tempo, in beats per minute, to make effects and sequences run at 
the same speed as the music. 

• It defines the phase synchronization, that is, when the beats occur, so effects 
and sequences are aligned with the music. 

There are several ways to set the global beat grid. You can: 

• “Tap” the beat by pressing the mouse button or a key four times. Lightkey will 
learn the beat and carry it forward at the same speed. 

• Enter the exact beats per minute. 

• Receive a MIDI Beat Clock signal sent by a DJ software, mixer, or audio analysis 
tool. 
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• Connect to other software through Ableton Link, a technology for synchronizing 
beat information between applications on the same computer or over a 
network. 

Beat-controlled sequences 
You can easily turn a regular sequence into a beat-controlled one. A beat-controlled 
sequence advances to the next step in sync with the beat. 

Make a sequence beat-controlled 

	 1	 Double-click a sequence in the Preset Palette to open its inspector. 

	 2	 Click Timing and then select Beat-controlled. 

When a sequence becomes beat-controlled, the Hold Time column changes to a 
Length column. By default each step has a length of 1 so the sequence advances on 
each beat. You can increase the steps’ lengths or apply a beat multiplier to adjust the 
timing. For example, a multiplier of ÷2 advances the sequence on every half beat, and 
a multiplier of ×3 advances it on every third beat. Additional parameters like 
quantum and offset give you even more control. For a thorough discussion see 
Sequence timing in chapter 9, Presets and sequences. 

Beat-controlled effects 
Some effects can be synchronized to the beat. This is true for pattern effects (some 
patterns only) and curve effects. 

Make an effect beat-controlled 

‣ Edit the effect, then select the  icon in the Timing Mode options. If the icon 

isn’t visible or is inactive then the effect can’t be beat-controlled. 

The exact behavior of beat-controlled effects is described in chapter 10, Effects. Like 
with sequences, you can apply a beat multiplier to adjust the timing. 

Set the beat grid 
There are various ways to set the beat grid—that is, define the tempo and alignment. 

Lightkey User Guide	 222



By tapping 
You can set the beat by pressing the mouse button or a key four times on each beat. 
Lightkey will “learn” the beat and carry it forward at the same speed. 

Tap the beat 

	 1	 Do one of the following: 

‣ Click the beat indicator at the bottom-left of the Live view. 

‣ Choose View > Set Beat (or press Shift-B). 

	 2	 Click Manual. 

	 3	 Press the mouse button or the Space bar four times on each beat. 

	 4	 Check if the animation in the beat indicator is in sync with the music. If not, 
repeat step 3. 

	 5	 Click the beat count at the bottom or press Return. 

 

As an exact value 
You can manually specify the tempo (beats per minute). You can also align the beat 
grid while maintaining the current tempo. 

Set the tempo to an exact value 

	 1	 Do one of the following: 

‣ Click the beat indicator. 

‣ Choose View > Set Beat (or press Shift-B). 

	 2	 Click Manual. 

	 3	 Do one of the following: 

‣ Click the text field near the bottom, type a new value, and press Return. 
You can use fractional values, like “12.5”. 

	❖	 Note: You can also tap the beat through external hardware, such as a MIDI 
controller, or through custom keyboard shortcuts. See chapter 16, External 
control, for more information.
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‣ Click the arrows next to the text field or press the Up/Down Arrow keys to 
increase or decrease the beats per minute. Hold down the Shift key as you 
click to change the value in intervals of 10. 

‣ Click ÷2 or ×2 to halve or double the current tempo. 

	 4	 Click the beat count at the bottom or press Return. 

Align the beat grid while maintaining tempo 

	 1	 Do one of the following: 

‣ Click the beat indicator. 

‣ Choose View > Set Beat (or press Shift-B). 

	 2	 Click Manual. 

	 3	 Do one of the following: 

‣ To synchronize the time of the next beat: Hold down the Option key and 
click once, or press Option-Space. 

‣ To synchronize the time of the downbeat: Hold down the Option and Shift 
keys and click once, or press Option-Shift-Space. 

	 4	 Click the beat count at the bottom or press Return. 

 

Through MIDI Beat Clock 
You can synchronize the beat with other software or external hardware which sends 
MIDI Beat Clock signals. MIDI (Musical Instrument Digital Interface) is a standard 
protocol that allows a wide variety of electronic music devices, control surfaces, and 
software to send and receive performance data. MIDI Beat Clock (or MIDI Clock) is a 
clock signal that is broadcast via MIDI to synchronize MIDI-enabled hardware and 
software. 

	❖	 Note: You can also change the tempo or align the beat through external 
hardware, such as a MIDI controller. See chapter 16, External control, for 
more information.
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You can synchronize the beat with the following kinds of software or hardware: 

• DJ software like Traktor or DJ mixers which detect the beats per minute. This is 
usually the most accurate form of BPM detection because the software can 
determine the beat grid in advance. 

• Audio analysis software such as Waveclock or Wavetick which analyzes audio as 
it plays. Lightkey itself does not perform audio analysis. 

There are generally two ways to establish a connection between the source software 
or hardware and Lightkey: 

• Some sources create a MIDI source port on which they send MIDI Clock signals. 
You select this port in Lightkey. 

• Other sources require that you specify a MIDI destination port to which they 
send MIDI Clock signals. In this case Lightkey can create a MIDI destination 
port. 

Synchronize Lightkey to a MIDI Clock source 

	 1	 Do one of the following: 

‣ Click the beat indicator. 

‣ Choose View > Set Beat (or press Shift-B). 

	 2	 Click External. 

	 3	 Select an input source from the list. 

‣ If your MIDI source creates a MIDI output port, select it from the list. 

‣ If your MIDI source requires a destination port, select Lightkey MIDI Input. 
Lightkey creates a MIDI input port which you can select as destination in 
another software. 

	 	 When MIDI Clock signals are received, the status changes to “Receiving”, and 
the animation in the beat indicator is in sync with the music. 

	 4	 Click the beat count at the bottom or press Return. 

Through Ableton Link 
Ableton Link is a technology that synchronizes beat information over a wireless or 
wired network. It works with Ableton Live and a variety of other applications and 
devices. The source must be either on the same computer or on a computer on the 
same local network. 
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Synchronize Lightkey via Ableton Link 

	 1	 Do one of the following: 

‣ Click the beat indicator. 

‣ Choose View > Set Beat (or press Shift-B). 

	 2	 Click External. 

	 3	 Click Ableton Link. 

	 	 Lightkey looks for Ableton Link users on the same local network and displays 
the number of peers found. When a connected peer changes its beat grid, 
Lightkey’s beat indicator adapts to the peer. 

	 4	 Click the beat count at the bottom or press Return. 

Examples 
The following examples show you how to synchronize the beat with selected software 
through MIDI Beat Clock or Ableton Link. 

 

Ableton Live 
Ableton Live is a music sequencer and digital audio workstation (DAW) software used 
by many musicians and DJs. This section shows how to synchronize Lightkey to 
Ableton Live through Ableton Link. 

Synchronize Lightkey with Ableton Live 

	 1	 Open Ableton Live and click Link at the upper-left of the main window to enable 
Link. 

	 	  

	❖	 Note: This section is about third-party software from other manufacturers. 
We have carefully tested the integration with Lightkey at the time it was 
written, but cannot guarantee this functionality will work without errors and 
continue to work in the future.
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	 	 If you don’t see the Link toggle, choose Live > Settings…, click Link, Tempo & 
MIDI, and make sure the button next to Show Link Toggle reads Show. 

	 2	 In Lightkey, click the beat indicator at the bottom-left of the Live view, then click 
External > Ableton Link. 

	 	 When Lightkey finds Ableton Live, the status text reads “1 peer” and the beat 
indicator adapts to the tempo in Ableton Live. 

Logic Pro 
Logic Pro is a music sequencer and digital audio workstation (DAW) software by 
Apple. This section shows how to synchronize Lightkey to Logic Pro through MIDI 
Clock. 

Synchronize Lightkey with Logic Pro 

	 1	 In Lightkey, click the beat indicator, then click External > Lightkey MIDI Input. 

	 2	 Open Logic Pro and choose Logic Pro X > Settings… > Synchronization. 

	 3	 Next to Transmit MIDI Clock, select one of the two destinations and choose 
Lightkey Input from the pop-up menu. 

	 	  

MultiTracks Playback 
Playback is a tracks player for worship services, available for iPad, iPhone, and Mac. 
This section shows how to synchronize Lightkey to Playback for iPad using MIDI 
Clock over Wi-Fi. For this, a MIDI network session is created in the app Audio MIDI 
Setup that comes with macOS. Your Mac and iPad must be connected to the same 
Wi-Fi network. 

Synchronize Lightkey with Playback 

In Audio MIDI Setup: 

	 1	 Choose Window > Show MIDI Studio to open the MIDI Studio window. 
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	 2	 Choose MIDI Studio > Open MIDI Network Setup… to open the MIDI Network 
Setup window. 

	 3	 Click 􀅼 in the My Sessions section. This creates a session which your iPad can 
connect to. Make sure the checkbox to the left of the session is selected. 

	 4	 Select “Anyone” in the menu “Who may connect to me”. 

	 5	 Open the Playback app on your iPad. The iPad should now appear in the 
Sessions and Directories section in Audio MIDI Setup. 

	 6	 Select your iPad in the Sessions and Directories section, then click Connect. 
This adds your iPad to the session. 

	 	  

On your iPad: 

	 1	 Open the settings area in the Playback app. 

	 2	 Tap MIDI. 

	 3	 Next to MIDI Clock, tap Select Ports. 

	 4	 Select Network Session, then tap Done. 
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In Lightkey: 

	 1	 Click the beat indicator at the bottom-left of the Live view. 

	 2	 Click External and then select Network Session. 

Once you start playback in the Playback app, the BPM display in Lightkey synchro- 
nizes to the music. 

Traktor 
Traktor is a DJ software developed by Native Instruments. This section shows how to 
synchronize Lightkey to Traktor through MIDI Clock. 

Synchronize Lightkey with Traktor 

	 1	 Open Traktor, choose Traktor > Preferences…, and select Controller Manager 
on the left. 

	 2	 Create a new generic MIDI device. As Out-Port, select Traktor Virtual Output. 

	 	  

	 3	 Click MIDI Clock on the left, then select Send MIDI Clock. 

	 	  

	 4	 Open the Master Clock panel in Traktor’s Global Section by clicking the 
metronome icon. (If you can’t see the Master Clock / FX Panel, choose to 
Traktor > Preferences… > Global Settings and select Show Global Section.) 

	 5	 To start sending a MIDI Clock signal, click the Play/Pause button. The button 
appears blue when MIDI Clock is active. 

	 	  

	 6	 In Lightkey, click the beat indicator, click External, and choose Traktor Virtual 
Output. 
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Waveclock 
Waveclock by Wavesum is an audio analysis tool which converts music to MIDI Beat 
Clock signals in real time. You can use it if you play music through an app that does 
not perform beat detection (like iTunes or Spotify) or a CD deck. This section shows 
how to synchronize Lightkey to Waveclock through MIDI Clock. 

Synchronize Lightkey with Waveclock 

	 1	 In Lightkey, click the beat indicator, then click External, and choose Lightkey 
MIDI Input. 

	 2	 Open Waveclock. Choose Waveclock > Settings… and select Lightkey Input as 
output device. Close the Waveclock I/O Settings window. 

	 	  

	 3	 In the Waveclock window, select MIDI Clock. 
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Chapter 13   
Manage DMX fixtures 

 

Before Lightkey can control your DMX lights you 
need to supply some basic information about the 
fixtures. This process is sometimes called 
“patching”. 

DMX (Digital Multiplex) enables a controller—in this case, Lightkey—to control the 
features of a wide range of DMX-compatible devices or fixtures. They are connected 
to the controller through a DMX connection which consists of a series of DMX cables 
between the controller and the fixtures in the form of a “daisy chain” (that is, each 
fixture links to the previous and next fixture or the controller). DMX signals flow in 
one direction from the controller to the fixtures. 

All fixtures on a single daisy chain form a universe. In many cases an installation will 
consist of only one universe, but depending on your license Lightkey can output DMX 
to up to 16 universes. 

The fixtures on a universe are controlled by 512 channels, each of which can have a 
unitary value from 0 to 255 which controls a property of a fixture. Each fixture is 
assigned a consecutive range of channels: Simple fixtures like dimmers require only 
a single channel while some intelligent lights may require 20 or over 100 channels. 
The number of the first channel occupied by a fixture is called its address. 

 

	❖	 Note: You can learn more about DMX universes and addresses in chapter 2, 
Intro to DMX.
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In order to know which fixture property is controlled by which channel, Lightkey 
needs a fixture profile. It contains a description of the fixture’s capabilities and the 
way they are controlled. Lightkey comes with a built-in library of fixture profiles from 
a wide range of manufacturers and can import thousands of freely available profiles 
in the formats SSL2, FXT, and PFF. You can also create your own profiles using the 
built-in fixture editor. 

In summary, in order to control a fixture you need to tell Lightkey its universe and 
address and provide a fixture profile. You manage this information in the Fixture 
Manager.

 

Open the Fixture Manager 

Do one of the following: 

‣ Click  in the toolbar. 

‣ Choose Lightkey > Manage Fixtures… (or press Command-Shift-Down Arrow). 

‣ Click a fixture’s short name in the Preview, then click the fixture’s address (e.g. 
“Universe 1, channels 1 – 10”) in the shortcut menu. This will open the Fixture 
Manager and show information about the clicked fixture. 

Close the Fixture Manager 

Do one of the following: 

‣ Click Done in the toolbar. 

Click a universe to select it
Click the arrow to configure a universe 
for output or input

Fixture library DMX channels and fixtures in the selected universe
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‣ Choose Lightkey > Manage Fixtures… (or press Command-Shift-Up Arrow). 

On the left of the Fixture Manager is the fixture library which contains all built-in, 
imported, and user-created fixture profiles. The first column lists the manufacturers, 
the second column shows the profiles for the selected manufacturer. The library also 
contains a number of generic profiles which don’t relate to a specific fixture model. 

On the right is a grid representing the 512 channels in a DMX universe. Click a 
universe at the top to reveal its channels. For information on how to configure a 
universe for output or input, see Configure universes in chapter 14, DMX output and 
input. 

Find the right fixture profile 
Many simple fixtures work with one of the profiles in the Generic category of the 
built-in library. Double-click a profile to view a description of the profile. You can also 
find an overview of the generic profiles at the end of this User Guide. 

The Generic category also includes a selection of flexible fixture profiles (“FLEX”) for 
LED strips and matrixes. Flexible fixture profiles let you choose the desired number 
of LEDs when you patch the fixture. 

For more complex lights you need a profile specific to the fixture. See Find the right 
fixture profile in chapter 4, Set up your lights, to learn how to get fixture profiles. It’s 
important to use a profile which exactly matches your fixture model, or the fixture 
will not work correctly. Profiles for other—even similar—lights will often not work. 

Filter the fixture library 
You can apply filters to the fixture library to quickly find matching profiles for your 
lights. 

	 1	 Enter something in the search field above the fixture library to search for a 
manufacturer or model name. 

	 2	 Click 􀋃 to view only fixture profiles that have been marked as favorites. (To 
mark a profile as favorite, Control-click the profile and choose Add to Favorites 
from the shortcut menu.) 

	 3	 Click the arrow to the right of the search field to reveal additional filter options. 

‣ Select a fixture type to only show fixtures of this type. 
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‣ Use the Channels field to find fixture profiles with the specified number of 
channels. For example, enter “11, 15” to find profiles with both an 11 
channel mode and a 15 channel mode. 

Double-click a fixture profile in the library to view additional information. 

Add DMX fixtures 

	 1	 Select the universe which the new fixture is connected to. 

	 2	 Drag a fixture profile from the library to the channel grid. The first occupied 
channel should match the fixture’s DMX address. Fixtures must not overlap. 

	 	 The fixture appears in the channel grid with a dashed outline. Below it you see a 
window with additional options. 

 

	 2	 If the fixture has different operation modes (or “personalities”), select a mode 
from the pop-up menu below the fixture name. Be sure to select the same 
mode as on the fixture, or Lightkey will not be able to control the fixture. The 
mode determines how many channels the fixture occupies. 

	 	 When patching a flexible LED strip or matrix, you can enter the desired number 
of LEDs here. The fixture will grow or shrink in the channel grid depending on 
the number of LEDs. 

3

Lightkey User Guide	 234



 

	 4	 Assign a short name to the fixture. Short names appear in Lightkey’s Preview; 
they can be up to four characters long and typically include one or two letters 
and a number. If the short name ends with a number, you can increase/
decrease it by pressing the Up/Down Arrow keys while the insertion point is in 
the field. 

	 	 Lightkey proposes a short name based on the fixture type, but you should 
choose a naming scheme that’s suitable for your lighting installation. For 
example, if you have a row of PAR cans on the floor and one at the ceiling, you 
can name them F1, F2, F3, … and C1, C2, C3, … 

	 5	 If necessary, you can correct the fixture’s DMX address in the Address field. 
(You can increase/decrease the address by pressing the Up/Down Arrow keys 
while the insertion point is in the field.) 

	 6	 If the Count value is greater than one, Lightkey displays multiple instances of 
the fixture in the Preview which always share the same fixture properties. This 
is useful when you patch several identical fixtures to the same DMX address. 

	 7	 To patch multiple fixtures of the same type to consecutive DMX addresses, 
enter their number here. (You can increase/decrease the number by pressing 
the Up/Down Arrow keys while the insertion point is in the field.) 

	 	 If the short name ends with a number, Lightkey automatically increments the 
number for each fixture. For example, if you add four moving heads and enter 
“MH6”, their names will be MH6 through MH9. 

	 8	 Click Patch (or press Return). 

Edit DMX fixtures 
After patching your fixtures you can always come back and edit the information. This 
section pertains to DMX fixtures; for Hue fixtures see chapter 15, Smart lights. 

4

6

5

7
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View and edit DMX fixture information 
You can change a fixture’s address, short name, instance count, and other 
information without affecting your presets, sequences, and cues. 

View and edit information about a fixture 

	 1	 In the Fixture Manager, do one of the following: 

‣ Double-click a fixture in the channel grid. 

‣ Control-click a fixture in the channel grid and choose Get Info from the 
shortcut menu. 

‣ Force click a fixture in the channel grid (requires a trackpad with Force 
Touch support). 

	 2	 The following information is shown below the fixture: 

	 	  

	 	 For flexible LED strips and matrixes you can also change the number of LEDs. It 
determines how many channels the fixture occupies. 

	 	  

	 	 The External reference field can hold arbitrary text. It can be useful when 
interchanging patching information with another application through the 
import/export feature. The value of this field is not used by Lightkey. 

	 	 Click Comments to attach a comment to the fixture. Comments also appear 
when you print or export fixtures. 

The mode currently in 
use and the number of 

occupied channels

Manufacturer
and model name

Number of instances 
shown in Preview

The short name is 
used to identify the 

fixture in the Preview
DMX address as 
decimal number and 
DIP switch (Dual In-
line Package) values
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Edit information for multiple fixtures 

	 1	 Double-click a fixture in the channel grid. 

	 	 A window appears below the fixture. 

	 2	 Press the mouse button over a blank part of the window and drag it to a 
different location, detaching it from its fixture. 

	 3	 Hold down the Shift or Command key and click other fixtures in the channel grid 
to select them. 

	 4	 Change the information in the detached window. For example, select a different 
mode. This changes all selected fixtures. 

	 	 You can’t change the address because it would not make sense to assign the 
same address to multiple fixtures. 

	 5	 Click 􀆄 to close the detached window. 

Reveal one or more fixtures in the Preview 

	 1	 Select one or more fixtures in the channel grid. (Hold down the Command or 
Shift key as you click to select multiple fixtures.) 

	 2	 Control-click one of the fixtures and choose Show in Preview from the shortcut 
menu. 

Reveal a fixture’s profile in the library 

‣ Control-click a fixture in the channel grid and choose Show Profile in Library 
from the shortcut menu. 

Change a fixture’s DMX address or universe 
You can change a fixture’s DMX address or universe at any time. All presets, 
sequences, and cues containing the fixture will continue to work. 

Change the DMX address of one or more fixtures 

	 1	 Select one or more fixtures in the channel grid. (Hold down the Command or 
Shift key as you click to select multiple fixtures.) 

	 2	 Do one of the following: 

‣ Drag the fixtures in the channel grid. 

‣ Double-click a fixture, then change the value in the “Start at” field. 
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Change the DMX universe of one or more fixtures 

	 1	 Select one or more fixtures in the channel grid. 

	 2	 Drag the fixtures to one of the universes at the top. You can’t drag fixtures to an 
input universe or Hue Bridge. 

Duplicate fixtures 
You can duplicate fixtures to quickly create new, independent fixtures of the same 
kind. Optionally, the new fixtures can adopt the properties of the existing one which 
are stored in presets. This can be useful if you extend your lighting installation: For 
example, assume you have a row of PARs for which you’ve created various presets, 
sequences, and cues. You can easily add another PAR to the row which behaves 
exactly like the others, without having to edit every preset. 

Duplicate fixtures 

	 1	 In the Fixture Manager, select one or more fixtures in the channel grid. (Hold 
down the Command or Shift key as you click to select multiple fixtures.) 

	 2	 Do one of the following: 

‣ Choose Edit > Duplicate (or press Command-D). 

‣ Control-click one of the fixtures and choose Duplicate from the shortcut 
menu. 

‣ Hold down the Option key and drag the fixtures in the channel grid. 

	 3	 In the dialog that appears, enter the desired number of copies. 

	 4	 Select or deselect the option “Adopt data in presets”. 

	 	 If the option is selected, Lightkey will copy all properties for the existing fixtures 
which are stored in presets to the new fixtures. In other words, the new fixtures 
will behave exactly like the existing fixtures. 

	 	 If the option is not selected, Lightkey will simply create new fixtures with the 
same fixture profiles and modes. 

	 5	 Click Duplicate. 
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Edit a fixture profile 
You can conveniently edit fixture profiles in Lightkey’s fixture editor. The fixture 
editor is built into the application so changes take effect immediately as you close the 
fixture profile. 

Edit a fixture’s profile 

Do one of the following: 

‣ In the Fixture Manager, Control-click a fixture in the channel grid and choose 
Open Profile from the shortcut menu. 

‣ Hold down the Option key and double-click a fixture in the channel grid. 

‣ Click a fixture’s short name in the Preview, then select the top item in the 
shortcut menu and choose Open Fixture Profile. 

‣ Select a fixture in the Preview and choose Fixture > Open Fixture Profile (or 
press Command-Shift-Option-Down Arrow). 

‣ Hold down the Option key and double-click a fixture in the Preview. 

 

Reassign fixture profiles 
When you replace a fixture with one of a different kind, you can assign the new light’s 
fixture profile to the existing fixture in Lightkey. This retains the fixture’s stored data 
in presets, sequences, and cues, as long as the stored properties exist in the new 
profile. 

Reassign a fixture profile 

	 1	 In the Fixture Manager, drag a fixture profile from the library to a fixture in the 
channel grid. 

	 2	 In the alert message that appears, select “Change all fixtures with this profile” 
if you want to replace the fixture profile throughout the project. 

	 3	 Click Change. 

	❖	 Note: Fixture profile information for the fixtures in a project is also stored in 
the project file, so you can use the project even if you don’t have the fixture 
profiles. If a fixture’s profile is not in your library, you can easily add it by 
editing the fixture’s profile as described above.
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Disable fixtures 
If a fixture is temporarily disconnected, broken, or simply not in use, you can disable 
it in Lightkey. A disabled fixture shows no light beam, can’t be selected in the 
Preview, and all its DMX channels are set to zero. 

Disabled fixtures do not count towards the maximum number of output channels 
permitted by your Lightkey license. If your fixtures use more channels than are 
enabled by your license you can disable fixtures to decide which fixtures should 
receive output. 

Disable or enable a fixture 

‣ In the Fixture Manager, Control-click a fixture in the channel grid and choose 
Disable or Enable from the shortcut menu. 

 

Delete fixtures 
When you delete a fixture from the project all information about the fixture is 
removed from presets, sequences, and cues. If you don’t want to permanently delete 
the fixture you can disable it instead, as described in the preceding section. 

Delete fixtures 

	 1	 In the Fixture Manager, select one or more fixtures in the channel grid. (Hold 
down the Command or Shift key as you click to select multiple fixtures.) 

	 2	 Do one of the following: 

‣ Drag a fixture out of the channel grid. 

‣ Control-click a fixture and choose Delete… from the shortcut menu. 

‣ Press the Delete key. 

	 3	 In the alert message that appears, click Delete (or press Command-Delete). 

 

	❖	 Note: You can also disable or enable fixtures in the Preview. See Disable 
fixtures in chapter 7, Preview.

	▲	 Warning: Deleting a fixture cannot be undone. All related data—for example, 
in presets, sequences, and cues—is removed from the project.
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Export and import fixtures 
Lightkey can export a list of the fixtures in your project as a delimiter-separated text 
file, such as CSV (comma-separated values) or TSV (tab-separated values). You can 
import files back into another Lightkey project or into other applications such as DMX 
visualizers. 

CSV and TSV files are structured in a simple, spreadsheet-like form: The first line 
contains column titles, and each following line represents a fixture. Many lighting 
control applications can import and export CSV and TSV files, even though the exact 
format varies from program to program. You can also import the files into 
spreadsheet applications or view them in a text editor. 

Export fixtures 

	 1	 In the Fixture Manager, click 􀈂 in the toolbar. A dialog with export settings 
appears. 

	 2	 Select the columns which should be exported. 

	 	 The universe and address can be exported as two separate columns or as a 
single column, depending on the requirements of the importing application. The 
same is true for the manufacturer and model. 

	 	 The Position X and Position Y options export the fixtures’ positions in the 
Preview. By default the values are in the Preview’s coordinate system, which 
has no reference to physical units. You can click 􀍠 and specify an origin and 
scale to transform the values into the coordinate system of the target 
application, e.g. a DMX visualizer. Lightkey can export fixture positions but does 
not import them. 

	 3	 Select a text encoding. The default selection, Unicode (UTF-8), is compatible 
with most other applications. 

	 4	 Choose which character should be used as field delimiter. 

	 5	 Click Save… 

	 6	 In the dialog that appears, enter a filename, choose a location, and click Export. 

You can import files previously exported from Lightkey or from other applications. 
Based on the imported information, Lightkey will add new fixtures to your project or 
update the existing fixtures. 
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Import fixtures 

	 1	 Click 􀈄 in the toolbar. 

	 2	 In the dialog that appears, select a text file containing fixture information. The 
file must use the CSV (comma-separated values) or TSV (tab-separated values) 
format; the field delimiter can also be a semicolon. The first line must contain 
column titles. 

	 	 In most cases Lightkey can automatically detect the text encoding and field 
delimiter. If necessary, you can click Show Options and explicitly choose a text 
encoding and field delimiter. 

	 3	 Click Continue. 

	 4	 The next dialog lets you determine how Lightkey interprets the information in 
each data column. The left table column contains fixture information Lightkey 
can import. In the right column, you can select which column the data should be 
taken from (if any). 

	 	 If the imported file was exported from Lightkey, Lightkey can automatically map 
all columns and no changes are necessary. If the file was created by another 
application, Lightkey tries to map the columns based on the their title, but you 
may need to adjust the settings to ensure all data is imported correctly. 

	 	 The universe and address can be in separate columns or in a single column. 
The same is true for the manufacturer and model. 

	 	 At least the following information is required to import a fixture: 

• Universe and address 
• Manufacturer and model 

	 	 The external reference can be used to import values which another application 
uses to identify fixtures. When you import updated data from the other 
application at a later time, Lightkey can use the external reference to determine 
if a fixture already exists. The external reference can also be included when 
exporting fixture data. 

	 	 Below the table you see the results of importing the file with the current 
settings: 

• New fixtures: The number of fixtures that will be added. 

• Updated fixtures: The number of fixtures that already exist in the project 
and will be updated with the imported information. 
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• Skipped lines: The number of lines that can’t be imported (not counting 
the header row). This may be because required information is missing, in 
the wrong format, or its value is invalid. 

	 5	 To specify the handling of fixtures that already exist in the project, click More 
Options… 

• Choose whether Lightkey should compare the short names or external 
references to determine whether a fixture already exists. 

• When Lightkey finds that an imported fixture already exists in the project, 
it can: 

• Update the fixture with the imported information, 

• Leave the fixture unchanged and ignore the imported information, or 

• Import the fixture anyway. 

	 6	 Click Continue. 

	 7	 The next dialog lets you map the imported manufacturer and model names to a 
fixture profile. The columns on the left show the imported data. Each row 
represents a combination of manufacturer, model, and mode which is used by 
one or more imported fixtures. 

	 	 The columns on the right let you map this information to a manufacturer, 
fixture profile, and mode from Lightkey’s fixture library. Lightkey automatically 
tries to find and select a matching fixture profile for each imported model. 

	 	 If no fixture profile is selected for one or more rows (“No selection”), Lightkey 
cannot add the corresponding fixtures. (It may still use the information to 
update existing fixtures, though,) 

	 8	 Click Import. Lightkey adds or updates fixtures based on your settings. It may 
also add new universes. 

	 	 If the result isn’t as expected, you can choose Edit > Undo Import to revert the 
changes. 

 

	★	 Tip: A quick way to import fixture information is to drag a CSV or TSV file to 
the channel grid.
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Print the patched fixtures 
You can print a list of all fixtures in your project, including patching information and 
comments. This can be convenient when assigning DMX addresses to the lights or 
when working with equipment hiring companies. 

Print a list of the fixtures in a project 

	 1	 In the Fixture Manager, click 􀎚 in the toolbar. 

	 2	 In the dialog that appears, click Print. 

Work with fixture profiles 
The fixture library on the left side of the Fixture Manager contains all built-in, 
imported, and user-created fixture profiles. 

Manage favorite fixture profiles 
You can mark frequently used fixture profiles as favorites to find them more easily. 
Favorites are marked with a 􀋃. 

Add a fixture profile to the favorites 

‣ Control-click a fixture profile in the library and choose Add to Favorites from 
the shortcut menu. To remove a fixture profile from the favorites, choose 
Remove From Favorites. 

View only favorite profiles 

‣ Click 􀋃 at the top of the fixture library. 

Edit a fixture profile 
You can edit fixture profiles in Lightkey’s built-in fixture editor. Changes take effect 
immediately as you close the fixture profile. 

 

	❖	 Note: You can view built-in profiles in the fixture editor but you cannot make 
changes. Instead, you can duplicate the profile.
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Edit a fixture profile 

Do one of the following: 

‣ Select a fixture profile in the library, then click 􀍠 and choose Open Profile from 
the menu. 

‣ Control-click a fixture profile in the library and choose Open Profile from the 
shortcut menu. 

‣ Hold down the Option key and double-click a fixture profile in the library. 

The fixture editor opens. A complete discussion of the fixture editor is beyond the 
scope of this User Guide. 

To close the fixture profile, click 􀆄 to the left of its name (at the top). 

Import a fixture profile 
You can import any Lightkey fixture profile into your library. You can also import 
profiles in the formats SSL2 (Sunlite) and FXT or PFF (DMX FreeStyler). 

Import a fixture profile 

	 1	 Click 􀍠 at the top of the fixture library and then choose Import Profiles… from 
the menu. 

	 2	 Select a fixture profile in one of the supported file formats 
(.lightkeyfxt, .ssl2, .fxt, .pff) and click Import. 

	 3	 If you’re importing an SSL2 profile, enter the manufacturer and fixture name in 
the dialog that appears, then click Import. 

	 4	 If the profile already exists in your library, Lightkey will display a warning. You 
can either replace the existing profile or keep both profiles. 

	 

Create a fixture profile 
Lightkey’s built-in fixture editor lets you create your own fixture profiles. 

	★	 Tip: A quick way to import a fixture profile is to drag the file to the fixture 
library.
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Create a fixture profile 

‣ Click 􀍠 at the top of the fixture library and then choose New Profile… from the 
menu. 

An interactive assistant will appear and ask you about the basic information for 
the fixture profile. Then Lightkey creates the fixture profile and opens it in the 
fixture editor. A complete discussion of the fixture editor is beyond the scope of 
this User Guide. 

Duplicate a fixture profile 
You can duplicate a fixture profile and use it as a starting point for new profiles. 
Another reason to duplicate fixture profiles may be that you want to make changes to 
a built-in profile. 

Duplicate a fixture profile 

‣ Control-click a fixture profile in the library and choose Duplicate Profile from 
the shortcut menu. 

A copy of the profile is added to the library, which you can then edit in the fixture 
editor. 

Delete a fixture profile 
You can move user-created fixture profiles to the Trash. Built-in profiles cannot be 
removed. 

Move a fixture profile to the Trash 

	 1	 Control-click a fixture profile in the library and choose Move to Trash… from the 
shortcut menu. 

	 2	 In the alert message that appears, click Move to Trash. 
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Chapter 14   
DMX output and input 

 

Lightkey provides numerous ways of DMX output 
and input. You can use USB–DMX interfaces from 
many manufacturers as well as the network 
protocols Art-Net, sACN (also called E1.31), and 
ESP Net. 

DMX input/output is configured primarily in two places: 

• The DMX Output pane of the Settings window contains application-wide settings 
for each output method. 

• The Fixture Manager is where you patch your project’s universes to a USB 
interface or network protocol. 

DMX Output settings 
The DMX Output settings contain general settings for the various output/input 
methods. These settings are global to the application and apply to all projects. 

Change DMX Output settings 

	 1	 Choose Lightkey > Settings… and click DMX Output. 

	 2	 Select an output method from the left, then change the settings on the right as 
appropriate. 

	 3	 Click Apply to apply your changes, or click Revert to leave the settings 
unchanged. 
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Serial USB Interfaces 
The Serial USB Interfaces output method includes the following USB–DMX 
interfaces: DMXking ultraDMX devices, Enttec DMX USB Pro, Jese DMX-TRI, Robe 
Universal Interface. Lightkey can control a single USB interface from this group. 

These interfaces cannot be used together with Open DMX or Eurolite PRO interfaces. 
Only one of these three output methods can be enabled at a time. A green dot next to 
“Serial USB Interfaces” indicates that the method is enabled. 

Enable Serial USB Interfaces 

‣ Select Serial USB Interfaces on the left and click Enable. 

	 	 This implicitly disables the options Open DMX Interfaces and Eurolite PRO. 

Open DMX Interfaces 
The Open DMX Interfaces output method includes the Enttec Open DMX USB 
interface and similar devices (but not the Enttec Open DMX Ethernet interface). 
Lightkey can control a single Open DMX interface. 

Open DMX interfaces cannot be used together with serial USB  or Eurolite PRO 
interfaces. Only one of these three output methods can be enabled at a time. A green 
dot next to “Open DMX Interfaces” indicates that the method is enabled. 

Unlike most other USB–DMX interfaces, Open DMX devices don’t include a 
microprocessor to create the DMX stream. Instead they rely on the computer to send 
DMX frames in regular intervals. If the computer can’t provide the DMX data at a high 
enough speed, you may experience flicker. In this case you should try to reduce the 
DMX refresh rate. 

Enable Open DMX Interfaces 

‣ Select Open DMX Interfaces on the left and click Enable. 

	 	 This implicitly disables the options Serial DMX Interfaces and Eurolite PRO. 

Change the rate at which DMX data is sent 

‣ Select an option from the “Refresh rate” pop-up menu. 
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Eurolite USB-DMX512-PRO MK2 
Enable this output method for the Eurolite USB-DMX512-PRO MK2 and Eurolite USB-
DMX512-PRO Cable. Lightkey can control a single USB interface from this group. 

These interfaces cannot be used together with serial USB or Open DMX interfaces. 
Only one of these three output methods can be enabled at a time. A green dot next to 
“Eurolite PRO” indicates that the method is enabled. 

Enable Eurolite PRO 

‣ Select Eurolite PRO Interfaces on the left and click Enable. 

	 	 This implicitly disables the options Serial DMX Interfaces and Open DMX 
Interfaces. 

	 

Other USB Interfaces 
This output method includes the following USB–DMX interfaces: Eurolite USB-
DMX512-PRO, and Stage-Profi devices. Lightkey can control a single USB interface 
from this group. 

No settings are required for these interfaces. 

Art-Net 
Art-Net is a communication protocol for distributing DMX data over a computer 
network. It was developed by Artistic Licence and has been placed in the public 
domain. Art-Net can carry a large number of DMX universes, and Ethernet cabling or 
Wi-Fi are useful for covering long distances. 

	★	 Tip: When you enable the Open DMX Interfaces output method, Lightkey will 
ask for an administrator password each time you start the application. 
Therefore you should not enable this option unless you actually use an Open 
DMX USB interface.

	★	 Tip: When you enable the Eurolite PRO output method, Lightkey will ask for 
an administrator password each time you start the application. Therefore you 
should not enable this option unless you actually use a Eurolite interface.
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An Ethernet–DMX interface—also called an Art-Net node—translates between Art-
Net and DMX. Since Art-Net is an open standard, you can use any interface which 
conforms to Art-Net version 1 or higher. Some fixtures can also connect to Art-Net 
directly, acting as an Art-Net node. This scenario is discussed later in this section. 

Each node has an address which consists of a net (0–127) and subnet (0–15) value. 
(They should not be confused with the IP address and subnet mask.) In most cases 
you don’t have to deal with these values. However, if your network contains multiple 
Art-Net nodes, make sure each one has a unique net/subnet pair. 

A node can have up to four ports, each of which can input or output one DMX 
universe. Lightkey can control a single Art-Net node with up to four ports, so you can 
use up to four DMX universes for output or input. Your computer must be in the same 
local network and IP subnet as the Art-Net node. 

Art-Net nodes require some configuration which is usually done through an on-
device menu, a software tool provided by the manufacturer, or a web browser 
interface. Configuration includes the node’s IP address, net and subnet, port 
directions (output vs. input), and universe numbers. It’s particularly important to 
select the same universe number(s) on the node as in Lightkey; see Configure 
universes later in this chapter. For more information see the documentation of your 
Art-Net node. 

 

	➤	 Important: Starting with macOS 15 Sequoia, Lightkey requires permission to 
connect to Art-Net interfaces. When you see a request for permission to 
access devices on local networks, click Allow. The message appears only 
once. If you previously clicked Don’t Allow you can still grant permission in 
System Settings > Privacy & Security > Local Network.
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In Lightkey, you configure Art-Net settings in the Art-Net section of Lightkey’s DMX 
Output settings. 

 

In most cases Lightkey can find connected Art-Net nodes automatically. If Lightkey 
can’t find the node it often helps to connect it directly to your computer using an 
Ethernet cable in order to rule out network problems. 

Connect to an Art-Net interface using automatic mode 

	 1	 Open the DMX Output settings (as described earlier in this chapter) and click 
Art-Net on the left. 

	 2	 Select the network interface your Art-Net node is connected to. Your computer 
usually has multiple network interfaces such as Wi-Fi, the built-in Ethernet port 
etc. If you are not sure it may help to look at the Network pane of System 
Settings and check which network interfaces are in use (click Open Network 
Settings…). 

	 	 Each of your computer’s network interfaces has its own IP address. The IP 
address of the selected interface is shown below the network interface. 

	 3	 Select Automatic. 

	 4	 Click Find Nodes. 

	 	 Lightkey finds any Art-Net nodes that are connected to the selected network 
interface and on the same local IP network. 

	 5	 Select your Art-Net interface in the list, if necessary. 

	 6	 Click Apply. 
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If your Art-Net interface has been found, proceed to Configure universes later in this 
chapter. 

In rare cases it may be necessary to use manual mode and specify the exact net and 
subnet values. This applies to older Art-Net nodes which don’t support the ArtPoll 
protocol. 

Connect to an Art-Net interface using manual mode 

	 1	 Select Art-Net on the left. 

	 2	 Select the network interface your Art-Net node is connected to. 

	 3	 Select Manual. 

	 4	 Fill in the following information: 

• Net: The Art-Net net of your interface (0–127). 

• Subnet: The Art-Net subnet of your interface (0–15). 

• Options: These are advanced options which should not be selected in most 
cases. 

• Use broadcast mode: Select this option for older Art-Net interfaces 
which only support Art-Net version 1. When selected, DMX data is 
sent to all devices on the network. This may significantly increase the 
network load and reduce the network’s performance. 

• Use limited broadcast: Select this option to use the limited broadcast 
address (255.255.255.255) rather than the subnet-directed broadcast 
address when broadcasting. Some devices which don’t follow the 
Art-Net specification require this. 

• Use loopback device: Select this if you want to receive Art-Net data 
on the same computer—for example, in a visualizer software. 

	 5	 Click Apply. 

Some fixtures have an RJ45 (Ethernet) port and can receive Art-Net data directly 
from Lightkey. In this case no Art-Net interface is needed. If you want to send Art-
Net data directly to fixtures, consider the following: 

• All fixtures must use the same net and subnet. (They may be on different 
universes.) 
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• In Automatic mode, Lightkey finds all Art-Net nodes on the network, but only 
one can be selected. You can select any fixture in this case. As long as all 
fixtures use the same net and subnet, all will receive data. Alternatively you can 
use Manual mode and enter the net and subnet numbers manually. 

• Some fixtures have special network requirements—for example, they might 
only work with IP addresses in the range 2.x.x.x or 10.x.x.x. Carefully read the 
fixture’s documentation for more information. 

sACN (E1.31) 
Streaming ACN (sACN or ANSI E1.31) is a communication protocol for distributing 
DMX data over a computer network. It was developed by ESTA (Entertainment 
Services and Technology Association, now PLASA). 

You use an Ethernet–DMX interface to translate sACN data to DMX. Some fixtures 
can also connect to sACN directly. This scenario is discussed later in this section. 

 

 

Connect to an sACN interface 

	 1	 Select sACN (E1.31) on the left. 

	➤	 Important: Starting with macOS 15 Sequoia, Lightkey requires permission to 
connect to sACN interfaces. When you see a request for permission to access 
devices on local networks, click Allow. The message appears only once. If you 
previously clicked Don’t Allow you can still grant permission in System 
Settings > Privacy & Security > Local Network.
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	 2	 Select the network interface your sACN interface is connected to. Your 
computer usually has multiple network interfaces such as Wi-Fi, the built-in 
Ethernet port etc. If you are not sure it may help to look at the Network pane of 
System Settings and check which network interfaces are in use (click Open 
Network Settings…). 

	 	 Each of your computer’s network interfaces has its own IP address. The IP 
address of the selected interface is shown below the network interface. 

	 3	 The following options are available but should usually be left unchanged: 

• DSCP value: You can specify a DSCP (differentiated services code point) 
value to tag the IP packets with. This is an advanced feature; in most cases 
you should enter 0. 

• Options: These are advanced options that you will not need in most cases. 

	 4	 Click Apply. 

 

Some fixtures have an RJ45 (Ethernet) port and can receive sACN data directly from 
Lightkey. In this case no sACN interface is needed. In most cases all you need to do is 
ensure the fixtures and Lightkey are in the same local network and subnet. Consult 
the documentation that came with your fixtures for more information. 

ESP Net 
ESP (Enttec Show Protocol) is a DMX-over-Ethernet communication protocol 
developed by Enttec. 

 

	❖	 Note: When using sACN you can assign a priority to each universe. See 
Configure universes later in this chapter.

	➤	 Important: Starting with macOS 15 Sequoia, Lightkey requires permission to 
connect to ESP Net interfaces. When you see a request for permission to 
access devices on local networks, click Allow. The message appears only 
once. If you previously clicked Don’t Allow you can still grant permission in 
System Settings > Privacy & Security > Local Network.

Lightkey User Guide	 254



Set up DMX output through ESP Net 

	 1	 Select ESP Net on the left. 

	 2	 Select the network interface which your ESP Net interface is connected to. Your 
computer usually has multiple network interfaces such as Wi-Fi, the built-in 
Ethernet port etc. If you are not sure it may help to look at the Network pane of 
System Settings and check which network interfaces are in use (click Open 
Network Settings…). 

	 	 Each of your computer’s network interfaces has its own IP address. The IP 
address of the selected interface is shown below the network interface. 

	 3	 Click Apply. 

 

Connect to an external OLA server 
Lightkey outputs DMX through the Open Lighting Architecture (OLA), an open-source 
framework developed by the Open Lighting Project. You can install your own version 
of OLA on your computer, run an OLA server (olad) and redirect Lightkey’s DMX 
output to it. This will open up additional DMX output and input options. 

 

Direct Lightkey’s DMX output to an external OLA server 

	 1	 Make sure your olad instance is running. 

	 2	 In the DMX Output settings, click Advanced Settings… 

If you can’t patch a universe to ESP Net 

If ESP Net does not appear in the list of output methods for a universe, make 
sure the Enttec “Node Management Utility” (NMU) is not running. If it is, quit the 
NME application, then choose Lightkey > Reset DMX Output, and try again.

	▲	 Warning: Running Lightkey with an external OLA server is considered an 
experimental feature. There is no guarantee that it will work because the OLA 
client built into Lightkey may not be compatible with other OLA versions. We 
do not provide technical support for this feature.
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	 3	 Select “Connect to an existing OLA server”. If the server does not use OLA’s 
default port number (9010), enter a different port number in the text field. The 
server must be running on the same computer. 

	 4	 Click OK. 

Lightkey will attempt to patch the OLA server’s universes according to the settings in 
the Fixture Manager. If you want to patch a universe through another way (for 
example, OLA’s web or command-line interface), select “No output” or “No input” in 
the Fixture Manager. In this case Lightkey will still send or receive DMX but not re-
patch the universe. This way you can use output or input methods that are not 
available in Lightkey, such as other OLA plug-ins. 

Configure universes 
To output or input DMX you need to map or “patch” DMX universes to either a USB–
DMX interface or a network protocol. You can use up to four universes for output, 
depending on your Lightkey license. You can use up to two universes for input. 

Add a universe 

	 1	 Click  in the toolbar or choose Lightkey > Manage Fixtures… to open the 
Fixture Manager. 

	 	 At the top of the Fixture Manager is a row of DMX universes and Hue Bridges. 

	 2	 Click 􀅼 (next to the last universe or Hue Bridge). 

	 3	 Click Add DMX Universe. A new universe is added. 

	 4	 Change the universe’s settings as described below. 

Each universe has a unique number. Usually these numbers are simply 1, 2, and so 
on, but you can assign any number to a universe. This can be useful with network 
protocols which carry multiple DMX universes. The universe numbers must match 
the settings on the network interface, as explained in Configure universes on a 
network node below. 

• Art-Net: You can use any universe number from 0 to 15. An Art-Net node 
address consists of the net (0 – 127), subnet (0 – 15), and universe number, 
giving a total of 32,768 values. When you create a project with Art-Net, the 
default universe number is 0, which is also the default of many Art-Net nodes. 
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• sACN: Possible universe numbers range from 1 to 63,999. Note that you cannot 
use 0. 

• ESP Net: You can use any number from 0 to 511. 

Universe numbers are mostly irrelevant for USB–DMX interfaces—their only purpose 
is to define the universes’ order. If an USB interface has multiple output ports, patch 
multiple universes to the interface. For example, if you patch universes 2 and 3 to an 
Enttec DMX USB Pro Mk2 interface, universe 2 is mapped to the first output port and 
universe 3 is mapped to the second output port. 

Configure a universe 

	 1	 Move the pointer over a universe at the top of the channel grid and click the 
arrow on the right. 

	 	  

	 	 A window window appears below the clicked universe: 

	 	  

	 2	 Enter a universe number in the Universe field. Universe numbers are mainly 
relevant for network protocols, as described above. 

	 3	 You can add an optional label to identify the universe. 

	 4	 Select Output to send DMX to the interface or Input to receive DMX for external 
control. 

Click to configure the 
universe
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	 5	 For output universes, the following options are available: 

• Output to: Select a USB–DMX interface or one of the network protocols 
(Art-Net, sACN, or ESP Net interfaces do not appear in the menu). If the 
menu does not show your USB interface, see If your USB–DMX interface 
does not appear below. 

• Refresh rate: The rate at which Lightkey sends new DMX frames to the 
DMX interface. For best results this should equal the output rate of the 
DMX interface. If you have multiple DMX interfaces it is recommended to 
use to the same output rate and refresh rate for all. 

If you’re using an Open DMX interface then the refresh rate always equals 
the rate at which the interface sends DMX frames to the fixtures, so it 
cannot be changed. 

• Priority: This field sets the universe priority for sACN, a value between 0 
and 200. Priorities are used when the receiving sACN node merges 
multiple sources. They don’t apply to other output methods than sACN. 

For input universes, the following option is available: 

• Input from: Select a USB–DMX interface or one of the network protocols. 
If your USB interface is not in the menu, see If your USB–DMX interface 
does not appear below. 

	 6	 Click Done in the toolbar to close the Fixture Manager and apply your changes. 
(Your changes won’t take effect until you close the Fixture Manager.) 

Delete a universe 

	 1	 Move the pointer over a universe at the top of the channel grid and click the 
arrow on the right. 

	 2	 Click 􀍠 and choose Delete Universe from the menu. 

	 3	 If an alert message appears, click Delete (or press Command-Delete). 

 

	▲	 Warning: Deleting a universe removes all fixtures in the universe, and the 
associated data, from the project.
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Configure universes on a network node 
If you output DMX through a network protocol like Art-Net or sACN, you need to 
select the same universe number(s) on the network interface as in Lightkey. This is 
usually done through an on-device menu, a software tool provided by the 
manufacturer, or a web browser interface; consult the documentation of your 
interface for details. 

A special pitfall is that some Art-Net interfaces (e.g. DMXking eDMX) use universe 
numbers which are offset by one from Lightkey’s: 

In this case you must add 1 to Lightkey’s universe numbers when you configure the 
Art-Net node. 

Monitor DMX output 
You can observe the current DMX output or input values for a universe or individual 
fixtures. This is useful to track down problems when fixtures don’t respond or deviate 
from what’s shown in the Preview. 

View the DMX output or input for a universe 

	 1	 Choose Window > DMX Monitor (or press Command-Shift-Option-O). The DMX 
Monitor window appears. 

	 2	 Select a DMX universe from the pop-up menu at the top. 

	 3	 Rest the pointer over one of the DMX channels. A help tag appears showing the 
corresponding fixture and property (applies to output universes only). 

View the DMX output for one or more fixtures 

	 1	 Select one or more fixtures in the Preview. 

	 2	 Choose Fixture > Show DMX Output (or press Command-Shift-Option-O). 

Lightkey universe number Device universe number

0 1

1 2

⋮ ⋮
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If you keep the DMX Monitor window open and select different fixtures, the output 
display updates accordingly. 
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Chapter 15   
Smart lights 

 

Smart lights can be a simple and cost-effective 
complement to DMX lighting in many venues. 
Lightkey lets you add Philips Hue lights to your 
projects and control them alongside your DMX 
fixtures. 

Lightkey can control bulbs, LED strips, plugs, and other types of lights of the Philips 
Hue brand. Smart lights from other manufacturers which connect to a Philips Hue 
Bridge will often work as well, but we cannot guarantee compatibility with them. 

To control Philips Hue lights from Lightkey you need: 

• A Lightkey license which includes smart lights. (Without the smart lights option 
you can control up to five Philips Hue lights.) 

• A Hue Bridge version 2 (square shaped) or Hue Bridge Pro. Lightkey cannot 
control Hue lights through Bluetooth. 

When you add smart lights to Lightkey it’s still possible to control them by other 
means such as the Hue app or smart wall switches. However, changes from other 
controllers will not show in Lightkey’s Preview. 

 

	❖	 Note: Lightkey doesn’t replace the official Hue app for iOS. You still need the 
Hue app to set up your Bridge and for tasks like adding lights, managing 
zones, etc.
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Smart lights vs. DMX 
At the center of a Hue system is the Hue Bridge, the link between your Mac and the 
lights. An Ethernet cable connects it to the Mac or a router. The Hue Bridge receives 
commands from Lightkey and transmits them wirelessly to lights and smart plugs. 
Each light repeats the commands and passes them on to others. This creates a 
wireless network which consumes very little power, but both the number of 
commands sent and the range of transmission are limited. 

 

There are some fundamental differences between DMX and smart lights which you 
need to be aware of. 

• Smart lights take (much) longer to respond. The low-power wireless network 
that connects lights to the Hue Bridge has a significantly higher latency than 
DMX, so it takes longer for smart lights to turn on or off and change their color. 
If you turn on or change multiple lights, each of them may respond with a 
different delay (called “popcorn effect”). 

• Smart lights can handle a limited amount of commands. The Hue network can 
transmit a limited number of messages per second. If you change the lights too 
fast they may take longer to respond or may not respond at all. The exact timing 
depends on the number and grouping of your lights, other apps in the network, 
additional traffic on the network such as software downloads, the distance of 
the lights from the Hue Bridge and from each other, and other factors. 

Network router or switch

Cat 5 (Ethernet)
cable

Hue Bridge Low-power 
wireless network

Ethernet cable or 
Wi-Fi connection

Smart lights 
and plugs

in out
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When integrating smart lights into your show, keep the following guidelines in mind: 

• Don’t use effects and sequences with smart lights. Effects and fast sequences 
often cause a continuous stream of messages which can easily overload the 
Hue network. In particular, do not use beat-controlled effects or sequences; 
this will not work due to the higher latency. 

• Smart lights handle fades internally. Unlike DMX fixtures, smart lights perform 
transitions internally. They follow the cue and sequence fade times set in 
Lightkey, but fade curves have no effect and fades are not shown in the Preview. 

• Divide smart lights into rooms and zones. Lightkey can reduce the messages 
sent when identical properties are applied to an entire room or zone, thus 
avoiding the “popcorn effect”. Use the Hue iOS app to combine lights which are 
often used together in a room or zone. (Lightkey doesn’t show zones but still 
uses them for optimizations.) This applies to groups of five or more lights. 

Manage Hue Bridges 
Before you can add your Hue Bridge to Lightkey, make sure it’s on the same local 
network as your Mac (that is, both connect to the same router). You should also verify 
that the Hue Bridge is using the latest firmware version. To do this, turn on 
automatic firmware updates in the Hue iOS app. 

 

Add a Hue Bridge 
You can add multiple Hue Bridges to a project and control their lights at the same 
time (for example, if the lights are in different rooms). 

	➤	 Important: Starting with macOS 15 Sequoia, Lightkey requires permission to 
connect to Hue Bridges. When you see a request for permission to access 
devices on local networks, click Allow. The message appears only once. If you 
previously clicked Don’t Allow you can still grant permission in System 
Settings > Privacy & Security > Local Network.
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Add a Hue Bridge to a project 

	 1	 Click  in the toolbar or choose Lightkey > Manage Fixtures… to open the 
Fixture Manager. 

	 	 At the top of the Fixture Manager is a row of DMX universes and Hue Bridges. 

	 2	 Click 􀅼 (next to the last universe or Hue Bridge). 

	 3	 Click Add Hue Bridge… 

	 4	 Wait for your Hue Bridge to appear. 

	 5	 Press the button on the front side of your Hue Bridge. 

	 	 This permanently links Lightkey to the Hue Bridge. 

Once a Hue Bridge has been added, it appears in the bar at the top of the Fixture 
Manager next to your DMX universes. Click the Hue Bridge to see its rooms and 
fixtures. 

View Hue Bridge details 

‣ Move the pointer over a Hue Bridge and click the arrow on the right. 

	 	 A window with details about the Hue Bridge appears. 

If you made changes in the Hue iOS app, such as adding a light, while the Fixture 
Manager is open, you can update the information in the Fixture Manager to reflect 
the changes. 

Update Hue Bridge information 

‣ Choose Lightkey > Reset Hue Output. 

Relink Lightkey to a Hue Bridge 
If Lightkey cannot connect to a Hue Bridge you previously added to a project, you may 
see an error message which says “Lightkey is no longer linked to the Hue Bridge.” 
This can happen after a factory reset of the Hue Bridge or if Lightkey has been 
unlinked through the Hue web interface. 

Relink Lightkey to a Hue Bridge 

	 1	 Choose Lightkey > Manage Fixtures… 
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	 	 If Lightkey still cannot connect to the Hue Bridge another error message 
appears. 

	 2	 Click Relink… below the error message. 

	 3	 Press the button on the front side of your Hue Bridge. 

Delete a Hue Bridge 
When you delete a Hue Bridge, the fixtures and the associated data are removed 
from the project. 

Remove a Hue Bridge 

	 1	 Move the pointer over a Hue Bridge and click the arrow on the right. 

	 	 A window with details about the Hue Bridge appears. 

	 2	 Click 􀍠 and choose Delete Hue Bridge… from the menu. 

	 3	 In the dialog that appears, click Delete. 

Manage smart lights 
The primary place for managing your smart lights remains the Hue iOS app. This is 
where you add lights to a Hue Bridge, set up rooms and zones, and move lights 
between rooms and zones, for example. 

You can view your smart lights in Lightkey’s Fixture Manager. Click a Hue Bridge in 
the bar at the top to see the associated rooms and fixtures in the area below. 

View and edit Hue fixture information 
Lightkey may display a status label below the name of a Hue fixture. The label can be 
one of the following: 

You can view and edit details about a Hue fixture such as its short name. Changing 
these details will not affect your presets, sequences, and cues. 

Unreachable The Hue Bridge is unable to connect to the light. Make sure the light is 
connected to power and try placing it closer to the Hue Bridge.

Removed The light has been removed from the Hue Bridge.
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View and edit information about a fixture 

	 1	 Do one of the following: 

‣ Double-click a fixture. 

‣ Control-click a fixture and choose Get Info from the shortcut menu. 

	 2	 The following information is shown below the fixture: 

	 	  

Reveal one or more fixtures in the Preview 

	 1	 Select one or more fixtures. (Hold down the Command or Shift key as you click 
to select multiple fixtures.) 

	 2	 Control-click one of the fixtures and choose Show in Preview from the shortcut 
menu. 

Identify a fixture 

‣ Control-click a fixture and choose Identify from the shortcut menu. The light 
will briefly change its brightness. 

Add a Hue fixture 
To add a new light, you first use the Hue iOS app to add it to your Hue Bridge. Then 
add a new fixture in Lightkey. 

Add a Hue fixture 

	 1	 Add the new light to your Hue Bridge in the Hue app. 

	 2	 In Lightkey, click  in the toolbar or choose Lightkey > Manage Fixtures… 

	 3	 Click the Hue Bridge in the bar at the top to select it. 

The short name is 
used to identify the 

fixture in the Preview

Name of the light
in the Hue app

The type affects how a 
fixture appears in the 
Preview. It is also used 
by the Hue app

Number of instances 
shown in Preview
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	 	 The new fixture appears in the area below and is marked with a star. 

	 4	 Click Done. 

Replace a Hue fixture 
If you replace a Hue fixture with another, it will appear as a new fixture in Lightkey. 
You can tell Lightkey to adopt the previous fixture’s data so presets and cues 
continue to work as before. You can also use this approach when you add a new 
fixture and want it to adopt the behavior of the existing fixture. 

Replace a Hue fixture 

	 1	 Add the new light to your Hue Bridge using the Hue app. 

	 2	 In Lightkey, click  in the toolbar or choose Lightkey > Manage Fixtures… 

	 3	 Click the Hue Bridge in the bar at the top to select it. 

	 	 The area below shows the existing lights and the new light which is marked 
with a star. 

	 4	 Control-click the new light and choose Adopt Data From… from the shortcut 
menu. 

	 5	 In the dialog that appears, select the original fixture and then click OK. 

	 6	 Click Done. 

Move fixtures to a different room 
You can move fixtures to a different room in Lightkey. The change is mirrored back to 
your Hue Bridge. 

	 1	 Select one or more Hue fixtures. (Hold down the Command or Shift key as you 
click to select multiple fixtures.) The fixtures must be in the same room. 

	 2	 Control-click one of the fixtures and choose Move To from the menu, then 
choose a room. 

Move a fixture between Hue Bridges 
When you move a Hue fixture from one Hue Bridge to another, Lightkey can preserve 
the data for the fixture so presets and cues continue to work as before. You can also 
use this process when you replace a Hue Bridge with a new device. 
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Move a fixture between Hue Bridges 

	 1	 Use the Hue app to delete the light from the original Hue Bridge. 

	 2	 Switch to the new Hue Bridge in the Settings area of the Hue app. 

	 3	 Add the light to the new Hue Bridge. 

	 4	 In Lightkey, click  in the toolbar or choose Lightkey > Manage Fixtures… 

	 	 When you select the original Hue Bridge, the fixture still appears but is marked 
as “Removed”. 

	 5	 Click the new Hue Bridge in the bar at the top to select it. (If you haven’t added 
the Hue Bridge to the project yet you can add it now.) 

	 	 The area below shows the new light which is marked with a star, indicating it’s 
a new fixture. 

	 6	 Control-click the new light and choose Adopt Data From… from the shortcut 
menu. 

	 7	 In the dialog that appears, select the original fixture and then click OK. 

	 8	 Click Done. 

Disable fixtures 
If a fixture is temporarily disconnected, broken, or simply not in use, you can disable 
it in Lightkey. A disabled fixture shows no light beam, can’t be selected in the 
Preview, and Lightkey doesn’t send commands to it. 

Disabled fixtures do not count towards the maximum number of smart lights 
permitted by your Lightkey license. If you have more smart lights than are enabled by 
your license you can disable fixtures to decide which ones should be controlled by 
Lightkey. 

Disable or enable a fixture 

‣ Control-click a fixture and choose Disable or Enable from the shortcut menu. 

 

	❖	 Note: You can also disable or enable fixtures in the Preview. See Disable 
fixtures in chapter 7, Preview.
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Delete fixtures 
Lights removed from a Hue Bridge are not automatically deleted from your Lightkey 
project. Perform the following steps to remove the fixtures and the associated data 
from your Lightkey project. 

Delete a Hue fixture 

	 1	 Use the Hue app to remove the light from the Bridge. 

	 2	 In Lightkey, click  in the toolbar or choose Lightkey > Manage Fixtures… 

	 3	 Click the Hue Bridge in the bar at the top to select it. 

	 	 The area below shows the lights connected to the Hue Bridge. The removed 
light still appears and is marked as “Removed”. 

	 4	 Select one or more fixtures. (Hold down the Command or Shift key as you click 
to select multiple fixtures.) 

	 5	 Control-click one of the fixtures and select Delete… from the shortcut menu. 

	 6	 In the dialog that appears, click Delete. 

Manage rooms 
You can add, rename, and delete rooms in Lightkey. These changes are mirrored 
back to your Hue Bridge. 

Add a room 

	 1	 Control-click in the blank space where lights and rooms appear and choose 
New Room… from the shortcut menu. 

	 2	 In the dialog that appears, enter a name for the room, then click Add. 

Rename a room 

	 1	 Move the pointer over the name of a room. 

	 2	 Click 􀍡 next to the room’s name and choose Rename… from the menu. 

	 3	 In the dialog that appears, enter a name for the room, then click Rename. 

Delete a room 

	 1	 Move the pointer over the name of a room. 
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	 2	 Click 􀍡 next to the room’s name and choose Delete from the menu. 
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Chapter 16   
External control 

 

Lightkey has extensive support for integrating 
with hardware and software through DMX, MIDI, 
OSC, custom keyboard shortcuts, and the 
system-wide shortcuts feature. 

Hardware controllers like DMX consoles and MIDI controllers provide an intuitive and 
ergonomic way to control your show during live performances. Lightkey lets you map 
their faders, buttons, and wheels to numerous software functions like activating cues 
or adjusting modifiers. It also sends feedback to connected MIDI controllers so their 
LEDs and motorized faders always match the state of the software. 

Beyond that you can control Lightkey from any other software that sends DMX, MIDI, 
or OSC messages. The external control system provides access to all important 
application features, down to individual fixture properties. Lightkey can also send 
MIDI to other applications. 

Other ways to control Lightkey include the macOS shortcuts feature which lets you 
build custom workflows and automations. Finally, Live Triggers is a unique feature to 
trigger cues directly from Ableton Live’s timeline, enabling you to create fully 
automated light shows that run in sync to the music. 

In more detail, Lightkey can receive input through the following technologies: 

• DMX-In: Many USB–DMX interfaces and Ethernet–DMX interfaces have input 
ports to feed DMX into your computer. This lets you control Lightkey from DMX 
consoles or other hard- or software which outputs DMX. 
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• MIDI: MIDI (Musical Instrument Digital Interface) is an established technology 
for sending real-time messages between a wide variety of electronic music 
devices, control surfaces, and software. You can control Lightkey from any 
hardware or software that can send MIDI data. 

Many MIDI controllers connect to your computer through the USB port. If a MIDI 
device has MIDI-In and Out ports instead, you can connect it through a MIDI–
USB interface. 

• Keyboard: In addition to the built-in keyboard shortcuts, Lightkey lets you 
define your own shortcuts. For example, you can assign keys to the cues in the 
Live view. You can use all letters, numbers, punctuation characters and the 
function keys (F1, F2, …) in combination with the Shift, Control, and Option 
modifier keys. 

• OSC: Open Sound Control is a communication protocol for sending short 
messages over a computer network. Many Mac and iOS applications can send 
OSC, including QLab, TouchOSC, Lemur, and Vezér. Each OSC-controllable 
element in Lightkey has an address, so it’s not necessary to first create trigger–
action bindings. See Open Sound Control (OSC) later in this chapter for more 
information. 

• Shortcuts: Shortcuts are a system-wide automation feature in macOS which 
also integrates with Siri. You can create and edit shortcuts in the Shortcuts app. 
See macOS shortcuts later in this chapter for details. 

Lightkey’s external control system is highly configurable, allowing you to custom-
tailor it to your specific setup and requirements. You can create multiple external 
control configurations, which is useful for different environments or users. 

External control settings are stored as part of your project, because actions like 
activating a cue are specific to the project. You can export and import configurations 
to transfer them between projects. 

Quickly assign triggers 
Lightkey provides a quick and convenient way to assign DMX-In, MIDI, and keyboard 
triggers to many elements in the user interface. For example, this works for cues in 
the Live view and many buttons and sliders in the Design view. 

A more comprehensive way to create and edit triggers and actions is through the 
External Control window, which is described in the following section. 

Lightkey User Guide	 272



Quickly assign a trigger to an element 

	 1	 Control-click an element in the user interface (e.g. a button or slider) and 
choose External Control > Add Trigger… from the shortcut menu. This 
command is only available for elements which support external control. 

	 2	 Do one of the following: 

‣ Operate a fader on a connected DMX console. 

‣ Operate a fader, button, or wheel on a connected MIDI controller. 

‣ Press a key or key combination on the keyboard. 

Triggers assigned though this method also appear in the External Control window, 
where you find additional options. 

Quickly replace a trigger 

	 1	 Control-click an element in the user interface and choose External Control > 
Replace Trigger… from the shortcut menu. 

	 2	 Operate a new trigger. 

Quickly remove a trigger 

‣ Control-click an element in the user interface and choose External Control > 
Remove Trigger from the shortcut menu. 

 

If you have a MIDI controller with feedback LEDs or motorized faders, Lightkey can 
show you which hardware control a user interface element is bound to. 

See which hardware control a user interface element is bound to 

‣ Control-click an element in the user interface and choose External Control, 
then move the pointer over a trigger in the menu. The corresponding LED on a 
MIDI controller will flash, or the corresponding fader will move. 

	❖	 Note: The Replace Trigger… and Remove Trigger commands are only 
available when an element has exactly one trigger. If it has more then you 
must replace or delete the trigger in the External Control window.
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View a trigger in the External Control window 

‣ Control-click an element in the user interface and choose External Control, 
then select a trigger from the menu. 

The External Control window 
The central place for configuring Lightkey’s external control system is the External 
Control window. 

Open the External Control window 

‣ Choose Window > External Control (or press Command-E). 

The External Control window is divided into three categories which appear at the top: 
DMX-In, MIDI, and Keyboard. Below is a pop-up menu where you can select and edit 
configurations for the current category. The main part of the window shows a list of 
the trigger–action bindings for the selected configuration. 

 

Select and manage configurations 
in the current category

Switch between 
categories

Bindings in the 
selected category

Edit trigger settings for 
the selected binding

Edit action settings for 
the selected binding
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Configurations 
For each category of external control devices (DMX-In, MIDI, Keyboard) you can save 
multiple configurations of external control bindings. This is useful if your control 
hardware changes or Lightkey is used in different scenarios or by several people. 
Only one configuration per category can be active at a time. Configurations can be 
exported to a file and imported again, which allows you to move them between 
projects or share them with others. 

The Configuration pop-up menu shows the control configurations for the selected 
category. The selected configuration is the one currently in effect. 

Manage configurations 

	 1	 Choose Manage Configurations… from the Configurations pop-up menu. 

	 	 A window with a list of configurations appears. 

	 2	 Change the configurations as appropriate: 

‣ To add a new, empty configuration: Click 􀅼, then enter a name for the 
new configuration and press Return. 

‣ To reorder configurations: Drag the rows in the list up or down. 

‣ To rename a configuration: Select the configuration, then click 􀍠 and and 
choose Rename from the menu. Alternatively, select the configuration and 
click its name. 

‣ To duplicate a configuration: Select the configuration, then click 􀍠 and 
and choose Duplicate from the menu. Enter a name for the new 
configuration and press Return. 

‣ To export a configuration to a file: Select the configuration, then click 􀍠 
and and choose Export… from the menu. In the dialog that appears, enter 
a filename, choose a location, and click Save. 

‣ To import a configuration file: Click 􀍠 and Choose Import… from the 
menu. In the dialog that appears, navigate to the configuration file and 
click Import. If a previous version of the configuration already exists in the 
project, Lightkey will display a warning. You can either replace the existing 
configuration or keep both. 

‣ To delete a configuration: Select the configuration and click 􀅽 or press 
the Delete key. 

Lightkey User Guide	 275



	 3	 Click Done. 

 

MIDI inputs 
When the MIDI category is selected, a pop-up menu labelled Input appears below the 
Configuration menu which lets you choose between the connected MIDI inputs. 
Lightkey normally associates bindings with the input from which the MIDI message 
was received, and sends feedback only to the corresponding output. This allows 
simultaneous control from multiple controllers, even if they send on the same MIDI 
channel. 

 

The bindings list shows the bindings for the selected input. Note that Lightkey 
responds to MIDI messages from all inputs, not just the selected one. 

The input named Lightkey Input can be used to receive MIDI from other applications. 
It appears as destination in other MIDI-capable apps, eliminating the need to use a 
virtual MIDI bus (like the IAC Driver) to send MIDI between apps. Feedback for 
bindings in Lightkey Input is sent to the Lightkey Output port. 

It’s also possible to create bindings which are not associated with a MIDI input. Those 
bindings respond to messages from any input and send feedback to all outputs. They 
are shown when you select Any in the Input pop-up menu. 

If necessary you can use copy and paste to move bindings between inputs. 

	❖	 Note: The configuration named Live Triggers is a special configuration for 
communicating with Ableton Live. It is created automatically and can’t be 
edited. You cannot delete this configuration unless you disable Live Triggers 
in the Settings window. For more information see Live Triggers later in this 
chapter.

	❖	 Note: Lightkey relies on the input name to distinguish between MIDI inputs. If 
you have two or more MIDI controllers of the same type, it is therefore 
important that they have unique names. You can change the names in the app 
Audio MIDI Setup (in Applications > Utilities).
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Associate MIDI bindings with a different MIDI input 

	 1	 Select one or more bindings. 

	 2	 Choose Edit > Cut. 

	 3	 In the Input pop-up menu, select the input you want to associate the bindings to. 

	 4	 Choose Edit > Paste. 

You can select which outputs and inputs are used for receiving and sending MIDI. 
This is described in MIDI routing later in this chapter. 

Bindings 
The central part of the External Control window shows a list of trigger–action pairs 
called bindings. A trigger describes an operation on an external control device, like 
pushing a button on a MIDI controller or operating a fader on a DMX console. An 
action describes how Lightkey should respond to the trigger. For example, an action 
may activate a particular cue or change the gobo rotation speed. 

There are three kinds of triggers: 

• Button: Buttons send a single message when pressed, and possibly another 
when depressed. They’re used for actions like tapping the beat or activating a 
cue. 

• Fader/knob: Faders or knobs represent a value within a finite range. Use them 
for actions like controlling the Master Dimmer or crossfading between cues. 

• Wheel: Wheels are infinite controls like jogwheels or rotary knobs. They can 
increase or decrease a continuous value like the Master Dimmer. Wheel 
triggers are only available for MIDI bindings. 

Keyboard triggers are always button-type triggers. 

The quickest way to create bindings is to operate a trigger and have Lightkey 
“capture” it. 

 

	❖	 Note: Before you can create DMX-In bindings, you must set up at least one 
universe for DMX input. This connects the universe to a DMX interface’s input 
port. See Configure universes in chapter 14, DMX output and input for more 
information.
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Create a binding by capturing a trigger 

	 1	 Open the External Control window and select a category (DMX-In, MIDI, or 
Keyboard). 

	 2	 For MIDI triggers, select the input to which the message will be sent, or select 
Any. 

	 3	 Operate a trigger: 

‣ DMX-In: Operate a fader or button on a DMX console. Lightkey creates a 
matching binding and automatically detects the trigger type (button or 
fader). 

‣ MIDI: Press a button, move a fader, or turn a wheel on a MIDI controller. 
Lightkey creates a matching binding and automatically detects the trigger 
type (button or fader). 

‣ Keyboard: Press a key on the keyboard. Lightkey creates a button-type 
binding for that key. You can use all letters, numbers, punctuation 
characters and the function keys (F1, F2, …) in combination with the Shift, 
Control, and Option modifier keys. (The Command key is reserved for 
Lightkey’s standard keyboard shortcuts.) 

	 	 A new binding is added to the list and selected. (If the trigger was already 
assigned to an existing binding, that binding is selected instead.) 

 

Lightkey automatically detects if a control sends a single message or continuous 
values, and sets the trigger type to either button or fader. However, it cannot detect 
wheels, so if the control is an infinite wheel then you need to change the trigger type 
after creating the binding. 

Manually create a binding 

Do one of the following: 

‣ Click 􀅼 in the toolbar. 

‣ Control-click in the bindings list and choose New Binding from the menu. 

	❖	 Note: If no binding is created when you operate a trigger, click 􀍠 (or 􀍡) in 
the toolbar and make sure Automatically Create Bindings is selected.
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After creating a binding, configure its action in the area below the bindings list (see 
Actions below). Note that some actions are only available for button triggers, others 
only for fader or wheel triggers. 

Find the binding associated with a control 

‣ Operate the control. Lightkey selects the corresponding binding in the list. 

 

You can use text search to filter the list of bindings. Only bindings whose trigger or 
action contains your search text will be shown. 

Search the visible bindings 

‣ Enter one or more words in the search field in the toolbar. 

Because only one Live page can be selected at any time, bindings that apply to cues 
or frames on other pages are ignored. The actions for those bindings appear gray in 
the list. You can also choose to hide the bindings entirely. 

Hide bindings for inactive Live pages 

‣ Click 􀍠 (or 􀍡) in the toolbar and choose one of the following options: 

• All: Shows all bindings for the current configuration and input. 

• Hide Inactive Live Pages: Hides bindings for objects on inactive Live 
pages. 

Duplicate a binding 

	 1	 Select one or more bindings. 

	 2	 Do one of the following: 

‣ Choose Edit > Duplicate or press Command-Shift-D. 

‣ Control-click a binding and choose Duplicate 

	❖	 Note: If the binding is not selected, click 􀍠 (or 􀍡) in the toolbar and make 
sure Automatically Select Bindings is selected.
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You can use cut, copy and paste to move bindings between different configurations or 
MIDI inputs. You can only move bindings within the same category (DMX-In, MIDI, or 
Keyboard). 

Move bindings between configurations or MIDI inputs 

	 1	 Select one or more bindings. 

	 2	 Choose Edit > Cut. 

	 3	 Select a different configuration or input. 

	 4	 Choose Edit > Paste. 

Delete bindings 

Do one of the following: 

‣ Select one or more bindings, then press the Delete key. 

‣ Control-click the binding and choose Delete from the menu. 

If you accidentally deleted a binding, choose Edit > Undo Delete Binding. 

Sometimes Lightkey inadvertently captures a trigger and creates a binding for it. 
Those bindings often have no actions or actions with missing parameters. There’s an 
easy way to clean them up. 

Delete bindings with incomplete actions 

	 1	 Click 􀍠 (or 􀍡) in the toolbar and choose Select Incomplete Bindings. 

	 2	 Press the Delete key. 

Triggers 
Most of the time Lightkey will simply “capture” triggers when you operate them (e.g. 
by pressing a button on a MIDI controller) and create a matching binding. You can 
replace the trigger of an existing binding in the same way. 

Change the trigger of an existing binding 

	 1	 Do one of the following: 

‣ Control-click the binding and choose Capture Trigger… from the menu. 

‣ Double-click the trigger in the bindings list. 
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	 2	 Operate the new trigger: 

‣ DMX-In: Operate a fader or button on a DMX console. 

‣ MIDI: Press a button, move a fader, or turn a wheel on a MIDI controller. 

‣ Keyboard: Press a key on the keyboard. 

You can also edit the trigger for the selected binding (or bindings) in the area below 
the bindings list. The left side shows the trigger details, which depend on the 
selected category. 

DMX-In triggers 

• Trigger: The type of trigger, either button or fader/knob. 

• Universe: The DMX universe which Lightkey should observe. Only input 
universes can be selected. See Configure universes in chapter 14, DMX output 
and input on how to configure universes for DMX input. 

• Channel: The DMX channel to observe in the universe (1–512). 

• Value (button-type triggers only): The channel value which triggers the action. 
Lightkey performs the action whenever the channel assumes this value. 

• Range (fader-type triggers only): The range of DMX values used by the trigger, 
often 0 – 255. For example, if the range is 128 – 255 and the action controls a 
fixture’s intensity, then a DMX value of 128 means 0% intensity and a DMX value 
of 255 means 100% intensity. 

• Inverted (fader-type triggers only): Reverses the fader direction. 

MIDI triggers 

• Trigger: The type of trigger, either button, fader/knob, or wheel. 

• Command: The MIDI command which triggers the action. Depending on the 
trigger type, the available commands are Note On/Off, Control Change, 
Program Change, and Pitch Wheel. The option No Command is used for 
bindings which send MIDI to another application; see Send MIDI to other 
applications later in this chapter for details. 

• Channel: The MIDI channel through which the message is sent (1–15). (Note: 
MIDI channel 16 is reserved for use by Live Triggers.) 
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• Note (only Note On/Off commands): The MIDI note to trigger the action. Notes 
may be displayed by their name, e.g. C#0, or a decimal number. You can enter 
them in either way. See MIDI notes later in this chapter. 

• Control (only Control Change commands): A control number identifying a 
physical control on your MIDI controller (0–127). 

• Value (only Control Change commands): The control value which triggers the 
action (0–127). 

• Program (only Program Change commands): A MIDI program number which 
triggers the action (0–127). 

• Sensitivity (only wheel-type triggers): Determines how quickly the value 
changes. 

• On/off (only button-type triggers): Select this for stateful buttons which send a 
single message when operated (for example, a CC message or alternating Note 
On/Off messages). In contrast, regular buttons send two messages—one when 
pressed (e.g. Note On or CC 127) and another (e.g. Note Off or CC 0) when 
released. 

• 14-bit (only fader-type triggers, Control Change commands): Select this if the 
fader sends 14-bit (high-resolution) values. 

• Inverted (only fader- and wheel-type triggers): Reverses the fader or wheel 
direction. 

• Shift: The trigger applies only when the MIDI controller’s Shift button is held 
down (see MIDI Shift button below). 

• Feedback: The kind of feedback messages sent back to the MIDI controller, e.g. 
to control LEDs or motorized faders. 

• None: Do not send feedback to the MIDI controller. 

• Default: The feedback is determined by the connected device. This is the 
appropriate option in most situations where feedback is being sent to a 
hardware controller. 

The remaining feedback options let you customize the exact MIDI messages 
sent when the trigger becomes active or inactive. Custom feedback is only 
available for button-type triggers. It can us used to change the LED colors on 
MIDI controllers or control other software programs from Lightkey. 
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• Note On/Off: Send a Note On message when the trigger becomes active 
and a Note Off message when it becomes inactive. You can choose the 
note and velocity parameters of the Note messages. 

• Note On: Send a Note On message when the trigger becomes active or 
inactive. You can choose the note and velocity parameters of the Note On 
messages. 

• Control Change: Send a Control Change message when the trigger state 
changes. You can choose the control and value parameters of each 
message. 

• Program Change: Send a Program Change message when the trigger 
state changes. You can choose the program field of each message. 

• SysEx: Send a System Exclusive message of arbitrary length when the 
trigger state changes. You can enter the contents of the messages in 
hexadecimal form. Each byte must be in the range 0–127 (00–7F). 

	 Click Send to send the MIDI message for testing. 

Keyboard triggers 

There are no trigger options for keyboard triggers. To change a keyboard trigger, 
capture a different trigger as described earlier in this section. 

Actions 
The area in the lower-right of the External Control window is where you configure the 
action for the selected binding (or bindings). The following table shows the different 
kinds of actions and their parameters. Note that the available actions depend on the 
trigger type. 
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Action Trigger type What it does Feedback

Activate/
Deactivate 
Preset

Button Activates or deactivates a preset. The Behavior 
options are described below this table.

􀆅

Deactivate All 
Presets

Button Deactivates all active presets. —

Start/Stop 
Sequence

Button Starts or stops a sequence. The Behavior 
options are described below this table.

􀆅

Stop all 
Sequences

Button Stops all running sequences. —

Activate/
Deactivate Cue

Button Activates or deactivates a cue. The Behavior 
options are described below this table.

􀆅

Previous/Next 
Cue in Fame

Button Activates the previous or next cue in a frame. —

Cuelist: Start/
Stop

Button Starts or stops playback in the a cuelist. 􀆅

Cuelist: Pause/
Resume

Button Pauses or resumes playback in a cuelist. 􀆅

Cuelist: Next 
Cue

Button Activates the next cue in a cuelist. 􀆅

Cuelist: 
Previous Cue

Button Activates the previous cue in a cuelist. —

Cuelist: Xfade Fader, Wheel Crossfades to the next cue in a cuelist, as by 
dragging the Xfade slider.

—

Change Cue 
Intensity

Fader, Wheel Changes a cue’s intensity, as with a fader in 
the Live view.

􀆅

Change Cue 
Modifier

Fader, Wheel Changes the value of a cue modifier. 

If you select “All cues” then the action will 
affect all cues on the current live page with 
this modifier.

􀆅

Reset Cue 
Modifier

Button Sets the value of a cue modifier to either its 
default or neutral value. 

If you select “All cues” then the action will 
affect all cues on the current live page with 
this modifier.

􀆅

Change Frame 
Modifier

Fader, Wheel Changes the value of a frame modifier. 􀆅

Reset Frame 
Modifier

Button Sets the value of a frame modifier to either its 
default or neutral value.

􀆅
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Deactivate Cues 
in Frame

Button Deactivates all cues in a frame. —

Deactivate All 
Cues

Button Deactivates all active cues. —

Select Live Page Button Selects a Live view page. You can choose to 
select: 

• The previous or next page (in the order 
in which they appear in the menu); 

• A particular page.

􀆅

Select Fixtures Button Selects one or more fixtures. You can choose 
to select: 

• All or no fixtures; 

• The previous or next fixture (by short 
name); 

• A particular fixture (if the fixture is in a 
group you can optionally select the 
entire group); 

• All fixtures with a particular profile.

—

Change Fixture 
Property

Button/
Fader, Wheel

Changes a fixture property, as in the Design 
view or the HUDs. The available options 
depend on the selected property. You can 
choose if the changes should affect the 
selected fixture(s) or a particular fixture or set 
of fixtures.

For most 
fixture 
proper- 
ties

Clear Properties Button Clears the overridden fixture properties. —

Blind Mode Button Enables or disables blind mode. 􀆅

Freeze Output Button Freezes or unfreezes the output. 􀆅

Master Dimmer Fader, Wheel Controls the Master Dimmer, as by dragging 
the Master slider in the Live view.

􀆅

Tap Beat Button Sets the beat grid by tapping four times, as 
with the beat controls in the Live view.

􀆅

Sync Beat Button Synchronizes the time of the next beat, keep 
the tempo.

􀆅

Sync Downbeat Button Synchronizes the time of the first beat, keep 
the tempo.

􀆅

Set Beat Fader, Wheel Adjusts the tempo (beats per minute) with a 
fader. You can choose the values which 
correspond to the minimum and maximum 
fader positions.

􀆅

Action Trigger type What it does Feedback
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Actions for activating a presets, sequences, and cues let you specify their exact 
behavior: 

• Toggle: Toggle the “active” state whenever the trigger’s state changes to on—
for example, when a button on a MIDI controller or a key on the keyboard is 
pressed. 

• Flash: Activate the object when the trigger’s state is on, for example, when a 
button or key is pressed. Deactivate the object when the trigger’s state is off, for 
example, when a button or key is released. 

• Activate: Activate the object when the trigger’s state is on. 

• Deactivate: Deactivate the object when the trigger’s state is on. 

Choose Set as Default to use the selected behavior for all new bindings you create in 
the External Control window. 

After configuring an action, you can test it to see its effect. 

Test an action 

‣ To test an action with a button trigger, click Run. 

‣ To test an action with a fader or wheel trigger, drag the Test slider. 

 

Halve Beat Button Halves the current tempo (beats per minute). —

Double Beat Button Doubles the current tempo (beats per minute). —

Select 
Configuration

Button Selects an external control configuration. You 
can choose to select: 

• The previous or next configuration (in 
the order in which they appear in the 
menu); 

• A particular configuration.

􀆅

Shift Button Designates the trigger as the Shift button. See 
MIDI Shift button below.

—

Action Trigger type What it does Feedback

	★	 Tip: If a message sent to Lightkey doesn’t have the intended effect, you can 
use the External Control Log to track down the problem. See External Control 
Log later in this chapter.
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MIDI Shift button 
Some MIDI controllers have a Shift button which works similarly to the Shift key on a 
keyboard: When you hold down Shift and operate another button, fader, or wheel, the 
other control performs a different action. Even if your controller has no button with a 
Shift label, you can designate any button as the Shift button. 

Before you can create triggers with Shift you need to tell Lightkey which button is the 
Shift button. 

Designate a button as the Shift button 

	 1	 In the External Control window, click MIDI. 

	 2	 In the Input pop-up menu, select the input which corresponds to your MIDI 
controller. 

	 3	 Press the Shift button on your MIDI controller. 

	 	 A new binding appears whose trigger matches the pressed button. 

	 4	 Choose Shift as the binding’s action. 

MIDI notes 
You can choose whether Lightkey should display MIDI note values as musical notes 
(C-2 through G8, middle C is C3) or decimal numbers (0 through 127). 

Change how MIDI notes are displayed 

	 1	 Choose Lightkey > Settings… and then click External Control. 

	 2	 Select an option next to “Show MIDI notes as”. 

In fields where you enter MIDI notes (in the External Control window) you can always 
use both notations. 

Live Triggers 
Ableton Live is a music sequencer and digital audio workstation (DAW) software used 
by many musicians and DJs. Live Triggers are a quick and convenient way to trigger 
lighting cues directly from the Ableton Live timeline, perfectly synchronized to the 
music. This enables live performers to run a fully automated light show without the 
need for manual operation. 
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This section assumes that you are familiar with the basics of Ableton Live and 
already have a Lightkey project with cues that will be triggered from Ableton Live. 
Lightkey and Ableton Live need to run on the same computer. 

It is up to you how you organize your cues. For example, can use a cuelist for each 
song and step through the cues one by one. Or you can use cue buttons and activate 
one or multiple cues at various points in the timeline. For more information on 
buttons, cuelists, and cues, see chapter 11, Live control. 

Set up communication between Ableton Live and Lightkey 

	 1	 In Lightkey, choose Lightkey > Settings…, click External Control, and make 
sure Enable Live Triggers is selected. 

	 2	 In Ableton Live, choose Live > Settings… and then click Link MIDI. 

	 3	 Locate the row “Output: Lightkey Input” in the MIDI Ports list (this row is only 
visible when Lightkey is open). 

	 4	 Make sure the button in the Track column reads “On”. 

After setting up the communication, you’ll add one or more MIDI tracks to your set 
from which you’ll control your lighting cues. (To activate more than one cue at a time, 
it is necessary to use multiple tracks.) 

Add a MIDI track to your project 

	 1	 In Ableton Live, go to Arrangement View. 

	 2	 Choose Create > Insert MIDI Track. 

	 3	 Make sure the In/Out section is visible (choose View > In/Out), then configure 
the options in the track’s In/Out section: 

	 	  

Now you’re ready to add lighting cues to your Ableton Live set. You’ll do that by 
dragging prepared MIDI clips to the MIDI track. 

Set the input type to
No Input.

Set the output type to
Lightkey Input.

Set the output channel to 16.
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Add clips to a MIDI track 

	 1	 Make sure that Ableton Live’s browser is visible (choose View > Show 
Browser). 

	 2	 Locate and expand the item User Library > Lightkey in the browser. 

	 3	 Expand the item for the current Lightkey project. It contains the following 
groups: 

• Actions: This contains clips for generic actions. 

• One group for each Live view page: These groups contain clips for every 
cue on the page. There’s also a clip which selects the page in Lightkey’s 
Live view. 

	 	  

	 4	 Drag clips to the MIDI track. 

	 5	 Drag the right edge of the clips to adjust their duration, if necessary: 

• Cues with a button: The cue is activated at the beginning of the clip and 
remains active for its entire duration. Adjust the clip’s duration to the time 
you would like the cue to stay active. 

• Cues in a cuelist: The cue is activated at the beginning of the clip and 
remains active until another cue is activated. You don’t need to adjust the 
clip’s duration. 

• Other clips: The action is performed at the beginning of the clip. You don’t 
need to adjust the clip’s duration. 

Generic actions for controlling 
cuelist playback

Select live page

Select live page

Cues from this page

Cues from this page
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	 6	 Play back the set. When playback reaches the beginning of a clip, the 
corresponding cue activates in Lightkey. 

For cues with a button, a clip’s duration determines how long the corresponding cue 
remains active. You can activate multiple cues at once by adding more MIDI tracks. 

 

	 

If you accidentally dragged the left end of a clip, you can fix it as follows: 

Fix a clip whose cue doesn’t activate correctly 

	 1	 Double-click the clip. The MIDI Note Editor appears in the Details view. 

Cues in a control panel remain active for the duration of the clip

Cues in a cuelist remain active until another cue is activated

	➤	 Important: Version 11.1 of Ableton Live has started to change the input and 
output type of empty MIDI tracks when you drag a clip to it. You will therefore 
need to restore those settings after adding the first MIDI clip.

	➤	 Important: Always drag the right end of a clip to change its duration, never 
the left end. (At the beginning of a clip a MIDI message is sent to Lightkey 
which activates the cue. When you drag the left end of a clip then either that 
message is sent too late or no message is sent.) 

	 	

Always drag this end 
to change the clip 
duration

Do not drag this end
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	 2	 Drag the Start Marker in the MIDI Note Editor to the very left. 

	  

When you use a cuelist, you can either use the clip “Cuelist: Next Cue” to step 
through the cues sequentially, or you can jump to a specific cue by dragging a cue to 
the timeline. 

The “Select Page” clips can be used to explicitly switch to a Live view page. Usually 
this isn’t necessary: Lightkey automatically switches to the respective page when a 
cue is activated. 

Behind the scenes 
Live Triggers work through MIDI messages. Lightkey sets up a number of external 
control bindings which bind MIDI messages to actions like activating a cue. It then 
creates a MIDI clip in Ableton Live for each binding. 

To view these bindings, choose Window > External Control, click MIDI, and select 
Live Triggers from the Configuration pop-up menu. This special configuration is 
managed by Lightkey and can’t be edited. If you keep the External Control window 
open you will see that bindings are selected when a matching MIDI message arrives. 

The bindings for activating cues use “Note On” MIDI messages. Since there are 128 
MIDI “notes”, Lightkey can create up to 128 cue bindings per Live view page. 

MIDI messages for Live Triggers are always sent on MIDI channel 16. This channel is 
reserved for messages between Ableton Live and Lightkey, you cannot use it for your 
own MIDI bindings. 

Start Marker
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Disable Live Triggers 
By default Lightkey creates Live Trigger bindings for all cues in every project and 
makes them available to Ableton Live. You can exclude individual cues from Live 
Triggers, which can be useful to keep the list of clips short, especially if you’re 
approaching the 128 cues limit. You can also disable Live Triggers completely if you 
don’t use it. 

Exclude a cue from Live Triggers 

	 1	 Open the cue inspector, as described in Edit cue contents and options in chapter 
11, Live control. 

	 2	 Scroll to “Options”. 

	 3	 Select “Exclude from Live Triggers”. 

Disable Live Triggers 

	 1	 Choose Lightkey > Settings… and then click External Control. 

	 2	 Deselect the option “Enable Live Triggers”. This disables Live Triggers for all 
projects. 

Troubleshooting 
Here are some helpful tips if Live Triggers don’t work as expected: 

• If your Lightkey project doesn’t appear in Ableton Live’s browser: Make sure 
Live Triggers are enabled in Lightkey’s Settings window. See Disable Live 
Triggers previously in this section. 

• If a change in Lightkey doesn’t show in Ableton Live’s browser: Select the Live 
Triggers configuration in the MIDI tab of the External Control window and click 
Update. Also make sure not to exceed the limit of 128 cues per Live view page. 

• If Lightkey shows no response to triggers: Check if the MIDI track has the 
correct input, output, and channel settings, as described earlier in this section. 
Use the External Control Log to verify that Lightkey receives the message. See 
External Control Log later in this chapter. 

• If a single clip doesn’t activate its cue, or if the cue activates too late: You may 
have accidentally dragged the left edge of the clip. This can be fixed in the MIDI 
Note Editor for the clip, as described earlier in this section. 
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Trigger actions from ProPresenter 
ProPresenter is a presentation software especially popular among houses of 
worship. The following example shows how to trigger cues and other actions in 
Lightkey from ProPresenter 17 through MIDI messages. The example assumes that 
Lightkey and ProPresenter run on the same computer. 

Set up communication from ProPresenter to Lightkey 

	 1	 Make sure that Lightkey is open. 

	 2	 In ProPresenter, open the Settings window and click Devices. 

	 3	 Click Add Device and choose MIDI from the pop-up menu. 

	 4	 In the next screen, make the following changes: 

	 	  

	 5	 Click 􀆉 in the upper-left corner. 

	 	 A new item appears in the list. 

	 	  

	 6	 Click Connect. 

Enter a device name

Turn on Auto Reconnect

Turn on Lightkey Input

Select CoreMIDI Device
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After MIDI communication has been established you can set up actions in Lightkey—
for example, activating a cue—to be performed when a certain slide is shown. 

Trigger an action in Lightkey when a ProPresenter slide appears 

	 1	 Control-click a slide in ProPresenter and choose Add Action > Communication 
> Lightkey > MIDI Note On. (Here, “Lightkey” is the name of the connection.) 

	 2	 In the window that appears, make the following changes: 

	 	  

	 3	 Click Done. 

	 	 Note the icon in the top-left corner of the slide’s preview, indicating that a MIDI 
message is associated with the slide. 

	 4	 In Lightkey, choose Window > External Control and click MIDI. 

	 5	 In the Input pop-up menu, select Lightkey Input. 

	 6	 Click 􀅼 in the toolbar. 

	 	 A new MIDI binding is added to the list. 

	 7	 Edit the binding in the area below the bindings list: 

‣ In the Channel and Note fields on the left, enter the same channel and 
note values as in ProPresenter. 

‣ In the right part, select an action and set its parameters. To activate a cue, 
select Activate/Deactivate Cue, then select a cue and set the behavior to 
Activate. 

When you run your ProPresenter presentation and a slide with a MIDI message 
appears, the corresponding action is triggered in Lightkey. If that doesn’t work you 
can use the External Control Log to track down the error. For more information see 
External Control Log later in this chapter. 

Choose any channel between 1 and 15. Typically 
you would use the same channel for all messages 
from ProPresenter to Lightkey, although this isn’t 
technically necessary. (Note that channel 16 can’t 
be used.)
Choose a unique note.
Choose an intensity greater than zero. The value 
has no effect as long as it’s greater than zero.
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Send MIDI to other applications 
Although the primary purpose of the external control system is to control Lightkey 
from external sources, you can also use it to send MIDI messages to other 
applications such as QLab or ProPresenter. Here’s an example how to make Lightkey 
send a MIDI message each time a certain cue is activated or deactivated. 

Send MIDI messages to another application 

	 1	 Open Lightkey and the application you would like to send MIDI messages to. 

	 2	 Configure the target application to receive MIDI messages from the Lightkey 
Output port. 

	 3	 In Lightkey, open the External Control window and click MIDI. 

	 4	 In the Input pop-up menu, select Lightkey Input, which represents Lightkey’s 
own MIDI port. Feedback messages for this port are sent to Lightkey Output. 

	 5	 Click 􀅼 in the toolbar. 

	 	 A new MIDI binding is added to the list. 

	 6	 Configure the trigger in the lower-left part of the window: 

• Trigger: Select Button. 

• Command: Select No Command, which indicates that the binding doesn’t 
respond to input and is used exclusively for sending messages. 

• Feedback: Select the type of MIDI message you would like to send, for 
example, Note On/Off. 

• Use the following fields to configure the messages sent when the cue 
becomes active and inactive. 

• You can click Send to send a test message. 

	 7	 Configure the action in the lower-right part of the window: 

• Action: Select Activate/Deactivate Cue. 

• Cue: Select a cue. 

	❖	 Note: It is also possible to do the reverse—have ProPresenter automatically 
go to a slide when you activate a cue in Lightkey. For details see the following 
section, Send MIDI to other applications.

Lightkey User Guide	 295



	 8	 To test the binding, click Run or activate the cue in the Live view. A MIDI 
message is sent to the target application. 

 

MIDI routing 
Lightkey automatically recognizes connected MIDI hardware as well as source and 
destination ports from other applications on your computer. You can choose which 
ports should be used for input and output. 

Select the MIDI ports used for external control 

	 1	 Choose Lightkey > Settings… and then click External Control. 

	 2	 Enable or disable inputs and outputs as necessary. 

For MIDI bindings associated with a particular input, Lightkey sends feedback 
messages to the corresponding output. In some situations it may be necessary to tell 
Lightkey which MIDI output belongs to a particular input. 

Select the MIDI output which belongs to a particular input 

	 1	 Choose Lightkey > Settings… and then click External Control. 

	 2	 Control-click a MIDI input and choose Send Feedback To from the menu, then 
choose a MIDI output. 

To receive MIDI messages from other software, Lightkey creates a MIDI port named 
Lightkey Input. You can select this port as a destination in other MIDI-capable apps 
when Lightkey is open. This eliminates the need to use a virtual MIDI bus (like the IAC 
Driver) to send MIDI between apps. Feedback for bindings in Lightkey Input is sent to 
the Lightkey Output port. 

	★	 Tip: To review the messages Lightkey is sending to other apps you can use 
the External Control Log. See External Control Log later in this chapter.
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Open Sound Control (OSC) 
OSC (Open Sound Control) is a communication protocol for sending short messages 
over a computer network. Any software that can send arbitrary OSC messages can be 
used to control Lightkey. Popular OSC-capable Mac and iOS applications include 
QLab, TouchOSC, Lemur, and Vezér. 

Each OSC-controllable element in Lightkey has an address. This means you don’t 
need to bind elements to triggers first, like with MIDI or DMX. OSC messages follow a 
logical structure and are much easier to read than MIDI or DMX. For example, here’s 
a message to activate a particular cue in the Live view: 

/live/My_Live_Page/cue/Ballyhoo/activate 

Connect to Lightkey 
Lightkey receives incoming OSC messages through UDP and TCP over a local 
network. Senders can use Bonjour to easily connect to Lightkey. 

Connect to Lightkey from another application 

	 1	 In Lightkey, choose Lightkey > Settings…, then click External Control and 
make sure Enable OSC is selected. 

	 2	 If the sender application runs on a different computer, make sure it’s connected 
to the same local network. 

	 3	 If the other application is on the same computer: 

‣ Set the destination address to “localhost” or “127.0.0.1”, and set the 
destination port to 21600. 

	 	 If the other application supports Bonjour: 

‣ Select Lightkey in the OSC settings of the sender application. 

	 	 If the other application does not support Bonjour: 

‣ In the sender application’s OSC settings, enter the IP address of the 
computer where Lightkey runs (you can find this number in the Network 
pane of System Settings) and set the port number to 21600. 
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OSC addresses 
An OSC message consists of an address followed by zero or more arguments. The 
address always starts with a / and is followed by one or more /-separated parts. 

An address selects a method in Lightkey, which is the equivalent of performing an 
action. The following section describes all OSC methods that Lightkey understands. 

Objects like cues, presets, and fixtures are addressed by their name. When you write 
the name in OSC, keep the following in mind: 

• OSC addresses are case-sensitive, so use uppercase and lowercase letters 
exactly as in the original name. 

• OSC addresses must not contain spaces, so you need to use an underscore 
instead. For a cue named “Front Lights On”, you would type 
Front_Lights_On in OSC. 

• There are a number of other characters which are forbidden in OSC address 
parts, so it’s best to avoid them in cue names. Address parts may only contain 
printable 7-bit ASCII characters except for the following: #*,/?[]{}

If you must use one of these characters in your object names, you can use 
address patterns to match them, as explained below. 

Lightkey supports OSC address patterns to match the names of objects like cues and 
presets. The syntax for patterns is as follows: 

• ? matches any single character. 

• * matches zero or more characters. 

• A string of characters in square brackets matches any character in the string. 
For example, Fab_[46] matches “Fab 4” and “Fab 6”. 

• Two characters in square brackets with a minus sign in between indicate the 
range of characters between the given two, in ASCII order. For example, 
Fab_[4-6] matches “Fab 4,” “Fab 5,” and “Fab 6.” 

• An exclamation point at the beginning of a bracketed string negates the sense 
of the list, so the list matches any character not in the list. 

• A comma-separated list of strings enclosed in curly braces matches any of the 
strings in the list. For example, Fab_{Four,Six} matches “Fab Four” and 
“Fab Six”. 
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Lightkey provides a quick and convenient way to copy of the OSC address of many 
elements in the user interface. For example, this works for cues in the Live view and 
many buttons and sliders in the Design view. 

Quickly copy the OSC address of an element 

‣ Control-click an element in the user interface (e.g. a button or slider) and 
choose External Control > Copy OSC Address from the shortcut menu. This 
command is only available for elemens whose action can be performed through 
OSC. 

Live view 
All elements of the Live view—like cues, frames, and modifiers—can be fully 
controlled through OSC. 

/live/pageName/select [fadeTime]

Use this method to select the Live view page with the name pageName. The optional 
fadeTime argument lets you specify a custom fade time, in seconds, which 
overrides the page’s fade time. 

/live/pageName/cue/cueName/activate [fadeTime]  

/live/pageName/cue/cueName/deactivate [fadeTime]  

/live/pageName/cue/cueName/toggle [fadeTime]

These methods let you activate or deactivate cues. pageName is the name of a Live 
view page; you can also use the keyword selected to address the currently 
selected page. cueName is the name of a cue or a pattern matching multiple cue 
names; you can also use active for all active cues. It’s possible to activate cues on 
pages other than the selected one, but this has no effect until the page is selected. 

The optional fadeTime argument lets you specify a custom fade time, in seconds, 
which overrides the cue’s fade time. If you use this argument the Fade Time modifier 
is ignored. 

Remember that names are case-sensitive and you must replace spaces with 
underscores. You can use wildcards to match multiple cues. 
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Here are some examples: 

• /live/Main_Page/cue/Red_Backlight/activate

Activates the cue “Red Backlight” on the page “Main Page”. 

• /live/selected/cue/Red_Backlight/activate

Activates the cue “Red Backlight” on the currently selected page. 

• /live/*/cue/Red_Backlight/activate 0.5

Activates the cue “Red Backlight” on all pages with a fade time of 0.5 seconds. 

• /live/*/cue/071*/activate

Activates cue number 071 in a cuelist. 

• /live/*/cue/*/deactivate 0

Deactivates all cues on all pages with no fade. 

/live/pageName/cue/cueName/intensity value

This method controls the intensity of fader buttons in the Live view. value is a 
number between 0 and 1. 

/live/pageName/frame/frameName/cue/cueName/…

This is an alternative way to address cue buttons within a frame. You can append any 
command for cues, like toggle. For example, this message deactivates all cues in 
the frame named “Backlight”: 

• /live/selected/frame/Backlight/cue/*/deactivate

The following method changes the intensity of the active cues inside the frame: 

• /live/selected/frame/Backlight/cue/active/intensity 0.8

/live/pageName/frame/frameName/previousCue [fadeTime]  

/live/pageName/frame/frameName/nextCue [fadeTime]

These methods activate the previous or next cue in a frame, respectively. The 
optional fadeTime argument lets you specify a custom fade time, in seconds.
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/live/cuelistName[/groupName1[/groupName2[…]]]/cueName/…

In a cuelist, you can also address cues through their enclosing groups. Replace 
groupName1, groupName2 and so on with the names of the groups containing the 
cue, or a pattern matching those names. You can append any command for cues, like 
activate. For example: 

• /live/selected/Song_1/001_Intro/activate

/live/pageName[/frame/frameName]/cue/cueName/modifier value  

/live/pageName/frame/frameName/modifier value

These methods give you control over cue and frame modifiers. modifier is one of 
the following: 

value is the value for the modifier. For percent values, use a number where 0.0 
maps to 0% and 1.0 maps to 100%. You can also use neutral or default to reset a 
modifier to its neutral or default value, respectively. Here are some examples: 

• /live/selected/cue/Waterfall/speed 1.2

• /live/selected/cue/Waterfall/beatMultiplier /6

• /live/selected/cue/Waterfall/beatMultiplier x12

• /live/selected/cue/*/fadeTime 0

• /live/selected/cue/*/dimmer neutral

• /live/selected/cue/active/colorTemperature 5600

• /live/selected/cue/active/hue 180

• /live/selected/frame/Movers/panAngle -30

• /live/selected/frame/Movers/tiltAngle default

• /live/selected/frame/Movers/cue/active/focus 1.3 

speed beatMultiplier timeOffset fadeTime

dimmer hue colorTemperature greenSaturation

xfadeToColor panAngle tiltAngle focus

zoomAngle irisSize frostAmount fogAmount
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/live/start  

/live/stop  

/live/toggle  

/live/pause  

/live/resume  

/live/togglePaused  

/live/nextCue [fadeTime]  

/live/previousCue [fadeTime]

These methods control cuelist playback. They are only available if a cuelist is 
selected. 

The optional fadeTime argument lets you specify a custom fade time, in seconds, 
which overrides the cue’s fade time. 

/live/xfade level

Use this method to control manual crossfades in a cuelist. level is the level of the 
Xfade slider, a number between 0 and 1. 

/live/cuelistName/cue/cueName/skip  

/live/cuelistName/cue/cueName/unskip

These methods change the checkmarks to the left of the cues’ names in a cuelist. 

Preset Palette 
You can activate or deactivate presets, and start or stop sequences, with OSC 
messages. Because the Preset Palette often contains multiple items with the same 
name, addresses include the names of the enclosing groups, for example: 

/palette/Movers/Colors/Indigo 

You can replace the names of groups, presets, and sequences with address patterns, 
as described earlier in this section. For example, this addresses all presets named 
“Indigo” that are nested in two groups: 

/palette/*/*/Indigo 
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What if you want to address all presets named “Indigo” in any group? In this case you 
use the // operator, which looks in all descendant items of the group to its left. For 
example: 

• /palette/Movers//Indigo

Addresses any item in “Movers”—including contained groups—named “Indigo”. 

• /palette//Indigo

Addresses any item named “Indigo”. 

• /palette/Movers//

Addresses all items in the “Movers” group and contained groups. 

/palette/address/of/preset/activate  

/palette/address/of/preset/deactivate  

/palette/address/of/preset/toggle

These methods activate or deactivate a preset. Replace address/of/preset with 
the address of one or more presets, as described above. 

/palette/address/of/sequence/start  

/palette/address/of/sequence/stop  

/palette/address/of/sequence/toggle

These methods start or stop a sequence. Replace address/of/sequence with the 
address of one or more sequences, as described above. 

Output control 
The following methods control the global DMX output. 

/output/enterBlind  

/output/exitBlind  

/output/cancelBlind  

/output/toggleBlind

These methods enter and exit blind mode. 
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/output/freeze  

/output/unfreeze  

/output/toggleFreeze

These method freeze or unfreeze DMX output. 

/output/master value

This method sets the Master Dimmer level. value is a number between 0 and 1. 

Beat control 
The following methods control beat synchronization. 

/beat/tap

Set the beat grid by sending this message four times on successive beats. 

/beat/sync

Synchronizes the time of the next beat while keeping the tempo. 

/beat/syncDownbeat

Synchronizes the time of the first beat while keeping the tempo. 

/beat/halve  

/beat/double

Halves or doubles the current tempo (beats per minute). 

/beat/tempo bpm

Specifies the tempo. bpm is a number which signifies the beats per minute. 

Fixture properties 
You can control the properties of individual fixtures through OSC, like in the Design 
view. The complete set of fixture properties is exposed through OSC. (It’s not 
currently possible to control individual light beams through OSC, though.) 
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/fixture/fixtureName/overrides/propertyName value

Use this method to set fixture properties. fixtureName is the short name of a 
fixture or a pattern matching multiple fixture names; you can use selected to 
address the currently selected fixtures. Choose propertyName and value 
according to the following table: 

Property name Value

on on or off

dimmer A number between 0 and 1.

color{1|2|3} The index of a color on a color wheel.

rainbowSpeed{1|2|3} A nonnegative number (revolutions per second).

color Three numbers between 0 and 1 corresponding to red, 
green, and blue. Alternatively, a string specifying RGB values 
in hexadecimal form (make sure the argument is sent as a 
string, not an integer).

hue, saturation, brightness A number between 0 and 1.

warmWhite, coolWhite, amber, 
lime, ultraviolet

A number between 0 and 1.

colorTemperature A color temperature in Kelvin.

greenSaturation A number between –1 and +1.

xfadeToColor A number between 0 and 1.

panAngle, tiltAngle A positive or negative angle in degrees.

infinitePanMode, 
infiniteTiltMode

One of the following: stopped, rotatingCW, 
rotatingCCW

infinitePanSpeed, 
infiniteTiltSpeed

A nonnegative number (revolutions per second).

speedMode One of the following: tracking, trackingSlow, 
trackingMedium, trackingFast, vector, 
blackoutDuringPanTiltMovement, 
blackoutDuringWheelMovement, 
blackoutDuringAnyMovement

vectorSpeed A number between 0 and 1.

gobo{1|2|3} The index of a gobo on a gobo wheel.

goboRotationMode{1|2|3} One of the following: stopped, rotatingCW, 
rotatingCCW, bouncing, indexed
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goboShakeMode{1|2|3} One of the following: stopped, shaking

goboRotationSpeed{1|2|3} A nonnegative number (revolutions per second).

goboAngle{1|2|3} An angle in degrees.

goboShakeSpeed{1|2|3} A nonnegative number in Hz.

goboCycleSpeed{1|2|3} A nonnegative number (revolutions per second).

shutterState One of the following: closed, open, strobe, syncStrobe, 
randomStrobe, randomSyncStrobe, lightningStrobe, 
pulseOpening, pulseClosing, pulseAlternating, 
burstPulse, randomPulseOpening, 
randomPulseClosing, randomPulseAlternating, 
randomPurstPulse

strobeSpeed For steady strobing: A value in Hz. 
For random strobing: A number between 0 and 1.

shutterPulseSpeed For steady pulsing: A value in Hz. 
For random pulsing: A number between 0 and 1.

prismType{1|2} One of the following: none, twoFacet, threeFacet, 
fourFacet, fiveFacet, sixFacet, eightFacet, 
sixteenFacet, fiveFacetCenter, threeFacetLinear, 
fourFacetLinear, fiveFacetLinear, 
sixFacetLinear, frost

prismRotationMode{1|2} One of the following: stopped, rotatingCW, 
rotatingCCW, indexed

prismRotationSpeed{1|2} A nonnegative number (revolutions per second).

prismAngle{1|2} An angle in degrees.

focus A number between 0 and 1.

zoomAngle A zoom angle in degrees.

irisSize A number between 0 and 1.

frostState One of the following: off, on, linear, pulseIncreasing, 
pulseDecreasing

frostAmount A number between 0 and 1.

frostPulseSpeed A value in Hz.

fogAmount A number between 0 and 1.

Property name Value
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Here are some examples: 

• /fixture/F4/overrides/dimmer 1.0

• /fixture/F4/overrides/color1 5

• /fixture/F4/overrides/color 0.29 0.0 0.51

• /fixture/F4/overrides/color "4b0082"

• /fixture/F4/overrides/hue 0.87

• /fixture/F4/overrides/amber 0.25

• /fixture/F4/overrides/colorTemperature 5600

• /fixture/F4/overrides/greenSaturation -0.2

• /fixture/F4/overrides/xfadeToColor 1

• /fixture/F4/overrides/shutterState strobe

• /fixture/F4/overrides/strobeSpeed 2.4

• /fixture/F4/overrides/panAngle 45

• /fixture/F4/overrides/focus 0.15

• /fixture/F4/overrides/zoomAngle 40

• /fixture/F4/overrides/irisSize 0.9 

Beyond that you can also control any custom fixture properties specific to the fixture. 
Use the property’s name as it appears in the Design view, but replace spaces with 
underscores. For properties with a list of options, replace value is the name of the 
option, for example: 

• /fixture/F6/overrides/Auto_Program Program_1

For properties with a slider, specify the slider value—either a number between 0 and 
1 for percentage sliders, or a number between 0 and 255 if the slider shows a DMX 
value: 

• /fixture/F6/overrides/Auto_Program_Speed 0.7

• /fixture/F6/overrides/Pattern 255

If a property has both options and a slider, use two arguments: 

• /fixture/F6/overrides/Effect Effect_7 0.15 
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/fixture/fixtureName/overrides/clear  

/fixture/fixtureName/overrides/propertyName/clear

The first method clears all overridden properties for one or more fixtures, the second 
clears a single overridden property. fixtureName is the short name of a fixture or a 
pattern matching multiple fixture names; you can use selected to address the 
currently selected fixtures. propertyName is one of the following fixture property 
names: 

propertyName can also be the name of a custom (fixture-specific) property. 

Here are some examples: 

• /fixture/F4/overrides/clear

Clears all overrides for the fixture F4. 

• /fixture/*/overrides/shutter/clear

Clears the Shutter property for all fixtures. 

/fixture/fixtureName/lamp/on  

/fixture/fixtureName/lamp/off

These methods send a Lamp On or Lamp Off signal to one or more fixtures which 
support this. 

/fixture/fixtureName/command/commandName

This sends a command to one or more fixtures. commandName is the name of a 
command understood by the fixture, e.g. Reset. 

dimmer colorWheel{1|2|3} color

position speed goboWheel{1|2|3}

shutter prismWheel{1|2} focus

zoom iris frost

fog
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/fixture/fixtureName/select  

/fixture/fixtureName/deselect

These methods select or deselect one or more fixtures. fixtureName is the short 
name of a fixture or a pattern matching multiple fixtures. 

 

External Control Log 
The External Control Log shows all DMX-In, MIDI, and OSC messages received by 
Lightkey, as well as feedback sent to MIDI controllers. It also shows what effect an 
input had and if errors occurred. This makes it a useful tool for tracking down issues 
with external control. 

Open the External Control Log 

‣ Choose Window > External Control Log (or press Command-Option-Shift-E). In 
the window that appears, click either DMX-In, MIDI, or OSC. 

Each row in the log corresponds to a message received or sent by Lightkey. Rows 
include a timestamp and a comment indicating which effect an input had or which 
binding a feedback message originated from. Click the arrow next to a comment to 
view the corresponding binding in the External Control window. 

Work with the External Control log 

‣ To pause logging new messages, click 􀊗. Click 􀊕 to resume. 

‣ To insert a marker, click 􀋋. 

‣ To clear previously logged messages, click 􀁠. 

‣ To filter the log, type one or more words in the search field. Only entries that 
contain your search text will be shown. 

‣ To copy the selected log items to the Clipboard, choose Edit > Copy. 

	★	 Tip: If an OSC message doesn’t have the intended effect, you can use the 
External Control Log to track down the problem. See External Control Log 
later in this chapter.
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macOS shortcuts 
Starting with macOS Monterey you can control Lightkey using the system-wide 
shortcuts feature. Lightkey provides numerous actions, primarily for live control, 
which are available in the Shortcuts app. You can also run shortcuts from Siri.	  

You create and edit shortcuts in the Shortcuts app that comes with macOS. For more 
information see the Shortcuts User Guide by Apple. 

 

You can also quickly create shortcuts from within Lightkey. These shortcuts will 
subsequently appear in the Shortcuts app and you can edit them there. 

Create a shortcut from Lightkey 

	 1	 Control-click an element in the user interface and choose External Control > 
Add Shortcut… from the shortcut menu. This command is only available for 
some elements, e.g. Live view buttons or cues in a cuelist. 

	 2	 In the window that opens, enter a phrase which can be used to invoke the 
shortcut from Siri, then press Return. (This is necessary even if you don’t want 
to use Siri.) The phrase is also used as the shortcut’s title. 

	 3	 Click Edit in Shortcuts to view and further edit the shortcut in the Shortcuts app. 

 

The following table lists the shortcut actions provided by Lightkey. 

	❖	 Note: The log only tracks messages that arrive while its window is open (and 
logging isn’t paused). It stores up to 1000 messages; after that, the oldest 
messages are discarded.

	❖	 Note: Starting with macOS 15, Lightkey may no longer appear in the Apps 
section of the Shortcuts app. To find Lightkey’s actions enter “Lightkey” in the 
search field.

	➤	 Important: Make sure to open Lightkey before you run or edit a shortcut with 
actions from Lightkey in Shortcuts. If Lightkey isn’t open, Shortcuts launches 
an invisible copy of Lightkey. Since it’s invisible you cannot quit this copy.

Lightkey User Guide	 310



Action What it does

Activate/Deactivate Cue Activates or deactivates one or more cues. If the cues are on a 
different Live page than the current one, they won’t become active 
until you switch to that page. 

You can choose one or more fixed cues to (de-)activate, or use the 
output of a preceding action like Find Cues or Get Active Cues, or use 
a variable containing one or more cues. 

You can optionally specify a custom fade time to override the cue’s 
fade time.

Get Active Cues Passes the active cues on the selected Live page to the next action. If 
the current page is a cuelist then this will return no more than one 
cue.

Blind Mode Enters or exits blind mode.

Find cues Finds cues on the current Live page by their name.

Freeze Output Freezes or unfreezes output.

Go to Cue in Cuelist Activates the next or previous cue in the current cuelist. 

You can optionally specify a custom fade time to override the cue’s 
fade time.

Pause/Resume Cuelist Pauses or resumes playback of the current cuelist.

Select Live Page Selects a page in the Live view. 

You can optionally specify a custom fade time to override the page’s 
fade time.

Set Cue Intensity Sets the intensity of one or more cues. 

You can choose one or more fixed cues, or use the output of a 
preceding action like Find Cues or Get Active Cues, or use a variable 
containing one or more cues.

Set Cue Modifier Sets the value of a modifier of one or multiple cues. 

You can choose one or more fixed cues, or use the output of a 
preceding action like Find Cues or Get Active Cues, or use a variable 
containing one or more cues.

Set Frame Modifier Sets the value of a modifier of one or multiple frames.

Activate Cue in Frame Activates the next or previous cue in a frame. 

You can optionally specify a custom fade time to override the cue’s 
fade time.

Set Master Dimmer Sets the Master Dimmer level.

Set Tempo Sets the beats per minute.

Start/Stop Cuelist Starts or stops playback of the current cuelist.
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You can combine Lightkey’s actions with other actions in the Shortcuts app to build 
your own workflows. For example, assume there’s a cue named Panel Color which 
defines the color of some lights and has a Hue modifier. The following shortcut 
repeatedly sets the Hue modifier to a random value every 30 seconds, effectively 
applying a random color to the lights: 

 

Multi-Touch gestures 
Lightkey supports configurable Multi-Touch gestures as an alternative way to quickly 
and conveniently change frequently-used fixture properties. You configure these 
gestures in Lightkey’s Settings window. 

Configure Multi-Touch gestures 

‣ Choose Lightkey > Settings… and then click Gestures. 

You can use gestures to control the following things: 

• Zoom: Enlarge or reduce the Preview. 

• Dimmer: Change the selected fixtures’ Dimmer property. 

• Master dimmer: Change the Master Dimmer level. 

• Color hue: Change the hue component of the selected fixtures’ color (if the 
fixtures support color mixing). 
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• Color saturation: Change the saturation component of the selected fixtures’ 
color (if the fixtures support color mixing). 

You can control the fixture properties by scrolling or by swiping up or down with 
three or four fingers while the pointer is over the Preview area. These gestures can 
be combined with modifier keys. The swipe gestures require a Multi-Touch trackpad. 

	 

If your trackpad supports Force Touch, you can force click a fixture icon to use one of 
the HUDs. This gesture is assigned to the Position HUD by default. 

	➤	 Important: Three or four finger swipes can only be recognized when they are 
not assigned to another action in the Trackpad pane of System Settings (even 
when combined with modifier keys).
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Appendix 1   
Shortcuts and 
gestures 

 

Lightkey’s comprehensive system of keyboard 
shortcuts and gestures lets you control virtually 
every application feature. 

General 

Application & windows 

Action Shortcut

Show Settings window Command–Comma

Show Fixture Manager Command–Shift–Down Arrow

Hide Fixture Manager Command–Shift–Up Arrow or Command–Return

Open External Control window Command–E

Hide Lightkey Command–H

Hide other applications Command–Option–H

Close window Command–W

Minimize window Command–M

Minimize all windows Command–Option–M

Open DMX Monitor window Command–Shift–Option–O
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Projects 

Editing 

View 

Open User Guide Command–?

Quit Lightkey Command–Q

Action Shortcut

Action Shortcut

Open a project (when no project is open) Command–O

Close the current project Command–W

Save project Command–S

Action Shortcut

Undo the last action Command–Z

Redo the last action Command–Shift–Z

Cut the selection Command–X

Copy the selection Command–C

Paste content of Clipboard Command–V

Select all text or objects Command–A

Show or hide the search field Command–Option–F

Action Shortcut

Show Design view Command–D

Show Live view Command–L

Show/hide Preset Palette Command–Shift–P

Show/hide shortcuts Command–Shift–S

Enter/exit blind mode Command–B
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Project setup assistant 

Preview editing 

General 

Selection 

Freeze/unfreeze output Command–Period

Edit Preview Command–J

Edit Live view Command–Option–J

Set beats per minute Shift-B or hold down B

Edit Design View Command–Shift–Option–D

Enter/exit full screen Command–F

Show shortcut menu for focused area Control–Return

Action Shortcut

Action Shortcut

Go to next step Command–Right Arrow or Command–Return

Go to previous step Command–Left Arrow

Action Shortcut

Edit Preview or end editing Command–J or Command–double-click Preview 
area

End editing Preview Command–Return

Enable/disable highlight mode Command–Shift–H

Scroll Space–drag

Action Shortcut

Select all objects Command–A

Deselect all objects Command–Shift–A or Esc
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Move 

Fixtures 

Shapes, text & images 

Select all fixtures of the same type as the 
selected fixture (e.g. all moving heads)

Command–Option–A

Select objects by dragging Drag from a blank part of the Preview (Option–
drag to select outward from starting point)

Add or remove an object from the selection Shift–click or Command–click on object

Add or remove objects from the selection Shift–drag or Command–drag from a blank part 
of the Preview

Select an individual fixture from a group Double-click on fixture icon

Select fixtures by name Type (lowercase) letters or numbers

Select next fixture, in alphabetical order Control–Tab

Select previous fixture, in alphabetical order Control–Shift–Tab

Action Shortcut

Action Shortcut

Move selected objects by one unit Arrow key

Move selected objects by ten units Shift–arrow key

Action Shortcut

Create group from selected fixtures Command–Option–G

Ungroup selected fixtures Command–Option–G

Set beam direction of selected fixtures Command–Shift–Option–P

Set beam color of selected fixtures (for fixtures 
with a fixed color)

Command–Shift–Option–C

Action Shortcut

Duplicate selected objects Command–Shift–D or Option–arrow key
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Preview 

Zoom 

Duplicate selected objects by dragging Option–drag

Constrain dragging to horizontal or vertical 
direction

Shift–drag

Disable alignment/spacing guides while 
dragging

Control–drag an object

Resize an object from the center Option–drag a selection handle

Constrain a shape’s aspect ratio while resizing Shift–drag a selection handle

Do not constrain the aspect ratio of an image or 
round truss while resizing

Command–drag a selection handle

Rotate an object Command–drag a selection handle

Rotate in 45° steps Command–Shift–drag a selection handle

Rotate a line around its center Option–drag a selection handle

Constrain a line’s or arc’s angle to 45° Shift–drag a selection handle

Do not snap when changing a line or arc Command–drag a selection handle

Disable alignment/spacing guides while resizing Press Control while resizing

Begin or end editing a line’s shape Return

Move the selected handles while editing a line Arrow keys

Delete the selected handles while editing a line Delete

Begin or end text editing Return

Show Font panel Command–T

Show Color panel Command–Shift–C

Action Shortcut

Action Shortcut

Zoom in or out Pinch gesture1 or Option–scroll up/down while 
mouse pointer is over Preview area2

Zoom in Command–Plus
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1 Requires multi-touch trackpad or Apple Magic Trackpad. 
2 This shortcut can be changed in the Settings window. 

Selection 

Fixtures 

Zoom out Command–Minus

Zoom to fit Command–0

Zoom to selection Command–Shift–0

Action Shortcut

Action Shortcut

Select all fixtures Command–A

Deselect all fixtures Command–Shift–A or Esc

Select all fixtures of the same type as the 
selected fixture (e.g. all moving heads)

Command–Option–A

Select fixtures by dragging Drag from a blank part of the Preview (Option–
drag to select outward from starting point)

Add or remove a fixture from the selection Shift–click or Command–click on fixture

Add or remove fixtures from the selection Shift–drag or Command–drag from a blank part 
of the Preview

Select an individual fixture from a group Double-click on fixture icon

Select fixtures by name Type (lowercase) letters or numbers

Select next fixture, in alphabetical order Control–Tab

Select previous fixture, in alphabetical order Control–Shift–Tab

Select nearest fixture in arrow direction Arrow keys

Extend fixture selection in arrow direction Shift–arrow key

Action Shortcut

Show a fixture’s shortcut menu Click fixture name or right-click/Control–click 
fixture icon

Show overridden fixture properties Command–P
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1 Requires multi-touch trackpad or Apple Magic Trackpad. 
2 This shortcut can be changed in the Settings window. 

Position HUD 

Clear overridden properties for selected fixtures Command–Delete

Clear overridden properties for all fixtures Command–Shift–Delete

Show beam selection dialog Command–Option–B

Show the selected fixture in Fixture Manager Command–Shift–Down Arrow

Edit a fixture’s profile Command–Shift–Option–Down Arrow or Option–
double-click fixture icon

Show DMX output for the selected fixture Command–Shift–Option–O

Change dimmer of selected fixtures Command–scroll up/down while mouse pointer 
is over Preview area2

Change hue of selected fixtures Command–Option–scroll up/down while mouse 
pointer is over Preview area2

Change saturation of selected fixtures Command–Option–scroll up/down while mouse 
pointer is over Preview area2

Change master dimmer Swipe up/down with four fingers while mouse 
pointer is over Preview area1, 2

Action Shortcut

Action Shortcut

Select Position property Shift–P or hold down P or hold down mouse 
button over fixture icon or force click1 fixture 
icon2

Clear (undefine) Position property Space or Delete

Move beam to clicked location Click in position control

Lock pan Command-drag

Lock tilt Shift-drag

Don’t snap Control-drag

Set pan angle according to location of key Numbers on numeric keypad

Change pan Scroll up/down while mouse pointer is over 
position control
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1 Requires trackpad with Force Touch. 
2 This shortcut can be changed in the Settings window. 

Focus HUD 

1 Requires multi-touch trackpad or Apple Magic Trackpad. 

Change tilt Command–Scroll up/down while mouse pointer 
is over position control

Increase/decrease pan angle by 1° Right/Left Arrow

Increase/decrease pan angle by 10° Shift–Right/Left Arrow

Increase/decrease pan angle by 0.1° Option–Right/Left Arrow

Increase/decrease tilt angle by 1° Up/Down Arrow or Plus/Minus

Increase/decrease tilt angle by 10° Shift–Up/Down Arrow

Increase/decrease tilt angle by 0.1° Option–Up/Down Arrow

Close Position HUD Return, Enter or Esc

Action Shortcut

Action Shortcut

Select Focus property Shift–F or hold down F

Clear (undefine) Focus property Space or Delete

Set focus Click in focus control

Don’t snap Control-drag

Change focus Pinch gesture1 or scroll up/down while mouse 
pointer is over focus control

Increase/decrease focus by 10% Up/Down Arrow or Plus/Minus

Increase/decrease focus by 1% Option–Up/Down Arrow

Set focus to an exact value Type numbers

Close Focus HUD Return, Enter or Esc

Lightkey User Guide	 321



Zoom HUD 

1 Requires multi-touch trackpad or Apple Magic Trackpad. 

Iris HUD 

1 Requires multi-touch trackpad or Apple Magic Trackpad. 

Action Shortcut

Select Zoom property Shift–Z or hold down Z

Clear (undefine) Zoom property Space or Delete

Set zoom angle Click in zoom control

Don’t snap Control-drag

Change zoom angle Pinch gesture1 or scroll up/down while mouse 
pointer is over zoom control

Increase/decrease zoom angle by 1° Up/Down Arrow or Plus/Minus

Set zoom to an exact angle Type numbers

Close Zoom HUD Return, Enter or Esc

Action Shortcut

Select Iris property Shift–I or hold down I

Clear (undefine) Iris property Space or Delete

Set iris size Click in iris control

Don’t snap Control-drag

Change iris size Pinch gesture1 or scroll up/down while mouse 
pointer is over iris control

Increase/decrease iris size by 10% Up/Down Arrow or Plus/Minus

Increase/decrease iris size by 1% Option–Up/Down Arrow

Set iris size to an exact value Type numbers

Close Iris HUD Return, Enter or Esc
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Design view 

General 

Dimmer 

1 This shortcut can be changed in the Settings window. 

Color 

Action Shortcut

Cycle through properties in Design view Tab

Cycle backwards through properties Shift–Tab

Show shortcut menu for selected property Control–Return

Clear (undefine) the selected property Delete

Deselect current property Return, Enter, or Esc

Move sliders in coarse steps Shift–drag

Don’t snap sliders Command–drag

Action Shortcut

Select Dimmer property Shift–D or hold down D

Increase/decrease intensity by 10% Up/Down Arrow or Plus/Minus

Increase/decrease intensity by 1% Option–Up/Down Arrow or Option–Plus/Minus

Set intensity to an exact value Type numbers

Change Dimmer property of selected fixtures Command–scroll up/down while mouse pointer 
is over Preview area1

Change Master Dimmer Swipe up/down with four fingers while mouse 
pointer is over Preview area1

Action Shortcut

Select Color property Shift–C or hold down C

Set hue to an exact value Type numbers
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Color Wheel 

Gobo 

Position 

Increase/decrease hue by 10° Up/Down Arrow or Plus/Minus

Increase/decrease hue by 1° Option–Up/Down Arrow or Option–Plus/Minus

Decrease/increase saturation by 10% Left/Right Arrow

Decrease/increase saturation by 1% Option–Left/Right Arrow

Action Shortcut

Action Shortcut

Select Color Wheel property Shift–C or hold down C

Select a color Arrow keys

Select color by index Type numbers

Select rainbow effect R

Action Shortcut

Select Gobo property Shift–G or hold down G

Select a gobo Arrow keys

Select gobo by index Type numbers

Select gobo change effect C

Toggle rotation or change rotation direction R

Toggle bounce B

Toggle indexing I or #

Toggle shake S

Action Shortcut

Select Position property Shift–P or hold down P
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Shutter/Strobe 

Move beam to clicked location Click in position control

Lock pan Command-drag

Lock tilt Shift-drag

Don’t snap Control-drag

Set pan angle according to location of key Numbers on numeric keypad

Change pan Scroll up/down while mouse pointer is over 
position control

Change tilt Command–Scroll up/down while mouse pointer 
is over position control

Increase/decrease pan angle by 1° Right/Left Arrow

Increase/decrease pan angle by 10° Shift–Right/Left Arrow

Increase/decrease pan angle by 0.1° Option–Right/Left Arrow

Increase/decrease tilt angle by 1° Up/Down Arrow or Plus/Minus

Increase/decrease tilt angle by 10° Shift–Up/Down Arrow

Increase/decrease tilt angle by 0.1° Option–Up/Down Arrow

Action Shortcut

Action Shortcut

Select Shutter/Strobe property Shift–S or hold down S

Open shutter O

Close shutter C

Select strobe or change strobe mode S

Select pulse or change pulse mode P

Decrease/increase strobe/pulse speed Up/Down Arrow or Minus/Plus

Fine control of strobe/pulse speed Option–Up/Down Arrow or Option–Minus/Plus
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Movement Speed 

Prism 

Focus 

Action Shortcut

Select tracking mode T

Select vector mode V

Select blackout mode B

Set speed to an exact percent value Type numbers

Increase/decrease speed by 10% Left/Right Arrow or Plus/Minus

Increase/decrease speed by 1% Option–Left/Right Arrow

Action Shortcut

Select Prism property Shift–M or hold down M

Select prism type Type numbers

Select previous/next prism type Left/Right Arrow

Toggle rotation or change rotation direction R

Toggle indexing I or #

Decrease/increase speed or angle Up/Down Arrow or Minus/Plus

Fine control of speed or angle Option–Up/Down Arrow or Option–Minus/Plus

Action Shortcut

Select Focus property Shift–F or hold down F

Don’t snap Control-drag

Increase/decrease focus by 10% Left/Right Arrow or Plus/Minus

Increase/decrease focus by 1% Option–Left/Right Arrow

Set focus to an exact value Type numbers
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Zoom 

Iris 

Frost 

Action Shortcut

Select Zoom property Shift–Z or hold down Z

Don’t snap Control-drag

Increase/decrease zoom angle by 1° Left/Right Arrow or Plus/Minus

Set zoom to an exact angle Type numbers

Action Shortcut

Select Iris property Shift–I or hold down I

Don’t snap Control-drag

Increase/decrease iris size by 10% Left/Right Arrow or Plus/Minus

Increase/decrease iris size by 1% Option–Left/Right Arrow

Set iris size to an exact value Type numbers

Action Shortcut

Select Frost property Shift–R or hold down R

Frost on or off O

Select linear L

Select pulse P

Decrease/increase frost amount by 10% Left/Right Arrow or Minus/Plus

Decrease/increase frost amount by 1% Option–Left/Right Arrow or Option–Minus/Plus

Set frost amount to an exact value Type numbers
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Fog 

Custom properties 

Preset Palette 

Selection 

Editing 

Action Shortcut

Decrease/increase fog amount by 10% Left/Right Arrow or Minus/Plus

Decrease/increase fog amount by 1% Option–Left/Right Arrow or Option–Minus/Plus

Set fog amount to an exact value Type numbers

Action Shortcut

Show or hide options Return or Enter

Select previous/next option Up/Down Arrow

Decrease/increase percent or DMX value Left/Right Arrow or Minus/Plus

Fine control of percent or DMX value Option–Left/Right Arrow or Option–Minus/Plus

Set percent or DMX value Type numbers

Select an option and hide the list of options Double-click option

Action Shortcut

Extend the selection Shift–click a row

Add or remove a row to/from the selection Command–click a row

Clear the selection Command–click the selected row

Action Shortcut

Create new preset Command–N

Create new preset group Command–Shift–N
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Live view 

General 

Create new group from selected items Command–Shift–Option–N

Create new sequence Command–Ctrl–N

Create new sequence from selected presets Command–Ctrl–Option–N

Show info for sequence Command–I or double-click a sequence

Edit the selected preset Command–Shift–E or Double-click preset

End editing a preset Command–Shift–E or Return or Enter

Cancel editing a preset Esc

Edit hold or fade time Click time

Increase/decrease hold or fade time by one 
second

Up/Down Arrow while editing time

Increase/decrease hold or fade time by 0.1 sec Option–Up/Down Arrow while editing time

Increase/decrease hold or fade time by 10 sec Shift–Up/Down Arrow while editing time

Jump to next field during editing Tab

Jump to previous field during editing Shift–Tab

Rename an item Return or click the item’s name

Duplicate the selected items Command–Shift–D

Duplicate one or more items Option–drag

Delete the selected items Delete

Delete an item Swipe left over a row

Action Shortcut

Action Shortcut

Show info for a button or frame Command–click button or frame

Show info for a button Force click on button1

Show properties defined in a cue Command–Option–click button
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1 Requires trackpad with Force Touch. 

Edit mode 

Change a modifier in coarse steps Hold down Shift while changing the modifier

Begin or end editing Live view Command–Option–J or Command–double-click 
LIve view

End editing Live view Command–Return

Action Shortcut

Action Shortcut

Scroll Space–drag

Select all objects Command–A

Deselect all objects Command–Shift–A or Esc

Select objects by dragging Drag from a blank part of the Live view (Option–
drag to select outward from starting point)

Add or remove an object from the selection Shift–click or Command–click an object

Add or remove objects from the selection Shift–drag or Command–drag from a blank part 
of the Live view

Move selected objects by one unit Arrow key

Move selected objects by five units Shift–arrow key

Constrain dragging to horizontal or vertical 
direction

Shift–drag

Disable alignment guides and magnetic grid 
while dragging

Control–drag

Resize an object from the center Option–drag a selection handle

Disable alignment guides and magnetic grid 
while resizing

Control–drag a selection handle

Show info for a button or frame Command–I Double-click button or frame

Rename a button or frame Return or click the button’s or frame’s name

Add a button to a frame Drag button to frame

Cut the selected objects Command–X

Copy the selected objects Command–C
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Cuelists 

Paste objects (or cues) from Clipboard Command–V

Duplicate selected objects Command–Shift–D or Option–arrow key

Duplicate selected objects by dragging Option–drag

Delete selected objects Delete

Begin or end text editing Return

Show Font panel Command–T

Show Color panel Command–Shift–C

Action Shortcut

Action Shortcut

Extend the selection Shift–click a row

Add or remove a row to/from the selection Command–click a row

Show info for cue Command–I or Command–click cue name or 
force click1 cue

Show properties defined in a cue Command–Option–click “Properties”

Activate cue Double-click cue

Activate cue with fade Option–double-click cue

Activate selected cue Command–Return

Activate selected cue with fade Command–Option–Return

Change a modifier in coarse steps Hold down Shift while changing the modifier

Add new cue below the selected item Command–N (when cuelist has focus)

Add new cue above the selected item Shift–click the 􀅼 icon

Add new group Command–Shift–N (when cuelist has focus)

Add new group from selected items Command–Shift–Option–N (when cuelist has 
focus)

Duplicate the selected items Command–Option–D (or Option–click the 􀅼 
icon)

Duplicate one or more items by dragging Option–drag
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1 Requires trackpad with Force Touch. 

Effects 

General 

Rename an item Return or click the item’s name

Delete the selected items Delete

Edit hold or fade time Click time

Increase/decrease hold or fade time by one 
second

Up/Down Arrow while editing time

Increase/decrease hold or fade time by 0.1 sec Option–Up/Down Arrow while editing time

Increase/decrease hold or fade time by 10 sec Shift–Up/Down Arrow while editing time

Jump to next field during editing Tab

Jump to previous field during editing Shift–Tab

Activate next cue Space

Activate previous cue Shift–Space

Activate cue by name (or number) Command–G

Action Shortcut

Action Shortcut

Add effect to selected fixtures Command–Option–E

End effect editing Return or Esc

Increment numeric value Up Arrow or Plus

Decrement numeric value Down Arrow or Minus

Numeric value fine control (not always 
available)

Option–Up Arrow or Option–Plus

Numeric value coarse control (not always 
available)

Shift–Up Arrow or Shift–Plus

Don’t snap sliders Command–drag
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Curve effects 

Movement paths 

Action Shortcut

Select all control points Command–A

Deselect all control points Command–Shift–A or Esc

Select the first or next control point Control–Tab

Select the last or previous control point Control–Shift–Tab

Move selected points Arrow keys

Move in large steps Shift–Arrow keys

Move in small steps Option–Arrow keys

Constrain movement to horizontal or vertical 
direction

Shift–drag

Disable alignment guides and magnetic grid 
while moving

Control–drag

Add control point below pointer Option-click on path

Delete selected control points Delete

Transform points or curve Return or Enter

Action Shortcut

Transform path T

Exit transform mode T or Esc

Close Position HUD Return, Enter, or Esc

Add control point Double-click on path

Delete selected control point Delete

Lock pan while dragging control point Command-drag

Lock tilt while dragging control point Shift-drag

Don’t snap while dragging control point Control-drag

Set pan angle of selected control point 
according to location of key

Numbers on numeric keypad
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Fixture Manager 

General 

Fixture library 

Change pan of selected control point Scroll up/down while mouse pointer is over 
Position HUD

Change tilt of selected control point Command–Scroll up/down while mouse pointer 
is over Position HUD

Increase/decrease pan angle of selected control 
point by 1°

Right/Left Arrow

Increase/decrease pan angle of selected control 
point by 10°

Shift–Right/Left Arrow

Increase/decrease tilt angle of selected control 
point by 1°

Up/Down Arrow or Plus/Minus

Increase/decrease tilt angle of selected control 
point by 10°

Shift–Up/Down Arrow

Action Shortcut

Action Shortcut

Show Fixture Manager Command–Shift–Down Arrow

Hide Fixture Manager Command–Shift–Up Arrow or Command–Return

Action Shortcut

Move focus to search field Command–Option–F

Get fixture profile info Return or Double-click a fixture profile

Edit a fixture profile Option–double-click a fixture profile

New fixture profile Command–Shift–Option–N
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Channel grid 

1 Requires trackpad with Force Touch. 

Fixture info window 

Fixture editor 

Navigation 

Action Shortcut

Select universe Command–0 through Command–9

Select previous/next universe Command–Shift–Left/Right Arrow

Select previous/next fixture Left/Right Arrow

Select first/last fixture Command–Left/Right Arrow

Select fixtures by name Type letters or numbers

Clear selection Esc

Get fixture info Return, double-click, or force click1 a fixture

Edit a fixture’s profile Option–double click a fixture

Duplicate fixtures Command–Option–D or Option–drag fixtures

Delete fixtures Delete or drag fixtures out of grid

Action Shortcut

Increase/decrease number of fixtures (when 
adding new fixtures)

Up/Down Arrow or Plus/Minus (while in fixture 
number field)

Increase/decrease fixture address Up/Down Arrow or Plus/Minus (while in fixture 
address field)

Patch fixtures Return or Enter

Don’t patch fixtures Esc

Action Shortcut

Go to previous/next fixture profile (if multiple 
profiles are open)

Command–Shift–Left/Right Arrow
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Numeric fields 

Multiple settings 

Custom capabilities 

Select previous/next mode (for profiles with 
multiple modes)

Command–Up/Down Arrow

Manage modes Command–Shift–Option–M

Edit light beams Command–Shift–Option–B

Scroll up Page Up

Scroll down Page Down

Move focus to next field Tab

Move focus to previous field Shift–Tab

Close fixture profile Command–W

Action Shortcut

Action Shortcut

Increment value Up Arrow or Plus

Decrement value Down Arrow or Minus

Action Shortcut

Add setting below the current one (for 
properties with multiple settings, e.g. Gobo)

Command–Plus

Add setting above the current one Command–Shift–Plus (or Shift–click the 􀅼 icon)

Duplicate the current setting (for properties 
with multiple settings)

Command–Option–Plus (or Option–click the 􀅼 
icon)

Remove the current setting (for properties with 
multiple settings)

Command–Minus

Action Shortcut

Toggle default setting Command-Option-X

Lightkey User Guide	 336



Beams 

External Control window 

Toggle slider Command-Option-S

Action Shortcut

Action Shortcut

Assign a property to a particular beam (when 
the property’s beam settings are visible)

Click a beam

Select beams by index (when the property’s 
beam settings are visible)

Type numbers or a range (e.g. “1–4”)

Add or remove beam from selection (when the 
property’s beam settings are visible)

Command–click a beam

Select a range of beams (when the property’s 
beam settings are visible)

Shift–click a beam

Action Shortcut

Open External Control window Command–E

Switch between categories Command–1, 2, 3

Move focus to search field Command–Option–F

Cancel search (while focus is in search field) Esc

Cut the selected bindings Command–X

Copy the selected bindings Command–C

Paste bindings from Clipboard Command–V

Duplicate the selected bindings Command–Shift–D

Delete the selected bindings Delete

Capture trigger for selected binding Return or Enter

Cancel capturing trigger Esc, Return, or Enter
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External Control Log window 

User Guide viewer 

Action Shortcut

Open External Control Log Command–Option–Shift–E

Switch between categories Command–1, 2, 3

Move focus to search field Command–Option–F

Cancel search (while focus is in search field) Esc

Copy the selected log entries Command–C

Action Shortcut

Open User Guide Command–?

Scroll up Page Up or Shift-Space

Scroll down Page Down or Space

Go to previous search result (while focus is in 
search field)

Shift–Return

Go to next search result (while focus is in 
search field)

Return

Cancel search (while focus is in search field) Esc

Zoom in Command–Plus

Zoom out Command–Minus
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Appendix 2   
Generic fixture 
profiles 

 

The following table provides an overview of the 
generic fixture profiles in the built-in library. 

Profile name Use for

Bulb Monochrome light bulb, one channel (Dimmer)

Fog Machine Fog machine or hazer, one channel (fog amount)

LED Matrix (DRGB) Flexible matrix, four channels per pixel (Dimmer, Red, Green, Blue)

LED Matrix (Mono) Flexible monochrome matrix, one channel per pixel (Dimmer)

LED Matrix (RGB) Flexible matrix, three channels per pixel (Red, Green, Blue)

LED Matrix (RGBA) Flexible matrix, four channels per pixel (Red, Green, Blue, Amber)

LED Matrix (RGBAW) Flexible matrix, five channels per pixel (Red, Green, Blue, Amber, 
White)

LED Matrix (RGBD) Flexible matrix, four channels per pixel (Red, Green, Blue, Dimmer)

LED Matrix (RGBW) Flexible matrix, four channels per pixel (Red, Green, Blue, White)

LED Strip (DRGB) Flexible LED strip, four channels per pixel (Dimmer, Red, Green, 
Blue)

LED Strip (Mono) Flexible Monochrome LED strip, one channel per pixel (Dimmer)

LED Strip (RGB) Flexible LED strip, three channels per pixel (Red, Green, Blue)
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The remaining profiles in the Generic category are for demo purposes and shouldn’t 
be used to control real fixtures. 

LED Strip (RGBA) Flexible LED strip, four channels per pixel (Red, Green, Blue, 
Amber)

LED Strip (RGBAW) Flexible LED strip, five channels per pixel (Red, Green, Blue, 
Amber, White)

LED Strip (RGBD) Flexible LED strip, four channels per pixel (Red, Green, Blue, 
Dimmer)

LED Strip (RGBW) Flexible LED strip, four channels per pixel (Red, Green, Blue, 
White)

PAR Beam Conventional beam light, one channel (monochrome)

PAR Spot Conventional spot, one channel (monochrome)

PAR Spot (DRGB) Spot light, four channels (Dimmer, Red, Green, Blue)

PAR Spot (RGB) Spot light, three channels (Red, Green, Blue)

PAR Spot (RGBAW) Spot light, five channels (Red, Green, Blue, Amber, White)

PAR Spot (RGBW) Spot light, four channels (Red, Green, Blue, White)

PAR Wash Conventional wash light, one channel (monochrome)

PAR Wash (DRGB) Wash light, four channels (Dimmer, Red, Green, Blue)

PAR Wash (RGB) Wash light, three channels (Red, Green, Blue)

PAR Wash (RGBAW) Wash light, five channels (Red, Green, Blue, Amber, White)

PAR Wash (RGBW) Wash light, four channels (Red, Green, Blue, White)

Switch DMX switch, one channel: Off (0) or On (255)

Profile name Use for
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Enjoy Lightkey! 
 

Thank you for choosing Lightkey: We hope that it enhances your 
creative process and wish you lots of fun creating exciting and 
impressive light shows. 

If you have any questions that weren’t answered in this User 
Guide, need technical support, or want to share your feedback, 
get in touch with our support team. 

We’re happy to help!

https://lightkeyapp.com/en/contact

	Chapter 1   Welcome to the world of Lightkey
	Chapter 2   Intro to DMX
	Connect your fixtures
	DMX interfaces
	Fixture addresses

	Chapter 3   Lightkey licenses
	Buy a license
	Activate your license
	Renew your license
	Move a license between computers

	Chapter 4   Set up your lights
	Step 1: Create a project
	Step 2: Choose an output method
	Step 3: Patch your fixtures
	Find the right fixture profile
	Add your fixtures

	Step 4: Build the Preview
	Locate fixtures
	Size and rotate fixture icons
	Add shapes, images, and text

	Step 5: Group fixtures
	Step 6: Set beam directions
	Step 7: Set beam colors
	You’re done

	Chapter 5   Projects
	Create a project
	Open or close a project
	What happens when you close a project

	Rename a project or save a copy
	Manage projects
	Search a project
	Undo changes

	Chapter 6   The Lightkey window
	Toolbar
	Customize the Lightkey window
	Full screen view
	Dual windows
	Adaptive background color
	Lock Lightkey
	Keyboard shortcuts and gestures

	Chapter 7   Preview
	Zoom
	Edit the Preview
	Edit objects
	Select objects
	Move objects
	Align objects
	Space objects evenly
	Resize and rotate objects

	Edit fixtures
	Size and rotate fixture icons
	Position fixture names
	Set beam directions
	Set beam colors
	Group fixtures
	Locate fixtures
	Disable fixtures or hide light beams
	Add or remove fixtures

	Edit shapes, images, and text
	Add shapes, images, or text
	Copy and paste shapes, images, and text
	Duplicate shapes, images, and text
	Delete shapes, images, and text
	Flip shapes and images
	Order shapes, images, and text
	Change the style of shapes and images
	Adjust shape features
	Change text formatting


	Chapter 8   Fixture properties
	Select fixtures
	Select all fixtures
	Select fixtures by location
	Select fixtures by type
	Select fixtures by name
	Select fixtures through external control

	Select light beams
	Fixture properties
	Select a fixture property
	Define a fixture property
	Effects

	Dimmer
	Master Dimmer

	Color
	Additional colors and features
	Color favorites

	Color Wheel
	Color wheel modes

	Gobo Wheel
	Gobo wheel modes
	Gobo states

	Position
	On/Off
	Shutter/Strobe
	Movement Speed
	Prism
	Prism states

	Focus
	Zoom
	Iris
	Frost
	Fog
	Custom fixture properties
	Slider
	List of options
	Reorder or hide custom properties

	Lamp
	Command
	Default values
	Copy and paste fixture properties
	View overridden fixture properties
	Clear fixture properties
	Undo changes
	Fanning
	Fan a fixture property
	Edit Fanning
	Delete Fanning


	Chapter 9   Presets and sequences
	Create a preset
	View preset contents
	Activate or deactivate presets
	Edit a preset
	Presets and overridden properties
	Create a preset group
	Create a sequence
	View sequence contents
	Run sequences
	Sequence order
	Reorder sequence steps
	Sequence timing
	Manual timing
	Beat-controlled timing

	Create fixture movements with sequences
	Organize presets and sequences
	Filter items in the Preset Palette
	Export and import items in the Preset Palette

	Chapter 10   Effects
	Pattern effects
	Curve effects
	Movement effects
	Add an effect
	Edit an effect
	Edit effect timing
	Edit the fixture order
	Edit pattern effects
	Chase
	Scanner
	Yo-yo
	Fill
	Rain
	Meteor
	Sparkle
	Fire
	Jellyfish
	Snakes

	Edit curve effects
	Edit movement effects
	Edit paths
	Path types
	Transform paths

	Copy and paste effects
	Delete an effect
	Overlay effects
	Save an effect template

	Chapter 11   Live control
	Live view pages
	Build Live view pages
	Edit a page
	Add cue buttons
	Add frames
	Add text labels
	Select objects
	Move objects
	Attach buttons
	Resize objects
	Rename objects
	Duplicate objects
	Copy and paste objects
	Delete objects
	Change text formatting
	Set default styles
	Configure frames
	Cuelists

	Edit cuelists
	Add cues
	Cue groups
	Cuelist timing
	Select cues for playback
	Organize cues
	Copy and paste cues
	Filter cuelist items

	Edit cue contents and options
	Edit cue contents
	View cue contents
	Edit ad hoc properties
	Edit cue timing options
	Edit button appearance and behavior
	Edit modifiers
	Fade curves

	Live control with cue buttons
	Push buttons
	Faders
	Step through buttons in a frame
	Change modifiers
	Continue effects across cues

	Live control with cuelists
	Control playback
	Manual crossfading
	Activate arbitrary cues
	Change modifiers
	Continue effects across cues

	Blind mode
	Freeze output
	Startup state
	Output order of precedence

	Chapter 12   Beat control
	Beat-controlled sequences
	Beat-controlled effects
	Set the beat grid
	By tapping
	As an exact value
	Through MIDI Beat Clock
	Through Ableton Link

	Examples
	Ableton Live
	Logic Pro
	MultiTracks Playback
	Traktor
	Waveclock


	Chapter 13   Manage DMX fixtures
	Find the right fixture profile
	Filter the fixture library
	Add DMX fixtures
	Edit DMX fixtures
	View and edit DMX fixture information
	Change a fixture’s DMX address or universe
	Duplicate fixtures
	Edit a fixture profile
	Reassign fixture profiles
	Disable fixtures
	Delete fixtures

	Export and import fixtures
	Print the patched fixtures
	Work with fixture profiles
	Manage favorite fixture profiles
	Edit a fixture profile
	Import a fixture profile
	Create a fixture profile
	Duplicate a fixture profile
	Delete a fixture profile


	Chapter 14   DMX output and input
	DMX Output settings
	Serial USB Interfaces
	Open DMX Interfaces
	Eurolite USB-DMX512-PRO MK2
	Other USB Interfaces
	Art-Net
	sACN (E1.31)
	ESP Net
	Connect to an external OLA server

	Configure universes
	Configure universes on a network node

	Monitor DMX output

	Chapter 15   Smart lights
	Smart lights vs. DMX
	Manage Hue Bridges
	Add a Hue Bridge
	Relink Lightkey to a Hue Bridge
	Delete a Hue Bridge

	Manage smart lights
	View and edit Hue fixture information
	Add a Hue fixture
	Replace a Hue fixture
	Move fixtures to a different room
	Move a fixture between Hue Bridges
	Disable fixtures
	Delete fixtures

	Manage rooms

	Chapter 16   External control
	Quickly assign triggers
	The External Control window
	Configurations
	MIDI inputs
	Bindings
	Triggers
	Actions
	MIDI Shift button
	MIDI notes

	Live Triggers
	Behind the scenes
	Disable Live Triggers
	Troubleshooting

	Trigger actions from ProPresenter
	Send MIDI to other applications
	MIDI routing
	Open Sound Control (OSC)
	Connect to Lightkey
	OSC addresses
	Live view
	Preset Palette
	Output control
	Beat control
	Fixture properties

	External Control Log
	macOS shortcuts
	Multi-Touch gestures

	Appendix 1   Shortcuts and gestures
	General
	Application & windows
	Projects
	Editing
	View

	Project setup assistant
	Preview editing
	General
	Selection
	Move
	Fixtures
	Shapes, text & images

	Preview
	Zoom
	Selection
	Fixtures
	Position HUD
	Focus HUD
	Zoom HUD
	Iris HUD

	Design view
	General
	Dimmer
	Color
	Color Wheel
	Gobo
	Position
	Shutter/Strobe
	Movement Speed
	Prism
	Focus
	Zoom
	Iris
	Frost
	Fog
	Custom properties

	Preset Palette
	Selection
	Editing

	Live view
	General
	Edit mode
	Cuelists

	Effects
	General
	Curve effects
	Movement paths

	Fixture Manager
	General
	Fixture library
	Channel grid
	Fixture info window

	Fixture editor
	Navigation
	Numeric fields
	Multiple settings
	Custom capabilities
	Beams

	External Control window
	External Control Log window
	User Guide viewer

	Appendix 2   Generic fixture profiles

